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مقدمه

ستايش پروردگار بي‌همتا را كه بار ديگر ما را مفتخر كرد تا بتوانيم در وادي علم و دانش 
گام برداشته و آموخته‌ها و تجارب خود را در اختيار همگان قرار دهيم. در اين زمان كه علم 
در همه عرصه‌هاي زندگي بشر پا نهاده است، بر آن شديم تا حضور آن را در كنار هنر يادآور 
شويم. در اين راستا كتاب حاضر به آموزش نرم‌افزار گرافيكي FreeHand MXa پرداخته كه در 
 FreeHand واقع نگارش 11/02 اين برنامه است. تنظيم مطالب كتاب بر اساس استاندارد كاربر
وزارت ارش��اد و فرهنگ اسال�مي صورت گرفته است و به جرأت مي‌توان گفت كه اين كتاب 

خودآموز و مرجع كاملي براي كاربران FreeHand است.
در اين كتاب س��عي ما بر اين بوده اس��ت كه مطالب آموزش��ي به ص��ورت گام به گام و 
تصويري همراه با مثال و تمرينات متعدد و خلاق براي دانش‌آموزان نوش��ته ش��ود. همچنين 
با تمرينات كاربردي و پروژه‌هاي عملي در انتهاي كتاب، هنرجويان را به كس��ب مهارت‌هاي 

بيشتر سوق داده‌ايم.
مطالب كتاب در 15 واحدكار تهيه شده كه شامل موارد زير است:

توانايي رعايت اصول ايمني و بهداشتي در محيط كار، نصب نرم‌افزار FreeHand و شناخت 
محيط آن، ايجاد فضاي مورد نياز براي قرارگيري اشياي گرافيكي و استفاده از عناصر و ابزار 
در طراحي و ترسيم‌ها، كار روي اشياء و ويرايش آن‌ها، كار با رنگ و پركننده‌ها، كار با متن، 
استفاده از جلوه‌هاي ويژه، استفاده از لايه‌ها، سمبل‌ها و سبك‌ها، متحرك‌سازي و استفاده از 

سند FreeHand در صفحات وب، صدور و چاپ فايل‌هاي گرافيكي.
 اميدواري��م ك��ه ب��ا ارس��ال نظرات و پيش��نهادات خ��ود ب��ه آدرس پس��ت الكترونيكي 

F_Riahi2000@yahoo.com  ما را در رفع كاستي‌هاي اين كتاب ياري نماييد.

مؤلفان
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کليات 
انس��ان با توجه به محي��ط کاري که در آن قراردارد و موقعيت بدني و نحوه اس��تفاده از 
ابزارهاي محيط کار و رعايت بهداشت در پيرامون خود، تحت تأثير شرايط قرار مي‌گيرد و اگر 
ارتباط مناس��ب و اصولي با ابزار و محيط کارش برقرار نکند، عوارض ناش��ي از فشارهاي وارد 
شده بر او سبب اخلال در اجراي درست کار، خستگي و ناراحتي در اندام‌هاي او مي‌شود. در 
دنياي امروز، کاربرد رايانه در زمينه‌هاي مختلف اهميت داشته و استفاده از آن اجتناب‌ناپذير 

است، نحوه قرارگيري درست کاربر پشت دستگاه در استفاده بهينه از آن مؤثر است.
1-1 مهندسي محيط و محل انجام كار )ارگونوميك(

دان��ش ارگونوميک، به مطالعه ارتباط و تعامل انس��ان با ابزارها، تکنولوژي )س��خت‌افزار/ 
نرم‌افزار( و فعاليت‌هاي کاري و محيطي که در آن کار ميک‌ند، مي‌پردازد. هدف اصلي، ايجاد 

هماهنگي و مناسب بودن کار براي هر فرد است.

شکل 1-1 دسترسي به ابزارهاي محيط کار

2-1 عوامل مؤثر در استفاده صحيح از رايانه
به منظور رعايت ارگونومي و حفظ سلامتي بايد به عواملي در هنگام کار با کامپيوتر توجه 

داشت، اين عوامل عبارتند از: 
1-2-1 چيدمان رايانه 

براي حفظ سال�مت و جلوگيري از ايجاد مشك��ل براي دس��ت‌ها و پشت، گردن و ... سه 
توصيه زير را رعايت كنيد:

1- ماوس و ساير ابزارهاي ورودي را در کنار صفحه کليد قرار دهيد تا فشار وارده در دسترسي 
 به وسايل، روي شانه‌ها کاهش يابد. براي اينکه ماوس حرکتي روان داشته باشد از زيرماوسي"

)Mouse Mat( استفاده کنيد.
 Mouse Mat : براي بهبود و پيشرفت كاربرد ماوس كامپيوتر مورد استفاده قرار مي‌گيرد 
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)شكل 1-2(.
Mouse Mate : اين وسيله مستقيماً به ماوس مي‌چسبد، كف دست در حالت خنثي قرار 

مي‌گيرد و ماوس به يك ماوس ارگونوميك تبديل مي‌شود )شكل 1-3(.
      

                       

                              

                                     شکل 2-1	     شکل 1-3

2- صفحه نمايش را در پشت صفحه کليد بگذاريد و لبه بالايي آن را در امتداد چشم‌هايتان 
قراردهيد. فاصله بين صفحه نمايش و چش��م‌ها را نزديک به اندازه طول شانه در نظر بگيريد 
)فاصله مناس��ب معمولاً بين 48 تا 71 س��انتي‌متر است(. براي کم کردن تشعشع در صفحه 
نمايش‌هاي کنوني تکنولوژي جديدي به کار مي‌رود. همچنين براي کاهش درخشندگي آن 
را به س��مت بالا، پايين يا راس��ت و چپ بچرخانيد. در صورت وجود پنجره، بايد امتداد آن با 

صفحه نمايش زاويه 90 درجه داشته باشد و کاربر پشت به آن قرار نگيرد.
3- براي نگه داشتن صفحه‌ها در هنگام تايپ مطالب، از يک نگهدارنده )Holder( استفاده 

کنيد. تنظيم فاصله و ارتفاع آن مانند صفحه نمايش است.
2-2-1 صندلي مناسب 

صندلي مناس��ب براي کار با رايانه مجهز به تکيه‌گاه )پشتي(، دسته و ارتفاع قابل تنظيم 
است و لبه جلوي نشيمنگاه آن انحنايي رو به پايين دارد.

تنظيم ارتفاع صندلي
ب��ا توجه به ق��د کاربر و ارتفاع ميز، ارتفاع صندلي با اهرم‌هاي��ي که براي اين کار در نظر 
گرفته ش��ده است، تنظيم مي‌شود. ارتفاع صندلي نبايد سبب ايجاد ناراحتي در پشت ران يا 

زانو شود.
3-2-1 ميز مناسب

س��طح ميز مناس��ب برای کار با رايانه، فضاي کافي براي همه وسايل را دارد و ارتفاع ميز 
نبايد آن قدر کم باش��د که کاربر پاهايش را جمع کند و محل اس��تقرار آن در صورت وجود 

پنجره در محيط کار، به نحوي است که کاربر در کنار پنجره قرار بگيرد.
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 نكت�ه: اگ��ر پاها روي زمين قرار نگرفت ب��راي جلوگيري از وارد آمدن فش��ار به آن‌ها، از يک 
زيرپايي استفاده کنيد.

4-2-1 تهويه و نور 
در محيط کار بايد هوا جريان داش��ته باش��د و از تهويه و وس��ايل خنک‌کننده براي کم 
اثر کردن حرارت ناش��ي از وجود جريان الکتريسيته در قطعه‌هاي الکتريکي استفاده شود تا 
کارايي سيس��تم رايانه با بالا رفتن حرارت کم نشود. براي روشن کردن ميز کار بهتر است از 

چراغ مطالعه استفاده شود همچنين نور مستقيم، به کاربر نتابد.

5-2-1 روش‌هاي به کارگيري ماوس و صفحه کليد
روش‌ها و تکني‌کهاي صحيح به کارگيري ماوس و صفحه کليد از فش��ار مچ‌ها، بازوها و 

آرنج‌ها کم ميک‌ند و مي‌تواند از فشار ثابت شانه‌ها بکاهد.
•هنگامي که تايپ ميک‌نيد دست‌ها و بازوها را ثابت نگه نداريد،  	

همچنين آن‌ها را روي ميانه دسته صندلي قرار ندهيد.
•هنگامي که با ماوس و صفحه کليد کار ميک‌نيد کف دست يا  	

مچ دستتان را ثابت نکنيد يا وزنش را روي آرنج نيندازيد.
•مچ دستتان را مس��تقيم نگه داريد و ميزان خم‌شدگي مچ به  	

سمت بالا يا پايين يا داخل و بيرون را به حداقل برسانيد.
• درجه يا بيشتر باشد و از زاويه  زاويه بازِ آرنج دس��تتان، 120	

کمتر از 90 درجه اجتناب کنيد.
 جدول 1-1 حالت‌هاي مناسب و نامناسب کار با صفحه کليد

حالت مناسب 
آزاد است، در حالي  دست‌هايتان 
قرار  طرف  دو  در  آرنجتان  كه 
دارد و صفحه كليد روي پاهايتان 

است.

حالت مناسب
 ساعدتان را روي دسته صندلي 
قرار دهيد و دست‌هايتان را به 

حالت آزاد قرار دهيد.

حالت مناسب
يا  ميز  روي  ساعدها 
مخصوص  صفحه  يک 

قرار دارد.

حالت نامناسب
وقتي که با صفحه کليد کار 
ميک‌نيد، مچتان را ثابت نگه 

نداريد.
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 نكت�ه: حداقل‌هرس��اعت يک ب��ار به مدت 5 دقيقه به خودتان اس��تراحت داده و 
حرکات کششي انجام دهيد.

3-1 خستگي بدن 
هنگامي که انسان در اجراي فعاليت خود از نظر ذهني و جسمي بازدهي مناسب نداشته 
باش��د، خسته ش��ده است. در کار با رايانه چشم‌ها، دست‌ها، پاها و ... با رعايت نکردن شرايط 

ارگونومي خسته مي‌شوند. 
1-3-1 رفع خستگي بدن هنگام کار

زماني که مش��غول به کار هستيد براي استراحت و تجديد قوا لازم است که موارد بعد را 
براي قسمت‌هاي مختلف بدن انجام دهيد:

• دقيقه يک بار به يک فاصله دورتر ن��گاه کرده و براي يک لحظه  چش�م‌ها: ه��ر 20	
کوتاه به يک فاصله نزديک نگاه کنيد.

• دقيقه انگش��ت‌هايتان را به ص��ورت بادبزني باز کرده و  دس�ت‌ها و بازوه�ا: هر20	
حرکت دهيد و بچرخانيد س��پس دس��تتان را روي پاهايتان بگذاريد و در حالي ک‌ه 

شست‌هايتان بالاست، آن را تکان دهيد.
• دقيقه يک بار بلند شويد و حرکت کششي انجام  بدن در وضعيت نشسته: هر 30	

دهيد و هر يک ساعت يک بار، 5 دقيقه بلند شويد و راه برويد.

       

  شکل 4-1 حرکت بادبزني انگشتان و حرکت شست                   شکل 5-1حالت کششي

4-1 عوارض استفاده از رايانه 
تداوم خس��تگي در کاربر رايانه و عدم رفع آن، س��بب ايجاد عوارض ناشي از کار با رايانه 
مي‌شود که عبارتند از کمردرد، پادرد، درد در مچ دست، احساس ناراحتي در گردن و شانه‌ها 

و ضعيف شدن ديد چشم‌ها.
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1-4-1 نحوه پيشگيري از عوارض استفاده از رايانه

هن��گام کار ب��ا رايانه طرز صحيح نشس��تن و به کارگيري درس��ت اندام‌ها طبق آنچه در 
صفحات قبل گفته ش��ده اس��ت، خس��تگي و عوارض کار با رايانه را کم کرده و حتي مانع از 

ايجاد ناراحتي مي‌شود.
در شکل 6-1 روش درست نشستن هنگام کار با رايانه نشان داده شده است.

شکل 6-1 طرز نشستن هنگام کار با رايانه

5-1 مقررات انضباطي كارگاه 
هنگام كار با رايانه رعايت يكسري مقررات براي به حداقل رسيدن آسيب‌ها، ضروري است 

که برخي از آن‌ها به اين شرح است:
•روشن و خاموش کردن سيستم‌ها بر طبق ضوابط و اصول درست 	
•شناسايي وسيله‌ها و تجهيزات جانبي و استفاده صحيح از آن‌ها  	

و  • اس��تفاده درست و مناس��ب از حافظه‌هاي كمكي مانند فلاپي، Cool disk ،CD و ... 	
اطمينان از بي‌عيب بودن حافظه‌هاي کمکي از لحاظ فيزيكي و بررس��ي آن‌ها با نرم 
افزارهاي ضد ويروس و کرم )Worm( و مطمئن شدن از عدم ويروسي بودن آن‌ها.

 نكته: دس��تگاه‌ها و ابزارها بايد از رطوبت، ميدان‌هاي مغناطيسي، ضربه خوردن، 
ساييده شدن و خش افتادن در امان باشند.
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واژه‌نامه
Cool diskحافظه کمکي

Ergonomicمهندسي محيط و محل انجام كار

Foot Restزيرپايي

Holderنگهدارنده

Postureطرز نشستن و ایستادن

                 	
                                 

 Posture       	طرز نشستن و ايستادن
خلاصه مطالب

•براي رعايت ارگونوميک بايد به موارد زير توجه داشت: 	
1- وضعيت مناسب بدن 

2- وضعيت مناسب  و محل قرار گرفتن ميز و صندلي
3- وضعيت مناسب نور و روشنايي

4- تهويه مناسب
5- استفاده از ابزارهايي که ارگونوميک در آن‌ها رعايت شده است.
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کليات 
امروزه پيش��رفت‌هاي علمي و تکنولوژي سبب شده است که سيستم سنتي صنعت چاپ 
و گرافيک دس��تي جاي خود را به کامپيوترها و اجزاي جانبي دقيق و نرم‌افزارهاي گرافيکي 

دهد و در اين صنعت تحول ايجاد کند.
نرم‌اف��زار FreeHand يک�� برنامه گرافيکي برداري اس��ت که ش��ما را در طراحي و ايجاد 
اشکال گرافيکي نظير آرم‌ها، طراحي جلد کتاب، بروشور، کارت ويزيت و پوستر ياري مي‌كند. 
علاوه بر ‌اين، مي‌توانيد تصاوير ساخته‌شده در اين ‌برنامه را با برنامه Flash به تصاوير متحرک 
تبديل کنيد، همچنين امکان ذخيره‌س��ازي تصاوير را به نحوي فراهم ک‌نيد که قابل استفاده 

در صفحات وب باشد.
اي��ن نرم‌افزار در کنار Photoshop به عنوان مکمل ويرايش تصوير، کاربران را در طراحي، 

تصوير‌سازي و چاپ ياري مي‌رساند.
 در اي��ن پيمان��ه مهارتي نس��خه )MXa 1102( از نرم‌افزار FreeHand آموزش داده ش��ده 

است.
1-2 آشنايي با تصاوير برداري و پيكسلي

 گرافيک کامپيوتري به‌طور کلي به دو بخش پيکسلي )Raster( يا طرح بيتي )Bitmap( و برداري 
)Vector( تقسيم مي‌شود.

• نظير فتوش��اپ با پيکسل‌ها سروکار دارد، يعني هرتصوير  نرم‌افزارهاي پيکس�لي:	
از تعداد زيادي نقاط مربع ش��کل يا پيکسل با رنگ‌هاي مختلف تشکيل مي‌شود که 
هرچه تعداد اين پيکسل‌ها بيشتر باشد، جزييات تصوير بيشتر مشخص شده و تصوير 

داراي وضوح بيشتري مي‌شود.
•متون در اين نوع نرم‌افزارها داراي کيفيت پايين‌تري هستند و وضوح آن‌ها به تعداد  	
پيکس��ل‌هاي تش��کيل‌‌دهنده متن بس��تگي دارد، به همين دليل بحث درجه وضوح 
)Resolution( پيش مي‌آيد يعني در فتوش��اپ کيفيت و هموار بودن لبه‌هاي حروف 

و اشکال به ميزان Resolution تصوير بستگي دارد. 
 نرم‌افزارهاي برداري: در اين‌گونه نرم‌افزارها تصاوير و متون از يکسري خطوط و منحني‌ها که 
براس��اس فرمول‌هاي رياضي تعريف شده‌اند، تشکيل مي‌ش��وند. به‌عبارت ديگر اشکالي نظير 
دايره، خط، کمان و غيره به صورت موضوعات مستقلي هستند که مي‌توانيد به سادگي آن‌ها 
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را جابه‌ج��ا کنيد يا تغيير مقياس دهيد بدون اينک‌ه در کيفيت آن‌ها تأثيري داش��ته باش��د. 
در اين نوع نرم‌افزارها درجه وضوح نقش��ي ندارد بنابراين س��طح کيفي ترسيمات و متون در 
حداکثر ميزان ممکن اس��ت. از اين‌رو بسياري از طراحان ترجيح مي‌دهند که تصويرسازي را 
در فتوش��اپ انجام دهند سپس آن ‌را به FreeHand منتقلک‌رده و تايپ و حروف‌نگاري را در 

اين محيط انجام دهند و در نهايت آن ‌را چاپ كنند.
نرم‌افزارهاي Adobe Illustrator ، FreeHand و CorelDRAW نمونه‌هايي از گرافيک برداري 

هستند.

 توجه: اندازه فايل‌هاي Vector از فايل‌هايBitmap بسيار کمتر است.

 نكته: کيفيت و وضوح ترسيم Vector به وضوح صفحه نمايش و چاپگر وابسته نيست.

 

شکل 1-2 به ترتيب از راست به چپ: تصوير برداري و پيکسلي

 توج�ه: اصلي‌ترين تفاوت نرم‌افزارهاي برداري و پيکس��لي در اين اس��ت که در نرم‌افزار 

برداري تغيير اندازه شك��ل رس��م شده، در کيفيت ترس��يم و حجم آن بي‌تأثير است، اما در نرم‌افزار 
پيکسلي با کاهش و افزايش اندازه تصوير، کيفيت و حجم آن نيز کم و زياد مي‌شود.

FreeHand  MXa 2-2 امکانات لازم براي نصب نرم‌افزار
 برنامه FreeHand با پردازش تصاوير و محاسبات پيچيده‌اي سروکار دارد، بنابراين رايانه‌اي که اين 

نرم‌افزار روي آن نصب مي‌شود، حداقل بايد اين امکانات را داشته باشد:
• پردازنده: سرعت پردازنده بايد Pentium III 600MHz يا بالاتر باشد.	
• سيستم عامل: مي‌تواند يکي از اين ويندوزها باشد:	

XP, Vista, Seven ,  NT4(Service Pack6 (, 2000

• حافظه MB :RAM 512 يا بالاتر 	
• کارت گرافيکي: کارت گرافيک 16 بيتي با وضوح 768×1024 مناسب است.	
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 • 	100  MBنصب مي‌شود حداقل FreeHand حافظه ديسک سخت: در پارتيشني که
فضاي آزاد موردنياز است. 

• درايوCD  يا DVD: کامپيوتر حداقل بايد به يکي از اين درايوها مجهز باشد.	
	 FreeHand 1-2-2 نصب نرم‌افزار

براي نصب برنامه گرافيکي FreeHand مي‌توانيد از سه روش مختلف استفاده کنيد. در هر 
سه روش با اجراي فايل Setup.exe، ويزارد نصب آشکار مي‌شود؛ اين روش‌ها عبارتند از:

1- اج�راي خودکار CD يا DVD نصب برنامه: اگر برنامه نصب به صورت خودکار اجرا 
 ،)Setup يا Install( شود، در پنجره ظاهر شده با کليک روي نام برنامه يا گزينه نصب نرم‌افزار

فايل اجرايي نصب برنامه يعنيSetup.exe  اجرا مي‌شود.
2- اجراي دستي نصب برنامه: در اين روش ابتدا روي آيکن CD يا DVD کليک راست 
کني��د و پس از آن با انتخ��اب گزينه Open به فايل اجرايي نصب برنامه دسترس��ي خواهيد 

داشت.
3- اس�تفاده از گزينه  Add or Remove Programs  درControl Panel : در اين روش 
با اس��تفاده از پنجره Add or Remove Programs روي دکم��هCD or Floppy  کليک کرده و 
مس��ير فاي��ل اجراي نصب برنامه یعنی setup.exe را با کليک�� روي دکمه مرور )Browse( در 

کادر متني Open درج کنيد.
با اجراي فايل setup.exe به مراحل مش��ترک بين س��ه روش گفته شده مي‌رسيد. در اين 
مرحله ويزارد نصب آش��کار مي‌ش��ود و در مرحله‌هاي بعدي، تعيين مس��ير نصب فايل‌هاي 
برنامه، سبب کپي شدن فايل‌ها در مسير انتخابي مي‌شود. پس از پايان نصب برنامه و اجراي 

آن، محيط برنامه طبق شكل 2-2 آشكار مي‌شود.

شکل 2-2 محيط برنامه FreeHand پس از اجرا
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FreeHand MXa  3-2 اجراي برنامه
براي ‌اجراي ‌برنامه مي‌توانيد ‌مسير

Start → All Programs → Macromedia → Macromedia FreeHand MXa  را انتخ��اب 

کرده يا از ميانبري که روي صفحه Desktop ايجاد کرده‌ايد، استفاده کنيد.
Welcome 4-2 کادرمحاوره

با اجراي مسيرHelp→Welcome  کادرمحاورهWelcome  ظاهر مي‌شود. کادر خوشامدگويي 
FreeHand شامل اين پيوندها است:

What’s New 2-4-1

خلاص��ه‌اي از ابزاره��ا و امکانات جديد برنامه را در اختيار کارب��ر قرار مي‌دهد. به منظور 
برق��راري ارتباط بهتر با کاربر برخي از امکانات اضافه ش��ده ب��ه برنامه با کليک روي علامت 

دوربين به صورت تصويري نشان داده مي‌شود.)شکل 2-3(
                                                                         

  

شکل 3-2 نمايش ابزارهاي جديد اضافه شده به برنامه  

Using FreeHand MX 2-4-2

کليک�� روي اي��ن گزينه، راهنماي برنامه FreeHand را نش��ان مي‌ده��د که مي‌‌توانيد به 
صورت سرفصل موضوعات، کلمه‌هاي کليدي و جستجوي عبارت‌ها و کلمه‌ها  از آن استفاده 

کنيد.
Learning FreeHand MX 2-4-3

 Adobe و با استفاده از سايت Online براي مرور س��رفصل‌ها و درس‌هاي برنامه به صورت
از اين پيوند استفاده مي‌شود. 
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View the FreeHand MX product pages 2-4-4
 Online به صورت Adobe در اين قس��مت ليس��تي از محصولات ارائه شده توسط شركت

مشاهده مي‌شود. 
Visit the Macromedia Designer & Developer Center 2-4-5

اي��ن پيون��د، براي برق��راري ارتب��اط با مر��کز طراح��ي و توس��عه نرم‌افزار بهک‌ار مي‌رود. 
پيون��د  روي  ش��ما  کليک��  هس��تيد،  متص��ل  اينترن��ت  ب��ه   هنگامي��ک ه 
Visit the Macromedia Designer & Developer Centerصفحه Adobe Design Center را ظاهر 

ميک‌ند.
Visit the FreeHand MX Support Center 2-4-6

 Visit the FreeHand MX Support با مرکز ارائه خدمات برنامه از طريق پيوند Online ارتباط
 Center امکان‌پذير است. در صفحه اين پيوند، نکات اساسي و منابع و تجهيزات مورد نياز برنامه

FreeHand MXa ، مشکلات چاپ و کار با متن‌ها و ... در اختيار کاربر قرار مي‌گيرد.

Wizard 5-2 کادرمحاوره
همان‌طورکه مي‌دانيد ويژگي برنامه‌هايي که به صورت Wizard اجرا مي‌ش��ود، اين است 
که در هر مرحله از اجراي برنامه مورد نظر، سؤال‌ها و انتخاب‌هايي آشکار مي‌شود که براساس 
انتخاب و پاس��خي که به سؤال مطرح شده مي‌دهيد، ش��ما را به مرحله بعدي اجراي برنامه 
هدايت ميک‌ند. به عبارتي ويزارد يک برنامه، راهنما و هدايتک‌ننده کاربر براي اجراي سريع 

و راحت فرمان‌ها و دستورالعمل‌هاي موردنظر اوست.
 ،Help→Wizards… نيز چنين امکاني وجود دارد و با اجراي مس��ير FreeHand در برنامه

کادرمحاوره Wizard مطابق شکل 4-2 مشاهده مي‌شود.
در کادرمح��اورهWizard ، پن��ج دکمه قرار دارد و کليک روي هر کدام س��بب اجراي يک 

ويزارد خاص مي‌شود كه در اين بخش به صورت خلاصه شرح داده شده است.

 Wizard شکل 4-2 کادرمحاوره اصلي
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Welcome 2-5-1

با کليک روي اين دکمه، ويزارد خوش��امدگويي مطابق ش��کل 5-2 اجرا مي‌شود که پنج 
دکمه موجود در اين کادرمحاوره به اين شرح است:

    

Welcome شکل 5-2 کادرمحاوره ويزارد

Setup 2-5-2

در اين بخش تنظيم‌ه��اي فايل FreeHand مثل واحد اندازه‌گيري، اندازه صفحه، افقي يا 
عمودي بودن صفحه و انتخاب رنگ‌هاي مورد استفاده در سند انجام مي‌شود. 

Setup شکل 6-2 فايل ايجاد شده با ويزارد

	   Screen-based 2-5-3

ب��راي انجام تنظيم‌هاي مرب��وط به ايجاد تصويره��ا و عناصرگرافيکي مورد اس��تفاده در 
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اينترنت، پروژه‌هاي چند‌رس��انه‌اي، تصويرهاي به‌دس��ت آمده از برنامه‌هاي گرافيکي تدوين و 
ويرايش تصوير از ويزاردScreen-based استفاده مي‌شود.

Stationary 2-5-4

ايجاد س��ند‌هاي چندصفحه‌اي که تنظيم‌هاي استاندارد سربرگ، کارت ويزيت، برچسب 
ديس��کت، برچسب پس��تي و پاکت نامه را دارند؛ همچنين نمونه‌هاي آماده آن‌ها در برنامه با 
استفاده از اين ويزارد قابل اجرا است. انتخاب رنگ با توجه به پالت‌هاي رنگي آماده يا حالت 

سياه و سفيد از ديگر مواردي است که مي‌توانيد با استفاده از اين ويزارد انجام دهيد. 

Stationary در ليست رنگ فايل اجرا شده در ويزارد Metallic و رنگ Fun  شکل 7-2 طرح

Publication 2-5-5

در اين ويزارد تنظيم‌هاي نش��ر و ايجاد صفحه‌ه��اي کاري براي تقويم، کتاب، خبرنامه و 
آگهي‌ها انجام مي‌شود. 

تمرين : در هر كدام از حالت‌هاي گفته ش��ده سندي را باز كنيد و به تفاوت‌هاي 
آن‌ها دقت كنيد.
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واژه‌نامه
Business cardکارت ويزيت
Developer Centerمرکز توسعه
Freestyleطرح آزاد

Interfaceرابط
Illustrationتصوير

Measurementاندازه‌گيري
Multi Pagesچندصفحه‌اي

Newsletterخبرنامه
Overviewبرداشت کلي

Publicationنشر
Screen-basedاساس نمايش تصوير

Snappingچسبيدن
Stationeryنوشت‌افزار

Support Centerمرکز خدمات
Web-relatedمربوط به وب

خلاصه مطالب
FreeHand MX يک نرم‌افزار گرافيکي برداري اس��ت که براي طراحي و ترسيم آرم، لوگو، 

جلد کتاب و مجله، کاغذ کادو و جعبه دستمال کاغذي و ... بهک‌ار مي‌رود. ابزارها و پنل‌هاي 
مختلف امکانات گوناگوني را براي اين برنامه فراهم کرده‌اند.

 ب��راي نص��ب برنام��ه FreeHand مي‌تواني��د از س��ه روش خ��ودکار، دس��تي و گزين��ه
Add Or Remove Programs در Control Panel استفاده کنيد.
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1-در نرم‌افزارهاي پيكسلي تصاوير از خطوط و منحني تشكيل شده است.
2- اندازه فايل‌هاي Vector از فايل‌هاي Bitmap كمتر است.

3- حافظهRAM  مورد نياز براي نصب FreeHand حداقل 64 مگابايت است. 
4- براي انجام تنظيمات مربوط به ايجاد تصاوير اينترنتي از ويزارد Stationary اس��تفاده 

مي‌شود.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Screen-based               FreeHand5- تنظيم‌هاي مربوط به ايجاد سند و صفحه کاري در
 ،FreeHand 6- ايجاد س��ند، بازکردن فايل‌هاي موجود با فرمت‌هاي ش��ناخته ش��ده در
Stationery                                            Help بازکردن فايل‌هاي ويرايش شده، نحوه استفاده از
7- ايج��اد تنظيم‌هاي س��ربرگ و کارت ويزيت و اس��تفاده از نمونه‌ه��اي آماده آن‌ها در 
 Welcome                                                                                       	برنامه
Setup 8- تنظيم‌هاي نشر و ايجاد صفحه‌هاي کاري براي تقويم و جلد کتاب            	
Publication    9- ايجاد تصوير براي وب و چندرسانه‌اي و تدوين تصويرها در حين کار

گزينه صحيح را انتخاب کنيد.

10- کدام‌يک از نرم‌افزارهاي زير از نوع برداري هستند؟
	FreeHand -ب              	 Photoshop -الف

د-  ب و ج هستند  	 	Corel Draw -ج
11- فايل اجرايي نصب برنامه FreeHand، .............. است.

Serialnumber.txt -د   	 Keygen.exe-ج 	Setup.exe -ب      	Setup.txt -الف
 FreeHand 12- کدام گزينه نش��ان دهنده مقدار فضاي آزاد موردنياز، براي نصب برنامه

است؟
ج- 100	                  د- 128 الف- 70                 ب- 64        	

13- کدام گزينه دسترسي کاربر به فايل‌هايي را که اخيراً با آن‌ها کار کرده و روي آن‌ها 
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ويرايش انجام داده است، فراهم ميک‌ند؟
	Open -ب           	  FreeHand Help -الف

New -د 	            Previous File  -ج
14- در کادر مح��اوره خوش��امدگويي، گزين��ه Learning FreeHand MX ب��ه چه منظور 

استفاده مي‌شود؟
الف- بررسي Help برنامه               

Online ب- مرور سرفصل‌ها و درس‌هاي برنامه به صورت
ج- کار با مرکز طراحي و توسعه نرم‌افزار از طريق اينترنت

  Online د- مشاهده محصولات به صورت
در جاي خالي عبارت مناسب را بنويسيد.

15- دکم��ه .............. امکان دسترس��ي ب��ه الگوهاي از پيش آم��اده FreeHand را فراهم 
ميک‌ند.

16- ........... يک�� برنام��ه، راهنما و هدايت کننده براي اجراي س��ريع و راحت فرمان‌ها و 
دستورالعمل‌هاي موردنظر کاربر است.

17- در نرم‌افزار پيکس��لي با ........... پيکس��ل‌ها جزييات تصوير بيش��تر ش��ده و با .......... 
پيکسل‌ها جزييات تصوير کمتر شده و حجم آن کاهش مي‌يابد.

به سؤالات زير پاسخ تشريحی دهيد.
18-  سه مورد از مزاياي برنامه گرافيکي برداری را بيان کنيد.

 19- حداقل چهار مورد از کاربردهاي FreeHand را بنويسيد. 
آزمون عملي

1- در برنامه فتوشاپ، تأثير تغيير کيفيت تصوير در اندازه و حجم آن را نشان دهيد.
2- نرم‌افزارFreeHand  را در درايو موردنظر نصب کرده و اجرا کنيد.

3- مواردي که در نگارش جديد نرم‌افزار اضافه ش��ده بررس��ي کرده و روش بهک‌ار بردن 
Help برنامه را نشان دهيد.
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كليات
نرم‌افزار FreeHand MXa داراي محيطي ش��بيه نسخه‌هاي قبلي اين نرم‌افزار است؛ البته 

ابزارها و قابليت‌هاي جديدي به آن افزوده شده است که به شرح آن خواهيم پرداخت. 
FreeHand MXa 1-3 شناخت محيط نرم‌افزار

پس از نصب اين برنامه که در واحد كار قبل گفته شد، از مسير زير برنامه را اجرا کنيد.
Start→All Programs→Macromedia→Macromedia FreeHand MXa

با اجراي برنامه، محيط کار FreeHand MXa ظاهر مي‌شود. اکنون مي‌توانيد براي ترسيم، 
ي��ك صفحه طراحي جديد ايجاد کنيد يا با اس��تفاده از فرمان File→Open يک فايل ذخيره 

شده را باز کنيد. 
ايجاد فايل جديد

براي ايجاد صفحه جديد به يکي از روش‌هاي زير عمل کنيد:
1- فرمان File→New را انتخاب کنيد.

2- کليد ميانبر Ctrl+N را بفشاريد.
3- ابزار  را از نوار ابزار اصلي برنامه انتخاب کنيد. 

که در اين صورت صفحه‌اي مطابق با ش��کل 1-3 ظاهر مي‌ش��ود كه مي‌توانيد در قسمت 
صفحه طراحي )به شكل يك ورق كاغذ ديده مي‌شود( ترسيمات خود را انجام دهيد.

      

FreeHand MXa شکل 1-3 محيط کار
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Main 1-1-3 نوارابزار

اين نوارابزار در بالاي پنجره برنامه و در زير نوار منو واقع ش��ده و حاوي آيکن‌هايي است 
که امکان دسترسي سريع به فرمان‌هاي مورداستفاده در FreeHand را فراهم مي‌سازد؛ نظير 
فرمان‌ه��اي Save، پنل Lock ،Object يا قفل موضوعات و غيره )ش��کل 1-3(. این نوار ابزار با 

استفاده از روش هایی که ذکر می شود قابل انتخاب است:  
 •  کلي  کراست  روي قسمت خاکستري نوارهاي ابزار ديگر)مانند نوار Info( بجز  نوارمنو	

Window→Toolbars→Mainانتخاب نوار ابزار موردنظر 
جدول 1-3  توضيح آيکن‌هاي نوارابزار

توضيحاتنام آيكنآيكن
Newايجاد يک فايل جديد
Openبازکردن فايل ذخیره شده
Saveذخيره فايل جاري

ImportFreeHand واردکردن فايل‌ها‌ از برنامه‌هاي ديگر به
Printچاپ فايل جاري
Lock   قفلک‌ردن موضوع انتخاب شده

Unlock   بازکردن قفل موضوع انتخاب شده
Graphicsجستجو و جايگزيني

Align  Alignبازکردن پنل
TransformTransform بازکردن پنل

LibraryLibrary بازکردن پنل
ObjectObject بازکردن پنل

Windowبازکردن‌فايل‌بدون‌بستن فايل‌هاي‌ديگر با‌قابليت‌دسترسي به‌تمامي پنل‌ها

Color MixerColor Mixer بازکردن پنل
SwatchesSwatches بازکردن پنل

LayersLayers بازکردن پنل
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)Info( 2-1-3 نوارابزار اطلاعات

اين‌ نوار در پايين پنجره برنامه ظاهر مي‌ش��ود و اطلاعاتي ش��امل اندازه، موقعيت و ساير 
خصوصيات موضوعات ترسيمي و موقعيت اشاره‌گر را نشان مي‌دهد )شکل 3-2(.

 Info شکل 2-3 نوارابزار

)Toolbox( 3-1-3 جعبه ابزار

جعبه‌ابزار در FreeHand MX دربرگيرنده ابزارهاي مختلفي است. 
جعبه‌ابزار Tools با استفاده از روش‌هاي زير ظاهر مي‌شود:

• 	Window→Tools انتخاب گزينه
• 	Ctrl+F2 کليد ميانبر

)Panels( 4-1-3 پنل‌ها

زماني که اولين بار وارد FreeHand مي‌شويد کادرهايي را مشاهده ميک‌نيد که با يکديگر 
ترکيب ش��ده‌اند و در سمت راست محيط برنامه قرارگرفته‌اند، به هر کدام از اين کادرها پنل 
مي‌گويند كه مي‌توانيد آن‌‌ها را جا‌به‌جا کنيد، از حالت ترکيب شده خارج نماييد و با پنل‌هاي 

مورد نظرخود در يک گروه قرار دهيد. 
پنل‌ها با استفاده از روش‌هاي زير قابل دستيابي هستند:

•  منوي Window و انتخاب پنل موردنظر 	
• 	Main انتخاب پنل موردنظر از نوار ابزار 

* اين پنل‌ها به طور پيش‌فرض با يکديگر گروه‌بندي شده‌اند:
• ق��رار گرفته‌ان��د  	Properties در يک�� گ��روه ب��ه ن��ام Document و Object پن��ل  

)شکل 3-3(.
• پنل  Styles ،Swatches وLibrary در يک گروه به نام  Assets قرارگرفته‌اند.	
• پنلColor Mixer  و Tints در يک گروه به نام  Mixer and Tints قرارگرفته‌اند.	
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  Properties شکل 3-3 پنل گروهي

• پنل Align و Transform در يک گروه به نام  Align and  Transformقرارگرفته‌اند.	
برخي از پنل‌ها نظير Layers با پنل‌هاي ديگري گروه‌بندي نش��ده‌اند ولي ش��ما مي‌توانيد 

آن‌ها را به دلخواه با پنل‌هاي ديگر در يک گروه قرار دهيد.
در س��مت راست پنل‌ها، آيکني به نام Panel’s Options Menu )شکل 4-3( قرار دارد که 

اگر روي آن کليک کنيد منوي كنترلي پنل باز مي‌شود.

 )Panel’s Options Menu( شکل 4-3 نمايش منوي پنل

اعمالي که مي‌توان روي پنل‌ها انجام داد عبارتند از:
کوچک و بزرگ کردن پنل‌ها

مثلث نوار عنوان پنل را کليک کنيد. هنگاميک‌ه جهت‌مثلث به س��مت‌پايين باشد اجزاي 
پنل نمايش مي‌يابد و در صورتي که جهت مثلث به س��مت راس��ت باشد فقط نوارعنوان پنل 

نشان داده مي‌شود.
جابه‌جاکردن پنل‌ها در بين گروه‌ها

براي انجام اين عمل مراحل بعد را انجام دهيد:
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1- روي منوي كنترلي پنل کليک کنيد.
 2- يکي از گروه‌هاي پنل را از زيرمنوي »With نام پنل Group« انتخاب نماييد يا گزينه
New Panel Group را برگزيني��د ت��ا پنل به گروه موردنظر انتقال يابد. در اين صورت پنل در 

يک پنجره جداگانه قرار خواهد گرفت.

 مث�ال 1: مي‌خواهيد پنل Mixer را که ب��ا پنل Tints در يک گروه قرار گرفته به 
پنل Document منتقل کنيد؛ براي اين منظور مراحل زير را انجام دهيد:

1- منوي كنترلي پنل Mixer را باز کنيد.
  Documentرا انتخاب کرده و از زير منوي باز ش��ده گزينه Group Mixer with 2- گزينه

را برگزينيد )شکل 3-5(.

شکل 5-3 جابه‌جايي پنل‌ها

3- در اين صورت پنل Mixer به صورت زبانه‌اي در پنل Document قرار مي‌گيرد.

 توجه: قبل از انتقال، پنل مقصد بايد روي صفحه قرار داشته باشد.

تمرين 1: پنل Layers را به پنل Object منتقل كنيد.

تغييرنام پنل‌هاي گروهي
براي تغيير نام يک پنل گروهي به صورت زير عمل کنيد:

1- از منوي پنل موردنظر، گزينه Rename Panel Group را انتخاب کنيد.
2- در نوار عنوان پنل، مکان‌نما به صورت چشم‌کزن ظاهر خواهد شد.
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 3- ن��ام جدي��د را  تاي��پ کرده و کلي��د Enter را بفش��اريد ت��ا نام جديد اعمال ش��ود 
)شکل 3-6(.

شکل 6-3 تغييرنام پنل گروهي

تمري�ن 2: نام پن��ل گروه��ي Object and Document را ب��ه My Layout تغيير 
دهيد.

ترکيب )dock( پنل‌ها 
مي‌تواني��د پنل‌ها را با يکديگ��ر و با پنل‌هاي گروهي ترکي��ب )dock( کنيد. هنگامي که 

پنل‌ها dock مي‌شوند جابه‌جايي آن‌ها روي صفحه نمايش آسان‌تر خواهد شد. 
براي اين منظور مراحل زير را انجام دهيد:

1- اشاره‌گر را به گوشه سمت چپ پنل موردنظر برده و نقاط gripper را که در اين محل 
قرار دارند، درگ کنيد )شكل 3-7(.

gripper شکل 7-3 نمايش نقاط

2- پنل را به س��مت پنل موردنظر برده و كليد ماوس را رها کنيد. در اين صورت پنل‌ها 
با هم ترکيب مي‌شوند )شکل 3-8(.

شکل 8-3 پنل‌هاي ترکيب )dock( شده
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 توج�ه: با اس��تفاده از درگ نق��اط gripper مي‌توانيد پنل‌ه��ا را از حالت dock خارج 

کنيد.
توصيف پنل‌ها

هر پنل ويژگي متفاوتي دارد كه در اين جا برخي از پنل‌ها به اختصار ش��رح داده ش��ده 
است:

پنل Object: امكان تنظيم زمينه، خط دور و جلوه‌هاي اشياء را فراهم مي‌كند. همچنين 
مي‌‌توانيد موقعيت و اندازه اش��ياء را تنظيم كنيد. گزينه‌هاي اين پنل برحس��ب شئ انتخاب 

شده تغيير مي‌كند.
پنل Document: به منظور ايجاد، اصلاح صفحات سند و وضوح چاپ به‌كار مي‌رود.

پنل Layers: كنترل ترتيب ظاهر ش��دن اشياء در صفحه نمايش را امكان‌پذير مي‌كند. از 
لايه‌ها مي‌توان به عنوان بخشي از ايجاد انيميشن‌ها استفاده كرد.

پنل Swatches: رنگ‌ها را ذخيره كرده و امكان اعمال آن‌ها را به خط دور يا زمينه براي 
اشكال فراهم مي‌سازد.

پنل Mixer: امكان تعريف رنگ‌ها را امكان‌پذير مي‌كند.
پنل Styles: به شما امكان مي‌دهد ظاهر تصاوير گرافيكي و متن را به صورت شيوه‌هايي 

ذخيره كنيد تا بعداً به ساير اشياء اعمال كنيد. 
پنل Tints: امكان ايجاد ته‌رنگ‌ها را فراهم مي‌كند.

پن�ل Library: نماده��اي گرافيكي را ذخيره كرده و از اي��ن نمادها براي كار با قلم‌موها، 
ايجاد صفحات اصلي و ايجاد انيميشن‌هاي SWF( Flash( استفاده مي‌شود.

پنل Align: براي تنظيم ترازبندي يا توزيع اشياء به‌كار مي‌رود.
پن�ل Transform: در اين پن��ل امكان جابه‌جايي، چرخش، تغيي��ر مقياس، كج‌كردن و 

انعكاس اشياء فراهم مي‌شود.
2-3 تنظيمات واحد اندازه‌گيري

در پايي��ن پنجره برنامه FreeHand MXa، نوار وضعي��ت )Status(  قرار دارد و دربرگيرنده 
گزينه‌هايي اس��ت که در ش��کل 9-3 نشان داده شده اس��ت. براي انتخاب واحد اندازه‌گيري 
بايد روي منوي بازش��ويUnits   از نوار وضعيت كليك کرده و واحد موردنظر خود را انتخاب 
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کنيد )مثلًا به‌ ميلي‌متر(. با انتخاب اين واحد، همه اشکال و موضوعاتي که از اين به بعد رسم 
مي‌شوند و همچنين خطک‌ش، برحسب آن واحد محاسبه خواهند شد.

(Status) شکل 9-3 نوار وضعيت

)Preferences( 3-3 تنظيمات ساختاري
با اس��تفاده از کادرمحاوره Preferences مي‌توانيد نحوه عملکرد برنامه FreeHand MXa را 

کنترل کرده و پارامترهاي اجرايي و ساختاري برنامه را تنظيم کنيد.
• را انتخ��اب کني��د، در اين‌ص��ورت کادرمحاوره  	Preferences گزين��ه Edit از من��وي
Preferences ظاهر مي‌ش��ود که شامل ده زبانه است و هرکدام تنظيمات بخش‌هايي 

از برنامه را به عهده دارند )شکل 3-10(.

Preferences شکل 10-3 کادرمحاوره



Free Hand پیمانه مهارتی : کاربر
41واحد کار سوم: توانایی شناخت محیط نرم افزارFreeHand  MXa و کار در آن 

 توجه: براي کار با Preferences، از كليد ميانبر Ctrl+U هم مي‌توانيد استفاده كنيد.

• وجود دارد که تنظيمات جاري را به حالت پيش‌فرض  	Defaults در همه زبانه‌‌‌ها دکمه
اوليه برمي‌گرداند. در ادامه به توضيح برخي از پارامترهاي مهم موجود در اين زبانه‌‌‌ها 

مي‌پردازيم:
1- زبانه General: تنظيمات عمومي در اين محل انجام مي‌گيرد.

ها براي برگرداندن اعمال انجام شده به عقب را تعيين ميک‌ند  • 	Undo تعداد :Undo's

که بهتر است مقدار آن‌را افزايش دهيد.
 توجه: Ctrl+Z  کليد ميانبر Undo است.

 

2- زبانه Object: تنظيمات مربوط به موضوعات و اشکال در اين محل انجام مي‌گيرد.
• و درگ  	Alt ب��ا فع��ال ب��ودن اين گزينه، نگه‌داش��تن کليد :Alt-drag copies paths

موضوع باعث کپي آن مي‌شود.
• اعدادي که در اين کادر وارد مي‌ش��وند، نشانگرضخامت‌هاي  	:Default Line weights

از پيش تعريف شده براي ابزار Line هستند.
3- زبانه Text: پارامترهاي تنظيمي مربوط به متن را کنترل ميک‌ند.

• را برگزينيد و روي  	Type بافعال بودن آن، درصورتيک‌ه ابزار :Always Use Text Editor

صفحه کليک‌کنيد يک کادر‌متني براي تايپ يا ويرايش‌متن‌موردنظر باز‌مي‌شود.
4- زبان�ه Document: تنظيم��ات مرب��وط به صفحات ايجاد ش��ده در س��ند را کنترل 

ميک‌ند.
• با اين گزينه مي‌توانيد يک فايل دلخواه را انتخاب کنيد  	:New document template

ت��ا در هنگام اجراي فرم��ان File→New صفحه جديد با فراخوان��ي اين فايل ايجاد 
شود.

• با فعال بودن آن در هنگام خروج  	:Always Review unsaved documents upon Exit

از برنامه، کادري ظاهر مي‌ش��ود که اعلان ميک‌ند تمام اسناد ذخيره نشده را ذخيره 
کنيد.
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5- زبان�ه Import: تنظيم��ات مربوط به فايل‌هاي وارد ش��ده ب��ه FreeHand را کنترل 
ميک‌ند.

6- زبانه Export: پارامترهاي تنظيمي مربوط‌ به فايل‌هاي صادر ش��ده از FreeHand به 
برنامه‌هاي ديگر را کنترل ميک‌ند.

7- زبان�ه Spelling: تنظيمات مرتبط با تصحيح متون تايپ ش��ده انگليس��ي را کنترل 
مي‌كند.

8- زبان�ه Colors: پارامتره��اي مرب��وط ب��ه نمايش رنگ‌ها توس��ط مانيت��ور را کنترل 
ميک‌ند.
• Guide color: تغيير رنگ خطوط راهنما	

• Grid color: تغيير رنگ خطوط شبکه‌اي 	

• انجام مديريت رنگ‌ها توس��ط مانيتور را انجام مي‌دهد يعني  	:Color management

نحوه ظاهر شدن رنگ‌ها روي صفحه نمايش را تعيين ميک‌ند.
9- زبان�ه Panels: تنظيمات‌مربوط‌ب��ه ‌نحوه نمايش ابزار و پنل‌ها در اين قس��مت انجام 

مي‌گيرد.
• فعال بودن اين گزينه باعث مي‌شود که با نگه‌داشتن اشاره‌گر ماوس  	:Show Tooltips

روي يک ابزار يا آيکن، نام آن نمايش داده ‌شود.
• در منوي بازشو اين گزينه، مي‌توان در پنل  	Text با انتخاب :Label Panel tabs with

جاري فقط نام زبانه‌هاي پنل را مشاهده کرد.
با انتخاب Icon، يک آيکن به نام زبانه پنل نشان داده مي‌شود.

 انتخابText and Icon ، س��بب نمايش نام به همراه آيکن در زبانه پنل مي‌ش��ود 
)شکل 3-11(.

شکل 11-3 سه تنظيم براي برچسب‌هاي زبانه‌هاي پنل

10- زبان�ه Redraw: وضعي��ت پ��ردازش تصاوير توس��ط مانيتور در اي��ن محل کنترل 
مي‌شود.

• فعال بودن اين گزينه، منحني و لبه‌هاي موضوعات  	:Enable Anti-aliasing گزين�ه
را حتي در زمان بزرگنمايي نرم‌تر نشان مي‌دهد.
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 ، • 	Preview براي بالا بردن سرعت پردازش تصوير در حالت :Redraw while scrolling

 Scroll بهتر اس��ت اين گزينه غيرفعال باش��د، در اين‌صورت وقتي توس��ط کليدهاي
)کليدهاي پيمايش صفحه(، صفحه را جابه‌جا ميک‌نيد بعد از توقف، تصوير پردازش 

مي‌شود يعني تصوير در حين Scroll  قابل ديدن است.
4-3 روش‌هاي بازکردن يک تصوير گرافيکي

ش��ما مي‌توانيد ترس��يماتي را که ايجاد و ذخيره کرده‌ايد، در برنامه FreeHand باز کنيد. 
همچنين تصاوير با فرمت‌هاي گوناگون در اين برنامه قابل باز شدن هستند.

Open 1-4-3 فرمان

با اس��تفاده از اين فرمان مي‌توان فايل‌هاي گرافيکي که براي FreeHand قابل شناس��ايي 
است، باز کرد. اين فرمان به چند روش اجرا مي‌شود:

File از منوي Open 1- انتخاب گزينه
  Ctrl+O 2- فشردن همزمان کليد تركيبي

Main 3- کليک روي آيکن  از نوار ابزار
کادرمحاوره Open در FreeHand مشابه نرم‌افزارهايي است که قبلًا با آن‌ها آشنا شده‌ايد 

بنابراين در اين جا از توضيحات بيشتر صرفنظر مي‌شود.

 نكته: با استفاده از گزينه Open Recent در منوي File مي‌توانيد فايل‌هايي را که 
اخيراً بازکرده‌ايد، مشاهده کنيد.

Import 2-4-3 فرمان

فرمان Import که در منوي File واقع شده است؛ به منظور وارد کردن فايل‌هاي گرافيکي 
ديگري غير از فرمت FreeHand به اين برنامه بهک‌ار مي‌رود. همچنين مي‌توانيد اين فرمان را 

با کليک روي آيکن  در نوار ابزار Main اجرا کنيد.
ب��ا اجراي فرمانFile→Import  کادر محاوره Import Document مطابق ش��کل 12-3 باز 

مي‌شود.

 توجه: کليد تركيبي Ctrl+R روش ديگري براي اجراي فرمان Import است.
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Import Document شکل 12-3 کادر محاوره

با روش اجراي آن در نرم‌افزار Photoshop قبلًا آشنا شده‌ايد.

 توجه: در منوي بازشو Files of type چنانچه All Known Types را انتخاب کنيد، در 

مرورگر کادر محاوره Import همه فايل‌هايي که يکي از قالب‌ها يا فرمت‌هاي قابل شناس��ايي 
توسط FreeHand را داشته باشند، نشان داده مي‌شوند.

كادر Preview پيش نمايش فايل اس��ت که هنگام مرور فايل‌ها، با ارائه پيش‌نمايش��ي از 
محتويات آن‌ها مي‌توان فايل موردنظر را به سرعت يافت.

پس از انتخاب فايل موردنظر روي دکمه Open کليک کنيد تا فايل فراخواني ش��ود، در 
اين صورت اشاره‌گر ماوس به صورت  تبديل شده و اکنون در هر کجا از صفحه گرافيکي 

کليک کنيد، فايل در آن نقطه درج مي‌شود. 

 توج�ه: پس از اجراي فرمان Import اگر بخواهي��د تصوير به اندازه موردنظر روي 
صفحه درج شود، بايد به اندازه دلخواه درگ کنيد.

فايل‌هاي گرافيکي پيکسلي )طرح بيتي يا Bitmap( با فرمت‌هاي tiff ،jpg و غيره پس از ورود به 
FreeHand، به صفحه جاري متصل )Link( مي‌شوند اما نمي‌چسبند؛ به عبارت ديگر وارد شدن آن‌ها به 

 صفحه در حجم فايل تأثيري ندارد و حجم آن زياد نمي‌شود و تنها از طريق مسيري که داده شده، 
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پيش‌نمايشي از آن در FreeHand نشان داده مي‌شود که قابل چاپ نيز هست.
اين خصوصيت باعث مي‌ش��ود که در صورت انتقال فاي��ل FreeHand به کامپيوتر ديگر، 
چنانچه فايل‌هاي پيکس��لي متصل شده )Link ش��ده( به فايل FreeHand موجود باشند، اين 
فايل‌ه��ا نيز همراه با فايل FreeHand منتقل ش��وند، در غير اي��ن صورت در کامپيوتر مقصد 

نمايش داده نخواهند شد و به صورت ديده مي‌شوند.
فايل‌ه��اي پيکس��لي را از طريق فرم��ان Edit→Links به فاي��ل FreeHand به طور کامل 

بچسبانيد )Embedded( که در اين صورت به حجم فايل افزوده مي‌شود.

 توجه: زماني که تعداد صفحات سند جاري زياد باشد و در اغلب صفحات فايل‌هاي 

ورودي پيکسلي داشته باشيم، در اين صورت Link کردن فايل پيکسلي جالب نيست و باعث 
افزايش بي‌رويه حجم فايل FreeHand خواهد شد.

تمرين 3: تفاوت فرمان Import و Open را بيان كنيد.

 مثال 2: در طراحي ش��کل 13-3 از ‌Shapeهاي Photoshop استفاده کرده و آن‌ها 
را در سند خود وارد کنيد. 

شکل 3-13

1- ابتدا شکل سگ را با ابزارهاي مناسب رسم کنيد.
2- ردپاي س��گ و شکل استخوان‌ها را با استفاده از Shape ها در Photoshop رسم کرده 

و در فايل‌هاي جداگانه با پسوند tif. ذخيره کنيد.
3- فايل‌ها را با فرمان Import وارد کار طراحي خود کرده و طبق ش��کل 13-3 در محل 

و در جهت مناسب  قرار دهيد.
تمرين 4: آرم موجود در شکل 14-3 را با استفاده از نرم‌افزار فتوشاپ رسم کرده، 
سپس در يک واژه‌پرداز )مثل WordPad(، متن زير آن را تايپ کرده و وارد )Import( محيط 
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FreeHand کنيد )کاربرد فرمان Import در وارد کردن متون طولاني(.

شکل 3-14

5-3 بزرگنمايي
در هن��گام کار، گاهي اوقات لازم مي‌ش��ود ��که براي ديدن جزييات بيش��تري از تصوير 
يا طرح، بخش��ي از آن بزرگنمايي ش��ود يا براي ديدن قس��مت‌هاي بيشتري از تصوير، عمل 

کوچکنمايي انجام گيرد.
براي اين عمل، روش‌هاي مختلفي وجود دارد که برخي از اين روش‌ها عبارتند از:

 Magnification 1-5-3 منوي بازشو

توسط اين منو که در شكل 15-3 نشان داده شده‌ است، مي‌توانيد يكي از بزرگنمايي‌هاي 
از پيش تنظيم شده را انتخاب كنيد. براي دسترسي به اين منوي بازشو از منوي View گزينه  

Magnification را برگزينيد.

Magnification شکل 15-3 فرامين بزرگنمايي گزينه

همچني��ن مي‌توانيد از منوي بازش��و Magnification واقع در نواروضعيت )شك��ل 3-9( 
بزرگنمايي موردنظر را انتخاب كنيد يا درصد بزرگنمايي موردنظر را تايپ كرده سپس كليد 

Enter را بفشاريد.

 Zoom 2-5-3 ابزار

انتخاب ابزار  در جعبه‌ابزار Tools يا فشردن کليدZ  از صفحه کليد علامت ذره‌بين را 
در اختيار شما قرار مي‌دهد. بعد از انتخاب اين ابزار روي ذره‌بين علامت + نشان داده مي‌شود. 
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ب��ا هر بار كليك‌، ميزان بزرگنمايي افزايش مي‌ياب��د؛ همچنين مي‌توان با ابزارZoom  اطراف 
شکل موردنظر کادري رسم کرد تا عمل بزرگنمايي انجام شود.

 نكته: درحالي که ابزارZoom  انتخاب شده است، مي‌توانيد با نگه‌داشتن کليد Alt شئ بزرگ 
شده را كوچك کنيد.

 تمرين 5: بررسي کنيد کليد ميانبر Ctrl+Spacebar چه عملي انجام مي‌دهد.
View 3-5-3 گزينه‌هاي بزرگنمايي در منوي

منويView  ش��امل گزينه‌هايي اس��ت که به منظور انجام عمل بزرگنمايي )Zoom(  براي 
تنظيم نمايش شئ انتخابي در صفحه به کار مي‌رود که در جدول 2-3 شرح داده شده‌اند.  

View از منوي Zoom جدول 2-3 گزينه‌هاي مربوط به

Fit SelectionCtrl + Alt + 0 بزرگنمايي را طوري تغيير مي‌دهد که فقط موضوع يا موضوعات انتخابي
در بزرگ‌ترين حالت، نمايش داده شود.

Fit To PageCtrl+Shift+W با اين گزينه مي‌توانيد صفحه جاري را به همراه همه موضوعات موجود
در آن مشاهده کنيد.

Fit AllCtrl + 0 بزرگنمايي به گونه‌اي خواهد شد که مي‌توانيد تمام صفحات موجود در
سند را مشاهده کنيد. 

Magnification)3-19 در اين مجموعه، انواع حالت‌هاي بزرگنمايي از 6% تا 800% وجود دارد. )شکل

تمرين 6: با اس��تفاده از زيرمنوي Magnification در قس��متي از تصوير دلخواه، 
بزرگنمايي 200% و کوچکنمايي 25% را اعمال کنيد.

 نكته: منوي بازش��وي بزرگنمايي )Magnification( در نوار وضعيت )Status( نيز 
شامل گزينه‌هاي مربوط به Zoom است.

6-3 كاربرد ابزار Hand در هنگام بزرگنمايي
در برخ��ي از ح��الات مثلًا هنگامي كه بزرگنمايي را افزايش مي‌دهيد، براي ديدن س��اير 
قسمت‌هاي تصوير نياز به ابزار Hand داريد. از اين ابزار براي جابه‌جايي به سمت بالا، پايين، 
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راست، چپ و مايل استفاده مي‌شود.
Hand استفاده از ابزار

1- از جعبه ابزار Tools ابزار Hand را انتخاب كنيد يا كليد H از صفحه كليد را بفشاريد 
)شكل 3-16(.	

Hand شكل 16-3 ابزار

2- با اين ابزار در پنجره سند كليك كنيد و ماوس را به سمت دلخواه بكشيد.

 نكت�ه: هنگام اس��تفاده از هر اب��زاري اگر كليد Spacebar را نگ��ه داريد‏، ابزار 
Hand براي جابه‌جايي، روي صفحه نمايش در اختيار شما قرار مي‌گيرد.

7-3 تنظيم حالت‌هاي نمايشي تصوير
FreeHand MXa گزينه‌هاي‌مختلف��ي را ب��راي نحوه نمايش تصوير يا طراحي ش��ما روي 

صفحه نمايش ارايه مي‌دهد. برخي از اين گزينه‌ها جزييات بيشتري از کار را نشان مي‌دهند 
ولي‌مدت ‌زيادي طول ميک‌ش��د تا اين‌جزييات نشان داده ‌شود. بعضي‌گزينه‌ها سريع‌تر ولي با 

جزييات کمتري تصوير را نشان مي‌دهند.
در نواروضعيت، امکان انتخاب حالت‌هاي نمايش��ي وجود دارد )شکل 17-3( که عبارتند 

از: 

شکل 17-3 انواع حالت‌هاي نمايشي 

همه موضوعات و رنگ‌ها در ش��کل واقع��ي خود همراه با  • Preview : در اي��ن حالت 	

جزييات به نمايش درمي‌آيند و به عنوان پيش‌نمايشي از چاپ خواهند بود.
در اين حالت رنگ‌هاي اصلي نش��ان داده مي‌شود ولي طيف رنگ‌ها  • 	 : Fast Preview

)Gradient( و ترکيب‌ها )Blend( با جزييات‌ کمتري نمايش ‌مي‌يابند. سرعت نمايش 
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در اين حالت بيشتر از Preview است.

 نكته: اگر در حالت Preview باش��يد، انتخ��اب گزينه View→Fast Mode حالت 
Fast Preview را نمايش مي‌دهد.

Keyline: اين حالت نمايش��ي در منوي View يا با اس��تفاده از كليد ميانبر Ctrl+K قابل 

دستيابي است. با انتخاب اين گزينه، موضوعات به‌صورت خطوط محيطي ديده شده و رنگ‌ها 
مخفي مي‌ش��وند، بدين ترتيب با ساده‌تر ش��دن نمايش موضوعات، نحوه قرارگيري آن‌ها در 

صفحه بهتر مشاهده شده و انتخاب موضوعات راحت‌تر است.

 توجه: براي اصلاح گره‌1ها و مسيرها بهتر است از حالت نمايشي Keyline استفاده 
کنيد.

Fast Keyline : در اين حالت نمايش خطوط به صورت س��اده‌تر و خلاصه‌تر ارايه مي‌شود 

و روش سريع‌تري براي نمايش تصاوير در حالت Keyline است.

 View→Fast Mode باشيد، انتخاب گزينه Keyline نكته: در صورتي که در حالت 
حالت Fast Keyline  را نمايش مي‌دهد.

1- با اصطلاح گره و مسير در واحدهاي كار 5 و 6  آشنا خواهيد شد.
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شکل 18-3 انواع حالت‌هاي نمايشي

تمري�ن 7: يکي از تصاوير موجود در FreeHand را باز کنيد و به بررس��ي چهار 
حالت نمايشي روي آن بپردازيد.

8-3 ايجاد نماي ديد سفارشي
اگ��ر در هن��گام طراحي به نماه��اي مختلف ديد از نظر بزرگي و كوچ��كي مكرراً احتياج 
داشتيد، مي‌توانيد از طريق گزينه View→Custom نماهاي سفارشي را ايجاد و ذخيره كنيد. 

  مثال 3: ايجاد يک نماي سفارشي 
1- قس��متي از موضوع رسم شده را Zoom کنيد، مثلًا بزرگنمايي گوشه سمت چپ يک 

تصوير دلخواه را به 326% افزايش دهيد )شکل 3-19(.
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Zoom 3-19 شکل

2- گزينه View→Custom→New را انتخاب کنيد.
.)Left corner نامي را براي اين نما انتخاب کنيد )مثلًا New View 3- در کادرمحاوره

4- دکمه OK را کليک کنيد تا نما ايجاد شود.

شکل 20-3 تعريف نماي سفارشي

تمري�ن 8: نمايي به نام See با بزرگنمايي 85% براي تصوير دلخواه ايجاد کنيد، 
سپس آن‌را در حالت Fast Keyline نمايش دهيد. 
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Keyboard Shortcuts 9-3 فرمان
يکي از س��ريع‌ترين روش‌هاي کار در برنامه کاربردي، استفاده از کليدهاي ميانبر صفحه 

کليد است. 
ميانبرهاي صفحه کليد در FreeHand تقريباً ش��امل تمام فرمان‌هاي منويي و بسياري از 
آيتم‌هاي غيرمنويي اس��ت. مي‌توانيد ميانبرهاي صفحه کلي��د را به گونه‌اي تغيير دهيد تا با 
عادت‌‌هاي کاري شما در نرم‌افزارهاي ديگر هماهنگ شود، همچنين مي‌توانيد به فرمان‌هايي 
که فاقد کليد ميانبر هستند، ميانبر اضافه کنيد. ليست ميانبرهاي پيش‌فرض FreeHand  در 

ضميمه آمده است.
1-9-3 اختصاصي ک‌ردن ميانبرها

FreeHand به ش��ما امکان مي‌دهد تا ميانبرهاي صفحه کليدي را که به فرمان‌ها نس��بت 

مي‌دهي��د، اختصاصي کنيد، بنابراين مي‌توانيد ميانبرهايي را به فرمان‌ها اضافه کنيد يا آن‌ها 
را به نحوي تغيير دهيد که با ساير برنامه‌ها تطبيق داشته باشند. براي اين منظور به صورت 

زير عمل کنيد:
1- از من��وي Edit فرم��ان Keyboard Shortcuts را اجرا کنيد. در اين صورت کادرمحاوره 

Customize نمايان مي‌شود )شکل 3-21(.

wCustomize

2- از بخش‌س��مت‌چپک‌ادرمحاوره Customize فرم��ان موردنظر را ب��راي تعريف ميانبر 
انتخاب کنيد.
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 Current shortcut keys 3- در صورتي که کليد ميانبري قبلًا تعريف شده باشد در ناحيه
ظاهر مي‌شود، در غير اين صورت مي‌توانيد کليد ميانبري به آن اختصاص دهيد.

4- ب��راي تعري��ف ميانب��ر مي‌توانيد در کادر مت��ن  Press new shortcut keyبا فش��ردن 
،Alt+Ctrl با کليدهاي ديگر صفحه کليد همچنين کليد ترکيبي Ctrl يا Alt همزمان کليدهاي 

Shift+Ctrl  ياShift+Alt  با کليدهاي ديگر، ميانبر تعريف کنيد.

5- روي دکمه Assign کليک کنيد تا کليد ميانبر تنظيم شود.
6- حال با کليک دکمه Close به صفحه برنامه بازگرديد.

 نكته: در صورتي که ميانبر به فرمان ديگري نس��بت داده ش��ده باشد آن فرمان بعد از عبارت
Currently assigned to ظاهر مي‌شود.

 توجه: دکمه Remove کليد ميانبر نسبت داده شده به يک فرمان را حذف ميک‌ند.

تمرين 9: براي فرمان Magnification کليد ميانبرCtrl+Shift+M  را تعريف كنيد.
FreeHand MXa 10-3 انواع فرمت‌هاي نرم‌افزار

به منظور ذخيره‌س��ازي ترس��يمات، براي تهيه خروجي به کمک چاپگ��ر يا تهيه فيلم و 
زينک�� ب��راي چاپخانه و همچنين انتقال فاي��ل از FreeHand به س��اير برنامه‌ها )Export( يا 
وارد��کردن فايل از برنامه‌هاي گرافيک��ي به Import( FreeHand( دانس��تن عملکرد و موارد 
اس��تفاده از قالب‌بندي‌ها يا فرمت‌هاي مختلف فايل‌ها ضروري اس��ت. FreeHand فرمت‌هاي 

مختلفي را براي ذخيره يا فراخواني فايل‌هاي گرافيکي پشتيباني ميک‌ند.

 توجه: فرمت FH11، فرمت استاندارد و اصلي  FreeHand MXa است.

 • 	Photoshop را به نرم‌افزارهاي ديگري نظير FreeHand درصورتيک‌ه بخواهيد فاي��ل
انتق��ال دهيد، لازم اس��ت فايل را به کمک�� فرمان Export با فرمتي که س��ازگار با 

نرم‌افزار مقصد باشد، ذخيره کنيد.
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• ي��ا روش‌هاي ديگر،  	File→Save هنگام ذخيره‌س��ازي تصوير با اس��تفاده از گزين��ه
کادرمح��اوره Save باز مي‌ش��ود که مي‌تواني��د از منوي بازش��و Save As Type قالب 

)فرمت( ذخيره‌سازي فايل را از بين اين فرمت‌ها انتخاب کنيد:
 fh11-1 : فرمت اصلي فايل‌ها در FreeHand است که معمولاً ترسيمات با اين فرمت ذخيره 

مي‌شوند.
ft11 -2 1: براي محافظت فايل از تغييرات غيرعمدي بهک‌ارمي‌رود.

Eps -3 2: درصورتيک‌ه مي‌خواهيد از تصوير ساخته شده در يک برنامه گرافيکي برداري 
يا برنامه نشر روميزي )مثل Page Maker( استفاده کنيد، اين فرمت را بهک‌ار بريد.

• ش��رح داده ش��ده  رايج‌ترين فرمت‌هاي قابل اس��تفاده در FreeHand در جدول 3-3	
است.

  1-FreeHand Template

                                                                                                                       2-Encapsulated postscript
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 FreeHand MX جدول 3-3 فرمت‌هاي رايج در

فرمت )پسوند رديف
شرحفايل(

1Fh5,Fh7,Fh8,
Fh9,Fh10

 MX و نسخه FreeHand براي نقل و انتقال فايل بين نسخه‌هاي قديمي‌تر
بهک‌ار مي‌رود.

2cdr .بهک‌ار مي‌رود CorelDRAW و FreeHand انتقال فايل بين براي نقل و 
اين‌پسوند فرمت فايل‌هاي برنامه CorelDRAW است.

3txt.بهک‌ار مي‌رود .txt براي نقل و انتقال فايل‌هاي متني با پسوند

4ai.بهک  ار   مي‌رودAdobe Illustratorو FreeHand براي  نقل   ‌و    ‌انتقال     فايل     بين

5gif
از قالب‌هاي گرافيکي پيکسلي است که ضمن ذخيره‌سازي، عمل فشرده‌سازي را  يکي 
هم انجام مي‌دهد. اين فرمت براي طراحي بخش‌هاي مختلف صفحات Web نيز به‌كار 

مي‌رود.

6jpeg يا  jpg در RGB و CMYK فرمتي ‌بسيار رايج و‌ كم‌حجم براي ذخيره‌سازي فايل‌هاي
فشرده‌ترين حالت ممکن است و در محيط وب نيز بهک‌ار مي‌رود. 

7png است و فشرده‌سازي را بدون افت کيفيت Web فرمت قابل استفاده در صفحات
انجام مي‌دهد.

8psd فرمت اصلي فايل‌هاي فتوشاپ است که براي نقل و انتقال فايل‌هاي پيکسلي
بين FreeHand و Photoshop بهک‌ار مي‌رود.

9pdf.است Adobe Acrobat  Reader اين فرمت قابل‌استفاده در برنامه

10tif و FreeHand  بـراي نقــل  و انتقــال  فايل‌هــاي‌گرافيـــکي   پيکســلي    بيـن
برنامه‌هـاي گرافيکي پيکسلي نظير فتوشاپ بهک‌ار مي‌رود.

11bmp است. اين ‌فرمت Windows فرمت   ‌استاندارد    برنامه‌هاي‌گرافيکي سيستم      ‌عامل
‌تصاوير را به‌صورت طرح‌بيتي )پيکسلي( درخود ذخيره‌ مي‌سازد.

FreeHand 11-3 روش‌هاي ذخيره‌سازي در
هنگام طراحي لازم اس��ت فايل مکرراً ذخيره ش��ود؛ اين کار باعث مي‌شود که در صورت 
قطع ناگهاني برق يا قفل شدن کامپيوتر، فايل کاري از بين نرفته و از انجام ترسيمات مجدد 

جلوگيري شود. 
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  Save 1-11-3 فرمان

با اجراي فرمان Save کادر محاوره Save Document روي صفحه ظاهر مي‌شود که با کليه 
قسمت‌هاي آن در نرم‌افزارهاي ديگر آشنا شده‌ايد.

 توجه: کليد ميانبر Ctrl+S راه ديگري براي ذخيره ترسيمات است.

از من��وي بازش��وي Save as type مي‌تواني��د نوع قالب ذخيره‌س��ازي يا فرم��ت فايل را از 
بين‌فرمت‌هاي eps. وFh11. انتخاب کنيد.

 توج�ه: اگر فايلي را قبلًا ذخيره کرده باش��يد، پس از انج��ام ويرايش براي ذخيره 

تغييرات روي همان فايل با نام، پسوند و مسير قبلي از فرمان Save استفاده کنيد.
Save As 2-11-3 فرمان

 هرگاه بخواهيد فايل را با نامي ديگر يا با فرمت و مسير ديگري روي ديسک ذخيره کنيد، از فرمان
Save As يا از کليد ترکيبي Ctrl+Shift+S استفاده کنيد. کادرمحاوره‌اي که پس از اجراي اين 

فرمان باز مي‌شود مانند کادر محاوره Save است.

 نكت�ه: اس��تفاده از فرم��ان Save As امکان ايج��اد کپي‌هاي متعدد از فاي��ل را فراهم 
ميک‌ند.

تمرين10: ي‌‌ک تصوير ‌دلخواه را وارد صفحه FreeHand کرده س��پس آن را به‌نام
My Picture.fh11 ذخيره کنيد. 

Revert 12-3 فرمان
با استفاده از فرمان Revert مي‌توانيد به آخرين مرحله ذخيره شده در ترسيمات بازگرديد. 

براي انجام اين کار به صورت زير عمل کنيد:
1- از منوي File گزينه Revert را انتخاب کنيد.

 2- کادر هش��داري ظاهر مي‌ش��ود که از ش��ما مي‌خواهد فرم��ان Revert را تأييد کنيد. 
)شکل 3-22(.

3- دکمه Revert را کليک نماييد.
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شكل 3-22
FreeHand 13-3 سفارشي کردن محيط برنامه

در محيط برنامه FreeHand امکان سفارشيک‌ردن موارد زير وجود دارد:
• اختصاصي کردن ميانبرهاي صفحه کليد	
• تغيير در نوار ابزارها	
• تغيير در جعبه ابزار	

1-13-3 تغيير در نوار ابزارها و جعبه ابزار

ب��ه راحت��ي مي‌توانيد هر يک از نوار ابزاره��ا و جعبه ابزار را با آيکن‌ه��اي موردنظر خود 
اختصاصي کنيد، براي اين منظور مراحل بعد را انجام دهيد:

1- مسير Window→Toolbars→Customize را انتخاب کنيد. کادرمحاوره Customize با 
فعال بودن زبانه Toolbars نمايش مي‌يابد )شکل 3-23(.

2- ح��ال از س��مت چپ کادر مح��اوره، نوار اب��زاري را که مي‌خواهيد سفارش��ي کنيد، 
برگزينيد.

Toolbars با انتخاب زبانه Customize شکل 23-3 کادر محاوره

3- در اين صورت آيکن‌هاي مربوط به نوار ابزار )Toolbar  ( انتخاب شده در سمت راست 
کادرمحاوره نمايش مي‌يابد.

4- آيک��ن موردنظر را به داخل نوار ابزار يا جعبه ابزار درگ کنيد. در اين هنگام آيکن به 
ابزارها اضافه مي‌شود )شکل 3-24(. 
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شکل 24-3 اضافه کردن آيکن به جعبه ابزار

 نكته: در صورتي که کادرمحاوره Customize Toolbars باز باشد، مي‌توانيد آيکن‌هاي يک نوار 
ابزار را با آيکن‌هاي نوار ابزار ديگر جابه‌جا کنيد.

 Alt مي‌توانيد با نگه داش��تن کليد Customize Toolbars توجه: بدون باز کردن کادر محاوره 
و درگ، آيکن دلخواهي را از يک نوار ابزار به نوار ابزار ديگر منتقل کنيد.

 FreeHand 14-3 بستن فايل و خروج از
چند راه پيشنهادي براي بستن فايل:

 File از منوي  Close1- انتخاب گزينه
 Ctrl+W2- فشردن کليد ترکيبي

:FreeHand چند راه پيشنهادي براي خروج از
1- دابل کليک روي  از نوار عنوان

 File از منوي  Exit2- انتخاب گزينه
3- فش��ردن کليد تركيبي Ctrl+Q که همه فايل‌هاي باز را مي‌بندد و از FreeHand خارج 

مي‌شود.
)Title Bar( 4- انتخاب علامت  از نوار عنوان
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واژه‌نامه
Fitاندازه شدن، مناسب کردن

Informationاطلاعات
Modifyتغيير دادن

Panelقاب
Preferenceارجحيت
Revertبازگشت
Unitsواحدها

خلاصه مطالب 
• کردن‌پنل‌ها  	dock عمليات کوچک ‌و بزرگک‌ردن، جابه‌جايي، گروه‌ کردن، تغييرنام و

را مي‌توان انجام داد.
•نواروضعيت شامل اجزاي زير است:  	

•بزرگنمايي، انواع حالات نمايش��ي، دکمه‌هاي انتخاب صفحه، دکمه افزودن صفحه و  	
منوي بازشوي واحد اندازه‌گيري. 

• هردو براي‌‌بزرگنمايي‌وک‌وچکنمايي ‌ترس��يمات  	Magnification و Zoomگزينه‌ه��اي
بهک‌ار‌ مي‌رود. 

•در اين برنامه مي‌ت��وان فايل‌ها را با قالب‌بندي يا فرمت‌هاي مختلفي ذخيره کرد )با  	
 .)File از منوي Save As يا Save انتخاب گزينه

• را طبق نياز  	FreeHand نيز مي‌توانيد محيط Edit→Preferences با استفاده از گزينه
خود تنظيم کنيد. 

 • 	FreeHand مي‌توان تصاوير گرافيکي را در  Importو Open با اس��تفاده از فرمان‌هاي
باز کرد.

• همه موضوعات و رنگ‌ها در شکل واقعي خود و همراه با  	Preview در حالت نمايشي
جزييات نمايش مي‌يابند. حالت Fast Preview رنگ‌هاي اصلي را نش��ان مي‌دهد ولي 

طيف رنگ‌ها و ترکيبات با جزييات کمتر ظاهر مي‌شود. 
در  • حالت Keyline تصاوير را به صورت خطوط محيطي و بدون رنگ نش��ان مي‌دهد. 	
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حالتFast Keyline ، نمايش خطوط به صورت س��اده‌تر است و روش سريع‌تري براي 
نمايش تصاوير است.

مي‌ت��وان ميانبر صفحه کليد براي اجراي  • 	 Keyboard Shortcuts با اس��تفاده از فرمان
فرمان‌ها تعريف کرد.

• مي‌توانيد تغييرات فايل ترس��يمي را به آخرين مرحله  	Revert با اس��تفاده از فرمان
ذخيره‌سازي برگردانيد.

• مي‌توانيد نوارابزارها و جعبه ابزار را سفارشي کنيد. 	FreeHand در محيط



Free Hand پیمانه مهارتی : کاربر
61واحد کار سوم: توانایی شناخت محیط نرم افزارFreeHand  MXa و کار در آن 

آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- کليد Ctrl+0 بزرگنمايي را به حدي مي‌رساند تا تمام صفحات سند مشاهده شود.
2- کليد Shift ابزار Hand را در تصوير جابه‌جا ميک‌ند.

3- سرعت حالت نمايشي Fast Preview بيشتر از Preview است.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

  Revert                                 .است FreeHand 4- فرمان وارد کردن فايل در برنامه
Customize Toolbar                         فعال مي‌شود Z 5- ابزار بزرگنمايي که با کليد
       Import                                     6- لغو کليه اعمال به بعد از آخرين ذخيره‌سازي
            Zoom                        .است Window 7- گزينه سفارشي کردن نوار ابزارها که در منوي

گزينه صحيح را انتخاب کنيد.

8- کدام‌يک از اعمال زير روي پنل‌ها صورت نمي‌گيرد؟
الف- تغيير نام         ب- جابه‌جايي        ج- ترکيب )dock(          د- حذف

9-  با استفاده از کدام نوارابزار مي‌توان اطلاعاتي در زمينه ‌شکل ‌ترسيم ‌شده ‌و ‌همچنين 
موقعيت مکان‌نما به‌دست آورد؟

Tools د- نوار        Status ج- نوار          Info ب- نوار         Menu  الف- نوار
10- کدام گزينه نادرست است؟

الف- توسط نقاط gripper مي‌توان عمل ترکيب پنل‌ها را انجام داد.
ب- FreeHand يک نرم‌افزار برداري است.

ج- منوي Unit در نوار ابزار Info قرار دارد.
د- کليد Ctrl+F2 جعبه ابزار را نمايان ميک‌ند.

11-  براي رسيدن به بزرگنمايي 130% از کدام گزينه استفاده مي‌شود؟
الف- Magnification از منوي View و انتخاب %130

ب- تايپ 130% در منوي  Magnification از نواروضعيت
Ctrl+1 ج- فشردن کليد ترکيبي

View در منوي Zoom د- استفاده از گزينه
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12- تنظيم تعداد Undo ها در کدام کادر محاوره انجام مي‌گيرد؟
Customize -د 	Open  -ج 	General -ب     Preferences -الف

13-  ب��ا انتخ��اب ک‌دام حالت نمايش��ي تصاوير به صورت خطوط محيطي ديده ش��ده و 
رنگ‌ها مخفي مي‌شوند؟

     Preview -ب 		   Fast Preview-الف
د- گزينه‌هاي الف و ج صحيح هستند. 	  	          Keyline -ج

14- گزينه Fit all در منوي View به چه منظور استفاده مي‌شود؟
الف- حداکثر بزرگنمايي را بر اساس موضوع انتخاب شده در تصوير ارايه مي‌دهد.

ب- اگر چندين صفحه گرافيکي داشته باشيد همه صفحات را در محيط نشان مي‌دهد.
ج- صفحه گرافيکي را به‌طور کامل در محيط کار نشان مي‌دهد.

د- همان بزرگنمايي 100% است.
15- در مورد فرمان Revert کدام گزينه صحيح است؟

الف- براي بازگرداندن هر عملي به يک مرحله قبل بهک‌ار مي‌رود.
ب- لغو کليه اعمال انجام شده در ترسيمات انجام مي‌گيرد.

ج- کليه تغييرات در ترسيم به آخرين مرحله ذخيره‌سازي برمي‌گردد.
د- به منظور تازه‌سازي صفحات برنامه بهک‌ار مي‌رود.
16- فرمت استاندارد براي FreeHand MX چيست؟

FH10 -د   	FH -ج     	FH11 -ب      	FHMX -الف
17- مناس��ب‌ترين فرمت براي واردکردن فايل‌هاي بيت‌مپي يا پيکس��لي )مثل فتوشاپ( 

به FreeHand کدام است؟
TIF -د     	 GIF-ج     	 EPS -ب              PDF -الف

 در جاي خالي عبارت مناسب را بنويسيد.

18- فرمان .................. براي تعريف کليد ميانبر به‌کار مي‌رود.
19- دستور ............. فايل را با نام و مسير ديگر ذخيره مي‌کند.

 Preferences  در زبان��ه .................. از کادر  Display font preview20- دس��تور تنظيم��ي
است.
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به سؤالات زير پاسخ تشريحی دهيد.

21-  وظيفه نوارابزار Main در محيط FreeHand چيست؟
22- تفاوت فرمانOpen  با Import را بنويسيد؟

23- مد نمايشي Keyline چه تفاوتي با مد Preview دارد؟
24- چگونه مي‌توان تعداد مراحل Undo را در FreeHand افزايش داد؟

آزمون عملي

يک  سند به نام Free1.Fh11 ايجاد کنيد، سپس:
1- فايل تصويري دلخواهي را بازکنيد.

2- تصوير را در بزرگ‌ترين حالت ممکن نمايش دهيد.
3- پنل Tint را با Layer در يک گروه قرار دهيد.

4- نام پنل گروهي سؤال 3 را به My Panel تغيير دهيد.
5- بزرگنمايي صفحه را از طريق منوي View به 400% برسانيد.

6- براي فرمان Revert کليد ميانبر Alt+R تعريف کنيد.
7- اب��زار Save را از نوار اب��زار Main به نوار ابزار Info منتقل کنيد س��پس به جاي خود 

بازگردانيد.
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كليات
 )Template( ق��دم اول در طراحي پروژه‌هاي گرافيکي، ايجاد س��ند يا اس��تفاده از الگوها
اس��ت. به منظور صفحه‌آرايي هماهنگ در يك سند مي‌توانيد صفحه اصلي )Master Page( و 
 Document  تعريف كنيد و تنظيمات صفحات را با استفاده  از پنل )Child Page( صفحه فرعي
تغيير دهيد. همچنين در اين واحدكار با ابزارهاي كمك رس��م براي ترس��يمات دقيق آش��نا 

مي‌شويد.
1-4 ايجاد صفحه پيش‌فرض

همان‌طور که قبلًا توضيح داده ش��د، مي‌توانيد با اس��تفاده از ويزارد Welcome يک سند 
پيش‌فرض بس��ازيد. علاوه بر اين که با اجراي FreeHand س��ندي شامل يک صفحه خواهيد 

داشت، اجراي مسير File→New نيز فايل يک صفحه‌اي ايجاد ميک‌ند.
Document 2-4 پنل

صفحه گرافيکي )Art board( قس��متي از س��ند جديد اس��ت که به شکل يک ورق کاغذ 
ديده شده و در واقع همان بوم نقاشي محسوب مي‌شود و موضوعاتي را که مايليد چاپ شود 
بايد در اين ناحيه ترس��يم کنيد. ناحيه اطراف صفح��ه را چرکنويس )Pasteboard( مي‌نامند 

)شکل 4-1(.
ابعاد و جهت صفحه گرافيکي توس��ط پنل Document قابل تنظيم اس��ت و در واقع ابعاد 
چاپ را تعيين ميک‌ند. اين کادر محاوره شامل يک کادر پيش‌نمايش در سمت چپ است که 

موقعيت صفحات را نمايش مي‌دهد.
اين پنل در مجموعه پنلProperties  قرار دارد )ش��کل 2-4( كه از منوي Window قابل 

دسترسي است. 
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FreeHand شکل 1-4 نمايش صفحه در برنامه

Document شکل 2-4 پنل

Document نمايش پنل
پنل Document با استفاده از روش‌هايي كه ذكر خواهد شد، ظاهر مي‌شود:

گزينه Document را از منوي Window انتخاب کنيد تا پنل باز شود.
روي آيکن  از نوارابزار Main کليک کرده و زبانه Document را انتخاب کنيد.
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 Main توجه: لازم به ذکر اس��ت که دکمه  ب��ه صورت پيش‌فرض در نوار ابزار 
ق��رار ندارد و از مس��ير Window→Toolbars→Customize براي ق��رار دادن آن در نوار ابزار 

Main استفاده مي‌شود.

Document 1-2-4 تنظيم ابعاد صفحه در پنل

صفحه پيش‌فرض در پنل Document به ابعاد Letter اس��ت و با اس��تفاده از منوي بازشو، 
مي‌توان اندازه صفحه موردنظر را تعيين كرد. درصورتيک‌ه صفحات اس��تانداردي مثل A4 را 
انتخاب کنيد، صفحه گرافيکي به طور اتوماتيک براس��اس اندازه‌هاي استاندارد تنظيم خواهد 

شد.
درصورتيک‌ه اندازه موردنظر شما در منوي بازشو نباشد، مي‌توان ابعاد صفحه را به دلخواه 
تعيين يا به اصطلاح سفارشي کرد. براي اين منظور از منوي بازشو، گزينه Custom را انتخاب 
 )Height( کرده، سپس جهت قرار‌گيري صفحه را مشخص کنيد. در مرحله بعد طول صفحه
را در کادر x و عرض صفحه )Width( را در کادر y وارد کنيد، سپس کليد Enter را بفشاريد 

تا اندازه‌ها به صفحه اعمال شوند )شکل 4-3(.

 Document شکل 3-4 تنظيم ابعاد سفارشي در پنل

 نكته: قبل از تنظيم ابعاد صفحه در پنل Document، ابتدا بايد واحد اندازه‌گيري صفحه تعيين 
شود.

 )Page( 2-2-4 ابزارانتخاب صفحه

تنظيم ابعاد سفارش��ي )دلخواه( يک صفحه با ابزارPage  به دو روش انجام مي‌شود که به 
شرح زيرهستند:
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روش اول:
1- ابزارPage  را از جعبه‌ ابزار Tools انتخاب کنيد.

2- روي صفحه‌اي که مي‌خواهيد ابعاد آن ‌را تغيير دهيد، کليک کنيد تا دس��تگيره‌هايي 
در اطراف لبه‌هاي آن ظاهر شود. 

3- با کش��يدن فلش دوطرفه هر يک از دستگيره‌هاي اطراف صفحه، اندازه صفحه تغيير 
خواهد کرد )شکل 4-4(.

Page شکل 4-4 تنظيم ابعاد صفحه با ابزار

 Info توجه: در هنگام کشيدن دستگيره‌ها، براي مشاهده ابعاد صفحه به نوار ابزار 
توجه داشته باشيد.

 نكته: تغيير اندازه صفحه تأثيري بر اندازه موضوع ترسيمي ندارد.

روش دوم:
1- ابزارPage  را از جعبه ‌ابزار Tools انتخاب کنيد.

2- كليد Alt را نگه داشته، روي صفحه دابل کليک کنيد.
3- کادرمحاوره Modify Page ظاهر مي‌شود )شکل 4-5(.
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Modify Page شکل 5-4 كادر

3-2-4 چرخاندن صفحه 

براي افقي و عمودي کردن صفحه به صورت زير عمل کنيد:
1- ابزار Page را از جعبه ابزار انتخاب کنيد.

2- روي صفحه موردنظر کليک کنيد تا دستگيره‌ها در اطراف صفحه ظاهر شود.
3- اش��اره‌گر را به گوش��ه‌اي در خارج از صفحه حرکت دهيد تا به صورت منحني درآيد، 

حال به سمت پايين درگ کنيد تا جهت صفحه تغيير کند.

 توجه: با چرخش صفحه، جهت محتويات آن تغيير نميک‌ند.
برخي از اعمالي که با اس��تفاده از ابزار Page روي صفحه انتخاب ش��ده انجام مي‌شود در 

جدول 1-4 درج شده ‌است.

جدول 1-4 عملكرد ابزار Page روي صفحه

Page Tool شرحاعمال ابزار

 Page Tool در هنگام درگ صفحه با ابزار 
از صفحه جاري يک کپي مشابه تهيه ميک‌ند.کليد Alt را بفشاريد.

Page Tool+Del.صفحه جاري را حذف ميک‌ند

Page Tool+جابه‌جايي صفحه در فضاي چرکنويس همراه با محتويات صفحهدرگ صفحه

 Page Tool+Ctrl+جابه‌جايي صفحه در فضاي چرکنويس بدون  محتويات صفحهدرگ صفحه



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
70

تمرين 1: با ابزار Page يك كپي از صفحه جاري تهيه كنيد، سپس آن را افقي كنيد.

4-2-4 تنظيم حاشيه مجازي )Bleed( يک صفحه

معم��ولاً FreeHand MX بخش‌هاي خارج از يک صفح��ه را چاپ نميک‌ند، بنابراين براي 
تنظيم ناحيه اضافي يا حاش��يه در اطراف صفحه گرافيکي از قس��مت Bleed استفاده مي‌شود 
و با وارد کردن اندازه موردنظر و فش��ردن کليد Enter يک کادر خاکس��تري رنگ در اطراف 

صفحهک‌اري ظاهر مي‌شود که ناحيه Bleed نام دارد )شکل 4-6(.
دليل استفاده از Bleed را هنگام برش لبه‌هاي کاغذ در چاپخانه متوجه مي‌شويد چرا که 
کادر Bleed به عنوان محافظ، دور صفحه اصلي قرار مي‌گيرد تا درصورتيک‌ه قسمت کوچکي 

از کار شما خارج از صفحه اصلي قرار داشت، در زمان برش چاپ حذف نشود.

            

Document شكل 7-4 جابه‌جايي صفحه با استفاده از پنل       Bleed شکل 6-4 نمايش ناحيه

Document 5-2-4 جابه‌جايي صفحه از طريق پنل

با نگه داش��تن کلي��دSpacebar  همزمان با درگ صفح��ه در ناحيه پيش‌نويس مي‌توانيد، 
صفحه را جابه‌جا کنيد )شکل 4-7(.	

6-2-4 افزودن ابعاد سفارشي به ليست اندازه صفحه

درصورتيک‌ه بخواهيد از صفحه ايجاد شده با ابعاد سفارشي )دلخواه( زياد استفاده کنيد، 
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مي‌توانيد آن را به ليس��ت اندازه صفحات اس��تاندارد موجود بی افزاييد تا در آينده بتوانيد به 
سرعت به آن دست يابيد. براي اين کار مراحل زير را دنبال کنيد:

 Document از من��وي بازش��وي اندازه صفح��ه واقع در پن��ل Edit 1- انتخ��اب گزين��ه 
)شکل 4-8(.

Edit  Page Sizes شکل 8-4 نحوه نمايش کادرمحاوره‌

Edit Page Sizes در کادر محاوره New 2- کليک روي دکمه
Page Size 3- تعريف يک نام براي اندازه سفارشي در قسمت

4- وارد کردن اندازه موردنظر در کادر x و y )طول و عرض صفحه(
5- انتخاب دکمه Close که با بسته شدن کادر محاوره، اندازه‌ اختصاصي در منوي بازشو 

ظاهر خواهد شد.

 توجه: دکمه Delete در كادر محاوره Edit Page Sizes براي حذف اندازه سفارش��ي 

به کار مي‌رود.

7-2-4 وضعيت نمايش صفحات

در پايين کادر پيش ‌نمايش در پنل Document س��ه دکمه قرار دارد )ش��کل 9-4( که با 
کليک روي هر يک از آن‌ها در صورتي‌ که بيش از يک صفحه داشته باشيد، مي‌توانيد حالت 

نمايش آن‌ها را روي کادر پيش‌نمايش و داخل فايل تنظيم کنيد. 

شکل 9-4 وضعيت نمايش صفحات
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 نكت�ه: با درگ صفحات از داخل کادر پيش‌نمايش، مي‌توان صفحات گرافيکي را 
به منظور طراحي صفحات کتاب، تقويم و ... به هم چسباند.

تمرين 2: بررس��ي کنيد آي��ا روش ديگري براي کنار هم ق��راردادن صفحات يا 
چسباندن آن‌ها به يكديگر وجود دارد؟

Document 8-2-4 منوي کنترل در پنل

همان‌طور كه گفته شد در گوشه سمت راست بالاي پنل Document، منوي کنترل وجود 
دارد  که با کليک روي آن زيرمنويي باز مي‌ش��ود كه شامل گزينه‌هايي است که برخي 

از آن‌ها در اين‌جا آمده‌اند:
چنانچه به بيش از يک صفحه نياز داشته باشيد، مي‌توانيد از اين گزينه  • 	 :Add pages

براي اضافهک‌ردن صفحه جديد در کنار صفحه قبلي استفاده کنيد )شکل 4-10(.

Add Pages شکل 10-4 نحوه نمايش کادر

 نكته: براي افزودن تعدادي صفحه با اندازه‌هاي متفاوت، لازم است براي هر اندازه 
خاص ي‌کبار فرمان Add pages را اجرا کنيد.

• Duplicate: از صفحه جاري يک کپي مشابه تهيه ميک‌ند.	

• Remove: صفحه جاري را حذف ميک‌ند.	
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تمرين 3: يک س��ند به نام Test2 به همراه يک صفحه 60×40 سانتي‌متري، سه 
صفحه A4 و دو صفحه B5 ايجاد کنيد، به طوريک‌ه دو صفحه B5 به هم چس��بيده باش��ند؛ 

سپس کليه صفحات را نمايش دهيد.

  )Printer Resolution(9-2-4 درجه وضوح

با اس��تفاده از منوي بازش��و در پايين پنل Document مي‌تواني��د درجه وضوح تصوير يا 
کيفيت چاپ را تعيين کنيد؛ اين درجه هرچه بالاتر باشد کيفيت تصاوير در چاپ بهتر خواهد 

بود. درجه وضوح براي صفحه نمايش، 72dpi و براي چاپ، 300dpi است.

 توجه: واحد اندازه‌گيري وضوح تصوير dpi1 و به معني نقطه در اينچ است.

 مثال 1: تنظيمات صفحه مي‌خواهید سندي به نام Test1 را كه شامل دو صفحه 
يک��ي به ان��دازه 200×450 ميلي‌متر و ديگري به اندازه A5 با درجه وضوح dpi 350 اس��ت، 

ايجاد کنید، براي اين منظور مراحل زير را انجام دهيد:
1- ابتدا واحد اندازه‌گيري ميلي‌متر را از نوار وضعيت انتخاب کنيد.

2- ب��راي وارد کردن ان��دازه 200×450، از منوي بازش��و تنظيم ان��دازه صفحه در پنل 
Document  گزين��ه Custom را انتخاب و مق��دار450 را در کادر x و 200 را در کادر  y وارد 

کنيد.
3- مقدار dpi 350 را در منوي بازشو  Printer Resolution  وارد کنيد.

4- ح��ال صفحه اول ايجاد ش��ده اس��ت، براي ايج��اد صفحه دوم از من��وي کنترل پنل 
Document  گزينه Add pages را انتخاب کنيد.

 Page size عدد 1 را وارد کرده، سپس در منوي بازشو  Number of new pages5- در کادر
اندازه استاندارد A5 را انتخاب کنيد.

.)File→Save( ذخيره کنيد Test1 6- فايل را به نام

   1- Dot Per Inches   



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
74

Master Page 3-4 صفحه
 Master Page )صفحه اصلي1( اين امکان را مي‌دهد تا صفحه‌هاي سندي که ايجاد ميک‌نيد؛ 

صفحه‌آرايي ثابت و منس��جم و از قبل مش��خص شده داشته باش��د. مي‌توانيد ويژگي‌هايي از 
صفح��ه معمولي مانند محل قرارگيري متن و گرافيک آن را در Master Page تعريف کنيد و 
اين خصوصيات را به همه يا تعدادي از صفحه‌هاي موردنظرتان اعمال کنيد. بدين ترتيب هر 
تغييري كه در صفحه اصلي ايجاد مي‌كنيد به طور خودكار به صفحه‌هاي ديگر س��ند اعمال 

مي‌شود.

 توجه: مي‌توانيد يک يا بيش از يک صفحه اصلي در سند داشته باشيد.

 نكته: از Templates نيز براي ‌ايجاد ‌سندهاييک‌ه صفحه‌آرايي ‌آن‌ها از قبل‌ تعريف 
‌شده ‌است، استفاده مي‌شود.

FreeHand به شما امكان مي‌دهد كه يکMaster Page  جديد ايجاد کنيد يا صفحه سند 

جاري را به يک Master Page تبديل کنيد.
زماني‌که يک Master Page مي‌س��ازيد، اندازه، جهت‌و‌تنظيمات Bleed صفحه جاري سند 
ب��راي آن در نظر گرفته مي‌ش��ود، البته اگ��ر بخواهيد، مي‌توانيد تنظيم��ات صفحه اصلي را 
تغيير‌دهيد. هنگامي که يک صفحه سند را به Master Page تبديل ميک‌نيد، عناصر و اجزاي 

صفحه سند در Master Page قرار مي‌گيرد.
 در پنلLibrary ، صفحه اصلي به عنوان يک نماد گرافيکي مديريت مي‌شود و کارهايي که در 

)جدول2-4( درج شده روي آن قابل اجراست:
جدول 4-2

آشکار ساختنپنهان کردنحذفتغييرنامگروه‌بنديايجاد يک نسخه کپي

DuplicateGroupRenameDeleteHideShow

1- صفحه مادر 
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 توجه: براي اس��تفاده از Master Page در سندهاي ديگرِ FreeHand مي‌توانيد آن 
را Export كرده سپس آن را به سند جاري وارد )Import( كنيد.

 • 	Childبه يک Master Page هنگام��ي که با صفحه اصلي کار ميک‌نيد؛ با اعم��ال يک
Page ، عناص��ر و اجزاي Master Page در پايين‌ترين لايه Child Page )صفحه فرعي( 

قرار مي‌گيرد.
Master Page 1-3-4 ايجاد

با استفاده از دو پنل Document و Library مي‌توانيد يک Master Page ايجاد کنيد؛ براي 
ساخت Master Page از طريق پنل Document مراحل زير را انجام دهيد:

1- انتخ��اب Window→Document، براي نمايش پن��ل Document در صورتي که فعال 
نباشد.

2- از منوي پنل Document گزينه New Master Page را طبق شکل 11-4 انتخاب کنيد. 
)همچنين مي‌توانيد از منوي پنل Library گزينه New Master Page را برگزينيد.(

3- متن و گرافيک موردنظرتان را در محلي از صفحه Master Page که در نظر گرفته‌ايد، 
قرار دهيد )شکل 4-11(.

4- صفحه‌ها و ويژگي‌هاي Master Page را ذخيره کرده و پنجره آن را ببنديد.

Document شکل 11-4 ايجاد صفحه اصلي با استفاده از پنل

 مث�ال 2: يک صفحه اصلی با ن��ام Master Page-01 در فايلی با نام Example1 با 
توجه به مشخصات زير ايجاد کنيد:

اندازه صفحه A4، عمودی و سه دکمه با رنگ دلخواه در سمت چپ صفحه قرار دهيد.	
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1- با اس��تفاده از برنامه گرافيکي نقاشي )Paint( يا فتوشاپ يك كادر با  اندازه 4/4×21 
  Export درج ش��ده اس��ت، ايجاد کنيد س��پس آن را My Project س��انتی‌متر که در آن متن

نماييد.
2- در برنامه FreeHand يك سند جديد ايجاد كرده، اندازه و جهت صفحه را از طريق پنل 
 Document از منوي كنترل پنل New Master Page تنظي��م نماييد و روي گزينه Document

کليک کنيد.
3- پنل library را از مسير  Window→Library باز كنيد.

4- از طريق منوي كنترلي Library فايلGel Buttons را از پوش��ه Samples که در پوش��ه 
برنامه FreeHand قرار دارد، Import كنيد س��پس دکمه‌های مورد نظرتان را انتخاب كرده و 

در صفحه قرار دهيد.
6- كادر رس��م ش��ده در برنام��ه گرافي��كي موردنظر را ب��ه س��ند FreeHand وارد كنيد 

)File→Import( و در بالاي صفحه قرار دهيد )مطابق شكل 4-12(.

شکل 12-4 مشخص کردن محل اشياء در صفحه اصلي

7- فايل را با نام Example1 ذخيره کنيد.	
ش��ما مي‌توانيد با استفاده از گزينه New Master Page در منوي كنترل پنل Library يك 

Master Page جديد نيز ايجاد كنيد كه شامل يك موضوع گرافيكي است )شكل 4-13(.
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شکل 13-4 قراردادن موضوع گرافيکي در صفحه اصلي

با بس��تن پنجره صفحه اصلي ويژگي‌ها و صفحه‌هاي Master Page در پنل Library قابل 
مشاهده است.

)Child Page( 2-3-4 اضافه کردن يک صفحه فرعي

روش اول:
1- گزينه Add pages را از منوي کنترلي پنل Document برگزينيد )شکل 4-14(.

2- گزينه Make child of Master Page را انتخاب كنيد )شکل 4-15(.
3- يکي از Master Page  هاي موجود را انتخاب و روي OK کليک کنيد)شکل 4-15(.
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Document از پنل Add pages شکل 14-4 انتخاب گزينه

شکل 15-4 اضافه کردن صفحه فرعي

 نكت�ه: ب��ا انتخاب يک صفح��ه Child و کليک�� روي گزين��ه Duplicate در پنل 
Document نيز مي‌توانيد يک صفحه فرعي به صفحه Master Page اضافه کنيد.

روش دوم:
با استفاده از ابزار Page صفحه Child را انتخاب كرده سپس آن صفحه را همزمان با نگه 
داش��تن كليد Alt در فضاي چركنويس سند درگ كنيد. اين عمل سبب اضافه شدن صفحه 

فرعي به سند مي‌شود.

اس��ت،  Master Pageاز  Child Page يک��  ج��اري  صفح��ه  اگ��ر  توج�ه:   
Master Page جديد تنظيمات Master Page اصلي را خواهد داش��ت که مي‌توانيد آن‌ها را از 

طريق پنل Document تغيير دهيد.
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تمري�ن 4: يك صفحه اصلي با محتويات دلخ��واه ايجاد كرده و به آن دو صفحه 
فرعي )Child( اضافه کنيد.

3-3-4 تبديل يک صفحه به يک Master Page جديد

اگر مي‌خواهيد يک صفحه س��ند را به Master Page تبديل کنيد به ترتيب اين مراحل را 
انجام دهيد:

1- صفحه‌اي را كه مي‌خواهيد به صفحه اصلي تبديل شود، انتخاب کنيد.
 Convert to Master Page کليک کرده و گزينه Document 2- روي من��وي کنترلي پن��ل

را انتخاب کنيد )شکل 4-16(.

شکل 16-4 تبديل يک صفحه به يک  Master Page جديد

عناص��ر موج��ود در صفحه اصلي پس از ظاهر ش��دن در صفحه‌هاي س��ند قابل ويرايش 
نيس��تند. اگر مي‌خواهيد اين عناصر را در صفحه س��ند اصلاح كني��د بايد آن‌ها را از صفحه 

اصلي خارج )Release( كنيد.

 نكت�ه: اگ��ر صفحه ش��ما فرع��ي )Child Page( اس��ت، براي تبدي��ل آن به يک 
Master Page ابتدا آن را Release کنيد.

Release 4-3-4 صفحه فرعي

1- صفحه يا صفحه‌ها را با استفاده از ابزار Page انتخاب كنيد.
2- گزينهRelease Child Page  را از منوي‌کنترلي پنل  Documentبرگزينيد.

در اين صورت مي‌توان عناصر صفحه اصلي را در سند ويرايش كرد.
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Library 5-3-4 نمايش و عدم نمايش صفحه اصلي در پنل

 اگر بخواهيد آيکن صفحه مادر در ليست پنل Library مشاهده شود طبق شکل 17-4 گزينه
Show Master Pages را در حالت فعال قرار دهيد. نداشتن علامتP نشانه پنهان بودن صفحه 

اصلي در ليست است.

شکل 17-4 نمايش و عدم نمايش صفحه اصلي

6-3-4 اعمال Master Page به صفحه سند

Library با استفاده از پنل
1- صفحه يا صفحه‌هاي موردنظر را با استفاده از ابزار Page  انتخاب كنيد.
2- ابتدا بررسي کنيد که نمايش صفحه اصلي در پنل Library فعال باشد.

3- آيکن Master Page را از پنل Library درگ کرده و داخل صفحه قرار دهيد.
 Document با استفاده از پنل

صفحه يا صفحه‌هاي موردنظر را با استفاده از ابزارPage  انتخاب كنيد.
از ليست Master Page در پنل Document، صفحه اصلي را انتخاب كنيد تا عناصر صفحه 

اصلي در سند ظاهر شوند.

 نكته: در س��ندهاي چندصفحه‌اي، صفحه انتخاب ش��ده به Master Page نسبت 
داده مي‌ش��ود و اگر تعداد صفحه‌هاي انتخابي از يکي بيش��تر باشد، با ابزار Page صفحه‌هاي 

مورد نظر را به عنوان صفحه‌هاي فرزند صفحه Master Page در نظر بگيريد.
Master Page 7-3-4 ويرايش

1- يکي از موارد زير را انجام دهيد:
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روي آيکن Master Page در پنل Library دابل کليک کنيد.
  Edit انتخ��اب کرده و روي دکمه )Master Page( يک صفحه اصلي Document در پن��ل

کليک کنيد.
2- تغييرات مورد نظر را در Master Page اعمال کنيد.

3- پنجره Master Page را ببنديد.	

 تمري�ن 5: با اس��تفاده از فاي��ل Gel Buttons از پوش��ه Samples واقع در برنامه 
FreeHand، يك صفحه اصلي با نام Buttons1 ايجاد كرده، س��پس رنگ دكمه‌هاي موجود در 

صفحه را تغيير دهيد.
Master Page 8-3-4 حذف

براي حذف صفحه اصلي از يك صفحه سند مراحل زير را انجام دهيد:
1- صفحه‌هاي موردنظر را انتخاب كنيد.

2- از ليست Master Page پنل Document    گزينه None را برگزينيد. بدين ترتيب عناصر 
صفحه اصلي از صفحه حذف مي‌شوند.

 توج�ه: ب��راي تغيير نام صفحه اصلي، روي نام Master Page در پنل Library دابل 
كليك كنيد.

Master Page يک Export و Import 4-3-9

براي وارد کردن يک صفحه اصلي در فايل مورد نظر، به ترتيب زير عمل کنيد.
1- گزينه Import را از منوي کنترلي در پنل Library انتخاب کنيد.

2- در کادر مح��اوره‌اي Import Symbols فاي��ل ح��اوي Master Pages را انتخاب و روي 
دکمه Open کليک کنيد.

3- پ��س از انتخ��اب صفح��ه اصلي موردنظ��ر از کادرمح��اوره‌ ظاهر ش��ده، روي دکمه 
"Import کليک کنيد. در اين صورت صفحه وارد ش��ده در پنل Library نش��ان داده مي‌ش��ود 

)شکل 4-18(.
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Import Symbols شکل 18-4 انتخاب صفحه اصلي از کادرمحاوره

 ،)Export( براي اين که بتوانيد از صفحه اصلي ايجاد شده در فايل‌هاي ديگر استفاده کنيد
مراحل زير بايد اجرا شود:

1- گزينه Export را از منوي کنترل در پنل Library انتخاب کنيد.
2- صفحه‌هايي را که مي‌خواهيد Export کنيد، برگزينيد )شکل 4-19(.

3- روي دکمه Export کليک کنيد.
4- در کادرمحاوره‌اي که ظاهر مي‌شود، پوشه Symbol هاي صادر شده را انتخاب کنيد. 

 

شکل 19-4 انتخاب صفحه اصلي از کادرمحاوره Export Symbols و ذخيره آن در پوشه موردنظر براي صادر کردن آن در فايل‌هاي 

ديگر

5- ن��ام فاي��ل را براي صادر ��کردن Master Pages درج ��کرده و روي دکمه Save کليک 
كنيد.
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 Shift توجه: براي انتخاب چند صفحه مي‌توانيد، همزمان با انتخاب صفحه‌ها کليد 
را نگه داريد.

)Page Rulers( 4-4 کار با خطک‌‌ش
با اس��تفاده ازخطک‌ش‌هاي افق��ي و عمودي مي‌توانيد موضوع��ات مختلف را اندازه‌گيري 

کنيد )شکل 4-20(.

Guides وGrid  ،Page Rulers شکل 20-4 نمايش

ب��راي نمايش خطک‌ش‌ها گزين��هView→Page Rulers→Show  را انتخاب کرده يا از کليد 
تركيبي Ctrl+Alt+R استفاده کنيد.

 توجه: براي انتخاب واحد اندازه‌گيري خطک‌ش، از منوي بازشو Units واقع در نوار  

وضعيت استفاده کنيد.

1-4-4 تغيير محل نقطه صفر خطک‌ش

علامت بعلاوه در گوش��ه س��مت چپ بالاي خطک‌ش )محل تقاطع دو خطک‌ش( نشانگر 
‌نقطه ‌صفر خطک‌ش است. مي‌توانيد براي کمک به اندازه‌گيري موضوعات روي صفحه، محل 
اي��ن نقطه را تغيير دهيد، به اين صورت که علام��ت بعلاوه را به محلي که مي‌خواهيد نقطه 

صفر از آن جا شروع شود، درگ کنيد.
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 توجه: براي برگش��ت نقطه صفر به جاي اول خود روي علامت بعلاوه دابل کليک 
کنيد.

تمرين 6: خطک‌شي با واحد ميلي‌متر روي صفحه، نمايش دهيد.

)Guides( 5-4 خط‌هاي راهنما
خط‌هاي راهنما، براي تقس��يم صفحات به نواح��ي مختلف و نيز تنظيم دقيق موضوعات 
رس��م ش��ده و تراز  اش��کال بهک‌ار مي‌رود. خطوط راهنما در چاپ ظاهر نخواهند شد و رنگ 

پيش‌فرض اين خطوط آبي است )شکل 4-20(. 
1-5-4 ترسيم خط‌هاي راهنما

ترس��يم خط‌هاي راهنما به دو روش دقيق و نس��بي انجام مي‌شود که به ترتيب به شرح 
زير است:

•ترسيم دقيق 	

براي ترسيم دقيق خط‌هاي راهنما در صفحه، مسير View→Guides→Edit را اجرا کرده و 
از دکمه Add که در کادرمحاوره Guides قرار دارد، استفاده کنيد )شكل 4-21(.

با کليک روي ‌دکمه Add، کادرمحاوره‌ Add Guides مطابق با شكل 22-4 ظاهر مي‌شود 
که عملکرد گزينه‌هاي آن در جدول 3-4 آمده است:

                      

	                     

Add Guides شکل‌ 22-4 کادرمحاوره                     Guides شکل‌ 21-4 کادرمحاوره             
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جدول 4-3

Guides

Horizontalبراي افزودن خطوط راهنماي افقي

Verticalبراي افزودن خطوط راهنماي عمودي

Add by

Countبراي وارد کردن تعداد خطوط راهنما در صفحه

Increment
براي وارد کردن عددي به عنوان فاصله خطوط راهنما که نرم‌افزار

 با محاسبه فاصله، تعداد خطوط را مشخص ميک‌ند.

Position

Firstتعيين نقطه شروع خطوط راهنما

Lastتعيين نقطه انتهاي خطوط راهنما

Page Range
در صورت داشتن بيش از يک صفحه در سند، مي‌توانيد مشخص کنيد خطوط راهنما از چه 

صفحه‌اي شروع و تا چه صفحه‌اي ادامه يابد. 

Add دکمه
با کليک روي اين دکمه به کادرمحاوره Guides باز

مي‌گرديد و مي‌توانيد خطوط تعريف شده را مشاهده کنيد.

•ترسيم نسبي 	

 View→Page Rulers→Show براي ترسيم خط‌هاي راهنماي افقي يا عمودي ابتدا از مسير
خط‌كش را فعال كنيد. حال مي‌توانيد اش��اره‌گر ماوس را روي خطک‌ش افقي يا عمودي قرار 

داده و آن را به داخل صفحه درگ کنيد.
ب��راي تنظي��م پيمايش )Scroll( پنجره س��ند، در زمان درگ خط‌ه��اي راهنماي افقي و 

عمودي بخصوص در زماني که تعداد صفحه‌ها زياد است؛ به طريق زير عمل کنيد:
 General باز کنيد سپس زبانه Edit→Preferences را از مسير Preferences 1- کادرمحاوره

را فعال کنيد.
2- گزينه Dragging a Guide Scrolls the Window را انتخاب کنيد.
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 توج�ه: در حال��ت پيش‌ف��رض، Scroll خط‌هاي راهنما در پنجره س��ند غير فعال 
است.

مثال 3: براي درك بهتر روش رس��م خ��ط راهنما و تنظيم Scroll مراحل بعد را 
انجام دهيد:

1- يك صفحه به اندازه 2000×800 پيكس��ل ايجاد كنيد. در اين صورت  قس��مت بالاي 
صفحه را مشاهده نمي‌كنيد. 

2- با اس��تفاده از روش ترسيم دقيق 5 خط راهنماي افقي و 4 خط راهنماي عمودي در 
صفحه قرار دهيد.

 Dragging a Guide گزينه General را باز ك��رده و در زبانه Preferences 3- كادر مح��اوره
Scrolls the Window را انتخاب كنيد.

4- حال با استفاده از خط‌كش 2 خط راهنماي افقي در بالاي صفحه رسم كنيد. براي اين 
كار بايد خط راهنما را از خط‌كش، به صفحه درگ كنيد و همزمان به س��مت بالاي صفحه، 
ماوس را حركت دهيد. مي‌بينيد كه صفحه به س��مت بالا Scroll  مي‌ش��ود تا شما خط را در 

محل مناسب قرار دهيد. 
2-5-4 نمايش خط‌هاي راهنما

براي نمايش خطوط راهنما گزينه View→Guides→Show  را انتخاب کنيد.
3-5-4 قفل کردن خط‌هاي راهنما

براي قفل کردن خطوط راهنما گزينه View→Guides→Lock را برگزينيد.
4-5-4 خاصيت آهنربايي خط‌هاي راهنما

 View→Guides→Snap To Guides براي ايجاد خاصيت آهنربايي خط��وط راهنما گزينه
را انتخ��اب کني��د، با انجام اين عمل، در هنگام جابه‌جايي يا ترس��يم وقتي موضوعي به خط 
راهنما نزديک مي‌ش��ود مانند يك آهنربا عمل كرده و از فاصله چند پيکس��لي آن را به سوي 

خود جذب ميک‌ند.
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5-5-4 حذف خط‌هاي راهنما

براي حذف خط‌هاي راهنما، ابتدا بايد ابزار Pointer را انتخاب کرده، سپس خط راهنماي 
 Guides در کادر محاوره Remove موردنظ��ر را ب��ه خارج از صفحه درگ کنيد ي��ا از دکم��ه

استفاده کنيد.

 نكته: براي تغيير رنگ خط‌هاي راهنما و نقاط شبکه‌اي، از زبانه Colors واقع در 
کادر محاوره Preferences استفاده کنيد.

6-5-4 ويرايش خط‌هاي راهنما

ب��راي ويرايش خط‌هاي راهنما، گزين��ه View→Guides→Edit را برگزينيد يا روي يکي 
از خط��وط راهنما دابل کليک کنيد، بدين ترتيب کادرمحاوره Guides باز مي‌ش��ود )ش��کل 

.)4-23
عملکرد گزينه و دکمه‌هاي کادر محاوره Guides در جدول 4-4 آمده است.

شکل 23-4 نمايش مشخصات خطوط راهنماي روي صفحه
با وارد کردن شماره‌ صفحه، صفحه‌ موردنظر براي‌ ويرايش‌ خط‌هاي ‌راهنما انتخاب مي‌شود. Page

خط‌هاي راهنماي انتخاب شده در ليست به خط واقعي تبديل مي‌شود. Release

خط‌ راهنماي انتخاب شده در ليست را حذف ميک‌ند. Remove

Add براي ‌افزودن خط‌هاي راهنما به‌طور دقيق به صفحه بهک‌ار مي‌رود.

براي تغيير موقعيت قرارگيري خط راهنماي انتخاب شده در ليست بهک‌ار مي‌رود. Edit

جدول 4-4
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 توجه: همه کارهاي گفته ش��ده بعد از تأيي��د کادر محاوره Guides يعني کليک 
دکمه OK، در صفحه جاري قابل مشاهده خواهد بود.

 مث�ال 4: مي‌خواهيم يك صفح��ه گرافيکي را از خطوط راهنماي افقي با فواصل 
نيم‌ سانتي‌متري پر کنيم، براي اين منظور مراحل زير را انجام دهيد:

1- ابتدا واحد اندازه‌گيري صفحه را به سانتي‌متر تغيير دهيد.
2- گزين��ه View→Guides→Edit را انتخاب ��کرده و از کادرمحاوره Guides روي دکمه 

Add کليک كنيد.

3- در کادر باز شده، گزينه Horizontal را برگزينيد.
4- در قسمت Increment عدد 0/5 را وارد کنيد.

5- ب��ا کليک�� روي دکم��ه Add تغيي��رات را تأييد ��کرده و س��پس OK را کليک کنيد 
)شکل4-24(.

شکل 24-4 افزودن خطوط راهنماي افقي 

تمرين 7:
1- يک سند حاوي يک صفحه A4 در جهت افقي ايجاد کنيد.
2- هفت خط راهنماي عمودي موازي روي صفحه ايجاد کنيد.

3- سه خط راهنماي افقي موازي نيز در صفحه ايجاد کنيد.
4- خطوط راهنما را قفل کنيد.
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5- اولين خط افقي را حذف کنيد.
)Grid( 6-4 خطوط شبکه

خطوط شبکه‌بندي، خط‌هاي نقطه‌چين افقي و عمودي هستند که قابل چاپ نبوده، براي 
تراز اش��ياء با هم و تعيين موقعيت موضوعات بهک‌ار مي‌روند. اين خطوط س��اختاري شبيه‌ به 
کاغذ شطرنجي را نشان مي‌دهند و در هنگام ترسيم شکل‌ها و جابه‌جايي دقيق اشياء بسيار 

مفيد هستند )شکل 4-25(.
1-6-4 نمايش خط‌هاي شبکه

براي فعال س��اختن ش��بکه راهنما، گزينهView→Grid→Show  را انتخاب کنيد تا نقاط 
مشبک روي صفحه ظاهر شوند.

 توجه: کليد تركيبي Ctrl+Alt+G نقاط شبکه‌اي را فعال مي‌سازد.

2-6-4 ويرايش خط‌هاي شبکه

براي تغيير فاصله‌هاي بين نقاط ش��بکه‌اي بر‌اس��اس واحد اندازه‌گي��ري جاري از گزينه 
View→Grid→Edit اس��تفاده کنيد، در اين‌صورت کادرمحاوره Edit Grid ظاهر مي‌شود. در 

قسمت Grid size فاصله موردنظر را وارد کرده و روي OK کليک کنيد )شکل 4-25(. 

شکل 4-25 

3-6-4 چسبندهک‌ردن نقاط شبکه

با انتخاب گزينه View→Grid→Snap to Grid  خطوط مش��بک حالت آهنربايي خواهند 
داش��ت و با نزدي‌ک کردن اشياي ترسيمي به خطوط شبکه‌اي، موضوعات جذب اين خطوط 

مي‌شوند.
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 توجه: کليد تركيبي Ctrl+Alt+Shift+G قابليت Snap to Grid را فعال مي‌سازد.

 Snap7-4 ابزار
با استفاده از اين ابزارها امکان چسباندن موضوع‌هاي گرافيکي و نقاط مسيرها به يکديگر 
در زمان جابه‌جايي و حرکت آن‌ها در صفحه فراهم مي‌ش��ود. همچنين مي‌توانيد ميزان اين 

چسبندگي را تعيين کنيد )شکل 4-26(.

شکل 4-26

1-7-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک نقطه ديگر

يکي از موارد زير را انجام دهيد:
1-از جعبه ابزار، دکمه   Snap to Point را برگزينيد.

2- مسيرView→Snap to Point  را پيگيري کنيد.
3- با استفاده از ابزار Pointer موضوع گرافيکي را انتخاب و به نزديکي يا روي نقطه‌اي که 

به عنوان هدف در نظر گرفته‌ايد درگ کرده و در محل مناسب رها کنيد )شکل 4-27(.

شکل 27-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک نقطه ديگر

2-7-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک مسير

يکي از موارد زير را انجام دهيد:
1- از جعبه ابزار، دکمه   Snap to Object را برگزينيد.

2- مسيرView→Snap to Object  را پيگيري کنيد.
3- با استفاده از ابزار Pointer موضوع گرافيکي را انتخاب و به نزديکي يا روي مسيري که 

به عنوان هدف در نظر گرفته‌ايد درگ کرده و در محل مناسب رها کنيد )شکل 4-28(.
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شکل 28-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک مسير

3-7-4 فاصله چسبندگي

 Preferences را در کادرمحاوره General را اجرا کرده و زبانه Edit→Preferences 1- مسير
انتخاب کنيد.

2- در کادر متن��يSnap distance   مطابق ش��کل، حداقل مقدار م��ورد نظر براي فاصله 
چسبندگي را وارد کنيد )شکل 4-29(.

3- روي دکمه OK کليک کنيد.

شکل 29-4 تغيير فاصله چسبندگي

 مثال كاربردي: مي‌خواهيم با استفاده از مثال كاربردي كه در آخر هر واحد كار 
ارايه مي‌شود يك نمونه كارت ويزيت طراحي كنيم. در اين واحد کار به ايجاد صفحه موردنظر 
خواهيم پرداخت، سپس در واحد کارهاي بعدي به طراحي آرم و کارت ويزيت مي‌پردازيم. 

1- يك صفحه جديد باز كنيد و واحد اندازه‌گيري آن را ميلي‌متر قرار دهيد.
2- در پن��ل Document گزين��ه Custom را براي ابعاد كاغذ انتخ��اب كنيد و مقادير 35 

ميلي‌متر را براي عرض و 50 را براي طول صفحه وارد كرده، كليد Enter را بفشاريد.
3- با ابزارZoom  صفحه را در حالت بزرگنمايي قرار دهيد.

4- خط‌كش‌ها را ظاهر كرده، خطوط راهنماي مورد نياز را به داخل صفحه بياوريد.
5- فايل ايجاد شده را در قالب يك فايل گرافيكي با فرمت FH11 و با نام Project ذخيره 

كنيد.
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واژه‌نامه
Bleedبريدن كاغذ، ناحيه برش کاغذ

Guideراهنما

Gridشبكه

Master Pageصفحه اصلي )صفحه با اولويت بالا، صفحه مادر(

Modifyتغيير دادن

Page Childصفحه فرعي )صفحه با اولويت پايين(

Relativeنسبي

Scrollلغزنده

خلاصه مطالب 
• يک صفحه  	New ابتدا بايد از طريق فرم��ان ،FreeHand براي ش��روع کار با برنام��ه
طراحي جديد ايجاد کنيد سپس به ترسيمات بپردازيد. براي تغيير تنظيمات صفحه 
از پنل Document اس��تفاده مي‌ش��ود. همچنين براي ترس��يمات دقيق و ترازکردن 
اشياء به ابزارهاي Guide )خطوط راهنما(، Ruler )خطک‌ش( و Grid )خطوط شبکه( 

نياز داريم.
 • 	Master Page مي‌توانيد از امکان ايجاد  Libraryو Document با اس��تفاده از پنل‌هاي
اس��تفاده کنيد که در ش��کل‌گيري س��ريع پس‌زمينه در صفحه‌هاي پروژه‌هاي چند 

صفحه‌اي و ارائه‌هاي گرافيکي Flash مفيد است.
• ابزار Snap نيز براي جابه‌جايي دقيق موضوع‌هاي گرافيکي بهک‌ار مي‌رود.	
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- با نگه داشتن کليدSpacebar  همزمان با درگ صفحه در ناحيه چرکنويس مي‌توانيد، 
صفحه را جابه‌جا کنيد.

2- ب��راي ويرايش Master Page در پنل Document يک�� صفحه Child  انتخاب کرده و 
روی دکمه View کليک کنيد.

3- تنها راه براي ترس��يم خط‌هاي راهنماي افقي يا عمودي اين است که اشاره‌گر ماوس 
را روي خطک‌ش افقي يا عمودي قرار داده و آن را به داخل صفحه درگ کنيد.

معادل گزينه هاي سمت‌ راست را از ستون سمت‌ چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

4- براي تنظيم ناحيه اضافي يا حاشيه در اطراف صفحه گرافيکي استفاده مي‌شود
 Release

                       Bleed                         .ايجاد کنيد Master Page 5- با استفاده از اين پنل، مي‌توانيد يک
6- اگر صفحه سند فرعی باشد، براي تبديل آن به يک Master Page قبل از انتخاب گزينه              
                                Snap Distance                    .اين فرمان روي آن انجام مي‌شود Convert to Master Page

Library    .بهک‌ار مي‌رود  Preferences 7- براي تنظيم فاصله چسبندگي در کادر محاوره
گزينه صحيح را انتخاب کنيد.

8- با استفاده از پنل Document کدام امکانات در دسترس شما قرار مي‌گيرد؟
الف- تنظيم اندازه صفحه              ب- تنظيم حالت نمايش صفحه  	
د- همه گزينه‌ها صحيح هستند. ج- تنظيم کيفيت چاپ        	 	

9- کدام گزينه نادرست است؟
الف- تغيير اندازه صفحه بر اندازه موضوع ترسيمي تأثير مي‌گذارد. 	

ب- FreeHand يک نرم‌افزار برداري است. 	
ج- واحد اندازه‌گيري وضوح تصوير )dpi( به معني نقطه در اينچ است. 	

د- کليد ترکيبي Ctrl+Alt+G نقاط شبکه‌اي را فعال مي‌سازد. 	
10- براي تعريف ابعاد کاغذ به صورت اختياري از کدام گزينه استفاده مي‌شود؟

	 A4 -د              Custom-ج               Legal -ب 		 Letter -الف
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11- ب��راي‌ کپ��ي‌ موضوع در حين اس��تفاده از ابزار پرس��پکتيو، از کدام‌ کليد اس��تفاده 
مي‌شود؟

Alt -د 	   Shift-ج 	          Ctrl-ب 	     Tab  -الف
12- کدام مورد صحيح است؟

الف- براي استفاده از خطوط راهنما، فعال بودن خطک‌ش‌ها الزامي است.
ب- خطوط راهنما به محض نزديک شدن موضوعات، آن‌ها را از خود دور ميک‌نند.

ج- خطوط شبکه قابل چاپ هستند.
د- رنگ و تعداد خطوط شبکه سه بعدي را نمي‌توان تغيير داد.

13- کدام گزينه از صفحه مشابه يک کپي مي‌گيرد؟
Hide  -د 	 Duplicate -ج 	Remove  -ب 	Bleed -الف

14- کدام عبارت درست است؟
الف- تنظيمات صفحه اصلي را نمي‌توان تغيير داد.

ب- براي‌‌اس��تفاده ‌از Master Page  هاي ‌ايجاد ش��ده ‌درسندهاي ‌ديگر FreeHand ‌آن‌ها‌ را 
Export ميک‌نند.

ج- هر سند فقط يک صفحه اصلي دارد.
د- با چرخش صفحه، جهت محتويات آن تغيير ميک‌ند.

15- براي چسباندن يک موضوع گرافيکي يا يک نقطه به يک مسير، کدام گزينه مناسب 
است؟

	  View→Snap to Object-ب 	              Edit→Snap to Point-الف
 View→Snap to Point-د            	Edit→Snap to Object -ج

در جاي خالي عبارت مناسب را بنويسيد.

16- دکمه ............. در کادر محاوره Guides، خط‌هاي راهنماي انتخاب ش��ده در ليست را به 
خط واقعي تبديل ميک‌ند.

17- اس��تفاده از ابزار  Page Tool همزمان با درگ صفحه و نگه داشتن کليد Ctrl، سبب 
........... در فضاي چرکنويس بدون محتويات صفحه مي‌شود.

به سؤالات زير پاسخ تشريحی دهيد.

18- ابزار جابه‌جايي صفحه گرافيکي چيست و کليد ميانبر آن‌را نام ببريد؟
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19- خط‌هاي راهنما به چه منظور به‌كار مي‌روند؟
20- كاربرد Snap to Grid چيست؟

آزمون عملي
1- يک سند به نام Azmoont4 - 1. Fh11  ايجاد کنيد، سپس:
• سانتی‌متر ايجاد کنيد. يک صفحه خالي  به ابعاد 25×20	

•از صفحه ايجاد شده يک کپي مشابه تهيه کنيد. 	
• به سند بيفزاييد. 	B5 سه صفحه به اندازه

•کليه صفحات را در محيط کار نمايش دهيد. 	
• را در بزرگ‌ترين حالت ممکن نمايش دهيد. فقط صفحه 3	

• بچسبانيد. صفحه 4 را به 5	
• را حذف کنيد. صفحه 5	

2- يک س��ند با نامAzmoont4 - 2.Fh11 مطابق شکل بعد که شامل مشخصات زير است 
 ،FreeHand برنامه Samples در پوشه ،Slide Show ايجاد کنيد. )راهنمايي: با استفاده از فايل

صفحه اصلي را ايجاد کنيد.(
Total Pages: 4

مشخصه هر صفحه سند:
Page 1
Origin X: 67.31, Origin Y: 71.195
Page 2
Origin X: 79.935, Origin Y: 71.195
Page 3
Origin X: 67.31, Origin Y: 58.57
Page 4
Origin X: 79.935, Origin Y: 58.57

مشخصات مشترک صفحه‌ها:
Width: 12.6245, Height: 12.6245
Bleed Size: 0
Orientation: Portrait
Page Type: Custom
Master Page: Slideshow Page
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3- در فايل Azmoont4 - 2.Fh11 با توجه به تنظيمات داده ش��ده در شك��ل زير خط‌هاي 
راهنما را قرار دهيد.


