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مقدمه

ستايش پروردگار بي‌همتا را كه بار ديگر ما را مفتخر كرد تا بتوانيم در وادي علم و دانش 
گام برداشته و آموخته‌ها و تجارب خود را در اختيار همگان قرار دهيم. در اين زمان كه علم 
در همه عرصه‌هاي زندگي بشر پا نهاده است، بر آن شديم تا حضور آن را در كنار هنر يادآور 
شويم. در اين راستا كتاب حاضر به آموزش نرم‌افزار گرافيكي FreeHand MXa پرداخته كه در 
 FreeHand واقع نگارش 11/02 اين برنامه است. تنظيم مطالب كتاب بر اساس استاندارد كاربر
وزارت ارش��اد و فرهنگ اسال�مي صورت گرفته است و به جرأت مي‌توان گفت كه اين كتاب 

خودآموز و مرجع كاملي براي كاربران FreeHand است.
در اين كتاب س��عي ما بر اين بوده اس��ت كه مطالب آموزش��ي به ص��ورت گام به گام و 
تصويري همراه با مثال و تمرينات متعدد و خلاق براي دانش‌آموزان نوش��ته ش��ود. همچنين 
با تمرينات كاربردي و پروژه‌هاي عملي در انتهاي كتاب، هنرجويان را به كس��ب مهارت‌هاي 

بيشتر سوق داده‌ايم.
مطالب كتاب در 15 واحدكار تهيه شده كه شامل موارد زير است:

توانايي رعايت اصول ايمني و بهداشتي در محيط كار، نصب نرم‌افزار FreeHand و شناخت 
محيط آن، ايجاد فضاي مورد نياز براي قرارگيري اشياي گرافيكي و استفاده از عناصر و ابزار 
در طراحي و ترسيم‌ها، كار روي اشياء و ويرايش آن‌ها، كار با رنگ و پركننده‌ها، كار با متن، 
استفاده از جلوه‌هاي ويژه، استفاده از لايه‌ها، سمبل‌ها و سبك‌ها، متحرك‌سازي و استفاده از 

سند FreeHand در صفحات وب، صدور و چاپ فايل‌هاي گرافيكي.
 اميدواري��م ك��ه ب��ا ارس��ال نظرات و پيش��نهادات خ��ود ب��ه آدرس پس��ت الكترونيكي 

F_Riahi2000@yahoo.com  ما را در رفع كاستي‌هاي اين كتاب ياري نماييد.

مؤلفان
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کليات 
انس��ان با توجه به محي��ط کاري که در آن قراردارد و موقعيت بدني و نحوه اس��تفاده از 
ابزارهاي محيط کار و رعايت بهداشت در پيرامون خود، تحت تأثير شرايط قرار مي‌گيرد و اگر 
ارتباط مناس��ب و اصولي با ابزار و محيط کارش برقرار نکند، عوارض ناش��ي از فشارهاي وارد 
شده بر او سبب اخلال در اجراي درست کار، خستگي و ناراحتي در اندام‌هاي او مي‌شود. در 
دنياي امروز، کاربرد رايانه در زمينه‌هاي مختلف اهميت داشته و استفاده از آن اجتناب‌ناپذير 

است، نحوه قرارگيري درست کاربر پشت دستگاه در استفاده بهينه از آن مؤثر است.
1-1 مهندسي محيط و محل انجام كار )ارگونوميك(

دان��ش ارگونوميک، به مطالعه ارتباط و تعامل انس��ان با ابزارها، تکنولوژي )س��خت‌افزار/ 
نرم‌افزار( و فعاليت‌هاي کاري و محيطي که در آن کار ميک‌ند، مي‌پردازد. هدف اصلي، ايجاد 

هماهنگي و مناسب بودن کار براي هر فرد است.

شکل 1-1 دسترسي به ابزارهاي محيط کار

2-1 عوامل مؤثر در استفاده صحيح از رايانه
به منظور رعايت ارگونومي و حفظ سلامتي بايد به عواملي در هنگام کار با کامپيوتر توجه 

داشت، اين عوامل عبارتند از: 
1-2-1 چيدمان رايانه 

براي حفظ سال�مت و جلوگيري از ايجاد مشك��ل براي دس��ت‌ها و پشت، گردن و ... سه 
توصيه زير را رعايت كنيد:

1- ماوس و ساير ابزارهاي ورودي را در کنار صفحه کليد قرار دهيد تا فشار وارده در دسترسي 
 به وسايل، روي شانه‌ها کاهش يابد. براي اينکه ماوس حرکتي روان داشته باشد از زيرماوسي"

)Mouse Mat( استفاده کنيد.
 Mouse Mat : براي بهبود و پيشرفت كاربرد ماوس كامپيوتر مورد استفاده قرار مي‌گيرد 
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)شكل 1-2(.
Mouse Mate : اين وسيله مستقيماً به ماوس مي‌چسبد، كف دست در حالت خنثي قرار 

مي‌گيرد و ماوس به يك ماوس ارگونوميك تبديل مي‌شود )شكل 1-3(.
      

                       

                              

                                     شکل 2-1	     شکل 1-3

2- صفحه نمايش را در پشت صفحه کليد بگذاريد و لبه بالايي آن را در امتداد چشم‌هايتان 
قراردهيد. فاصله بين صفحه نمايش و چش��م‌ها را نزديک به اندازه طول شانه در نظر بگيريد 
)فاصله مناس��ب معمولاً بين 48 تا 71 س��انتي‌متر است(. براي کم کردن تشعشع در صفحه 
نمايش‌هاي کنوني تکنولوژي جديدي به کار مي‌رود. همچنين براي کاهش درخشندگي آن 
را به س��مت بالا، پايين يا راس��ت و چپ بچرخانيد. در صورت وجود پنجره، بايد امتداد آن با 

صفحه نمايش زاويه 90 درجه داشته باشد و کاربر پشت به آن قرار نگيرد.
3- براي نگه داشتن صفحه‌ها در هنگام تايپ مطالب، از يک نگهدارنده )Holder( استفاده 

کنيد. تنظيم فاصله و ارتفاع آن مانند صفحه نمايش است.
2-2-1 صندلي مناسب 

صندلي مناس��ب براي کار با رايانه مجهز به تکيه‌گاه )پشتي(، دسته و ارتفاع قابل تنظيم 
است و لبه جلوي نشيمنگاه آن انحنايي رو به پايين دارد.

تنظيم ارتفاع صندلي
ب��ا توجه به ق��د کاربر و ارتفاع ميز، ارتفاع صندلي با اهرم‌هاي��ي که براي اين کار در نظر 
گرفته ش��ده است، تنظيم مي‌شود. ارتفاع صندلي نبايد سبب ايجاد ناراحتي در پشت ران يا 

زانو شود.
3-2-1 ميز مناسب

س��طح ميز مناس��ب برای کار با رايانه، فضاي کافي براي همه وسايل را دارد و ارتفاع ميز 
نبايد آن قدر کم باش��د که کاربر پاهايش را جمع کند و محل اس��تقرار آن در صورت وجود 

پنجره در محيط کار، به نحوي است که کاربر در کنار پنجره قرار بگيرد.
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 نكت�ه: اگ��ر پاها روي زمين قرار نگرفت ب��راي جلوگيري از وارد آمدن فش��ار به آن‌ها، از يک 
زيرپايي استفاده کنيد.

4-2-1 تهويه و نور 
در محيط کار بايد هوا جريان داش��ته باش��د و از تهويه و وس��ايل خنک‌کننده براي کم 
اثر کردن حرارت ناش��ي از وجود جريان الکتريسيته در قطعه‌هاي الکتريکي استفاده شود تا 
کارايي سيس��تم رايانه با بالا رفتن حرارت کم نشود. براي روشن کردن ميز کار بهتر است از 

چراغ مطالعه استفاده شود همچنين نور مستقيم، به کاربر نتابد.

5-2-1 روش‌هاي به کارگيري ماوس و صفحه کليد
روش‌ها و تکني‌کهاي صحيح به کارگيري ماوس و صفحه کليد از فش��ار مچ‌ها، بازوها و 

آرنج‌ها کم ميک‌ند و مي‌تواند از فشار ثابت شانه‌ها بکاهد.
•هنگامي که تايپ ميک‌نيد دست‌ها و بازوها را ثابت نگه نداريد،  	

همچنين آن‌ها را روي ميانه دسته صندلي قرار ندهيد.
•هنگامي که با ماوس و صفحه کليد کار ميک‌نيد کف دست يا  	

مچ دستتان را ثابت نکنيد يا وزنش را روي آرنج نيندازيد.
•مچ دستتان را مس��تقيم نگه داريد و ميزان خم‌شدگي مچ به  	

سمت بالا يا پايين يا داخل و بيرون را به حداقل برسانيد.
• درجه يا بيشتر باشد و از زاويه  زاويه بازِ آرنج دس��تتان، 120	

کمتر از 90 درجه اجتناب کنيد.
 جدول 1-1 حالت‌هاي مناسب و نامناسب کار با صفحه کليد

حالت مناسب 
آزاد است، در حالي  دست‌هايتان 
قرار  طرف  دو  در  آرنجتان  كه 
دارد و صفحه كليد روي پاهايتان 

است.

حالت مناسب
 ساعدتان را روي دسته صندلي 
قرار دهيد و دست‌هايتان را به 

حالت آزاد قرار دهيد.

حالت مناسب
يا  ميز  روي  ساعدها 
مخصوص  صفحه  يک 

قرار دارد.

حالت نامناسب
وقتي که با صفحه کليد کار 
ميک‌نيد، مچتان را ثابت نگه 

نداريد.
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 نكت�ه: حداقل‌هرس��اعت يک ب��ار به مدت 5 دقيقه به خودتان اس��تراحت داده و 
حرکات کششي انجام دهيد.

3-1 خستگي بدن 
هنگامي که انسان در اجراي فعاليت خود از نظر ذهني و جسمي بازدهي مناسب نداشته 
باش��د، خسته ش��ده است. در کار با رايانه چشم‌ها، دست‌ها، پاها و ... با رعايت نکردن شرايط 

ارگونومي خسته مي‌شوند. 
1-3-1 رفع خستگي بدن هنگام کار

زماني که مش��غول به کار هستيد براي استراحت و تجديد قوا لازم است که موارد بعد را 
براي قسمت‌هاي مختلف بدن انجام دهيد:

• دقيقه يک بار به يک فاصله دورتر ن��گاه کرده و براي يک لحظه  چش�م‌ها: ه��ر 20	
کوتاه به يک فاصله نزديک نگاه کنيد.

• دقيقه انگش��ت‌هايتان را به ص��ورت بادبزني باز کرده و  دس�ت‌ها و بازوه�ا: هر20	
حرکت دهيد و بچرخانيد س��پس دس��تتان را روي پاهايتان بگذاريد و در حالي ک‌ه 

شست‌هايتان بالاست، آن را تکان دهيد.
• دقيقه يک بار بلند شويد و حرکت کششي انجام  بدن در وضعيت نشسته: هر 30	

دهيد و هر يک ساعت يک بار، 5 دقيقه بلند شويد و راه برويد.

       

  شکل 4-1 حرکت بادبزني انگشتان و حرکت شست                   شکل 5-1حالت کششي

4-1 عوارض استفاده از رايانه 
تداوم خس��تگي در کاربر رايانه و عدم رفع آن، س��بب ايجاد عوارض ناشي از کار با رايانه 
مي‌شود که عبارتند از کمردرد، پادرد، درد در مچ دست، احساس ناراحتي در گردن و شانه‌ها 

و ضعيف شدن ديد چشم‌ها.
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1-4-1 نحوه پيشگيري از عوارض استفاده از رايانه

هن��گام کار ب��ا رايانه طرز صحيح نشس��تن و به کارگيري درس��ت اندام‌ها طبق آنچه در 
صفحات قبل گفته ش��ده اس��ت، خس��تگي و عوارض کار با رايانه را کم کرده و حتي مانع از 

ايجاد ناراحتي مي‌شود.
در شکل 6-1 روش درست نشستن هنگام کار با رايانه نشان داده شده است.

شکل 6-1 طرز نشستن هنگام کار با رايانه

5-1 مقررات انضباطي كارگاه 
هنگام كار با رايانه رعايت يكسري مقررات براي به حداقل رسيدن آسيب‌ها، ضروري است 

که برخي از آن‌ها به اين شرح است:
•روشن و خاموش کردن سيستم‌ها بر طبق ضوابط و اصول درست 	
•شناسايي وسيله‌ها و تجهيزات جانبي و استفاده صحيح از آن‌ها  	

و  • اس��تفاده درست و مناس��ب از حافظه‌هاي كمكي مانند فلاپي، Cool disk ،CD و ... 	
اطمينان از بي‌عيب بودن حافظه‌هاي کمکي از لحاظ فيزيكي و بررس��ي آن‌ها با نرم 
افزارهاي ضد ويروس و کرم )Worm( و مطمئن شدن از عدم ويروسي بودن آن‌ها.

 نكته: دس��تگاه‌ها و ابزارها بايد از رطوبت، ميدان‌هاي مغناطيسي، ضربه خوردن، 
ساييده شدن و خش افتادن در امان باشند.
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واژه‌نامه
Cool diskحافظه کمکي

Ergonomicمهندسي محيط و محل انجام كار

Foot Restزيرپايي

Holderنگهدارنده

Postureطرز نشستن و ایستادن

                 	
                                 

 Posture       	طرز نشستن و ايستادن
خلاصه مطالب

•براي رعايت ارگونوميک بايد به موارد زير توجه داشت: 	
1- وضعيت مناسب بدن 

2- وضعيت مناسب  و محل قرار گرفتن ميز و صندلي
3- وضعيت مناسب نور و روشنايي

4- تهويه مناسب
5- استفاده از ابزارهايي که ارگونوميک در آن‌ها رعايت شده است.
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کليات 
امروزه پيش��رفت‌هاي علمي و تکنولوژي سبب شده است که سيستم سنتي صنعت چاپ 
و گرافيک دس��تي جاي خود را به کامپيوترها و اجزاي جانبي دقيق و نرم‌افزارهاي گرافيکي 

دهد و در اين صنعت تحول ايجاد کند.
نرم‌اف��زار FreeHand يک�� برنامه گرافيکي برداري اس��ت که ش��ما را در طراحي و ايجاد 
اشکال گرافيکي نظير آرم‌ها، طراحي جلد کتاب، بروشور، کارت ويزيت و پوستر ياري مي‌كند. 
علاوه بر ‌اين، مي‌توانيد تصاوير ساخته‌شده در اين ‌برنامه را با برنامه Flash به تصاوير متحرک 
تبديل کنيد، همچنين امکان ذخيره‌س��ازي تصاوير را به نحوي فراهم ک‌نيد که قابل استفاده 

در صفحات وب باشد.
اي��ن نرم‌افزار در کنار Photoshop به عنوان مکمل ويرايش تصوير، کاربران را در طراحي، 

تصوير‌سازي و چاپ ياري مي‌رساند.
 در اي��ن پيمان��ه مهارتي نس��خه )MXa 1102( از نرم‌افزار FreeHand آموزش داده ش��ده 

است.
1-2 آشنايي با تصاوير برداري و پيكسلي

 گرافيک کامپيوتري به‌طور کلي به دو بخش پيکسلي )Raster( يا طرح بيتي )Bitmap( و برداري 
)Vector( تقسيم مي‌شود.

• نظير فتوش��اپ با پيکسل‌ها سروکار دارد، يعني هرتصوير  نرم‌افزارهاي پيکس�لي:	
از تعداد زيادي نقاط مربع ش��کل يا پيکسل با رنگ‌هاي مختلف تشکيل مي‌شود که 
هرچه تعداد اين پيکسل‌ها بيشتر باشد، جزييات تصوير بيشتر مشخص شده و تصوير 

داراي وضوح بيشتري مي‌شود.
•متون در اين نوع نرم‌افزارها داراي کيفيت پايين‌تري هستند و وضوح آن‌ها به تعداد  	
پيکس��ل‌هاي تش��کيل‌‌دهنده متن بس��تگي دارد، به همين دليل بحث درجه وضوح 
)Resolution( پيش مي‌آيد يعني در فتوش��اپ کيفيت و هموار بودن لبه‌هاي حروف 

و اشکال به ميزان Resolution تصوير بستگي دارد. 
 نرم‌افزارهاي برداري: در اين‌گونه نرم‌افزارها تصاوير و متون از يکسري خطوط و منحني‌ها که 
براس��اس فرمول‌هاي رياضي تعريف شده‌اند، تشکيل مي‌ش��وند. به‌عبارت ديگر اشکالي نظير 
دايره، خط، کمان و غيره به صورت موضوعات مستقلي هستند که مي‌توانيد به سادگي آن‌ها 
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را جابه‌ج��ا کنيد يا تغيير مقياس دهيد بدون اينک‌ه در کيفيت آن‌ها تأثيري داش��ته باش��د. 
در اين نوع نرم‌افزارها درجه وضوح نقش��ي ندارد بنابراين س��طح کيفي ترسيمات و متون در 
حداکثر ميزان ممکن اس��ت. از اين‌رو بسياري از طراحان ترجيح مي‌دهند که تصويرسازي را 
در فتوش��اپ انجام دهند سپس آن ‌را به FreeHand منتقلک‌رده و تايپ و حروف‌نگاري را در 

اين محيط انجام دهند و در نهايت آن ‌را چاپ كنند.
نرم‌افزارهاي Adobe Illustrator ، FreeHand و CorelDRAW نمونه‌هايي از گرافيک برداري 

هستند.

 توجه: اندازه فايل‌هاي Vector از فايل‌هايBitmap بسيار کمتر است.

 نكته: کيفيت و وضوح ترسيم Vector به وضوح صفحه نمايش و چاپگر وابسته نيست.

 

شکل 1-2 به ترتيب از راست به چپ: تصوير برداري و پيکسلي

 توج�ه: اصلي‌ترين تفاوت نرم‌افزارهاي برداري و پيکس��لي در اين اس��ت که در نرم‌افزار 

برداري تغيير اندازه شك��ل رس��م شده، در کيفيت ترس��يم و حجم آن بي‌تأثير است، اما در نرم‌افزار 
پيکسلي با کاهش و افزايش اندازه تصوير، کيفيت و حجم آن نيز کم و زياد مي‌شود.

FreeHand  MXa 2-2 امکانات لازم براي نصب نرم‌افزار
 برنامه FreeHand با پردازش تصاوير و محاسبات پيچيده‌اي سروکار دارد، بنابراين رايانه‌اي که اين 

نرم‌افزار روي آن نصب مي‌شود، حداقل بايد اين امکانات را داشته باشد:
• پردازنده: سرعت پردازنده بايد Pentium III 600MHz يا بالاتر باشد.	
• سيستم عامل: مي‌تواند يکي از اين ويندوزها باشد:	

XP, Vista, Seven ,  NT4(Service Pack6 (, 2000

• حافظه MB :RAM 512 يا بالاتر 	
• کارت گرافيکي: کارت گرافيک 16 بيتي با وضوح 768×1024 مناسب است.	
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 • 	100  MBنصب مي‌شود حداقل FreeHand حافظه ديسک سخت: در پارتيشني که
فضاي آزاد موردنياز است. 

• درايوCD  يا DVD: کامپيوتر حداقل بايد به يکي از اين درايوها مجهز باشد.	
	 FreeHand 1-2-2 نصب نرم‌افزار

براي نصب برنامه گرافيکي FreeHand مي‌توانيد از سه روش مختلف استفاده کنيد. در هر 
سه روش با اجراي فايل Setup.exe، ويزارد نصب آشکار مي‌شود؛ اين روش‌ها عبارتند از:

1- اج�راي خودکار CD يا DVD نصب برنامه: اگر برنامه نصب به صورت خودکار اجرا 
 ،)Setup يا Install( شود، در پنجره ظاهر شده با کليک روي نام برنامه يا گزينه نصب نرم‌افزار

فايل اجرايي نصب برنامه يعنيSetup.exe  اجرا مي‌شود.
2- اجراي دستي نصب برنامه: در اين روش ابتدا روي آيکن CD يا DVD کليک راست 
کني��د و پس از آن با انتخ��اب گزينه Open به فايل اجرايي نصب برنامه دسترس��ي خواهيد 

داشت.
3- اس�تفاده از گزينه  Add or Remove Programs  درControl Panel : در اين روش 
با اس��تفاده از پنجره Add or Remove Programs روي دکم��هCD or Floppy  کليک کرده و 
مس��ير فاي��ل اجراي نصب برنامه یعنی setup.exe را با کليک�� روي دکمه مرور )Browse( در 

کادر متني Open درج کنيد.
با اجراي فايل setup.exe به مراحل مش��ترک بين س��ه روش گفته شده مي‌رسيد. در اين 
مرحله ويزارد نصب آش��کار مي‌ش��ود و در مرحله‌هاي بعدي، تعيين مس��ير نصب فايل‌هاي 
برنامه، سبب کپي شدن فايل‌ها در مسير انتخابي مي‌شود. پس از پايان نصب برنامه و اجراي 

آن، محيط برنامه طبق شكل 2-2 آشكار مي‌شود.

شکل 2-2 محيط برنامه FreeHand پس از اجرا
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FreeHand MXa  3-2 اجراي برنامه
براي ‌اجراي ‌برنامه مي‌توانيد ‌مسير

Start → All Programs → Macromedia → Macromedia FreeHand MXa  را انتخ��اب 

کرده يا از ميانبري که روي صفحه Desktop ايجاد کرده‌ايد، استفاده کنيد.
Welcome 4-2 کادرمحاوره

با اجراي مسيرHelp→Welcome  کادرمحاورهWelcome  ظاهر مي‌شود. کادر خوشامدگويي 
FreeHand شامل اين پيوندها است:

What’s New 2-4-1

خلاص��ه‌اي از ابزاره��ا و امکانات جديد برنامه را در اختيار کارب��ر قرار مي‌دهد. به منظور 
برق��راري ارتباط بهتر با کاربر برخي از امکانات اضافه ش��ده ب��ه برنامه با کليک روي علامت 

دوربين به صورت تصويري نشان داده مي‌شود.)شکل 2-3(
                                                                         

  

شکل 3-2 نمايش ابزارهاي جديد اضافه شده به برنامه  

Using FreeHand MX 2-4-2

کليک�� روي اي��ن گزينه، راهنماي برنامه FreeHand را نش��ان مي‌ده��د که مي‌‌توانيد به 
صورت سرفصل موضوعات، کلمه‌هاي کليدي و جستجوي عبارت‌ها و کلمه‌ها  از آن استفاده 

کنيد.
Learning FreeHand MX 2-4-3

 Adobe و با استفاده از سايت Online براي مرور س��رفصل‌ها و درس‌هاي برنامه به صورت
از اين پيوند استفاده مي‌شود. 
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View the FreeHand MX product pages 2-4-4
 Online به صورت Adobe در اين قس��مت ليس��تي از محصولات ارائه شده توسط شركت

مشاهده مي‌شود. 
Visit the Macromedia Designer & Developer Center 2-4-5

اي��ن پيون��د، براي برق��راري ارتب��اط با مر��کز طراح��ي و توس��عه نرم‌افزار بهک‌ار مي‌رود. 
پيون��د  روي  ش��ما  کليک��  هس��تيد،  متص��ل  اينترن��ت  ب��ه   هنگامي��ک ه 
Visit the Macromedia Designer & Developer Centerصفحه Adobe Design Center را ظاهر 

ميک‌ند.
Visit the FreeHand MX Support Center 2-4-6

 Visit the FreeHand MX Support با مرکز ارائه خدمات برنامه از طريق پيوند Online ارتباط
 Center امکان‌پذير است. در صفحه اين پيوند، نکات اساسي و منابع و تجهيزات مورد نياز برنامه

FreeHand MXa ، مشکلات چاپ و کار با متن‌ها و ... در اختيار کاربر قرار مي‌گيرد.

Wizard 5-2 کادرمحاوره
همان‌طورکه مي‌دانيد ويژگي برنامه‌هايي که به صورت Wizard اجرا مي‌ش��ود، اين است 
که در هر مرحله از اجراي برنامه مورد نظر، سؤال‌ها و انتخاب‌هايي آشکار مي‌شود که براساس 
انتخاب و پاس��خي که به سؤال مطرح شده مي‌دهيد، ش��ما را به مرحله بعدي اجراي برنامه 
هدايت ميک‌ند. به عبارتي ويزارد يک برنامه، راهنما و هدايتک‌ننده کاربر براي اجراي سريع 

و راحت فرمان‌ها و دستورالعمل‌هاي موردنظر اوست.
 ،Help→Wizards… نيز چنين امکاني وجود دارد و با اجراي مس��ير FreeHand در برنامه

کادرمحاوره Wizard مطابق شکل 4-2 مشاهده مي‌شود.
در کادرمح��اورهWizard ، پن��ج دکمه قرار دارد و کليک روي هر کدام س��بب اجراي يک 

ويزارد خاص مي‌شود كه در اين بخش به صورت خلاصه شرح داده شده است.

 Wizard شکل 4-2 کادرمحاوره اصلي
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Welcome 2-5-1

با کليک روي اين دکمه، ويزارد خوش��امدگويي مطابق ش��کل 5-2 اجرا مي‌شود که پنج 
دکمه موجود در اين کادرمحاوره به اين شرح است:

    

Welcome شکل 5-2 کادرمحاوره ويزارد

Setup 2-5-2

در اين بخش تنظيم‌ه��اي فايل FreeHand مثل واحد اندازه‌گيري، اندازه صفحه، افقي يا 
عمودي بودن صفحه و انتخاب رنگ‌هاي مورد استفاده در سند انجام مي‌شود. 

Setup شکل 6-2 فايل ايجاد شده با ويزارد

	   Screen-based 2-5-3

ب��راي انجام تنظيم‌هاي مرب��وط به ايجاد تصويره��ا و عناصرگرافيکي مورد اس��تفاده در 
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اينترنت، پروژه‌هاي چند‌رس��انه‌اي، تصويرهاي به‌دس��ت آمده از برنامه‌هاي گرافيکي تدوين و 
ويرايش تصوير از ويزاردScreen-based استفاده مي‌شود.

Stationary 2-5-4

ايجاد س��ند‌هاي چندصفحه‌اي که تنظيم‌هاي استاندارد سربرگ، کارت ويزيت، برچسب 
ديس��کت، برچسب پس��تي و پاکت نامه را دارند؛ همچنين نمونه‌هاي آماده آن‌ها در برنامه با 
استفاده از اين ويزارد قابل اجرا است. انتخاب رنگ با توجه به پالت‌هاي رنگي آماده يا حالت 

سياه و سفيد از ديگر مواردي است که مي‌توانيد با استفاده از اين ويزارد انجام دهيد. 

Stationary در ليست رنگ فايل اجرا شده در ويزارد Metallic و رنگ Fun  شکل 7-2 طرح

Publication 2-5-5

در اين ويزارد تنظيم‌هاي نش��ر و ايجاد صفحه‌ه��اي کاري براي تقويم، کتاب، خبرنامه و 
آگهي‌ها انجام مي‌شود. 

تمرين : در هر كدام از حالت‌هاي گفته ش��ده سندي را باز كنيد و به تفاوت‌هاي 
آن‌ها دقت كنيد.
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واژه‌نامه
Business cardکارت ويزيت
Developer Centerمرکز توسعه
Freestyleطرح آزاد

Interfaceرابط
Illustrationتصوير

Measurementاندازه‌گيري
Multi Pagesچندصفحه‌اي

Newsletterخبرنامه
Overviewبرداشت کلي

Publicationنشر
Screen-basedاساس نمايش تصوير

Snappingچسبيدن
Stationeryنوشت‌افزار

Support Centerمرکز خدمات
Web-relatedمربوط به وب

خلاصه مطالب
FreeHand MX يک نرم‌افزار گرافيکي برداري اس��ت که براي طراحي و ترسيم آرم، لوگو، 

جلد کتاب و مجله، کاغذ کادو و جعبه دستمال کاغذي و ... بهک‌ار مي‌رود. ابزارها و پنل‌هاي 
مختلف امکانات گوناگوني را براي اين برنامه فراهم کرده‌اند.

 ب��راي نص��ب برنام��ه FreeHand مي‌تواني��د از س��ه روش خ��ودکار، دس��تي و گزين��ه
Add Or Remove Programs در Control Panel استفاده کنيد.
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1-در نرم‌افزارهاي پيكسلي تصاوير از خطوط و منحني تشكيل شده است.
2- اندازه فايل‌هاي Vector از فايل‌هاي Bitmap كمتر است.

3- حافظهRAM  مورد نياز براي نصب FreeHand حداقل 64 مگابايت است. 
4- براي انجام تنظيمات مربوط به ايجاد تصاوير اينترنتي از ويزارد Stationary اس��تفاده 

مي‌شود.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Screen-based               FreeHand5- تنظيم‌هاي مربوط به ايجاد سند و صفحه کاري در
 ،FreeHand 6- ايجاد س��ند، بازکردن فايل‌هاي موجود با فرمت‌هاي ش��ناخته ش��ده در
Stationery                                            Help بازکردن فايل‌هاي ويرايش شده، نحوه استفاده از
7- ايج��اد تنظيم‌هاي س��ربرگ و کارت ويزيت و اس��تفاده از نمونه‌ه��اي آماده آن‌ها در 
 Welcome                                                                                       	برنامه
Setup 8- تنظيم‌هاي نشر و ايجاد صفحه‌هاي کاري براي تقويم و جلد کتاب            	
Publication    9- ايجاد تصوير براي وب و چندرسانه‌اي و تدوين تصويرها در حين کار

گزينه صحيح را انتخاب کنيد.

10- کدام‌يک از نرم‌افزارهاي زير از نوع برداري هستند؟
	FreeHand -ب              	 Photoshop -الف

د-  ب و ج هستند  	 	Corel Draw -ج
11- فايل اجرايي نصب برنامه FreeHand، .............. است.

Serialnumber.txt -د   	 Keygen.exe-ج 	Setup.exe -ب      	Setup.txt -الف
 FreeHand 12- کدام گزينه نش��ان دهنده مقدار فضاي آزاد موردنياز، براي نصب برنامه

است؟
ج- 100	                  د- 128 الف- 70                 ب- 64        	

13- کدام گزينه دسترسي کاربر به فايل‌هايي را که اخيراً با آن‌ها کار کرده و روي آن‌ها 
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ويرايش انجام داده است، فراهم ميک‌ند؟
	Open -ب           	  FreeHand Help -الف

New -د 	            Previous File  -ج
14- در کادر مح��اوره خوش��امدگويي، گزين��ه Learning FreeHand MX ب��ه چه منظور 

استفاده مي‌شود؟
الف- بررسي Help برنامه               

Online ب- مرور سرفصل‌ها و درس‌هاي برنامه به صورت
ج- کار با مرکز طراحي و توسعه نرم‌افزار از طريق اينترنت

  Online د- مشاهده محصولات به صورت
در جاي خالي عبارت مناسب را بنويسيد.

15- دکم��ه .............. امکان دسترس��ي ب��ه الگوهاي از پيش آم��اده FreeHand را فراهم 
ميک‌ند.

16- ........... يک�� برنام��ه، راهنما و هدايت کننده براي اجراي س��ريع و راحت فرمان‌ها و 
دستورالعمل‌هاي موردنظر کاربر است.

17- در نرم‌افزار پيکس��لي با ........... پيکس��ل‌ها جزييات تصوير بيش��تر ش��ده و با .......... 
پيکسل‌ها جزييات تصوير کمتر شده و حجم آن کاهش مي‌يابد.

به سؤالات زير پاسخ تشريحی دهيد.
18-  سه مورد از مزاياي برنامه گرافيکي برداری را بيان کنيد.

 19- حداقل چهار مورد از کاربردهاي FreeHand را بنويسيد. 
آزمون عملي

1- در برنامه فتوشاپ، تأثير تغيير کيفيت تصوير در اندازه و حجم آن را نشان دهيد.
2- نرم‌افزارFreeHand  را در درايو موردنظر نصب کرده و اجرا کنيد.

3- مواردي که در نگارش جديد نرم‌افزار اضافه ش��ده بررس��ي کرده و روش بهک‌ار بردن 
Help برنامه را نشان دهيد.
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كليات
نرم‌افزار FreeHand MXa داراي محيطي ش��بيه نسخه‌هاي قبلي اين نرم‌افزار است؛ البته 

ابزارها و قابليت‌هاي جديدي به آن افزوده شده است که به شرح آن خواهيم پرداخت. 
FreeHand MXa 1-3 شناخت محيط نرم‌افزار

پس از نصب اين برنامه که در واحد كار قبل گفته شد، از مسير زير برنامه را اجرا کنيد.
Start→All Programs→Macromedia→Macromedia FreeHand MXa

با اجراي برنامه، محيط کار FreeHand MXa ظاهر مي‌شود. اکنون مي‌توانيد براي ترسيم، 
ي��ك صفحه طراحي جديد ايجاد کنيد يا با اس��تفاده از فرمان File→Open يک فايل ذخيره 

شده را باز کنيد. 
ايجاد فايل جديد

براي ايجاد صفحه جديد به يکي از روش‌هاي زير عمل کنيد:
1- فرمان File→New را انتخاب کنيد.

2- کليد ميانبر Ctrl+N را بفشاريد.
3- ابزار  را از نوار ابزار اصلي برنامه انتخاب کنيد. 

که در اين صورت صفحه‌اي مطابق با ش��کل 1-3 ظاهر مي‌ش��ود كه مي‌توانيد در قسمت 
صفحه طراحي )به شكل يك ورق كاغذ ديده مي‌شود( ترسيمات خود را انجام دهيد.

      

FreeHand MXa شکل 1-3 محيط کار
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Main 1-1-3 نوارابزار

اين نوارابزار در بالاي پنجره برنامه و در زير نوار منو واقع ش��ده و حاوي آيکن‌هايي است 
که امکان دسترسي سريع به فرمان‌هاي مورداستفاده در FreeHand را فراهم مي‌سازد؛ نظير 
فرمان‌ه��اي Save، پنل Lock ،Object يا قفل موضوعات و غيره )ش��کل 1-3(. این نوار ابزار با 

استفاده از روش هایی که ذکر می شود قابل انتخاب است:  
 •  کلي  کراست  روي قسمت خاکستري نوارهاي ابزار ديگر)مانند نوار Info( بجز  نوارمنو	

Window→Toolbars→Mainانتخاب نوار ابزار موردنظر 
جدول 1-3  توضيح آيکن‌هاي نوارابزار

توضيحاتنام آيكنآيكن
Newايجاد يک فايل جديد
Openبازکردن فايل ذخیره شده
Saveذخيره فايل جاري

ImportFreeHand واردکردن فايل‌ها‌ از برنامه‌هاي ديگر به
Printچاپ فايل جاري
Lock   قفلک‌ردن موضوع انتخاب شده

Unlock   بازکردن قفل موضوع انتخاب شده
Graphicsجستجو و جايگزيني

Align  Alignبازکردن پنل
TransformTransform بازکردن پنل

LibraryLibrary بازکردن پنل
ObjectObject بازکردن پنل

Windowبازکردن‌فايل‌بدون‌بستن فايل‌هاي‌ديگر با‌قابليت‌دسترسي به‌تمامي پنل‌ها

Color MixerColor Mixer بازکردن پنل
SwatchesSwatches بازکردن پنل

LayersLayers بازکردن پنل
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)Info( 2-1-3 نوارابزار اطلاعات

اين‌ نوار در پايين پنجره برنامه ظاهر مي‌ش��ود و اطلاعاتي ش��امل اندازه، موقعيت و ساير 
خصوصيات موضوعات ترسيمي و موقعيت اشاره‌گر را نشان مي‌دهد )شکل 3-2(.

 Info شکل 2-3 نوارابزار

)Toolbox( 3-1-3 جعبه ابزار

جعبه‌ابزار در FreeHand MX دربرگيرنده ابزارهاي مختلفي است. 
جعبه‌ابزار Tools با استفاده از روش‌هاي زير ظاهر مي‌شود:

• 	Window→Tools انتخاب گزينه
• 	Ctrl+F2 کليد ميانبر

)Panels( 4-1-3 پنل‌ها

زماني که اولين بار وارد FreeHand مي‌شويد کادرهايي را مشاهده ميک‌نيد که با يکديگر 
ترکيب ش��ده‌اند و در سمت راست محيط برنامه قرارگرفته‌اند، به هر کدام از اين کادرها پنل 
مي‌گويند كه مي‌توانيد آن‌‌ها را جا‌به‌جا کنيد، از حالت ترکيب شده خارج نماييد و با پنل‌هاي 

مورد نظرخود در يک گروه قرار دهيد. 
پنل‌ها با استفاده از روش‌هاي زير قابل دستيابي هستند:

•  منوي Window و انتخاب پنل موردنظر 	
• 	Main انتخاب پنل موردنظر از نوار ابزار 

* اين پنل‌ها به طور پيش‌فرض با يکديگر گروه‌بندي شده‌اند:
• ق��رار گرفته‌ان��د  	Properties در يک�� گ��روه ب��ه ن��ام Document و Object پن��ل  

)شکل 3-3(.
• پنل  Styles ،Swatches وLibrary در يک گروه به نام  Assets قرارگرفته‌اند.	
• پنلColor Mixer  و Tints در يک گروه به نام  Mixer and Tints قرارگرفته‌اند.	
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  Properties شکل 3-3 پنل گروهي

• پنل Align و Transform در يک گروه به نام  Align and  Transformقرارگرفته‌اند.	
برخي از پنل‌ها نظير Layers با پنل‌هاي ديگري گروه‌بندي نش��ده‌اند ولي ش��ما مي‌توانيد 

آن‌ها را به دلخواه با پنل‌هاي ديگر در يک گروه قرار دهيد.
در س��مت راست پنل‌ها، آيکني به نام Panel’s Options Menu )شکل 4-3( قرار دارد که 

اگر روي آن کليک کنيد منوي كنترلي پنل باز مي‌شود.

 )Panel’s Options Menu( شکل 4-3 نمايش منوي پنل

اعمالي که مي‌توان روي پنل‌ها انجام داد عبارتند از:
کوچک و بزرگ کردن پنل‌ها

مثلث نوار عنوان پنل را کليک کنيد. هنگاميک‌ه جهت‌مثلث به س��مت‌پايين باشد اجزاي 
پنل نمايش مي‌يابد و در صورتي که جهت مثلث به س��مت راس��ت باشد فقط نوارعنوان پنل 

نشان داده مي‌شود.
جابه‌جاکردن پنل‌ها در بين گروه‌ها

براي انجام اين عمل مراحل بعد را انجام دهيد:
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1- روي منوي كنترلي پنل کليک کنيد.
 2- يکي از گروه‌هاي پنل را از زيرمنوي »With نام پنل Group« انتخاب نماييد يا گزينه
New Panel Group را برگزيني��د ت��ا پنل به گروه موردنظر انتقال يابد. در اين صورت پنل در 

يک پنجره جداگانه قرار خواهد گرفت.

 مث�ال 1: مي‌خواهيد پنل Mixer را که ب��ا پنل Tints در يک گروه قرار گرفته به 
پنل Document منتقل کنيد؛ براي اين منظور مراحل زير را انجام دهيد:

1- منوي كنترلي پنل Mixer را باز کنيد.
  Documentرا انتخاب کرده و از زير منوي باز ش��ده گزينه Group Mixer with 2- گزينه

را برگزينيد )شکل 3-5(.

شکل 5-3 جابه‌جايي پنل‌ها

3- در اين صورت پنل Mixer به صورت زبانه‌اي در پنل Document قرار مي‌گيرد.

 توجه: قبل از انتقال، پنل مقصد بايد روي صفحه قرار داشته باشد.

تمرين 1: پنل Layers را به پنل Object منتقل كنيد.

تغييرنام پنل‌هاي گروهي
براي تغيير نام يک پنل گروهي به صورت زير عمل کنيد:

1- از منوي پنل موردنظر، گزينه Rename Panel Group را انتخاب کنيد.
2- در نوار عنوان پنل، مکان‌نما به صورت چشم‌کزن ظاهر خواهد شد.
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 3- ن��ام جدي��د را  تاي��پ کرده و کلي��د Enter را بفش��اريد ت��ا نام جديد اعمال ش��ود 
)شکل 3-6(.

شکل 6-3 تغييرنام پنل گروهي

تمري�ن 2: نام پن��ل گروه��ي Object and Document را ب��ه My Layout تغيير 
دهيد.

ترکيب )dock( پنل‌ها 
مي‌تواني��د پنل‌ها را با يکديگ��ر و با پنل‌هاي گروهي ترکي��ب )dock( کنيد. هنگامي که 

پنل‌ها dock مي‌شوند جابه‌جايي آن‌ها روي صفحه نمايش آسان‌تر خواهد شد. 
براي اين منظور مراحل زير را انجام دهيد:

1- اشاره‌گر را به گوشه سمت چپ پنل موردنظر برده و نقاط gripper را که در اين محل 
قرار دارند، درگ کنيد )شكل 3-7(.

gripper شکل 7-3 نمايش نقاط

2- پنل را به س��مت پنل موردنظر برده و كليد ماوس را رها کنيد. در اين صورت پنل‌ها 
با هم ترکيب مي‌شوند )شکل 3-8(.

شکل 8-3 پنل‌هاي ترکيب )dock( شده
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 توج�ه: با اس��تفاده از درگ نق��اط gripper مي‌توانيد پنل‌ه��ا را از حالت dock خارج 

کنيد.
توصيف پنل‌ها

هر پنل ويژگي متفاوتي دارد كه در اين جا برخي از پنل‌ها به اختصار ش��رح داده ش��ده 
است:

پنل Object: امكان تنظيم زمينه، خط دور و جلوه‌هاي اشياء را فراهم مي‌كند. همچنين 
مي‌‌توانيد موقعيت و اندازه اش��ياء را تنظيم كنيد. گزينه‌هاي اين پنل برحس��ب شئ انتخاب 

شده تغيير مي‌كند.
پنل Document: به منظور ايجاد، اصلاح صفحات سند و وضوح چاپ به‌كار مي‌رود.

پنل Layers: كنترل ترتيب ظاهر ش��دن اشياء در صفحه نمايش را امكان‌پذير مي‌كند. از 
لايه‌ها مي‌توان به عنوان بخشي از ايجاد انيميشن‌ها استفاده كرد.

پنل Swatches: رنگ‌ها را ذخيره كرده و امكان اعمال آن‌ها را به خط دور يا زمينه براي 
اشكال فراهم مي‌سازد.

پنل Mixer: امكان تعريف رنگ‌ها را امكان‌پذير مي‌كند.
پنل Styles: به شما امكان مي‌دهد ظاهر تصاوير گرافيكي و متن را به صورت شيوه‌هايي 

ذخيره كنيد تا بعداً به ساير اشياء اعمال كنيد. 
پنل Tints: امكان ايجاد ته‌رنگ‌ها را فراهم مي‌كند.

پن�ل Library: نماده��اي گرافيكي را ذخيره كرده و از اي��ن نمادها براي كار با قلم‌موها، 
ايجاد صفحات اصلي و ايجاد انيميشن‌هاي SWF( Flash( استفاده مي‌شود.

پنل Align: براي تنظيم ترازبندي يا توزيع اشياء به‌كار مي‌رود.
پن�ل Transform: در اين پن��ل امكان جابه‌جايي، چرخش، تغيي��ر مقياس، كج‌كردن و 

انعكاس اشياء فراهم مي‌شود.
2-3 تنظيمات واحد اندازه‌گيري

در پايي��ن پنجره برنامه FreeHand MXa، نوار وضعي��ت )Status(  قرار دارد و دربرگيرنده 
گزينه‌هايي اس��ت که در ش��کل 9-3 نشان داده شده اس��ت. براي انتخاب واحد اندازه‌گيري 
بايد روي منوي بازش��ويUnits   از نوار وضعيت كليك کرده و واحد موردنظر خود را انتخاب 
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کنيد )مثلًا به‌ ميلي‌متر(. با انتخاب اين واحد، همه اشکال و موضوعاتي که از اين به بعد رسم 
مي‌شوند و همچنين خطک‌ش، برحسب آن واحد محاسبه خواهند شد.

(Status) شکل 9-3 نوار وضعيت

)Preferences( 3-3 تنظيمات ساختاري
با اس��تفاده از کادرمحاوره Preferences مي‌توانيد نحوه عملکرد برنامه FreeHand MXa را 

کنترل کرده و پارامترهاي اجرايي و ساختاري برنامه را تنظيم کنيد.
• را انتخ��اب کني��د، در اين‌ص��ورت کادرمحاوره  	Preferences گزين��ه Edit از من��وي
Preferences ظاهر مي‌ش��ود که شامل ده زبانه است و هرکدام تنظيمات بخش‌هايي 

از برنامه را به عهده دارند )شکل 3-10(.

Preferences شکل 10-3 کادرمحاوره
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 توجه: براي کار با Preferences، از كليد ميانبر Ctrl+U هم مي‌توانيد استفاده كنيد.

• وجود دارد که تنظيمات جاري را به حالت پيش‌فرض  	Defaults در همه زبانه‌‌‌ها دکمه
اوليه برمي‌گرداند. در ادامه به توضيح برخي از پارامترهاي مهم موجود در اين زبانه‌‌‌ها 

مي‌پردازيم:
1- زبانه General: تنظيمات عمومي در اين محل انجام مي‌گيرد.

ها براي برگرداندن اعمال انجام شده به عقب را تعيين ميک‌ند  • 	Undo تعداد :Undo's

که بهتر است مقدار آن‌را افزايش دهيد.
 توجه: Ctrl+Z  کليد ميانبر Undo است.

 

2- زبانه Object: تنظيمات مربوط به موضوعات و اشکال در اين محل انجام مي‌گيرد.
• و درگ  	Alt ب��ا فع��ال ب��ودن اين گزينه، نگه‌داش��تن کليد :Alt-drag copies paths

موضوع باعث کپي آن مي‌شود.
• اعدادي که در اين کادر وارد مي‌ش��وند، نشانگرضخامت‌هاي  	:Default Line weights

از پيش تعريف شده براي ابزار Line هستند.
3- زبانه Text: پارامترهاي تنظيمي مربوط به متن را کنترل ميک‌ند.

• را برگزينيد و روي  	Type بافعال بودن آن، درصورتيک‌ه ابزار :Always Use Text Editor

صفحه کليک‌کنيد يک کادر‌متني براي تايپ يا ويرايش‌متن‌موردنظر باز‌مي‌شود.
4- زبان�ه Document: تنظيم��ات مرب��وط به صفحات ايجاد ش��ده در س��ند را کنترل 

ميک‌ند.
• با اين گزينه مي‌توانيد يک فايل دلخواه را انتخاب کنيد  	:New document template

ت��ا در هنگام اجراي فرم��ان File→New صفحه جديد با فراخوان��ي اين فايل ايجاد 
شود.

• با فعال بودن آن در هنگام خروج  	:Always Review unsaved documents upon Exit

از برنامه، کادري ظاهر مي‌ش��ود که اعلان ميک‌ند تمام اسناد ذخيره نشده را ذخيره 
کنيد.
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5- زبان�ه Import: تنظيم��ات مربوط به فايل‌هاي وارد ش��ده ب��ه FreeHand را کنترل 
ميک‌ند.

6- زبانه Export: پارامترهاي تنظيمي مربوط‌ به فايل‌هاي صادر ش��ده از FreeHand به 
برنامه‌هاي ديگر را کنترل ميک‌ند.

7- زبان�ه Spelling: تنظيمات مرتبط با تصحيح متون تايپ ش��ده انگليس��ي را کنترل 
مي‌كند.

8- زبان�ه Colors: پارامتره��اي مرب��وط ب��ه نمايش رنگ‌ها توس��ط مانيت��ور را کنترل 
ميک‌ند.
• Guide color: تغيير رنگ خطوط راهنما	

• Grid color: تغيير رنگ خطوط شبکه‌اي 	

• انجام مديريت رنگ‌ها توس��ط مانيتور را انجام مي‌دهد يعني  	:Color management

نحوه ظاهر شدن رنگ‌ها روي صفحه نمايش را تعيين ميک‌ند.
9- زبان�ه Panels: تنظيمات‌مربوط‌ب��ه ‌نحوه نمايش ابزار و پنل‌ها در اين قس��مت انجام 

مي‌گيرد.
• فعال بودن اين گزينه باعث مي‌شود که با نگه‌داشتن اشاره‌گر ماوس  	:Show Tooltips

روي يک ابزار يا آيکن، نام آن نمايش داده ‌شود.
• در منوي بازشو اين گزينه، مي‌توان در پنل  	Text با انتخاب :Label Panel tabs with

جاري فقط نام زبانه‌هاي پنل را مشاهده کرد.
با انتخاب Icon، يک آيکن به نام زبانه پنل نشان داده مي‌شود.

 انتخابText and Icon ، س��بب نمايش نام به همراه آيکن در زبانه پنل مي‌ش��ود 
)شکل 3-11(.

شکل 11-3 سه تنظيم براي برچسب‌هاي زبانه‌هاي پنل

10- زبان�ه Redraw: وضعي��ت پ��ردازش تصاوير توس��ط مانيتور در اي��ن محل کنترل 
مي‌شود.

• فعال بودن اين گزينه، منحني و لبه‌هاي موضوعات  	:Enable Anti-aliasing گزين�ه
را حتي در زمان بزرگنمايي نرم‌تر نشان مي‌دهد.
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 ، • 	Preview براي بالا بردن سرعت پردازش تصوير در حالت :Redraw while scrolling

 Scroll بهتر اس��ت اين گزينه غيرفعال باش��د، در اين‌صورت وقتي توس��ط کليدهاي
)کليدهاي پيمايش صفحه(، صفحه را جابه‌جا ميک‌نيد بعد از توقف، تصوير پردازش 

مي‌شود يعني تصوير در حين Scroll  قابل ديدن است.
4-3 روش‌هاي بازکردن يک تصوير گرافيکي

ش��ما مي‌توانيد ترس��يماتي را که ايجاد و ذخيره کرده‌ايد، در برنامه FreeHand باز کنيد. 
همچنين تصاوير با فرمت‌هاي گوناگون در اين برنامه قابل باز شدن هستند.

Open 1-4-3 فرمان

با اس��تفاده از اين فرمان مي‌توان فايل‌هاي گرافيکي که براي FreeHand قابل شناس��ايي 
است، باز کرد. اين فرمان به چند روش اجرا مي‌شود:

File از منوي Open 1- انتخاب گزينه
  Ctrl+O 2- فشردن همزمان کليد تركيبي

Main 3- کليک روي آيکن  از نوار ابزار
کادرمحاوره Open در FreeHand مشابه نرم‌افزارهايي است که قبلًا با آن‌ها آشنا شده‌ايد 

بنابراين در اين جا از توضيحات بيشتر صرفنظر مي‌شود.

 نكته: با استفاده از گزينه Open Recent در منوي File مي‌توانيد فايل‌هايي را که 
اخيراً بازکرده‌ايد، مشاهده کنيد.

Import 2-4-3 فرمان

فرمان Import که در منوي File واقع شده است؛ به منظور وارد کردن فايل‌هاي گرافيکي 
ديگري غير از فرمت FreeHand به اين برنامه بهک‌ار مي‌رود. همچنين مي‌توانيد اين فرمان را 

با کليک روي آيکن  در نوار ابزار Main اجرا کنيد.
ب��ا اجراي فرمانFile→Import  کادر محاوره Import Document مطابق ش��کل 12-3 باز 

مي‌شود.

 توجه: کليد تركيبي Ctrl+R روش ديگري براي اجراي فرمان Import است.
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Import Document شکل 12-3 کادر محاوره

با روش اجراي آن در نرم‌افزار Photoshop قبلًا آشنا شده‌ايد.

 توجه: در منوي بازشو Files of type چنانچه All Known Types را انتخاب کنيد، در 

مرورگر کادر محاوره Import همه فايل‌هايي که يکي از قالب‌ها يا فرمت‌هاي قابل شناس��ايي 
توسط FreeHand را داشته باشند، نشان داده مي‌شوند.

كادر Preview پيش نمايش فايل اس��ت که هنگام مرور فايل‌ها، با ارائه پيش‌نمايش��ي از 
محتويات آن‌ها مي‌توان فايل موردنظر را به سرعت يافت.

پس از انتخاب فايل موردنظر روي دکمه Open کليک کنيد تا فايل فراخواني ش��ود، در 
اين صورت اشاره‌گر ماوس به صورت  تبديل شده و اکنون در هر کجا از صفحه گرافيکي 

کليک کنيد، فايل در آن نقطه درج مي‌شود. 

 توج�ه: پس از اجراي فرمان Import اگر بخواهي��د تصوير به اندازه موردنظر روي 
صفحه درج شود، بايد به اندازه دلخواه درگ کنيد.

فايل‌هاي گرافيکي پيکسلي )طرح بيتي يا Bitmap( با فرمت‌هاي tiff ،jpg و غيره پس از ورود به 
FreeHand، به صفحه جاري متصل )Link( مي‌شوند اما نمي‌چسبند؛ به عبارت ديگر وارد شدن آن‌ها به 

 صفحه در حجم فايل تأثيري ندارد و حجم آن زياد نمي‌شود و تنها از طريق مسيري که داده شده، 
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پيش‌نمايشي از آن در FreeHand نشان داده مي‌شود که قابل چاپ نيز هست.
اين خصوصيت باعث مي‌ش��ود که در صورت انتقال فاي��ل FreeHand به کامپيوتر ديگر، 
چنانچه فايل‌هاي پيکس��لي متصل شده )Link ش��ده( به فايل FreeHand موجود باشند، اين 
فايل‌ه��ا نيز همراه با فايل FreeHand منتقل ش��وند، در غير اي��ن صورت در کامپيوتر مقصد 

نمايش داده نخواهند شد و به صورت ديده مي‌شوند.
فايل‌ه��اي پيکس��لي را از طريق فرم��ان Edit→Links به فاي��ل FreeHand به طور کامل 

بچسبانيد )Embedded( که در اين صورت به حجم فايل افزوده مي‌شود.

 توجه: زماني که تعداد صفحات سند جاري زياد باشد و در اغلب صفحات فايل‌هاي 

ورودي پيکسلي داشته باشيم، در اين صورت Link کردن فايل پيکسلي جالب نيست و باعث 
افزايش بي‌رويه حجم فايل FreeHand خواهد شد.

تمرين 3: تفاوت فرمان Import و Open را بيان كنيد.

 مثال 2: در طراحي ش��کل 13-3 از ‌Shapeهاي Photoshop استفاده کرده و آن‌ها 
را در سند خود وارد کنيد. 

شکل 3-13

1- ابتدا شکل سگ را با ابزارهاي مناسب رسم کنيد.
2- ردپاي س��گ و شکل استخوان‌ها را با استفاده از Shape ها در Photoshop رسم کرده 

و در فايل‌هاي جداگانه با پسوند tif. ذخيره کنيد.
3- فايل‌ها را با فرمان Import وارد کار طراحي خود کرده و طبق ش��کل 13-3 در محل 

و در جهت مناسب  قرار دهيد.
تمرين 4: آرم موجود در شکل 14-3 را با استفاده از نرم‌افزار فتوشاپ رسم کرده، 
سپس در يک واژه‌پرداز )مثل WordPad(، متن زير آن را تايپ کرده و وارد )Import( محيط 
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FreeHand کنيد )کاربرد فرمان Import در وارد کردن متون طولاني(.

شکل 3-14

5-3 بزرگنمايي
در هن��گام کار، گاهي اوقات لازم مي‌ش��ود ��که براي ديدن جزييات بيش��تري از تصوير 
يا طرح، بخش��ي از آن بزرگنمايي ش��ود يا براي ديدن قس��مت‌هاي بيشتري از تصوير، عمل 

کوچکنمايي انجام گيرد.
براي اين عمل، روش‌هاي مختلفي وجود دارد که برخي از اين روش‌ها عبارتند از:

 Magnification 1-5-3 منوي بازشو

توسط اين منو که در شكل 15-3 نشان داده شده‌ است، مي‌توانيد يكي از بزرگنمايي‌هاي 
از پيش تنظيم شده را انتخاب كنيد. براي دسترسي به اين منوي بازشو از منوي View گزينه  

Magnification را برگزينيد.

Magnification شکل 15-3 فرامين بزرگنمايي گزينه

همچني��ن مي‌توانيد از منوي بازش��و Magnification واقع در نواروضعيت )شك��ل 3-9( 
بزرگنمايي موردنظر را انتخاب كنيد يا درصد بزرگنمايي موردنظر را تايپ كرده سپس كليد 

Enter را بفشاريد.

 Zoom 2-5-3 ابزار

انتخاب ابزار  در جعبه‌ابزار Tools يا فشردن کليدZ  از صفحه کليد علامت ذره‌بين را 
در اختيار شما قرار مي‌دهد. بعد از انتخاب اين ابزار روي ذره‌بين علامت + نشان داده مي‌شود. 
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ب��ا هر بار كليك‌، ميزان بزرگنمايي افزايش مي‌ياب��د؛ همچنين مي‌توان با ابزارZoom  اطراف 
شکل موردنظر کادري رسم کرد تا عمل بزرگنمايي انجام شود.

 نكته: درحالي که ابزارZoom  انتخاب شده است، مي‌توانيد با نگه‌داشتن کليد Alt شئ بزرگ 
شده را كوچك کنيد.

 تمرين 5: بررسي کنيد کليد ميانبر Ctrl+Spacebar چه عملي انجام مي‌دهد.
View 3-5-3 گزينه‌هاي بزرگنمايي در منوي

منويView  ش��امل گزينه‌هايي اس��ت که به منظور انجام عمل بزرگنمايي )Zoom(  براي 
تنظيم نمايش شئ انتخابي در صفحه به کار مي‌رود که در جدول 2-3 شرح داده شده‌اند.  

View از منوي Zoom جدول 2-3 گزينه‌هاي مربوط به

Fit SelectionCtrl + Alt + 0 بزرگنمايي را طوري تغيير مي‌دهد که فقط موضوع يا موضوعات انتخابي
در بزرگ‌ترين حالت، نمايش داده شود.

Fit To PageCtrl+Shift+W با اين گزينه مي‌توانيد صفحه جاري را به همراه همه موضوعات موجود
در آن مشاهده کنيد.

Fit AllCtrl + 0 بزرگنمايي به گونه‌اي خواهد شد که مي‌توانيد تمام صفحات موجود در
سند را مشاهده کنيد. 

Magnification)3-19 در اين مجموعه، انواع حالت‌هاي بزرگنمايي از 6% تا 800% وجود دارد. )شکل

تمرين 6: با اس��تفاده از زيرمنوي Magnification در قس��متي از تصوير دلخواه، 
بزرگنمايي 200% و کوچکنمايي 25% را اعمال کنيد.

 نكته: منوي بازش��وي بزرگنمايي )Magnification( در نوار وضعيت )Status( نيز 
شامل گزينه‌هاي مربوط به Zoom است.

6-3 كاربرد ابزار Hand در هنگام بزرگنمايي
در برخ��ي از ح��الات مثلًا هنگامي كه بزرگنمايي را افزايش مي‌دهيد، براي ديدن س��اير 
قسمت‌هاي تصوير نياز به ابزار Hand داريد. از اين ابزار براي جابه‌جايي به سمت بالا، پايين، 
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راست، چپ و مايل استفاده مي‌شود.
Hand استفاده از ابزار

1- از جعبه ابزار Tools ابزار Hand را انتخاب كنيد يا كليد H از صفحه كليد را بفشاريد 
)شكل 3-16(.	

Hand شكل 16-3 ابزار

2- با اين ابزار در پنجره سند كليك كنيد و ماوس را به سمت دلخواه بكشيد.

 نكت�ه: هنگام اس��تفاده از هر اب��زاري اگر كليد Spacebar را نگ��ه داريد‏، ابزار 
Hand براي جابه‌جايي، روي صفحه نمايش در اختيار شما قرار مي‌گيرد.

7-3 تنظيم حالت‌هاي نمايشي تصوير
FreeHand MXa گزينه‌هاي‌مختلف��ي را ب��راي نحوه نمايش تصوير يا طراحي ش��ما روي 

صفحه نمايش ارايه مي‌دهد. برخي از اين گزينه‌ها جزييات بيشتري از کار را نشان مي‌دهند 
ولي‌مدت ‌زيادي طول ميک‌ش��د تا اين‌جزييات نشان داده ‌شود. بعضي‌گزينه‌ها سريع‌تر ولي با 

جزييات کمتري تصوير را نشان مي‌دهند.
در نواروضعيت، امکان انتخاب حالت‌هاي نمايش��ي وجود دارد )شکل 17-3( که عبارتند 

از: 

شکل 17-3 انواع حالت‌هاي نمايشي 

همه موضوعات و رنگ‌ها در ش��کل واقع��ي خود همراه با  • Preview : در اي��ن حالت 	

جزييات به نمايش درمي‌آيند و به عنوان پيش‌نمايشي از چاپ خواهند بود.
در اين حالت رنگ‌هاي اصلي نش��ان داده مي‌شود ولي طيف رنگ‌ها  • 	 : Fast Preview

)Gradient( و ترکيب‌ها )Blend( با جزييات‌ کمتري نمايش ‌مي‌يابند. سرعت نمايش 
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در اين حالت بيشتر از Preview است.

 نكته: اگر در حالت Preview باش��يد، انتخ��اب گزينه View→Fast Mode حالت 
Fast Preview را نمايش مي‌دهد.

Keyline: اين حالت نمايش��ي در منوي View يا با اس��تفاده از كليد ميانبر Ctrl+K قابل 

دستيابي است. با انتخاب اين گزينه، موضوعات به‌صورت خطوط محيطي ديده شده و رنگ‌ها 
مخفي مي‌ش��وند، بدين ترتيب با ساده‌تر ش��دن نمايش موضوعات، نحوه قرارگيري آن‌ها در 

صفحه بهتر مشاهده شده و انتخاب موضوعات راحت‌تر است.

 توجه: براي اصلاح گره‌1ها و مسيرها بهتر است از حالت نمايشي Keyline استفاده 
کنيد.

Fast Keyline : در اين حالت نمايش خطوط به صورت س��اده‌تر و خلاصه‌تر ارايه مي‌شود 

و روش سريع‌تري براي نمايش تصاوير در حالت Keyline است.

 View→Fast Mode باشيد، انتخاب گزينه Keyline نكته: در صورتي که در حالت 
حالت Fast Keyline  را نمايش مي‌دهد.

1- با اصطلاح گره و مسير در واحدهاي كار 5 و 6  آشنا خواهيد شد.
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شکل 18-3 انواع حالت‌هاي نمايشي

تمري�ن 7: يکي از تصاوير موجود در FreeHand را باز کنيد و به بررس��ي چهار 
حالت نمايشي روي آن بپردازيد.

8-3 ايجاد نماي ديد سفارشي
اگ��ر در هن��گام طراحي به نماه��اي مختلف ديد از نظر بزرگي و كوچ��كي مكرراً احتياج 
داشتيد، مي‌توانيد از طريق گزينه View→Custom نماهاي سفارشي را ايجاد و ذخيره كنيد. 

  مثال 3: ايجاد يک نماي سفارشي 
1- قس��متي از موضوع رسم شده را Zoom کنيد، مثلًا بزرگنمايي گوشه سمت چپ يک 

تصوير دلخواه را به 326% افزايش دهيد )شکل 3-19(.
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Zoom 3-19 شکل

2- گزينه View→Custom→New را انتخاب کنيد.
.)Left corner نامي را براي اين نما انتخاب کنيد )مثلًا New View 3- در کادرمحاوره

4- دکمه OK را کليک کنيد تا نما ايجاد شود.

شکل 20-3 تعريف نماي سفارشي

تمري�ن 8: نمايي به نام See با بزرگنمايي 85% براي تصوير دلخواه ايجاد کنيد، 
سپس آن‌را در حالت Fast Keyline نمايش دهيد. 
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Keyboard Shortcuts 9-3 فرمان
يکي از س��ريع‌ترين روش‌هاي کار در برنامه کاربردي، استفاده از کليدهاي ميانبر صفحه 

کليد است. 
ميانبرهاي صفحه کليد در FreeHand تقريباً ش��امل تمام فرمان‌هاي منويي و بسياري از 
آيتم‌هاي غيرمنويي اس��ت. مي‌توانيد ميانبرهاي صفحه کلي��د را به گونه‌اي تغيير دهيد تا با 
عادت‌‌هاي کاري شما در نرم‌افزارهاي ديگر هماهنگ شود، همچنين مي‌توانيد به فرمان‌هايي 
که فاقد کليد ميانبر هستند، ميانبر اضافه کنيد. ليست ميانبرهاي پيش‌فرض FreeHand  در 

ضميمه آمده است.
1-9-3 اختصاصي ک‌ردن ميانبرها

FreeHand به ش��ما امکان مي‌دهد تا ميانبرهاي صفحه کليدي را که به فرمان‌ها نس��بت 

مي‌دهي��د، اختصاصي کنيد، بنابراين مي‌توانيد ميانبرهايي را به فرمان‌ها اضافه کنيد يا آن‌ها 
را به نحوي تغيير دهيد که با ساير برنامه‌ها تطبيق داشته باشند. براي اين منظور به صورت 

زير عمل کنيد:
1- از من��وي Edit فرم��ان Keyboard Shortcuts را اجرا کنيد. در اين صورت کادرمحاوره 

Customize نمايان مي‌شود )شکل 3-21(.

wCustomize

2- از بخش‌س��مت‌چپک‌ادرمحاوره Customize فرم��ان موردنظر را ب��راي تعريف ميانبر 
انتخاب کنيد.
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 Current shortcut keys 3- در صورتي که کليد ميانبري قبلًا تعريف شده باشد در ناحيه
ظاهر مي‌شود، در غير اين صورت مي‌توانيد کليد ميانبري به آن اختصاص دهيد.

4- ب��راي تعري��ف ميانب��ر مي‌توانيد در کادر مت��ن  Press new shortcut keyبا فش��ردن 
،Alt+Ctrl با کليدهاي ديگر صفحه کليد همچنين کليد ترکيبي Ctrl يا Alt همزمان کليدهاي 

Shift+Ctrl  ياShift+Alt  با کليدهاي ديگر، ميانبر تعريف کنيد.

5- روي دکمه Assign کليک کنيد تا کليد ميانبر تنظيم شود.
6- حال با کليک دکمه Close به صفحه برنامه بازگرديد.

 نكته: در صورتي که ميانبر به فرمان ديگري نس��بت داده ش��ده باشد آن فرمان بعد از عبارت
Currently assigned to ظاهر مي‌شود.

 توجه: دکمه Remove کليد ميانبر نسبت داده شده به يک فرمان را حذف ميک‌ند.

تمرين 9: براي فرمان Magnification کليد ميانبرCtrl+Shift+M  را تعريف كنيد.
FreeHand MXa 10-3 انواع فرمت‌هاي نرم‌افزار

به منظور ذخيره‌س��ازي ترس��يمات، براي تهيه خروجي به کمک چاپگ��ر يا تهيه فيلم و 
زينک�� ب��راي چاپخانه و همچنين انتقال فاي��ل از FreeHand به س��اير برنامه‌ها )Export( يا 
وارد��کردن فايل از برنامه‌هاي گرافيک��ي به Import( FreeHand( دانس��تن عملکرد و موارد 
اس��تفاده از قالب‌بندي‌ها يا فرمت‌هاي مختلف فايل‌ها ضروري اس��ت. FreeHand فرمت‌هاي 

مختلفي را براي ذخيره يا فراخواني فايل‌هاي گرافيکي پشتيباني ميک‌ند.

 توجه: فرمت FH11، فرمت استاندارد و اصلي  FreeHand MXa است.

 • 	Photoshop را به نرم‌افزارهاي ديگري نظير FreeHand درصورتيک‌ه بخواهيد فاي��ل
انتق��ال دهيد، لازم اس��ت فايل را به کمک�� فرمان Export با فرمتي که س��ازگار با 

نرم‌افزار مقصد باشد، ذخيره کنيد.
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• ي��ا روش‌هاي ديگر،  	File→Save هنگام ذخيره‌س��ازي تصوير با اس��تفاده از گزين��ه
کادرمح��اوره Save باز مي‌ش��ود که مي‌تواني��د از منوي بازش��و Save As Type قالب 

)فرمت( ذخيره‌سازي فايل را از بين اين فرمت‌ها انتخاب کنيد:
 fh11-1 : فرمت اصلي فايل‌ها در FreeHand است که معمولاً ترسيمات با اين فرمت ذخيره 

مي‌شوند.
ft11 -2 1: براي محافظت فايل از تغييرات غيرعمدي بهک‌ارمي‌رود.

Eps -3 2: درصورتيک‌ه مي‌خواهيد از تصوير ساخته شده در يک برنامه گرافيکي برداري 
يا برنامه نشر روميزي )مثل Page Maker( استفاده کنيد، اين فرمت را بهک‌ار بريد.

• ش��رح داده ش��ده  رايج‌ترين فرمت‌هاي قابل اس��تفاده در FreeHand در جدول 3-3	
است.

  1-FreeHand Template

                                                                                                                       2-Encapsulated postscript
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 FreeHand MX جدول 3-3 فرمت‌هاي رايج در

فرمت )پسوند رديف
شرحفايل(

1Fh5,Fh7,Fh8,
Fh9,Fh10

 MX و نسخه FreeHand براي نقل و انتقال فايل بين نسخه‌هاي قديمي‌تر
بهک‌ار مي‌رود.

2cdr .بهک‌ار مي‌رود CorelDRAW و FreeHand انتقال فايل بين براي نقل و 
اين‌پسوند فرمت فايل‌هاي برنامه CorelDRAW است.

3txt.بهک‌ار مي‌رود .txt براي نقل و انتقال فايل‌هاي متني با پسوند

4ai.بهک  ار   مي‌رودAdobe Illustratorو FreeHand براي  نقل   ‌و    ‌انتقال     فايل     بين

5gif
از قالب‌هاي گرافيکي پيکسلي است که ضمن ذخيره‌سازي، عمل فشرده‌سازي را  يکي 
هم انجام مي‌دهد. اين فرمت براي طراحي بخش‌هاي مختلف صفحات Web نيز به‌كار 

مي‌رود.

6jpeg يا  jpg در RGB و CMYK فرمتي ‌بسيار رايج و‌ كم‌حجم براي ذخيره‌سازي فايل‌هاي
فشرده‌ترين حالت ممکن است و در محيط وب نيز بهک‌ار مي‌رود. 

7png است و فشرده‌سازي را بدون افت کيفيت Web فرمت قابل استفاده در صفحات
انجام مي‌دهد.

8psd فرمت اصلي فايل‌هاي فتوشاپ است که براي نقل و انتقال فايل‌هاي پيکسلي
بين FreeHand و Photoshop بهک‌ار مي‌رود.

9pdf.است Adobe Acrobat  Reader اين فرمت قابل‌استفاده در برنامه

10tif و FreeHand  بـراي نقــل  و انتقــال  فايل‌هــاي‌گرافيـــکي   پيکســلي    بيـن
برنامه‌هـاي گرافيکي پيکسلي نظير فتوشاپ بهک‌ار مي‌رود.

11bmp است. اين ‌فرمت Windows فرمت   ‌استاندارد    برنامه‌هاي‌گرافيکي سيستم      ‌عامل
‌تصاوير را به‌صورت طرح‌بيتي )پيکسلي( درخود ذخيره‌ مي‌سازد.

FreeHand 11-3 روش‌هاي ذخيره‌سازي در
هنگام طراحي لازم اس��ت فايل مکرراً ذخيره ش��ود؛ اين کار باعث مي‌شود که در صورت 
قطع ناگهاني برق يا قفل شدن کامپيوتر، فايل کاري از بين نرفته و از انجام ترسيمات مجدد 

جلوگيري شود. 
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  Save 1-11-3 فرمان

با اجراي فرمان Save کادر محاوره Save Document روي صفحه ظاهر مي‌شود که با کليه 
قسمت‌هاي آن در نرم‌افزارهاي ديگر آشنا شده‌ايد.

 توجه: کليد ميانبر Ctrl+S راه ديگري براي ذخيره ترسيمات است.

از من��وي بازش��وي Save as type مي‌تواني��د نوع قالب ذخيره‌س��ازي يا فرم��ت فايل را از 
بين‌فرمت‌هاي eps. وFh11. انتخاب کنيد.

 توج�ه: اگر فايلي را قبلًا ذخيره کرده باش��يد، پس از انج��ام ويرايش براي ذخيره 

تغييرات روي همان فايل با نام، پسوند و مسير قبلي از فرمان Save استفاده کنيد.
Save As 2-11-3 فرمان

 هرگاه بخواهيد فايل را با نامي ديگر يا با فرمت و مسير ديگري روي ديسک ذخيره کنيد، از فرمان
Save As يا از کليد ترکيبي Ctrl+Shift+S استفاده کنيد. کادرمحاوره‌اي که پس از اجراي اين 

فرمان باز مي‌شود مانند کادر محاوره Save است.

 نكت�ه: اس��تفاده از فرم��ان Save As امکان ايج��اد کپي‌هاي متعدد از فاي��ل را فراهم 
ميک‌ند.

تمرين10: ي‌‌ک تصوير ‌دلخواه را وارد صفحه FreeHand کرده س��پس آن را به‌نام
My Picture.fh11 ذخيره کنيد. 

Revert 12-3 فرمان
با استفاده از فرمان Revert مي‌توانيد به آخرين مرحله ذخيره شده در ترسيمات بازگرديد. 

براي انجام اين کار به صورت زير عمل کنيد:
1- از منوي File گزينه Revert را انتخاب کنيد.

 2- کادر هش��داري ظاهر مي‌ش��ود که از ش��ما مي‌خواهد فرم��ان Revert را تأييد کنيد. 
)شکل 3-22(.

3- دکمه Revert را کليک نماييد.
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شكل 3-22
FreeHand 13-3 سفارشي کردن محيط برنامه

در محيط برنامه FreeHand امکان سفارشيک‌ردن موارد زير وجود دارد:
• اختصاصي کردن ميانبرهاي صفحه کليد	
• تغيير در نوار ابزارها	
• تغيير در جعبه ابزار	

1-13-3 تغيير در نوار ابزارها و جعبه ابزار

ب��ه راحت��ي مي‌توانيد هر يک از نوار ابزاره��ا و جعبه ابزار را با آيکن‌ه��اي موردنظر خود 
اختصاصي کنيد، براي اين منظور مراحل بعد را انجام دهيد:

1- مسير Window→Toolbars→Customize را انتخاب کنيد. کادرمحاوره Customize با 
فعال بودن زبانه Toolbars نمايش مي‌يابد )شکل 3-23(.

2- ح��ال از س��مت چپ کادر مح��اوره، نوار اب��زاري را که مي‌خواهيد سفارش��ي کنيد، 
برگزينيد.

Toolbars با انتخاب زبانه Customize شکل 23-3 کادر محاوره

3- در اين صورت آيکن‌هاي مربوط به نوار ابزار )Toolbar  ( انتخاب شده در سمت راست 
کادرمحاوره نمايش مي‌يابد.

4- آيک��ن موردنظر را به داخل نوار ابزار يا جعبه ابزار درگ کنيد. در اين هنگام آيکن به 
ابزارها اضافه مي‌شود )شکل 3-24(. 
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شکل 24-3 اضافه کردن آيکن به جعبه ابزار

 نكته: در صورتي که کادرمحاوره Customize Toolbars باز باشد، مي‌توانيد آيکن‌هاي يک نوار 
ابزار را با آيکن‌هاي نوار ابزار ديگر جابه‌جا کنيد.

 Alt مي‌توانيد با نگه داش��تن کليد Customize Toolbars توجه: بدون باز کردن کادر محاوره 
و درگ، آيکن دلخواهي را از يک نوار ابزار به نوار ابزار ديگر منتقل کنيد.

 FreeHand 14-3 بستن فايل و خروج از
چند راه پيشنهادي براي بستن فايل:

 File از منوي  Close1- انتخاب گزينه
 Ctrl+W2- فشردن کليد ترکيبي

:FreeHand چند راه پيشنهادي براي خروج از
1- دابل کليک روي  از نوار عنوان

 File از منوي  Exit2- انتخاب گزينه
3- فش��ردن کليد تركيبي Ctrl+Q که همه فايل‌هاي باز را مي‌بندد و از FreeHand خارج 

مي‌شود.
)Title Bar( 4- انتخاب علامت  از نوار عنوان
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واژه‌نامه
Fitاندازه شدن، مناسب کردن

Informationاطلاعات
Modifyتغيير دادن

Panelقاب
Preferenceارجحيت
Revertبازگشت
Unitsواحدها

خلاصه مطالب 
• کردن‌پنل‌ها  	dock عمليات کوچک ‌و بزرگک‌ردن، جابه‌جايي، گروه‌ کردن، تغييرنام و

را مي‌توان انجام داد.
•نواروضعيت شامل اجزاي زير است:  	

•بزرگنمايي، انواع حالات نمايش��ي، دکمه‌هاي انتخاب صفحه، دکمه افزودن صفحه و  	
منوي بازشوي واحد اندازه‌گيري. 

• هردو براي‌‌بزرگنمايي‌وک‌وچکنمايي ‌ترس��يمات  	Magnification و Zoomگزينه‌ه��اي
بهک‌ار‌ مي‌رود. 

•در اين برنامه مي‌ت��وان فايل‌ها را با قالب‌بندي يا فرمت‌هاي مختلفي ذخيره کرد )با  	
 .)File از منوي Save As يا Save انتخاب گزينه

• را طبق نياز  	FreeHand نيز مي‌توانيد محيط Edit→Preferences با استفاده از گزينه
خود تنظيم کنيد. 

 • 	FreeHand مي‌توان تصاوير گرافيکي را در  Importو Open با اس��تفاده از فرمان‌هاي
باز کرد.

• همه موضوعات و رنگ‌ها در شکل واقعي خود و همراه با  	Preview در حالت نمايشي
جزييات نمايش مي‌يابند. حالت Fast Preview رنگ‌هاي اصلي را نش��ان مي‌دهد ولي 

طيف رنگ‌ها و ترکيبات با جزييات کمتر ظاهر مي‌شود. 
در  • حالت Keyline تصاوير را به صورت خطوط محيطي و بدون رنگ نش��ان مي‌دهد. 	
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حالتFast Keyline ، نمايش خطوط به صورت س��اده‌تر است و روش سريع‌تري براي 
نمايش تصاوير است.

مي‌ت��وان ميانبر صفحه کليد براي اجراي  • 	 Keyboard Shortcuts با اس��تفاده از فرمان
فرمان‌ها تعريف کرد.

• مي‌توانيد تغييرات فايل ترس��يمي را به آخرين مرحله  	Revert با اس��تفاده از فرمان
ذخيره‌سازي برگردانيد.

• مي‌توانيد نوارابزارها و جعبه ابزار را سفارشي کنيد. 	FreeHand در محيط
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- کليد Ctrl+0 بزرگنمايي را به حدي مي‌رساند تا تمام صفحات سند مشاهده شود.
2- کليد Shift ابزار Hand را در تصوير جابه‌جا ميک‌ند.

3- سرعت حالت نمايشي Fast Preview بيشتر از Preview است.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

  Revert                                 .است FreeHand 4- فرمان وارد کردن فايل در برنامه
Customize Toolbar                         فعال مي‌شود Z 5- ابزار بزرگنمايي که با کليد
       Import                                     6- لغو کليه اعمال به بعد از آخرين ذخيره‌سازي
            Zoom                        .است Window 7- گزينه سفارشي کردن نوار ابزارها که در منوي

گزينه صحيح را انتخاب کنيد.

8- کدام‌يک از اعمال زير روي پنل‌ها صورت نمي‌گيرد؟
الف- تغيير نام         ب- جابه‌جايي        ج- ترکيب )dock(          د- حذف

9-  با استفاده از کدام نوارابزار مي‌توان اطلاعاتي در زمينه ‌شکل ‌ترسيم ‌شده ‌و ‌همچنين 
موقعيت مکان‌نما به‌دست آورد؟

Tools د- نوار        Status ج- نوار          Info ب- نوار         Menu  الف- نوار
10- کدام گزينه نادرست است؟

الف- توسط نقاط gripper مي‌توان عمل ترکيب پنل‌ها را انجام داد.
ب- FreeHand يک نرم‌افزار برداري است.

ج- منوي Unit در نوار ابزار Info قرار دارد.
د- کليد Ctrl+F2 جعبه ابزار را نمايان ميک‌ند.

11-  براي رسيدن به بزرگنمايي 130% از کدام گزينه استفاده مي‌شود؟
الف- Magnification از منوي View و انتخاب %130

ب- تايپ 130% در منوي  Magnification از نواروضعيت
Ctrl+1 ج- فشردن کليد ترکيبي

View در منوي Zoom د- استفاده از گزينه
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12- تنظيم تعداد Undo ها در کدام کادر محاوره انجام مي‌گيرد؟
Customize -د 	Open  -ج 	General -ب     Preferences -الف

13-  ب��ا انتخ��اب ک‌دام حالت نمايش��ي تصاوير به صورت خطوط محيطي ديده ش��ده و 
رنگ‌ها مخفي مي‌شوند؟

     Preview -ب 		   Fast Preview-الف
د- گزينه‌هاي الف و ج صحيح هستند. 	  	          Keyline -ج

14- گزينه Fit all در منوي View به چه منظور استفاده مي‌شود؟
الف- حداکثر بزرگنمايي را بر اساس موضوع انتخاب شده در تصوير ارايه مي‌دهد.

ب- اگر چندين صفحه گرافيکي داشته باشيد همه صفحات را در محيط نشان مي‌دهد.
ج- صفحه گرافيکي را به‌طور کامل در محيط کار نشان مي‌دهد.

د- همان بزرگنمايي 100% است.
15- در مورد فرمان Revert کدام گزينه صحيح است؟

الف- براي بازگرداندن هر عملي به يک مرحله قبل بهک‌ار مي‌رود.
ب- لغو کليه اعمال انجام شده در ترسيمات انجام مي‌گيرد.

ج- کليه تغييرات در ترسيم به آخرين مرحله ذخيره‌سازي برمي‌گردد.
د- به منظور تازه‌سازي صفحات برنامه بهک‌ار مي‌رود.
16- فرمت استاندارد براي FreeHand MX چيست؟

FH10 -د   	FH -ج     	FH11 -ب      	FHMX -الف
17- مناس��ب‌ترين فرمت براي واردکردن فايل‌هاي بيت‌مپي يا پيکس��لي )مثل فتوشاپ( 

به FreeHand کدام است؟
TIF -د     	 GIF-ج     	 EPS -ب              PDF -الف

 در جاي خالي عبارت مناسب را بنويسيد.

18- فرمان .................. براي تعريف کليد ميانبر به‌کار مي‌رود.
19- دستور ............. فايل را با نام و مسير ديگر ذخيره مي‌کند.

 Preferences  در زبان��ه .................. از کادر  Display font preview20- دس��تور تنظيم��ي
است.
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به سؤالات زير پاسخ تشريحی دهيد.

21-  وظيفه نوارابزار Main در محيط FreeHand چيست؟
22- تفاوت فرمانOpen  با Import را بنويسيد؟

23- مد نمايشي Keyline چه تفاوتي با مد Preview دارد؟
24- چگونه مي‌توان تعداد مراحل Undo را در FreeHand افزايش داد؟

آزمون عملي

يک  سند به نام Free1.Fh11 ايجاد کنيد، سپس:
1- فايل تصويري دلخواهي را بازکنيد.

2- تصوير را در بزرگ‌ترين حالت ممکن نمايش دهيد.
3- پنل Tint را با Layer در يک گروه قرار دهيد.

4- نام پنل گروهي سؤال 3 را به My Panel تغيير دهيد.
5- بزرگنمايي صفحه را از طريق منوي View به 400% برسانيد.

6- براي فرمان Revert کليد ميانبر Alt+R تعريف کنيد.
7- اب��زار Save را از نوار اب��زار Main به نوار ابزار Info منتقل کنيد س��پس به جاي خود 

بازگردانيد.
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كليات
 )Template( ق��دم اول در طراحي پروژه‌هاي گرافيکي، ايجاد س��ند يا اس��تفاده از الگوها
اس��ت. به منظور صفحه‌آرايي هماهنگ در يك سند مي‌توانيد صفحه اصلي )Master Page( و 
 Document  تعريف كنيد و تنظيمات صفحات را با استفاده  از پنل )Child Page( صفحه فرعي
تغيير دهيد. همچنين در اين واحدكار با ابزارهاي كمك رس��م براي ترس��يمات دقيق آش��نا 

مي‌شويد.
1-4 ايجاد صفحه پيش‌فرض

همان‌طور که قبلًا توضيح داده ش��د، مي‌توانيد با اس��تفاده از ويزارد Welcome يک سند 
پيش‌فرض بس��ازيد. علاوه بر اين که با اجراي FreeHand س��ندي شامل يک صفحه خواهيد 

داشت، اجراي مسير File→New نيز فايل يک صفحه‌اي ايجاد ميک‌ند.
Document 2-4 پنل

صفحه گرافيکي )Art board( قس��متي از س��ند جديد اس��ت که به شکل يک ورق کاغذ 
ديده شده و در واقع همان بوم نقاشي محسوب مي‌شود و موضوعاتي را که مايليد چاپ شود 
بايد در اين ناحيه ترس��يم کنيد. ناحيه اطراف صفح��ه را چرکنويس )Pasteboard( مي‌نامند 

)شکل 4-1(.
ابعاد و جهت صفحه گرافيکي توس��ط پنل Document قابل تنظيم اس��ت و در واقع ابعاد 
چاپ را تعيين ميک‌ند. اين کادر محاوره شامل يک کادر پيش‌نمايش در سمت چپ است که 

موقعيت صفحات را نمايش مي‌دهد.
اين پنل در مجموعه پنلProperties  قرار دارد )ش��کل 2-4( كه از منوي Window قابل 

دسترسي است. 
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FreeHand شکل 1-4 نمايش صفحه در برنامه

Document شکل 2-4 پنل

Document نمايش پنل
پنل Document با استفاده از روش‌هايي كه ذكر خواهد شد، ظاهر مي‌شود:

گزينه Document را از منوي Window انتخاب کنيد تا پنل باز شود.
روي آيکن  از نوارابزار Main کليک کرده و زبانه Document را انتخاب کنيد.
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 Main توجه: لازم به ذکر اس��ت که دکمه  ب��ه صورت پيش‌فرض در نوار ابزار 
ق��رار ندارد و از مس��ير Window→Toolbars→Customize براي ق��رار دادن آن در نوار ابزار 

Main استفاده مي‌شود.

Document 1-2-4 تنظيم ابعاد صفحه در پنل

صفحه پيش‌فرض در پنل Document به ابعاد Letter اس��ت و با اس��تفاده از منوي بازشو، 
مي‌توان اندازه صفحه موردنظر را تعيين كرد. درصورتيک‌ه صفحات اس��تانداردي مثل A4 را 
انتخاب کنيد، صفحه گرافيکي به طور اتوماتيک براس��اس اندازه‌هاي استاندارد تنظيم خواهد 

شد.
درصورتيک‌ه اندازه موردنظر شما در منوي بازشو نباشد، مي‌توان ابعاد صفحه را به دلخواه 
تعيين يا به اصطلاح سفارشي کرد. براي اين منظور از منوي بازشو، گزينه Custom را انتخاب 
 )Height( کرده، سپس جهت قرار‌گيري صفحه را مشخص کنيد. در مرحله بعد طول صفحه
را در کادر x و عرض صفحه )Width( را در کادر y وارد کنيد، سپس کليد Enter را بفشاريد 

تا اندازه‌ها به صفحه اعمال شوند )شکل 4-3(.

 Document شکل 3-4 تنظيم ابعاد سفارشي در پنل

 نكته: قبل از تنظيم ابعاد صفحه در پنل Document، ابتدا بايد واحد اندازه‌گيري صفحه تعيين 
شود.

 )Page( 2-2-4 ابزارانتخاب صفحه

تنظيم ابعاد سفارش��ي )دلخواه( يک صفحه با ابزارPage  به دو روش انجام مي‌شود که به 
شرح زيرهستند:
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روش اول:
1- ابزارPage  را از جعبه‌ ابزار Tools انتخاب کنيد.

2- روي صفحه‌اي که مي‌خواهيد ابعاد آن ‌را تغيير دهيد، کليک کنيد تا دس��تگيره‌هايي 
در اطراف لبه‌هاي آن ظاهر شود. 

3- با کش��يدن فلش دوطرفه هر يک از دستگيره‌هاي اطراف صفحه، اندازه صفحه تغيير 
خواهد کرد )شکل 4-4(.

Page شکل 4-4 تنظيم ابعاد صفحه با ابزار

 Info توجه: در هنگام کشيدن دستگيره‌ها، براي مشاهده ابعاد صفحه به نوار ابزار 
توجه داشته باشيد.

 نكته: تغيير اندازه صفحه تأثيري بر اندازه موضوع ترسيمي ندارد.

روش دوم:
1- ابزارPage  را از جعبه ‌ابزار Tools انتخاب کنيد.

2- كليد Alt را نگه داشته، روي صفحه دابل کليک کنيد.
3- کادرمحاوره Modify Page ظاهر مي‌شود )شکل 4-5(.
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Modify Page شکل 5-4 كادر

3-2-4 چرخاندن صفحه 

براي افقي و عمودي کردن صفحه به صورت زير عمل کنيد:
1- ابزار Page را از جعبه ابزار انتخاب کنيد.

2- روي صفحه موردنظر کليک کنيد تا دستگيره‌ها در اطراف صفحه ظاهر شود.
3- اش��اره‌گر را به گوش��ه‌اي در خارج از صفحه حرکت دهيد تا به صورت منحني درآيد، 

حال به سمت پايين درگ کنيد تا جهت صفحه تغيير کند.

 توجه: با چرخش صفحه، جهت محتويات آن تغيير نميک‌ند.
برخي از اعمالي که با اس��تفاده از ابزار Page روي صفحه انتخاب ش��ده انجام مي‌شود در 

جدول 1-4 درج شده ‌است.

جدول 1-4 عملكرد ابزار Page روي صفحه

Page Tool شرحاعمال ابزار

 Page Tool در هنگام درگ صفحه با ابزار 
از صفحه جاري يک کپي مشابه تهيه ميک‌ند.کليد Alt را بفشاريد.

Page Tool+Del.صفحه جاري را حذف ميک‌ند

Page Tool+جابه‌جايي صفحه در فضاي چرکنويس همراه با محتويات صفحهدرگ صفحه

 Page Tool+Ctrl+جابه‌جايي صفحه در فضاي چرکنويس بدون  محتويات صفحهدرگ صفحه
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تمرين 1: با ابزار Page يك كپي از صفحه جاري تهيه كنيد، سپس آن را افقي كنيد.

4-2-4 تنظيم حاشيه مجازي )Bleed( يک صفحه

معم��ولاً FreeHand MX بخش‌هاي خارج از يک صفح��ه را چاپ نميک‌ند، بنابراين براي 
تنظيم ناحيه اضافي يا حاش��يه در اطراف صفحه گرافيکي از قس��مت Bleed استفاده مي‌شود 
و با وارد کردن اندازه موردنظر و فش��ردن کليد Enter يک کادر خاکس��تري رنگ در اطراف 

صفحهک‌اري ظاهر مي‌شود که ناحيه Bleed نام دارد )شکل 4-6(.
دليل استفاده از Bleed را هنگام برش لبه‌هاي کاغذ در چاپخانه متوجه مي‌شويد چرا که 
کادر Bleed به عنوان محافظ، دور صفحه اصلي قرار مي‌گيرد تا درصورتيک‌ه قسمت کوچکي 

از کار شما خارج از صفحه اصلي قرار داشت، در زمان برش چاپ حذف نشود.

            

Document شكل 7-4 جابه‌جايي صفحه با استفاده از پنل       Bleed شکل 6-4 نمايش ناحيه

Document 5-2-4 جابه‌جايي صفحه از طريق پنل

با نگه داش��تن کلي��دSpacebar  همزمان با درگ صفح��ه در ناحيه پيش‌نويس مي‌توانيد، 
صفحه را جابه‌جا کنيد )شکل 4-7(.	

6-2-4 افزودن ابعاد سفارشي به ليست اندازه صفحه

درصورتيک‌ه بخواهيد از صفحه ايجاد شده با ابعاد سفارشي )دلخواه( زياد استفاده کنيد، 



Free Hand پیمانه مهارتی : کاربر
71واحد کار چهارم: توانایی ایجاد فضای مورد نیاز جهت قرارگیری اشیای گرافیکی 

مي‌توانيد آن را به ليس��ت اندازه صفحات اس��تاندارد موجود بی افزاييد تا در آينده بتوانيد به 
سرعت به آن دست يابيد. براي اين کار مراحل زير را دنبال کنيد:

 Document از من��وي بازش��وي اندازه صفح��ه واقع در پن��ل Edit 1- انتخ��اب گزين��ه 
)شکل 4-8(.

Edit  Page Sizes شکل 8-4 نحوه نمايش کادرمحاوره‌

Edit Page Sizes در کادر محاوره New 2- کليک روي دکمه
Page Size 3- تعريف يک نام براي اندازه سفارشي در قسمت

4- وارد کردن اندازه موردنظر در کادر x و y )طول و عرض صفحه(
5- انتخاب دکمه Close که با بسته شدن کادر محاوره، اندازه‌ اختصاصي در منوي بازشو 

ظاهر خواهد شد.

 توجه: دکمه Delete در كادر محاوره Edit Page Sizes براي حذف اندازه سفارش��ي 

به کار مي‌رود.

7-2-4 وضعيت نمايش صفحات

در پايين کادر پيش ‌نمايش در پنل Document س��ه دکمه قرار دارد )ش��کل 9-4( که با 
کليک روي هر يک از آن‌ها در صورتي‌ که بيش از يک صفحه داشته باشيد، مي‌توانيد حالت 

نمايش آن‌ها را روي کادر پيش‌نمايش و داخل فايل تنظيم کنيد. 

شکل 9-4 وضعيت نمايش صفحات
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 نكت�ه: با درگ صفحات از داخل کادر پيش‌نمايش، مي‌توان صفحات گرافيکي را 
به منظور طراحي صفحات کتاب، تقويم و ... به هم چسباند.

تمرين 2: بررس��ي کنيد آي��ا روش ديگري براي کنار هم ق��راردادن صفحات يا 
چسباندن آن‌ها به يكديگر وجود دارد؟

Document 8-2-4 منوي کنترل در پنل

همان‌طور كه گفته شد در گوشه سمت راست بالاي پنل Document، منوي کنترل وجود 
دارد  که با کليک روي آن زيرمنويي باز مي‌ش��ود كه شامل گزينه‌هايي است که برخي 

از آن‌ها در اين‌جا آمده‌اند:
چنانچه به بيش از يک صفحه نياز داشته باشيد، مي‌توانيد از اين گزينه  • 	 :Add pages

براي اضافهک‌ردن صفحه جديد در کنار صفحه قبلي استفاده کنيد )شکل 4-10(.

Add Pages شکل 10-4 نحوه نمايش کادر

 نكته: براي افزودن تعدادي صفحه با اندازه‌هاي متفاوت، لازم است براي هر اندازه 
خاص ي‌کبار فرمان Add pages را اجرا کنيد.

• Duplicate: از صفحه جاري يک کپي مشابه تهيه ميک‌ند.	

• Remove: صفحه جاري را حذف ميک‌ند.	
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تمرين 3: يک س��ند به نام Test2 به همراه يک صفحه 60×40 سانتي‌متري، سه 
صفحه A4 و دو صفحه B5 ايجاد کنيد، به طوريک‌ه دو صفحه B5 به هم چس��بيده باش��ند؛ 

سپس کليه صفحات را نمايش دهيد.

  )Printer Resolution(9-2-4 درجه وضوح

با اس��تفاده از منوي بازش��و در پايين پنل Document مي‌تواني��د درجه وضوح تصوير يا 
کيفيت چاپ را تعيين کنيد؛ اين درجه هرچه بالاتر باشد کيفيت تصاوير در چاپ بهتر خواهد 

بود. درجه وضوح براي صفحه نمايش، 72dpi و براي چاپ، 300dpi است.

 توجه: واحد اندازه‌گيري وضوح تصوير dpi1 و به معني نقطه در اينچ است.

 مثال 1: تنظيمات صفحه مي‌خواهید سندي به نام Test1 را كه شامل دو صفحه 
يک��ي به ان��دازه 200×450 ميلي‌متر و ديگري به اندازه A5 با درجه وضوح dpi 350 اس��ت، 

ايجاد کنید، براي اين منظور مراحل زير را انجام دهيد:
1- ابتدا واحد اندازه‌گيري ميلي‌متر را از نوار وضعيت انتخاب کنيد.

2- ب��راي وارد کردن ان��دازه 200×450، از منوي بازش��و تنظيم ان��دازه صفحه در پنل 
Document  گزين��ه Custom را انتخاب و مق��دار450 را در کادر x و 200 را در کادر  y وارد 

کنيد.
3- مقدار dpi 350 را در منوي بازشو  Printer Resolution  وارد کنيد.

4- ح��ال صفحه اول ايجاد ش��ده اس��ت، براي ايج��اد صفحه دوم از من��وي کنترل پنل 
Document  گزينه Add pages را انتخاب کنيد.

 Page size عدد 1 را وارد کرده، سپس در منوي بازشو  Number of new pages5- در کادر
اندازه استاندارد A5 را انتخاب کنيد.

.)File→Save( ذخيره کنيد Test1 6- فايل را به نام

   1- Dot Per Inches   
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Master Page 3-4 صفحه
 Master Page )صفحه اصلي1( اين امکان را مي‌دهد تا صفحه‌هاي سندي که ايجاد ميک‌نيد؛ 

صفحه‌آرايي ثابت و منس��جم و از قبل مش��خص شده داشته باش��د. مي‌توانيد ويژگي‌هايي از 
صفح��ه معمولي مانند محل قرارگيري متن و گرافيک آن را در Master Page تعريف کنيد و 
اين خصوصيات را به همه يا تعدادي از صفحه‌هاي موردنظرتان اعمال کنيد. بدين ترتيب هر 
تغييري كه در صفحه اصلي ايجاد مي‌كنيد به طور خودكار به صفحه‌هاي ديگر س��ند اعمال 

مي‌شود.

 توجه: مي‌توانيد يک يا بيش از يک صفحه اصلي در سند داشته باشيد.

 نكته: از Templates نيز براي ‌ايجاد ‌سندهاييک‌ه صفحه‌آرايي ‌آن‌ها از قبل‌ تعريف 
‌شده ‌است، استفاده مي‌شود.

FreeHand به شما امكان مي‌دهد كه يکMaster Page  جديد ايجاد کنيد يا صفحه سند 

جاري را به يک Master Page تبديل کنيد.
زماني‌که يک Master Page مي‌س��ازيد، اندازه، جهت‌و‌تنظيمات Bleed صفحه جاري سند 
ب��راي آن در نظر گرفته مي‌ش��ود، البته اگ��ر بخواهيد، مي‌توانيد تنظيم��ات صفحه اصلي را 
تغيير‌دهيد. هنگامي که يک صفحه سند را به Master Page تبديل ميک‌نيد، عناصر و اجزاي 

صفحه سند در Master Page قرار مي‌گيرد.
 در پنلLibrary ، صفحه اصلي به عنوان يک نماد گرافيکي مديريت مي‌شود و کارهايي که در 

)جدول2-4( درج شده روي آن قابل اجراست:
جدول 4-2

آشکار ساختنپنهان کردنحذفتغييرنامگروه‌بنديايجاد يک نسخه کپي

DuplicateGroupRenameDeleteHideShow

1- صفحه مادر 
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 توجه: براي اس��تفاده از Master Page در سندهاي ديگرِ FreeHand مي‌توانيد آن 
را Export كرده سپس آن را به سند جاري وارد )Import( كنيد.

 • 	Childبه يک Master Page هنگام��ي که با صفحه اصلي کار ميک‌نيد؛ با اعم��ال يک
Page ، عناص��ر و اجزاي Master Page در پايين‌ترين لايه Child Page )صفحه فرعي( 

قرار مي‌گيرد.
Master Page 1-3-4 ايجاد

با استفاده از دو پنل Document و Library مي‌توانيد يک Master Page ايجاد کنيد؛ براي 
ساخت Master Page از طريق پنل Document مراحل زير را انجام دهيد:

1- انتخ��اب Window→Document، براي نمايش پن��ل Document در صورتي که فعال 
نباشد.

2- از منوي پنل Document گزينه New Master Page را طبق شکل 11-4 انتخاب کنيد. 
)همچنين مي‌توانيد از منوي پنل Library گزينه New Master Page را برگزينيد.(

3- متن و گرافيک موردنظرتان را در محلي از صفحه Master Page که در نظر گرفته‌ايد، 
قرار دهيد )شکل 4-11(.

4- صفحه‌ها و ويژگي‌هاي Master Page را ذخيره کرده و پنجره آن را ببنديد.

Document شکل 11-4 ايجاد صفحه اصلي با استفاده از پنل

 مث�ال 2: يک صفحه اصلی با ن��ام Master Page-01 در فايلی با نام Example1 با 
توجه به مشخصات زير ايجاد کنيد:

اندازه صفحه A4، عمودی و سه دکمه با رنگ دلخواه در سمت چپ صفحه قرار دهيد.	
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1- با اس��تفاده از برنامه گرافيکي نقاشي )Paint( يا فتوشاپ يك كادر با  اندازه 4/4×21 
  Export درج ش��ده اس��ت، ايجاد کنيد س��پس آن را My Project س��انتی‌متر که در آن متن

نماييد.
2- در برنامه FreeHand يك سند جديد ايجاد كرده، اندازه و جهت صفحه را از طريق پنل 
 Document از منوي كنترل پنل New Master Page تنظي��م نماييد و روي گزينه Document

کليک کنيد.
3- پنل library را از مسير  Window→Library باز كنيد.

4- از طريق منوي كنترلي Library فايلGel Buttons را از پوش��ه Samples که در پوش��ه 
برنامه FreeHand قرار دارد، Import كنيد س��پس دکمه‌های مورد نظرتان را انتخاب كرده و 

در صفحه قرار دهيد.
6- كادر رس��م ش��ده در برنام��ه گرافي��كي موردنظر را ب��ه س��ند FreeHand وارد كنيد 

)File→Import( و در بالاي صفحه قرار دهيد )مطابق شكل 4-12(.

شکل 12-4 مشخص کردن محل اشياء در صفحه اصلي

7- فايل را با نام Example1 ذخيره کنيد.	
ش��ما مي‌توانيد با استفاده از گزينه New Master Page در منوي كنترل پنل Library يك 

Master Page جديد نيز ايجاد كنيد كه شامل يك موضوع گرافيكي است )شكل 4-13(.



Free Hand پیمانه مهارتی : کاربر
77واحد کار چهارم: توانایی ایجاد فضای مورد نیاز جهت قرارگیری اشیای گرافیکی 

شکل 13-4 قراردادن موضوع گرافيکي در صفحه اصلي

با بس��تن پنجره صفحه اصلي ويژگي‌ها و صفحه‌هاي Master Page در پنل Library قابل 
مشاهده است.

)Child Page( 2-3-4 اضافه کردن يک صفحه فرعي

روش اول:
1- گزينه Add pages را از منوي کنترلي پنل Document برگزينيد )شکل 4-14(.

2- گزينه Make child of Master Page را انتخاب كنيد )شکل 4-15(.
3- يکي از Master Page  هاي موجود را انتخاب و روي OK کليک کنيد)شکل 4-15(.



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
78

Document از پنل Add pages شکل 14-4 انتخاب گزينه

شکل 15-4 اضافه کردن صفحه فرعي

 نكت�ه: ب��ا انتخاب يک صفح��ه Child و کليک�� روي گزين��ه Duplicate در پنل 
Document نيز مي‌توانيد يک صفحه فرعي به صفحه Master Page اضافه کنيد.

روش دوم:
با استفاده از ابزار Page صفحه Child را انتخاب كرده سپس آن صفحه را همزمان با نگه 
داش��تن كليد Alt در فضاي چركنويس سند درگ كنيد. اين عمل سبب اضافه شدن صفحه 

فرعي به سند مي‌شود.

اس��ت،  Master Pageاز  Child Page يک��  ج��اري  صفح��ه  اگ��ر  توج�ه:   
Master Page جديد تنظيمات Master Page اصلي را خواهد داش��ت که مي‌توانيد آن‌ها را از 

طريق پنل Document تغيير دهيد.
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تمري�ن 4: يك صفحه اصلي با محتويات دلخ��واه ايجاد كرده و به آن دو صفحه 
فرعي )Child( اضافه کنيد.

3-3-4 تبديل يک صفحه به يک Master Page جديد

اگر مي‌خواهيد يک صفحه س��ند را به Master Page تبديل کنيد به ترتيب اين مراحل را 
انجام دهيد:

1- صفحه‌اي را كه مي‌خواهيد به صفحه اصلي تبديل شود، انتخاب کنيد.
 Convert to Master Page کليک کرده و گزينه Document 2- روي من��وي کنترلي پن��ل

را انتخاب کنيد )شکل 4-16(.

شکل 16-4 تبديل يک صفحه به يک  Master Page جديد

عناص��ر موج��ود در صفحه اصلي پس از ظاهر ش��دن در صفحه‌هاي س��ند قابل ويرايش 
نيس��تند. اگر مي‌خواهيد اين عناصر را در صفحه س��ند اصلاح كني��د بايد آن‌ها را از صفحه 

اصلي خارج )Release( كنيد.

 نكت�ه: اگ��ر صفحه ش��ما فرع��ي )Child Page( اس��ت، براي تبدي��ل آن به يک 
Master Page ابتدا آن را Release کنيد.

Release 4-3-4 صفحه فرعي

1- صفحه يا صفحه‌ها را با استفاده از ابزار Page انتخاب كنيد.
2- گزينهRelease Child Page  را از منوي‌کنترلي پنل  Documentبرگزينيد.

در اين صورت مي‌توان عناصر صفحه اصلي را در سند ويرايش كرد.
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Library 5-3-4 نمايش و عدم نمايش صفحه اصلي در پنل

 اگر بخواهيد آيکن صفحه مادر در ليست پنل Library مشاهده شود طبق شکل 17-4 گزينه
Show Master Pages را در حالت فعال قرار دهيد. نداشتن علامتP نشانه پنهان بودن صفحه 

اصلي در ليست است.

شکل 17-4 نمايش و عدم نمايش صفحه اصلي

6-3-4 اعمال Master Page به صفحه سند

Library با استفاده از پنل
1- صفحه يا صفحه‌هاي موردنظر را با استفاده از ابزار Page  انتخاب كنيد.
2- ابتدا بررسي کنيد که نمايش صفحه اصلي در پنل Library فعال باشد.

3- آيکن Master Page را از پنل Library درگ کرده و داخل صفحه قرار دهيد.
 Document با استفاده از پنل

صفحه يا صفحه‌هاي موردنظر را با استفاده از ابزارPage  انتخاب كنيد.
از ليست Master Page در پنل Document، صفحه اصلي را انتخاب كنيد تا عناصر صفحه 

اصلي در سند ظاهر شوند.

 نكته: در س��ندهاي چندصفحه‌اي، صفحه انتخاب ش��ده به Master Page نسبت 
داده مي‌ش��ود و اگر تعداد صفحه‌هاي انتخابي از يکي بيش��تر باشد، با ابزار Page صفحه‌هاي 

مورد نظر را به عنوان صفحه‌هاي فرزند صفحه Master Page در نظر بگيريد.
Master Page 7-3-4 ويرايش

1- يکي از موارد زير را انجام دهيد:
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روي آيکن Master Page در پنل Library دابل کليک کنيد.
  Edit انتخ��اب کرده و روي دکمه )Master Page( يک صفحه اصلي Document در پن��ل

کليک کنيد.
2- تغييرات مورد نظر را در Master Page اعمال کنيد.

3- پنجره Master Page را ببنديد.	

 تمري�ن 5: با اس��تفاده از فاي��ل Gel Buttons از پوش��ه Samples واقع در برنامه 
FreeHand، يك صفحه اصلي با نام Buttons1 ايجاد كرده، س��پس رنگ دكمه‌هاي موجود در 

صفحه را تغيير دهيد.
Master Page 8-3-4 حذف

براي حذف صفحه اصلي از يك صفحه سند مراحل زير را انجام دهيد:
1- صفحه‌هاي موردنظر را انتخاب كنيد.

2- از ليست Master Page پنل Document    گزينه None را برگزينيد. بدين ترتيب عناصر 
صفحه اصلي از صفحه حذف مي‌شوند.

 توج�ه: ب��راي تغيير نام صفحه اصلي، روي نام Master Page در پنل Library دابل 
كليك كنيد.

Master Page يک Export و Import 4-3-9

براي وارد کردن يک صفحه اصلي در فايل مورد نظر، به ترتيب زير عمل کنيد.
1- گزينه Import را از منوي کنترلي در پنل Library انتخاب کنيد.

2- در کادر مح��اوره‌اي Import Symbols فاي��ل ح��اوي Master Pages را انتخاب و روي 
دکمه Open کليک کنيد.

3- پ��س از انتخ��اب صفح��ه اصلي موردنظ��ر از کادرمح��اوره‌ ظاهر ش��ده، روي دکمه 
"Import کليک کنيد. در اين صورت صفحه وارد ش��ده در پنل Library نش��ان داده مي‌ش��ود 

)شکل 4-18(.
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Import Symbols شکل 18-4 انتخاب صفحه اصلي از کادرمحاوره

 ،)Export( براي اين که بتوانيد از صفحه اصلي ايجاد شده در فايل‌هاي ديگر استفاده کنيد
مراحل زير بايد اجرا شود:

1- گزينه Export را از منوي کنترل در پنل Library انتخاب کنيد.
2- صفحه‌هايي را که مي‌خواهيد Export کنيد، برگزينيد )شکل 4-19(.

3- روي دکمه Export کليک کنيد.
4- در کادرمحاوره‌اي که ظاهر مي‌شود، پوشه Symbol هاي صادر شده را انتخاب کنيد. 

 

شکل 19-4 انتخاب صفحه اصلي از کادرمحاوره Export Symbols و ذخيره آن در پوشه موردنظر براي صادر کردن آن در فايل‌هاي 

ديگر

5- ن��ام فاي��ل را براي صادر ��کردن Master Pages درج ��کرده و روي دکمه Save کليک 
كنيد.
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 Shift توجه: براي انتخاب چند صفحه مي‌توانيد، همزمان با انتخاب صفحه‌ها کليد 
را نگه داريد.

)Page Rulers( 4-4 کار با خطک‌‌ش
با اس��تفاده ازخطک‌ش‌هاي افق��ي و عمودي مي‌توانيد موضوع��ات مختلف را اندازه‌گيري 

کنيد )شکل 4-20(.

Guides وGrid  ،Page Rulers شکل 20-4 نمايش

ب��راي نمايش خطک‌ش‌ها گزين��هView→Page Rulers→Show  را انتخاب کرده يا از کليد 
تركيبي Ctrl+Alt+R استفاده کنيد.

 توجه: براي انتخاب واحد اندازه‌گيري خطک‌ش، از منوي بازشو Units واقع در نوار  

وضعيت استفاده کنيد.

1-4-4 تغيير محل نقطه صفر خطک‌ش

علامت بعلاوه در گوش��ه س��مت چپ بالاي خطک‌ش )محل تقاطع دو خطک‌ش( نشانگر 
‌نقطه ‌صفر خطک‌ش است. مي‌توانيد براي کمک به اندازه‌گيري موضوعات روي صفحه، محل 
اي��ن نقطه را تغيير دهيد، به اين صورت که علام��ت بعلاوه را به محلي که مي‌خواهيد نقطه 

صفر از آن جا شروع شود، درگ کنيد.
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 توجه: براي برگش��ت نقطه صفر به جاي اول خود روي علامت بعلاوه دابل کليک 
کنيد.

تمرين 6: خطک‌شي با واحد ميلي‌متر روي صفحه، نمايش دهيد.

)Guides( 5-4 خط‌هاي راهنما
خط‌هاي راهنما، براي تقس��يم صفحات به نواح��ي مختلف و نيز تنظيم دقيق موضوعات 
رس��م ش��ده و تراز  اش��کال بهک‌ار مي‌رود. خطوط راهنما در چاپ ظاهر نخواهند شد و رنگ 

پيش‌فرض اين خطوط آبي است )شکل 4-20(. 
1-5-4 ترسيم خط‌هاي راهنما

ترس��يم خط‌هاي راهنما به دو روش دقيق و نس��بي انجام مي‌شود که به ترتيب به شرح 
زير است:

•ترسيم دقيق 	

براي ترسيم دقيق خط‌هاي راهنما در صفحه، مسير View→Guides→Edit را اجرا کرده و 
از دکمه Add که در کادرمحاوره Guides قرار دارد، استفاده کنيد )شكل 4-21(.

با کليک روي ‌دکمه Add، کادرمحاوره‌ Add Guides مطابق با شكل 22-4 ظاهر مي‌شود 
که عملکرد گزينه‌هاي آن در جدول 3-4 آمده است:

                      

	                     

Add Guides شکل‌ 22-4 کادرمحاوره                     Guides شکل‌ 21-4 کادرمحاوره             
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جدول 4-3

Guides

Horizontalبراي افزودن خطوط راهنماي افقي

Verticalبراي افزودن خطوط راهنماي عمودي

Add by

Countبراي وارد کردن تعداد خطوط راهنما در صفحه

Increment
براي وارد کردن عددي به عنوان فاصله خطوط راهنما که نرم‌افزار

 با محاسبه فاصله، تعداد خطوط را مشخص ميک‌ند.

Position

Firstتعيين نقطه شروع خطوط راهنما

Lastتعيين نقطه انتهاي خطوط راهنما

Page Range
در صورت داشتن بيش از يک صفحه در سند، مي‌توانيد مشخص کنيد خطوط راهنما از چه 

صفحه‌اي شروع و تا چه صفحه‌اي ادامه يابد. 

Add دکمه
با کليک روي اين دکمه به کادرمحاوره Guides باز

مي‌گرديد و مي‌توانيد خطوط تعريف شده را مشاهده کنيد.

•ترسيم نسبي 	

 View→Page Rulers→Show براي ترسيم خط‌هاي راهنماي افقي يا عمودي ابتدا از مسير
خط‌كش را فعال كنيد. حال مي‌توانيد اش��اره‌گر ماوس را روي خطک‌ش افقي يا عمودي قرار 

داده و آن را به داخل صفحه درگ کنيد.
ب��راي تنظي��م پيمايش )Scroll( پنجره س��ند، در زمان درگ خط‌ه��اي راهنماي افقي و 

عمودي بخصوص در زماني که تعداد صفحه‌ها زياد است؛ به طريق زير عمل کنيد:
 General باز کنيد سپس زبانه Edit→Preferences را از مسير Preferences 1- کادرمحاوره

را فعال کنيد.
2- گزينه Dragging a Guide Scrolls the Window را انتخاب کنيد.
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 توج�ه: در حال��ت پيش‌ف��رض، Scroll خط‌هاي راهنما در پنجره س��ند غير فعال 
است.

مثال 3: براي درك بهتر روش رس��م خ��ط راهنما و تنظيم Scroll مراحل بعد را 
انجام دهيد:

1- يك صفحه به اندازه 2000×800 پيكس��ل ايجاد كنيد. در اين صورت  قس��مت بالاي 
صفحه را مشاهده نمي‌كنيد. 

2- با اس��تفاده از روش ترسيم دقيق 5 خط راهنماي افقي و 4 خط راهنماي عمودي در 
صفحه قرار دهيد.

 Dragging a Guide گزينه General را باز ك��رده و در زبانه Preferences 3- كادر مح��اوره
Scrolls the Window را انتخاب كنيد.

4- حال با استفاده از خط‌كش 2 خط راهنماي افقي در بالاي صفحه رسم كنيد. براي اين 
كار بايد خط راهنما را از خط‌كش، به صفحه درگ كنيد و همزمان به س��مت بالاي صفحه، 
ماوس را حركت دهيد. مي‌بينيد كه صفحه به س��مت بالا Scroll  مي‌ش��ود تا شما خط را در 

محل مناسب قرار دهيد. 
2-5-4 نمايش خط‌هاي راهنما

براي نمايش خطوط راهنما گزينه View→Guides→Show  را انتخاب کنيد.
3-5-4 قفل کردن خط‌هاي راهنما

براي قفل کردن خطوط راهنما گزينه View→Guides→Lock را برگزينيد.
4-5-4 خاصيت آهنربايي خط‌هاي راهنما

 View→Guides→Snap To Guides براي ايجاد خاصيت آهنربايي خط��وط راهنما گزينه
را انتخ��اب کني��د، با انجام اين عمل، در هنگام جابه‌جايي يا ترس��يم وقتي موضوعي به خط 
راهنما نزديک مي‌ش��ود مانند يك آهنربا عمل كرده و از فاصله چند پيکس��لي آن را به سوي 

خود جذب ميک‌ند.
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5-5-4 حذف خط‌هاي راهنما

براي حذف خط‌هاي راهنما، ابتدا بايد ابزار Pointer را انتخاب کرده، سپس خط راهنماي 
 Guides در کادر محاوره Remove موردنظ��ر را ب��ه خارج از صفحه درگ کنيد ي��ا از دکم��ه

استفاده کنيد.

 نكته: براي تغيير رنگ خط‌هاي راهنما و نقاط شبکه‌اي، از زبانه Colors واقع در 
کادر محاوره Preferences استفاده کنيد.

6-5-4 ويرايش خط‌هاي راهنما

ب��راي ويرايش خط‌هاي راهنما، گزين��ه View→Guides→Edit را برگزينيد يا روي يکي 
از خط��وط راهنما دابل کليک کنيد، بدين ترتيب کادرمحاوره Guides باز مي‌ش��ود )ش��کل 

.)4-23
عملکرد گزينه و دکمه‌هاي کادر محاوره Guides در جدول 4-4 آمده است.

شکل 23-4 نمايش مشخصات خطوط راهنماي روي صفحه
با وارد کردن شماره‌ صفحه، صفحه‌ موردنظر براي‌ ويرايش‌ خط‌هاي ‌راهنما انتخاب مي‌شود. Page

خط‌هاي راهنماي انتخاب شده در ليست به خط واقعي تبديل مي‌شود. Release

خط‌ راهنماي انتخاب شده در ليست را حذف ميک‌ند. Remove

Add براي ‌افزودن خط‌هاي راهنما به‌طور دقيق به صفحه بهک‌ار مي‌رود.

براي تغيير موقعيت قرارگيري خط راهنماي انتخاب شده در ليست بهک‌ار مي‌رود. Edit

جدول 4-4
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 توجه: همه کارهاي گفته ش��ده بعد از تأيي��د کادر محاوره Guides يعني کليک 
دکمه OK، در صفحه جاري قابل مشاهده خواهد بود.

 مث�ال 4: مي‌خواهيم يك صفح��ه گرافيکي را از خطوط راهنماي افقي با فواصل 
نيم‌ سانتي‌متري پر کنيم، براي اين منظور مراحل زير را انجام دهيد:

1- ابتدا واحد اندازه‌گيري صفحه را به سانتي‌متر تغيير دهيد.
2- گزين��ه View→Guides→Edit را انتخاب ��کرده و از کادرمحاوره Guides روي دکمه 

Add کليک كنيد.

3- در کادر باز شده، گزينه Horizontal را برگزينيد.
4- در قسمت Increment عدد 0/5 را وارد کنيد.

5- ب��ا کليک�� روي دکم��ه Add تغيي��رات را تأييد ��کرده و س��پس OK را کليک کنيد 
)شکل4-24(.

شکل 24-4 افزودن خطوط راهنماي افقي 

تمرين 7:
1- يک سند حاوي يک صفحه A4 در جهت افقي ايجاد کنيد.
2- هفت خط راهنماي عمودي موازي روي صفحه ايجاد کنيد.

3- سه خط راهنماي افقي موازي نيز در صفحه ايجاد کنيد.
4- خطوط راهنما را قفل کنيد.
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5- اولين خط افقي را حذف کنيد.
)Grid( 6-4 خطوط شبکه

خطوط شبکه‌بندي، خط‌هاي نقطه‌چين افقي و عمودي هستند که قابل چاپ نبوده، براي 
تراز اش��ياء با هم و تعيين موقعيت موضوعات بهک‌ار مي‌روند. اين خطوط س��اختاري شبيه‌ به 
کاغذ شطرنجي را نشان مي‌دهند و در هنگام ترسيم شکل‌ها و جابه‌جايي دقيق اشياء بسيار 

مفيد هستند )شکل 4-25(.
1-6-4 نمايش خط‌هاي شبکه

براي فعال س��اختن ش��بکه راهنما، گزينهView→Grid→Show  را انتخاب کنيد تا نقاط 
مشبک روي صفحه ظاهر شوند.

 توجه: کليد تركيبي Ctrl+Alt+G نقاط شبکه‌اي را فعال مي‌سازد.

2-6-4 ويرايش خط‌هاي شبکه

براي تغيير فاصله‌هاي بين نقاط ش��بکه‌اي بر‌اس��اس واحد اندازه‌گي��ري جاري از گزينه 
View→Grid→Edit اس��تفاده کنيد، در اين‌صورت کادرمحاوره Edit Grid ظاهر مي‌شود. در 

قسمت Grid size فاصله موردنظر را وارد کرده و روي OK کليک کنيد )شکل 4-25(. 

شکل 4-25 

3-6-4 چسبندهک‌ردن نقاط شبکه

با انتخاب گزينه View→Grid→Snap to Grid  خطوط مش��بک حالت آهنربايي خواهند 
داش��ت و با نزدي‌ک کردن اشياي ترسيمي به خطوط شبکه‌اي، موضوعات جذب اين خطوط 

مي‌شوند.
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 توجه: کليد تركيبي Ctrl+Alt+Shift+G قابليت Snap to Grid را فعال مي‌سازد.

 Snap7-4 ابزار
با استفاده از اين ابزارها امکان چسباندن موضوع‌هاي گرافيکي و نقاط مسيرها به يکديگر 
در زمان جابه‌جايي و حرکت آن‌ها در صفحه فراهم مي‌ش��ود. همچنين مي‌توانيد ميزان اين 

چسبندگي را تعيين کنيد )شکل 4-26(.

شکل 4-26

1-7-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک نقطه ديگر

يکي از موارد زير را انجام دهيد:
1-از جعبه ابزار، دکمه   Snap to Point را برگزينيد.

2- مسيرView→Snap to Point  را پيگيري کنيد.
3- با استفاده از ابزار Pointer موضوع گرافيکي را انتخاب و به نزديکي يا روي نقطه‌اي که 

به عنوان هدف در نظر گرفته‌ايد درگ کرده و در محل مناسب رها کنيد )شکل 4-27(.

شکل 27-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک نقطه ديگر

2-7-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک مسير

يکي از موارد زير را انجام دهيد:
1- از جعبه ابزار، دکمه   Snap to Object را برگزينيد.

2- مسيرView→Snap to Object  را پيگيري کنيد.
3- با استفاده از ابزار Pointer موضوع گرافيکي را انتخاب و به نزديکي يا روي مسيري که 

به عنوان هدف در نظر گرفته‌ايد درگ کرده و در محل مناسب رها کنيد )شکل 4-28(.
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شکل 28-4 چسباندن يک موضوع گرافيکي يا يک نقطه به يک مسير

3-7-4 فاصله چسبندگي

 Preferences را در کادرمحاوره General را اجرا کرده و زبانه Edit→Preferences 1- مسير
انتخاب کنيد.

2- در کادر متن��يSnap distance   مطابق ش��کل، حداقل مقدار م��ورد نظر براي فاصله 
چسبندگي را وارد کنيد )شکل 4-29(.

3- روي دکمه OK کليک کنيد.

شکل 29-4 تغيير فاصله چسبندگي

 مثال كاربردي: مي‌خواهيم با استفاده از مثال كاربردي كه در آخر هر واحد كار 
ارايه مي‌شود يك نمونه كارت ويزيت طراحي كنيم. در اين واحد کار به ايجاد صفحه موردنظر 
خواهيم پرداخت، سپس در واحد کارهاي بعدي به طراحي آرم و کارت ويزيت مي‌پردازيم. 

1- يك صفحه جديد باز كنيد و واحد اندازه‌گيري آن را ميلي‌متر قرار دهيد.
2- در پن��ل Document گزين��ه Custom را براي ابعاد كاغذ انتخ��اب كنيد و مقادير 35 

ميلي‌متر را براي عرض و 50 را براي طول صفحه وارد كرده، كليد Enter را بفشاريد.
3- با ابزارZoom  صفحه را در حالت بزرگنمايي قرار دهيد.

4- خط‌كش‌ها را ظاهر كرده، خطوط راهنماي مورد نياز را به داخل صفحه بياوريد.
5- فايل ايجاد شده را در قالب يك فايل گرافيكي با فرمت FH11 و با نام Project ذخيره 

كنيد.
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واژه‌نامه
Bleedبريدن كاغذ، ناحيه برش کاغذ

Guideراهنما

Gridشبكه

Master Pageصفحه اصلي )صفحه با اولويت بالا، صفحه مادر(

Modifyتغيير دادن

Page Childصفحه فرعي )صفحه با اولويت پايين(

Relativeنسبي

Scrollلغزنده

خلاصه مطالب 
• يک صفحه  	New ابتدا بايد از طريق فرم��ان ،FreeHand براي ش��روع کار با برنام��ه
طراحي جديد ايجاد کنيد سپس به ترسيمات بپردازيد. براي تغيير تنظيمات صفحه 
از پنل Document اس��تفاده مي‌ش��ود. همچنين براي ترس��يمات دقيق و ترازکردن 
اشياء به ابزارهاي Guide )خطوط راهنما(، Ruler )خطک‌ش( و Grid )خطوط شبکه( 

نياز داريم.
 • 	Master Page مي‌توانيد از امکان ايجاد  Libraryو Document با اس��تفاده از پنل‌هاي
اس��تفاده کنيد که در ش��کل‌گيري س��ريع پس‌زمينه در صفحه‌هاي پروژه‌هاي چند 

صفحه‌اي و ارائه‌هاي گرافيکي Flash مفيد است.
• ابزار Snap نيز براي جابه‌جايي دقيق موضوع‌هاي گرافيکي بهک‌ار مي‌رود.	
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- با نگه داشتن کليدSpacebar  همزمان با درگ صفحه در ناحيه چرکنويس مي‌توانيد، 
صفحه را جابه‌جا کنيد.

2- ب��راي ويرايش Master Page در پنل Document يک�� صفحه Child  انتخاب کرده و 
روی دکمه View کليک کنيد.

3- تنها راه براي ترس��يم خط‌هاي راهنماي افقي يا عمودي اين است که اشاره‌گر ماوس 
را روي خطک‌ش افقي يا عمودي قرار داده و آن را به داخل صفحه درگ کنيد.

معادل گزينه هاي سمت‌ راست را از ستون سمت‌ چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

4- براي تنظيم ناحيه اضافي يا حاشيه در اطراف صفحه گرافيکي استفاده مي‌شود
 Release

                       Bleed                         .ايجاد کنيد Master Page 5- با استفاده از اين پنل، مي‌توانيد يک
6- اگر صفحه سند فرعی باشد، براي تبديل آن به يک Master Page قبل از انتخاب گزينه              
                                Snap Distance                    .اين فرمان روي آن انجام مي‌شود Convert to Master Page

Library    .بهک‌ار مي‌رود  Preferences 7- براي تنظيم فاصله چسبندگي در کادر محاوره
گزينه صحيح را انتخاب کنيد.

8- با استفاده از پنل Document کدام امکانات در دسترس شما قرار مي‌گيرد؟
الف- تنظيم اندازه صفحه              ب- تنظيم حالت نمايش صفحه  	
د- همه گزينه‌ها صحيح هستند. ج- تنظيم کيفيت چاپ        	 	

9- کدام گزينه نادرست است؟
الف- تغيير اندازه صفحه بر اندازه موضوع ترسيمي تأثير مي‌گذارد. 	

ب- FreeHand يک نرم‌افزار برداري است. 	
ج- واحد اندازه‌گيري وضوح تصوير )dpi( به معني نقطه در اينچ است. 	

د- کليد ترکيبي Ctrl+Alt+G نقاط شبکه‌اي را فعال مي‌سازد. 	
10- براي تعريف ابعاد کاغذ به صورت اختياري از کدام گزينه استفاده مي‌شود؟

	 A4 -د              Custom-ج               Legal -ب 		 Letter -الف
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11- ب��راي‌ کپ��ي‌ موضوع در حين اس��تفاده از ابزار پرس��پکتيو، از کدام‌ کليد اس��تفاده 
مي‌شود؟

Alt -د 	   Shift-ج 	          Ctrl-ب 	     Tab  -الف
12- کدام مورد صحيح است؟

الف- براي استفاده از خطوط راهنما، فعال بودن خطک‌ش‌ها الزامي است.
ب- خطوط راهنما به محض نزديک شدن موضوعات، آن‌ها را از خود دور ميک‌نند.

ج- خطوط شبکه قابل چاپ هستند.
د- رنگ و تعداد خطوط شبکه سه بعدي را نمي‌توان تغيير داد.

13- کدام گزينه از صفحه مشابه يک کپي مي‌گيرد؟
Hide  -د 	 Duplicate -ج 	Remove  -ب 	Bleed -الف

14- کدام عبارت درست است؟
الف- تنظيمات صفحه اصلي را نمي‌توان تغيير داد.

ب- براي‌‌اس��تفاده ‌از Master Page  هاي ‌ايجاد ش��ده ‌درسندهاي ‌ديگر FreeHand ‌آن‌ها‌ را 
Export ميک‌نند.

ج- هر سند فقط يک صفحه اصلي دارد.
د- با چرخش صفحه، جهت محتويات آن تغيير ميک‌ند.

15- براي چسباندن يک موضوع گرافيکي يا يک نقطه به يک مسير، کدام گزينه مناسب 
است؟

	  View→Snap to Object-ب 	              Edit→Snap to Point-الف
 View→Snap to Point-د            	Edit→Snap to Object -ج

در جاي خالي عبارت مناسب را بنويسيد.

16- دکمه ............. در کادر محاوره Guides، خط‌هاي راهنماي انتخاب ش��ده در ليست را به 
خط واقعي تبديل ميک‌ند.

17- اس��تفاده از ابزار  Page Tool همزمان با درگ صفحه و نگه داشتن کليد Ctrl، سبب 
........... در فضاي چرکنويس بدون محتويات صفحه مي‌شود.

به سؤالات زير پاسخ تشريحی دهيد.

18- ابزار جابه‌جايي صفحه گرافيکي چيست و کليد ميانبر آن‌را نام ببريد؟
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19- خط‌هاي راهنما به چه منظور به‌كار مي‌روند؟
20- كاربرد Snap to Grid چيست؟

آزمون عملي
1- يک سند به نام Azmoont4 - 1. Fh11  ايجاد کنيد، سپس:
• سانتی‌متر ايجاد کنيد. يک صفحه خالي  به ابعاد 25×20	

•از صفحه ايجاد شده يک کپي مشابه تهيه کنيد. 	
• به سند بيفزاييد. 	B5 سه صفحه به اندازه

•کليه صفحات را در محيط کار نمايش دهيد. 	
• را در بزرگ‌ترين حالت ممکن نمايش دهيد. فقط صفحه 3	

• بچسبانيد. صفحه 4 را به 5	
• را حذف کنيد. صفحه 5	

2- يک س��ند با نامAzmoont4 - 2.Fh11 مطابق شکل بعد که شامل مشخصات زير است 
 ،FreeHand برنامه Samples در پوشه ،Slide Show ايجاد کنيد. )راهنمايي: با استفاده از فايل

صفحه اصلي را ايجاد کنيد.(
Total Pages: 4

مشخصه هر صفحه سند:
Page 1
Origin X: 67.31, Origin Y: 71.195
Page 2
Origin X: 79.935, Origin Y: 71.195
Page 3
Origin X: 67.31, Origin Y: 58.57
Page 4
Origin X: 79.935, Origin Y: 58.57

مشخصات مشترک صفحه‌ها:
Width: 12.6245, Height: 12.6245
Bleed Size: 0
Orientation: Portrait
Page Type: Custom
Master Page: Slideshow Page
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3- در فايل Azmoont4 - 2.Fh11 با توجه به تنظيمات داده ش��ده در شك��ل زير خط‌هاي 
راهنما را قرار دهيد.
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كليات
بعد از ايجاد صفحه جديد و انتخاب واحد اندازه‌گيري مي‌توانيد طراحي را ش��روع کنيد. 
با توجه به نوع شکلي که مي‌خواهيد آن را ترسيم نماييد در جعبه ابزار FreeHand مي‌توانيد 
ابزار مورد نظر را انتخاب كنيد. با اس��تفاده از ابزارهاي ترس��يمي در  FreeHand MX مي‌توان 
اش��کال و تصاوير مختلفي را ايجاد کرد. هر کدام از‌ اين‌ابزارها، قابليت‌هاي مختلفي دارند که 

در اين‌جا به شرح کامل آن‌ها خواهيم پرداخت.   
1-5 ابزار Pen و تنظيمات آن 

براي رسم خطوط صاف و منحني از ابزار  Pen استفاده مي‌شود. هنگام استفاده از اين ابزار 
در هر قسمتي از صفحه که کليک کنيد يک گره )لنگر( ايجاد مي‌شود و با متصل شدن اين 

گره‌ها به يكديگر مسير مورد نظر به‌وجود مي‌آيد.
Pen 1-1-5 ترسيم مسير صاف با استفاده از ابزار

1- از جعبه ابزارTools  ابزار Pen را برگزينيد.
 توجه: P كليد ميانبر ابزار Pen است.

1- با ماوس روي قس��متي از صفحه که مي‌خواهيد نقطه ش��روع خط باشد، کليک کنيد 
در اين حالت يک مستطيل توخالي نمايان مي‌شود.

2- در قسمتي از صفحه که مي‌خواهيد نقطه دوم خط باشد، کليک کنيد.
3- وقتي رس��م مس��ير پايان يافت، کافي اس��ت فقط دابل کليک کنيد ي��ا کليد Tab  را 

بفشاريد تا مسير از حالت انتخاب خارج شود.

Pen شکل 1-5 رسم مسير صاف با ابزار

 نکته: با نگه داش��تن کليد Shift مي‌توانيد خطوطي با زاويه °45 يا عمود ايجاد 
کنيد.

Pen 2-1-5 ترسيم مسير منحني با استفاده از ابزار

1- از جعبه ابزار Tools ابزار Pen را انتخاب کنيد.
2- با ماوس روي قس��متي از صفحه که مي‌خواهيد نقطه اول منحني باش��د کليک کرده 



Free Hand پیمانه مهارتی : کاربر
99واحد کار پنجم: توانایی استفاده از عناصر و ابزار در طراحی و ترسیم میسرها 

و درگ کنيد و بدون اينك‌ه آن‌را رها كنيد، ماوس را جابه‌جا كنيد در نتيجه دس��تگيره‌هاي 
کنترل ايجاد مي‌شود. 

3- مكان بعدي را انتخاب كرده و مجدداً مانند مورد 2 عمل كنيد تا نقطه دوم )گره فعال( 
ايجاد شود. به اين صورت مي‌توانيد مسير منحني را با هر تعداد انحنا داشته باشيد.

شکل 2-5 ترسيم يک منحني

4- ب��ا درگ و تغيير مکان اش��اره‌گر ماوس مي‌توانيد جهت و ق��وس انحنا را تغيير دهيد 
)شكل 5-3(.

5- هنگامي که مسير پايان يافت کليد Tab را بفشاريد يا کليد Ctrl را نگه داشته و کليک 
کنيد تا مسير از حالت انتخاب خارج شود.   	                                                                                       

شکل 3-5  تغيير جهت و قوس منحني   

 نکته:  با استفاده از ابزار Pen مي‌توانيد يک مسير بسته نيز ايجاد کنيد، براي اين 
منظور بايد پس از تعيين نقطه انتهايي، اش��اره‌گر را روي نقطه شروع قرار دهيد تا يک دايره 

کوچک در کنار اشاره‌گر ظاهر شود سپس کليک کنيد )شكل 5-4(.
هنگام حذف يگ گره، همراه با اشاره‌گر ماوس يک علامت منفي )-( و هنگام اضافه کردن 

گره، کنار اشاره‌گر ماوس علامت مثبت )+( نمايان مي‌شود.
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 نکت�ه: ب��راي ايجاد يک منحن��ي برآمده هنگامي که مي‌خواهيد دس��تگيره‌هاي 
کنترل را تغيير اندازه يا تغيير جهت دهيد، از کليد Alt  استفاده کنيد )شكل 5-5(.

  

شکل 4-5 ايجاد يک مسير بسته با ابزار Pen              شکل 5-5 رسم منحني برآمده

 نکته:  براي رس��م تصاوير وارد شده به محيط FreeHand )تصاوير اسکن شده( از 
ابزار Pen نيز مي‌توان استفاده کرد.

 نکته: 
براي ويرايش يک مسير منحني پس از رسم آن، توسط ابزارPointer  روي هريک از 

نقاط منحني کليک کنيد تا دستگيره‌هاي کنترل آن نقطه نمايان شوند.

 نکت�ه: فش��ردن کليد Alt هنگام اس��تفاده از ابزار Pointer، س��بب کپي مس��ير 
مي‌شود.

 زماني که براي قرار دادن نقطه روي صفحه با ابزار Pen کليک مي‌کنيد، يک نقطه گوشه
)Corner Point( ايجاد مي‌شود که به شکل مربع است.

هنگام اس��تفاده از ابزار Pen وقتي درگ مي‌کنيد يک نقطه منحني )Curve Point( ايجاد 
مي‌ش��ود که به ش��کل دايره اس��ت. به نقاطي که براي اتصال هموار يک خط راس��ت به يک 
منحني ايجاد مي‌ش��ود، نقاط اتصال‌دهنده )Connector Point( مي‌گويند که با گرفتن کليد 
Alt و کليک راس��ت به‌وجود مي‌آيد و به شکل مثلث ديده مي‌شود ولي بعد از خارج شدن از 

حالت انتخاب به مربع تبديل مي‌شود )شکل 5-6(.
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شکل 6-5 نمايش انواع نقاط 

مثال 1: به منظور آشنايي بيشتر با نقاط اتصال دهنده شکل 7-5 را رسم کنيد.

شکل 7-5 رسم شکل با کمک نقطه اتصال دهنده

مراحل انجام کار به صورت زير است:
1- نقط��ه a را ب��ا کليک روي صفحه ق��رار داده و درگ کنيد، س��پس در نقطه b کليک 

کنيد.
2- مانند مرحله قبل درگ کرده روي نقطه c کليک کنيد.

3- براي رسم مسير منحني cd روي نقطه d کليک کرده و بدون رها کردن کليد ماوس 
با حرکت دادن دستگيره‌هاي کنترل، منحني را به وجود آوريد.

4- براي رسم پاره‌خط بعدي به يک خط صاف نياز داريد. اگر روي نقطه e کليک کنيد، 
يک خط منحني به‌وجود مي‌آيد. در اين قسمت براي رسم يک خط صاف به يک نقطه اتصال 
دهنده نياز داريد؛ چنانچه براي رس��م مس��ير منحني cd در نقطه d کليک کنيد، بايد کليد

 Alt را همزمان پايين نگه داريد تا اين نقطه به نقطه اتصال‌دهنده تبديل شود؛ در اين لحظه 

دس��تگيره کنترل در سمت راست ناپديد مي‌شود؛ س��پس در نقطه e کليک کرده و مسير را 
ببنديد.

•گره‌هاي موجود در مس��يرها قابل تبديل به يکديگر هستند يعني مي‌توان يک نقطه  	
گوش��ه را به نقطه منحني و برعکس تبديل کرد. همچنين مي‌توان کمان‌ها را نيز به 
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ــتفاده مي شود. اين  ــتقيم تبديل کرد؛ براي اين منظور از پنل Object اس خطوط مس
پنل، اطلاعاتي در مورد نقطه و مسير انتخاب شده ارايه مي دهد.                                                                                                                    

 مثال 2: شکل 8-5 را با استفاده از ابزار Pen رسم کنيد.

شکل 5-8

1- ابتدا يک مسير بيضي با 8 گره توسط ابزار Pen رسم کنيد.
ــمت دم ماهي قرار دهيد تا يک  2- ابزار Pen را روي گره هاي س
ــود. حال با کليک ماوس گره  ــت منفي )-( در کنار آن ظاهر ش علام

مربوطه را حذف کنيد. چنين شکلي خواهد شد. 
براي دم مي توانيد با کليک و درگ به سمت بالا از روي انتهاي دم رسم کنيد.

ــاره گر  Penرا در  ــمت دهان ماهي بايد گره اضافه کنيد، براي اين منظور اش 3- براي قس
قسمت موردنظر روي مسير قرار دهيد تا يک علامت مثبت )+( در کنار آن ظاهر شود. اکنون 
کافي است کليک کنيد تا يک گره به مسير اضافه شود و با درگ کردن، دهان ماهي را رسم 

کنيد.
Pen 3-1-5 تنظيمات ابزار

ــود. انتخاب  ــکل 9-5( باز مي ش ــا دابل کليک روي ابزار Pen کادرمحاوره Pen Tool )ش ب
ــيم با ابزار Pen پيش نمايشي از مسير  ــود تا هنگام ترس گزينهShow Pen Preview باعث مي ش

نشان داده شود.

Pen Tool شکل 9-5 کادر محاوره
تمرين 1: شکل 10-5 را با استفاده از ابزار Pen رسم کنيد.

  

شکل 5-10 
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 نکته: با استفاده از ابزارهاي انتخاب )Pointer و Sub Select( مي‌توانيد نقاط گره‌اي 
را انتخاب و سپس اصلاح كنيد.

Bezigon 2-5 ابزار ترسيم
اب��زار Bezigon در گ��روه ابزارهاي Pen قرار دارد و براي رس��م خط صاف يا منحني مورد 
اس��تفاده قرار مي‌گيرد. اين ابزار همانند ابزار Pen عمل مي‌کند با اين تفاوت که توس��ط ابزار 
 Bezigon با کليک و درگ کردن مي‌توان منحني رسم كرد اما هنگام رسم منحني با ابزار Pen

بايد کليد Alt را پايين نگه داريد و بعد کليک کنيد؛ پس از ترس��يم، هر گره‌اي را که نياز به 
انحنا دارد، انتخاب کرده و تغيير دهيد )شکل 5-11(.

Bezigon رسم منحني با ابزار                       Pen رسم منحني با ابزار

شکل 5-11

Bezigon 1-2-5 ترسيم مسير صاف با استفاده از ابزار
1- ب��ا اس��تفاده از ماوس روي ابزار Pen واقع در جعبه اب��زار Tools کليک کرده و از منوي 

ظاهر شده گزينه Bezigon tool را انتخاب کنيد.                                 

Bezigon شکل 12-5  ابزار 

2- با ماوس روي قس��متي از صفحه که مي‌خواهيد نقطه شروع خط باشد، کليک کنيد؛ 
در اين حالت يک مستطيل توخالي نمايان مي‌شود.

3- با اس��تفاده از ماوس در قسمتي از صفحه که مي‌خواهيد نقطه دوم خط باشد، کليک 
کنيد.

Bezigon 2-2-5 ترسيم مسير منحني با استفاده از ابزار
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4- روي اب��زار Pen واق��ع در جعبه اب��زار  Toolsکليک کرده و ازمنوي‌ظاهر ش��ده گزينه
 Bezigon tool را انتخاب کنيد. 

5- با ماوس روي قس��متي از صفحه که مي‌خواهيد نقطه شروع خط باشد، کليک کنيد؛ 
در اين حالت يک مستطيل توخالي نمايان مي‌شود.

6- کليد Alt را پايين نگه داش��ته و با ماوس در قس��متي از صفحه که مي‌خواهيد نقطه 
دوم خط باشد، کليک کنيد.

7- همان‌طورکه در ش��کل 13-5 مشاهده مي‌کنيد، س��ه گره b ،a و c روي مسير ايجاد 
شده‌اند حال مي‌توانيد به وسيله ماوس هر يک از اين گره‌ها را انتخاب کرده و درگ کنيد تا 

منحني موردنظر ايجاد شود )شکل 5-14(.

   
        شکل 13-5 رسم منحني با ابزار Bezigon          شکل 14-5 تغيير گره b و ايجاد منحني

• مي‌توانيد با کليک روي يک گره  	Pen پس از ايجاد يک مسير با اين ابزار، همانند ابزار
واقع در مسير، آن گره را حذف کنيد و با يک بار کليک روي قسمتي از مسير، در آن 

قسمت يک گره ايجاد کرده، سپس مسير موردنظر را ويرايش کنيد.
Bezigon 3-2-5 تنظيمات ابزار

با دابل کليک روي ابزار  Bezigon کادرمحاوره Bezigon Tool )ش��کل 15-5( باز مي‌شود. 
انتخاب گزينه Auto constrain باعث مي‌ش��ود تا هنگام ترسيم با ابزار Bezigon، شئ به طور 
خودكار محدود ش��ود. به عبارت ديگر خطوط در زواياي 0، 45 و90 درجه به صورت راس��ت 
ترسيم مي‌شوند و مانند اين است كه كليد ‌‌Shift را هنگام ترسيم نگه ‌داشته‌ايد. در اين زوايا 
دايره كوچكي كنار اش��اره‌گر ظاهر مي‌ش��ود كه نشان مي‌دهد شئ محدود )constrain( شده 

است.

Bezigon Tool شکل 15-5 کادرمحاوره

 مثال 3: شکل 16-5 را با ابزار Bezigon رسم کنيد.
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شکل 5-16 

1- ابتدا ابزار Bezigon را از جعبه ابزار برگزينيد.
2- قسمت بدنه فلفل را رسم کنيد. به ميزان انحناي مسير براي رسم بدنه توجه کنيد و 

هنگام ترسيم، براي ايجاد اين انحنا ماوس را به اندازه لازم درگ کنيد.         
3- قسمت سر فلفل را رسم کنيد.

 تمرين 2: شکل 17-5 را با ابزار Bezigon و Pen رسم کنيد.    

شکل 5-17

3-5 ابزار ترسيم خط )Line( و تنظيمات آن 
براي رس��م خطوط مايل و مس��تقيم و ايجاد اشکال دلخواه يا متصل کردن چند شکل به 

يکديگر از ابزار Line استفاده مي‌شود.
1-3-5 ترسيم خط

1- ابزار Line را از جعبه ابزار Tools انتخاب کنيد.
2- اشاره‌گر ماوس را در نقطه‌اي از صفحه قرار دهيد.

3- ماوس را در جهت و زاويه موردنظر به اندازه دلخواه درگ کنيد.
4- به محض اين که کليد ماوس را رها کنيد، ترسيم خط تمام مي‌شود.

 توج�ه: براي رس��م خط با زاويه° 45 )خط مايل( يا °90 يا خط راس��ت )افقي و 
عمودي( هنگام استفاده از ابزار Line کليد Shift را پايين نگه داريد.
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اگر هنگام‌رس��م‌خط کليدهاي Shift و Alt را همزمان پايين نگه داريد، خط به صورت 
صاف و از مرکز رسم مي‌شود.

2-3-5 مشاهده خواص خط در هنگام رسم
با اس��تفاده از نوارابزار Info واقع در من��وي Windows→Toolbars→Info مي‌توانيد هنگام 
رس��م خط، قبل از رها ک��ردن کليد ماوس در نقطه انتهايي، مختص��ات، طول و زاويه خط را 

مشاهده کنيد.

                      

Info شکل 18-5  نوار

Line 3-3-5 تنظيمات ابزار
 با دابل کليک روي ابزار Line کادرمحاوره Line Tool )شکل 19-5( باز مي‌شود. انتخاب گزينه
Auto constrain باع��ث مي‌ش��ود تا هنگام ترس��يم با ابزار Line در زواي��اي 45، 0 و90 درجه 

                      		 خطوط به اين زوايا محدود شده و به صورت راست رسم شوند.

Line Tool شکل 19-5 کادر

 مثال 4: شکل 20-5 را با ابزار Line رسم کنيد.
1- ابتدا از محل مشخص شده در شکل شروع کنيد )محل شروع دلخواه است(.

2- ابزار  Lineرا از جعبه ابزار برگزينيد.                                                     

شکل 5-20
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 3- اشاره‌گر ماوس را در نقطه‌اي از صفحه قرار داده و به طور مورب به سمت بالا درگ کنيد
)زاويه در حدود 35°(، قبل از رها کردن کليد ماوس در نقطه انتهايي، طول و زاويه خط را از 

نوار ابزار Info مشاهده کنيد. 
4- اکنون اشاره‌گر ماوس را روي نقطه پاياني خط اول قرار داده و به طور مورب به سمت 

پايين درگ کنيد، توجه کنيد که طول و زاويه خط به اندازه خط اول باشد. 
5- خطوط بعدي را هم با روش ذکر شده، رسم کنيد.

تمرين 3: شکل‌هاي بعد را با کمک ابزار Line رسم کنيد.
 

شکل 5-21  

4-5 ابزار Pencil و تنظيمات آن 
اين ابزار امکان ترس��يم ش��کل‌هاي به صورت آزاد را به شما مي‌دهد به طوري که به نظر 
مي‌رسد يک مداد واقعي را در دست داريد و مي‌توانيد اشکال مورد نظر خود را رسم كنيد. 

  Pencil 1-4-5 ترسيم مسير با استفاده از ابزار
1- از جعبه ابزار Tools ابزار Pencil را برگزينيد.

2- با ماوس روي قسمتي از صفحه که مي‌خواهيد نقطه شروع خط باشد، کليک کنيد و 
بدون رها کردن كليد سمت چپ ماوس عمل درگ را انجام دهيد. 

3- براي رسم خطوط راست در حين ترسيم با ماوس، کليد Alt را پايين نگه داريد و براي 
ادامه مسير كليد Alt را رها كنيد ولي كليد ماوس را رها نكنيد.

Pencil شکل 22-5 رسم مسير با ابزار
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4- وقتي رسم مسير پايان يافت، كليد سمت چپ ماوس را رها کنيد.
ب��ه منظ��ور انجام تنظيمات ابزار Pencil، در جعبه اب��زار Tools روي اين ابزار دابل کليک 

كنيد. کادر محاوره Pencil Tool مطابق شکل 23-5 ظاهر مي‌شود.
• را  در قس��مت Precision مي‌توانيد با حرکت دادن دکمه لغزنده عددي بين 1 تا 10	
تعيين كنيد. انتخاب اعداد بزرگ‌تر باعث مي‌شود تا هنگام ترسيم، روي مسير رسم 
ش��ده گره‌هاي بيش��تري وجود داشته باشد و بتوانيد با اس��تفاده از اين گره‌ها شکل 
را ويرايش نماييد. با اس��تفاده از اين گزينه مي‌توانيد ميزان دقت کار خود و تبعيت 

مسير از حرکت مکان‌نما را تعيين كنيد.

Pencil Tool شکل 23-5 کادرمحاوره

• باعث مي‌ش��ود در پيش‌نمايش رس��م، خطوط به  	Draw dotted line انتخ��اب گزينه
صورت نقطه‌چين نمايان ش��وند و مس��يرها س��ريع‌تر ترسيم ش��وند اما بعد از رسم، 

خطوط به صورت رنگ توپر نمايش داده مي‌شوند.

مثال 5: شکل 24-5 را با ابزار Pencil رسم کنيد.
 

ابزار Pencil را انتخاب کرده ش��کل مورد نظر را رس��م نماييد. براي رسم خطوط صاف از 
کليد Alt استفاده كنيد.

براي ادامه دادن مس��ير، ابزار Pencil را روي نقطه پاياني مسير قرار دهيد؛ علامت بعلاوه 
)+( نمايان مي‌شود. در همان نقطه کليک کرده و مسير را ادامه دهيد.	

شکل 5-24
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5-5 ابزار Variable Stroke Pen tool و تنظيمات آن 
براي ترسيم خطوط با ضخامت‌هاي متغير مي‌توانيد از اين ابزار استفاده كنيد.

Variable Stroke Pen tool 1-5-5 ترسيم مسير با استفاده از ابزار
 Variable Stroke Pen tool کليک کرده و از منوي ظاهر ش��ده ابزار Pencil 1- روي اب��زار

را انتخاب نماييد.

Variable Stroke Pen tool شکل 25-5  ابزار

2- مکان‌نم��اي م��اوس را در محل مورد نظر روي صفحه ق��رار داده و همان‌طورکه کليد 
ماوس را نگه داشته‌ايد مسير مورد نظر را با درگ کردن رسم نماييد.

3- به منظور اعمال تنظيمات روي اين ابزار در جعبه ابزار دابل کليک كنيد. در اين‌صورت 
کادر محاوره  Variable Stroke Pen مطابق شکل 26-5 نمايان مي‌شود.

Variable Stroke Pen شکل 26-5 کادرمحاوره

• گزينه Precision: اين گزينه به شما امکان بالا بردن دقت کار را مي‌دهد.	
• با انتخاب اين گزينه به صورت اتوماتيک قسمت‌هايي  	:Auto remove overlap گزينه

از شکل که روي هم قرار دارند، حذف مي‌شوند.
اين قسمت داراي دو گزينه است که به شما امکان تنظيم پهنا براي  • 	 :Width قسمت

نازک‌ترين و ضخيم‌ترين قسمت خط از 1 تا 72 را مي‌دهد.

Auto remove overlap شکل 27-5 نتيجه حاصل از فعال و غيرفعال بودن گزينه



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
110

 توجه: هنگام رس��م مس��ير با اب��زار Variable Stroke Pen tool مي‌توانيد توس��ط 
کليدهاي جهت‌دار صفحه کليد، ضخامت مسير را تغيير دهيد.

6-5 ابزار خوشنويسي Calligraphic Pen tool و تنظيمات آن
با استفاده از اين ابزار مي‌توانيد خطوط هنري ايجاد كنيد.

Calligraphic Pen tool 1-6-5 ترسيم خطوط هنري با استفاده از ابزار
1- روي اب��زار Pencil کليک کرده و از منوي ظاهر ش��ده اب��زار Calligraphic Pen tool را 

انتخاب نماييد. 

 Calligraphic Penشکل 28-5  ابزار

2- مکان‌نم��اي ماوس را در محل مورد نظ��ر روي صفحه قرار داده و همان‌طور که کليد 
ماوس را نگه داشته‌ايد مسير مورد نظر را با درگ کردن رسم نماييد.

Calligraphic Pen toolشکل 29-5 ايجادخطوط‌هنري به‌وسيله ‌ابزار

3- به منظور اعمال تنظيمات روي اين ابزار در جعبه ابزار دابل کليک كنيد. در اين‌صورت 
کادر محاوره Calligraphic Pen مطابق شکل 30-5 نمايان مي‌شود.

بعضي از گزينه‌هاي اين کادر محاوره‌ قبلًا توضيح داده شده است، در ادامه به توضيح ساير گزينه‌ها 
مي‌پردازيم:

• يا  	(Fixed) توسط گزينه‌هاي اين قسمت مي‌توانيد يک ضخامت ثابت :Width قسمت
متغير (Variable) را براي نوک قلم تعيين كنيد.

• در اين قس��مت مي‌توان زاويه قلم را به صورت عددي يا به‌‌وس��يله  	:Angle قس�مت
دايره کناري کنترل كرد.



Free Hand پیمانه مهارتی : کاربر
111واحد کار پنجم: توانایی استفاده از عناصر و ابزار در طراحی و ترسیم میسرها 

 Calligraphic Pen شکل 30-5 کادرمحاوره

 Variable Strokeو Pencil ،Calligraphic Pen tool  تمرين 4: شکل 31-5 را با ابزار

Pen tool رسم کنيد. 

شکل 5-31

  (Rectangle) 7-5 ابزار ترسيم چهارگوش
از اي��ن ابزار براي ترس��يم مس��تطيل، مربع و به طورکلي اش��کال چهارگوش اس��تفاده 

مي‌کنيم.          
1-7-5 ترسيم مستطيل 

1- روي ابزار Rectangle واقع در جعبه ابزار Tools کليک کنيد.                                      
2- اشاره‌گر ماوس را )که با علامت + نمايش داده مي‌شود( روي صفحه قرار داده و كليد 
ماوس را نگه داشته و به سمت چپ يا راست درگ کنيد. در اين حالت مربع‌هاي کوچکي در 

اطراف چهارضلعي ظاهر مي‌شود که به آن‌ها مربع‌هاي انتخاب مي‌گويند. 
پس‌از انتخاب شك��ل توس��ط اب��زار Pointer، اش��اره‌گر را درامتداد‌خط‌قط��ري )مورب( 

بين‌دوگوشه درگ کنيد.
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پ

شکل 32-5 جهت حرکت اشاره‌گر براي رسم مستطيل

 توجه: براي رسم مستطيل از نقطه وسط )مرکز( کليد Alt را نگه داريد.      
در صورت لزوم مي‌توانيد بعد از رسم مستطيل، ابعاد آن را از طريق پنل Object واقع در 

منوي Window تغيير دهيد.

2-7-5 ترسيم مربع

1- براي رسم مربع مانند مراحل قبل عمل کنيد.
2- در هنگام درگ ماوس کليد Shift را پايين نگه داريد.

 توجه: براي رس��م مربع از نقطه وس��ط )مرکز( کليده��اي Shift و Alt را همزمان 
فشار دهيد.

مي‌توان با ابزار Rectangle چهارضلعي‌هايي با گوش��ه‌هاي منحني )گرد( رسم کرد. ميزان 
انحناي گوشه‌ها به گزينه Corner radius )شعاع گوشه‌ها( بستگي دارد )شکل 5-33(.

تنظيمات Corner radius باعث انحنا يا تيزي گوشه‌هاي چهارگوش مي‌شود.

شکل 33- 5

تنظيم شعاع‌هاي گوشه‌اي چهارضلعي
 Rectangle دابل کليک کنيد تا کادرمحاوره Rectangle روي ابزار Tools 1- در جعبه ابزار
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 Tool باز شود.

به طور پيش‌فرض شعاع انحناي گوشه‌ها صفر است. هر چه اين عدد بزرگ‌تر باشد، ميزان 
انحناي گوشه‌هاي چهارضلعي بيشتر خواهد شد. 

2- در کادرمحاوره ظاهر ش��ده مي‌توانيد مقدار مورد نظر جهت شعاع گوشه را در مقابل 
گزينه  Corner radius   تايپ کرده يا از دکمه لغزنده استفاده کنيد.

3- روي دکمه OK کليک کرده و شکل را رسم کنيد.

Rectangle Tool شکل 34-5 کادر محاوره

 نكته: واحد انحناي گوشه‌ها بر اساس واحد صفحه است.

تغيير ابعاد مستطيل
1-مستطيل مورد نظر را انتخاب کنيد.

2- به پنل Object برويد و مراحل بعد را انجام دهيد.
3- با استفاده از گزينه Corners مي‌توان مقدار انحناي گوشه‌ها را تغيير داد.

4- براي اعمال تغييرات کليد Enter را فشار دهيد.

 توجه: براي ايجاد تنظيمات مختلف براي هر گوشه مستطيل، گزينه Uniform را 
غيرفعال كنيد و در هر فيلد مقدار شعاع گوشه را وارد كنيد.
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Object شکل 35-5  پنل

 مثال 6: شکل 36-5 را با ابزار Rectangle رسم کنيد.  

Rectangleشکل 36- 5 ترسيم شکل با ابزار

1- ابتدا يک مستطيل بزرگ رسم کنيد.
2- در بالاي اين مستطيل يک مستطيل ديگر رسم کنيد.

3- براي پنجره‌هاي اين خانه دو مربع هم اندازه و هم مرکز رسم کنيد.
4- يک مس��تطيل براي در خانه رس��م کرده و داخل آن يک مس��تطيل کوچک‌تر قرار 

دهيد. 

تمرين 5: شکل‌هاي زير را توسط ابزار مستطيل ايجاد کنيد.

شکل 37-5 مربع‌هاي هم‌مرکز، آدم آهني و نردبان                
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 Ellipse 8-5 ابزار ترسيم
از اين ابزار براي رسم بيضي يا دايره استفاده مي‌کنيم.

1-8-5 ترسيم بيضي يا دايره

1- در جعبه ابزار  Tools روي ابزار Ellipse کليک کنيد.
2- اش��اره‌گر ماوس را روي مح��ل موردنظر از صفحه قرار داده و به س��مت مقابل درگ 

کنيد.

 توجه: با نگه داش��تن کليد Shift مي‌توان از ابزار Ellipse براي رسم دايره استفاده 
کرد.

هنگام استفاده از ابزار Ellipse اگر کليد Alt را پايين نگه داريد، بيضي از مرکز رسم مي‌شود.

براي رسم دايره از مرکز هنگام استفاده از ابزار Ellipse کليدهاي Alt وShift را پايين نگه‌داريد.

با استفاده از پنل Object مي‌توان ابعاد بيضي رسم شده را تغيير داد.
تمرين 6: ش��کل‌هاي بعدي را توس��ط ابزارهايي که تاکنون آموخته‌ايد، رس��م 

کنيد. 

شکل 5-38

(Polygon) 9-5 ابزار ترسيم چندضلعي
از اين ابزار براي ترس��يم چندضلعي و س��تاره استفاده مي‌ش��ود. ابزار ترسيم چندضلعي 

همراه با ابزار ترسيم مستطيل در يک گروه قرار دارند.
1-9-5 ترسيم يک چند‌ضلعي

1- روي ابزار Rectangle واقع در جعبه ابزار Tools کليک کرده و از منوي ظاهر شده ابزار 
Polygon tool را انتخاب کنيد.
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Polygon tool شکل 39-5 ابزار

2- ح��ال روي اب��زار Polygon واقع در نوار ابزار Tools دابل کلي��ک کنيد تا کادرمحاوره
 Polygon Tool باز شود.

3- در اين کادرمحاوره، گزينه Number of Sides مشخص کننده تعداد اضلاع چند ضلعي 
اس��ت. تعداد اضلاع چند ضلعي بيشتر مي‌ش��ود تا به عدد 20 برسد که در اين صورت شکل 

حاصله دايره خواهد بود.       

         

Polygon Tool شکل 40-5 کادرمحاوره

Shape -4 مش��خص کننده نوع چند ضلعي است که امکان انتخاب شکل را از بين ستاره 

)Star( يا چند ضلعي )Polygon( مي‌دهد )در اينجا Polygon انتخاب مي‌شود).
5- روي دکمه OK کليک کنيد.

6- اش��اره‌گر م��اوس را روي قس��متي از صفحه که مي‌خواهيد مرک��ز چند ضلعي در آن 
قسمت قرار گيرد، بگذاريد و به سمت خارج درگ کنيد.

7- با چرخش ماوس مي‌توانيد چندضلعي را نيز بچرخانيد.
تمرين 7: شکل 41-5 را رسم کنيد.

 

شکل 5-41
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10-5 ابزار ترسيم ستاره  
از ابزار Polygon براي ترسيم ستاره استفاده مي شود.

ترسيم ستاره
1- در جعبه ابزار Tools روي Polygon دابل کليک کنيد تا کادرمحاوره Polygon Tool باز 

شود.
2- در قسمت Shape گزينه Star را برگزينيد.

3- در قسمت Number of Sides تعداد اضلاع ستاره را وارد کنيد.
4- با فعال کردن گزينه Automatic ستاره اي رسم مي شود که زاويه بين اضلاع آن به طور 

اتوماتيک تنظيم شده است.
5- با فعال کردن گزينه Manual مي توانيد زاويه بين اضلاع ستاره را به صورت دستي به 

کمک دکمه لغزنده واقع در قسمت  Star Pointsتنظيم کنيد.

شکل 42-5 کادر محاوره Polygon Tool براي رسم ستاره

 نکته: انتخاب گزينه Star به شما امکان رسم يک شکل سه وجهي )شبيه مثلث 
متساوي الاضلاع( تا يک شکل 20 وجهي يعني شکلي مشابه دايره را مي دهد.

ــکال 43-5 را رسم کنيد، براي رسم ستاره مشخص شده مراحل بعد  مثال 7: اش
را انجام دهيد: 

1- روي گزينه Polygon از نوار ابزار دابل کليک کنيد.
2- در کادرمحاوره Polygon Tool گزينه Star را برگزينيد.

ــکل 6 است، وارد  ــتاره را که در اين ش ــمت Number of Sides تعداد اضلاع س 3- در قس
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کنيد.

شکل 5-43 

4- با فعال کردن گزينه Manual، دکمه لغزنده واقع در قس��مت Star Points را به س��مت
acute ببريد تا زاويه بين اضلاع ستاره مطابق شکل شود. 

5- بقيه ستاره‌ها مشابه روش ذکر شده، رسم مي‌شوند.
تمرين 8: شکل 44-5 را با استفاده از ابزارهايي که آموخته‌ايد، رسم کنيد.

شکل 5-44

مثال كاربردي: در اين‌ مثال مي‌خواهيم بخش��ي از آرم مثال كاربردي را رس��م 
 

کنيم، براي اين منظور مراحل زير را انجام دهيد:

شكل 5-45

1- فايل Project مثال کاربردي واحد کار 4 را باز کنيد. 
 w يك چهارگوش با ابعاد Pen 2- در صفحه‌اي که قبلًا ايجاد کرديد؛ با اس��تفاده از ابزار
برابر 7 و h برابر 26/5 رس��م كنيد، س��پس كليد Enter را بفشاريد. چهارگوش مطابق شكل 

46-5 به يك مستطيل 26/5×7 عمودي تبديل مي‌شود.
3- اکنون مي‌خواهيم گوش��ه س��مت راس��ت پايين مس��تطيل را گرد كنيم. از آن‌جا كه 
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ترس��يم يك كمان نياز به س��ه نقطه لنگر دارد با توجه به دو نقطه لنگر پايين مستطيل؛ يك 
نقطه لنگر روي مستطيل ايجاد ك‌نيد. براي اين كار به‌وسيله ابزار Pen در نقطه تعيين شده در 

شكل 47-5 روي ضلع سمت راست مستطيل كليك كنيد تا يك نقطه به آن اضافه شود.
4- تغييرات را ذخيره کنيد.

               

 شكل 46-5                                     شکل 5-47

واژه‌نامه
Angleزاويه

Bezigonبزيه

Calligraphicخوشنويسي

Ellipseبيضي

Overlapهمپوشاني

Precisionدقت

Shapeشکل

Strokeخط

Variableمتغير

خلاصه مطالب
• براي ترسيم اشکال در FreeHand MXa از جعبه ابزار Tools استفاده مي‌شود.	
• ابزار Bezigon براي رسم خط صاف يا منحني مورد استفاده قرار مي‌گيرد.	
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 • 	Line هر دو براي رس��م خط به‌کار مي‌رود، با اين تفاوت که با Bezigon و Line ابزار
فقط مي‌توان پاره‌خط رسم کرد اما نمي‌توان خطوط را به هم متصل کرد.

 • 	Variable Stroke Pen براي ترس��يم خطوط با ضخامت‌هاي متغير مي‌تواني��د از ابزار
tool استفاده كنيد.

• با استفاده از ابزار Calligraphic Pen tool مي‌توانيد خطوط هنري ايجاد كنيد.	
• به منظور ترسيم اشکال چهارگوش استفاده مي‌شود.           	Rectangle از ابزار

• از ابزار Ellipse براي رسم بيضي يا دايره استفاده مي‌شود.	
• از ابزار Polygon براي ترسيم چندضلعي و ستاره استفاده مي‌شود.	
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- براي ترسيم اشکال در FreeHand MXa از جعبه ابزار Tools استفاده مي‌شود.
2- با استفاده از ابزار Variable Stroke Pen tool مي‌توانيد خطوط هنري ايجاد نماييد.

3- از ابزار Polygon براي ترسيم چندضلعي و ستاره استفاده مي‌شود.
4- از ابزار Rectangle براي رسم بيضي يا دايره استفاده مي‌شود.

معادل گزينه هاي سمت ‌راست را از ستون سمت ‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

      Line                   .1- از اين ابزار به منظور ترسيم اشکال چهارگوش استفاده مي‌شود
Pen                     .2- اين گزينه به شما امکان رسم يک شکل سه وجهي را مي‌دهد
Rectangle             .3- براي رسم خطوط مايل و مستقيم از اين ابزار استفاده مي‌شود

                  Star                     .4- براي رسم خطوط صاف و منحني از اين ابزار استفاده مي‌شود
گزينه صحيح را انتخاب کنيد.

5- در چه مواقعي از ابزار Ellipse در جعبه ابزار استفاده مي‌کنيد؟
ب- رسم دايره و بيضي الف- رسم چندضلعي          	

		            د- رسم چهارگوش ج- رسم کمان
6- براي اين‌که اش��کال گرافيکي هنگام ترس��يم از مرکز به اطراف گسترش يابند از کدام 

کليد استفاده  مي‌کنيد؟
                          Alt -د                Shift -ج               Ctrl  -ب            Tab -الف

7- براي رسم ستاره (Star) از کدام ابزار استفاده مي‌کنيد؟
 Ellipse -ب 		        Rectangle -الف
 Bezigon -د 		      Polygon -ج

8- در کادرمحاوره Polygon گزينه Number of Sides چه کاربردي دارد؟
الف- زاويه بين اضلاع چند‌ضلعي را مشخص مي‌کند.

ب- تعداد اضلاع چندضلعي را مشخص مي‌کند.
ج- مشخص‌ کننده نوع چندضلعي است.

د- باعث رسم شکل با لبه‌هاي هموار مي‌شود.
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9- کدام‌‌يک از ابزارهاي زير، فقط امکان رسم خطوط مستقل از هم را فراهم مي‌آورد؟
Rectangle -د               Bezigon -ج               Pen -ب              Line  -الف 

10- براي ترس��يم خط صاف و ° 45 به هنگام استفاده از ابزار Line از کدام کليد مي‌توان 
استفاده کرد؟

Alt -د               Shift  -ج                Ctrl -ب               Space -الف
11- کدام گزينه صحيح است؟

الف- هنگام اس��تفاده از ابزار Bezigon براي رس��م منحني بايد کلي��د Shift را پايين نگه 
داريد.

ب- با استفاده از ابزار Rectangle مي‌توان اشکالي به شکل ستاره رسم کرد.
ج- درص��ورت فعال بودن ابزار  Penهنگامي ک��ه روي صفحه، کليک مي‌کنيم يک نقطه 

گوشه به‌وجود مي‌آيد.
د- با ابزار Line مي‌توان خطوط منحني رسم کرد.

در جاي خالي عبارت مناسب را بنويسيد.

12- انتخاب  گزينه  Precision در کادرمحاوره Variable Stroke Pen tool به شما ................ 
را مي‌دهد.

13- با نگه داش��تن کلي��د ......... مي‌تواني��د خطوطي با زاويه 45 درجه ي��ا عمود ايجاد 
کنيد.

14- براي رسم مستطيل از نقطه وسط )مرکز( کليد ........ را نگه داريد.
15- ابزار Bezigon براي ........................... مورد استفاده قرار مي‌گيرد.

به سؤالات زير پاسخ تشريحی دهيد.

16- تفاوت ابزار Pen با ابزار Bezigon چيست؟
17- چگونه مي‌توان مربعي با گوشه‌هاي گرد رسم کرد؟

18- چند نوع نقطه روي يک مسير موجود است، نام ببريد.
19- تفاوت ابزار Line با ابزار  Pen چيست؟
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آزمون عملي  
1- شکل‌هاي زير را رسم کنيد.

2- شکل‌هاي زير را با ابزارهاي خطوط هنري ترسيم كنيد.
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كليات
با اس��تفاده از ابزارهاي ترسيمي در FreeHand MXa مي‌توان اشکال و تصاوير مختلفي را 
ايجاد کرد. در واحد كار 5 با تعدادي از ابزارها براي طراحي و ترسيم مسيرها آشنا شديد؛ در 

اين واحد كار به معرفي ابزارهاي ترسيمي ديگر خواهيم پرداخت.   
  Arc1-6 ابزار

براي ترسيم کمان )باز، بسته، محدب و مقعر( يا منحني از اين ابزار استفاده مي‌شود.
Arc 1-1-6 روش کار با ابزار

1- روي ابزار Line، كليد س��مت چپ ماوس را نگه داريد تا كادري مطابق شكل 1-6 باز 
شود، سپس ابزار Arc را انتخاب كنيد.

Arc tool شکل 1-6 انتخاب ابزار

2- در قس��مت دلخواه��ي از صفحه، کليک کرده و عم��ل درگ را انجام دهيد. مي‌توانيد 
نحوه ترس��يم کمان را تغيير دهيد و کمان را به صورت باز، محدب يا مقعر رس��م كنيد. براي 

اين منظور ابتدا بايد ابزار Arc را تنظيم كنيد.
Arc 2-1-6 تنظيمات ابزار

1- روي ابزار  Arcدابل کليک کنيد تا کادر محاوره Arc مطابق شکل 2-6 باز شود.

Arc شکل 2-6 کادر محاوره

نتيجه انتخاب  هر يك از گزينه‌هاي كادرمحاوره Arc در ش��کل 3-6 نش��ان داده ش��ده 
است.

2- روي دکمه OK کليک کنيد.
3- حال در نقطه‌اي دلخواه از صفحه، کمان را رسم کنيد.
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شکل 3-6 رسم سه نوع کمان

 مثال 1: يک کمان بسته محدب رسم کنيد.
1- روي ابزار  Arcدابل کليک کنيد تا کادرمحاوره Arc باز شود.

2- از کادرمحاوره باز شده، گزينه Create flipped arc را انتخاب کنيد تا کمان به صورت 
بسته با قوس محدب ترسيم شود.

3- روي دکمه OK کليک کنيد.
4- در نقطه دلخواهي از صفحه، کمان را رسم کنيد.

 نكته: براي تغيير جهت کمان در راس��تاي افقي و عمودي، پس از ترس��يم، کليد 
 Shift را نگه داريد. براي ترس��يم کمان به صورت قوس بس��ته يک چهارم دايره از کليد Alt

استفاده كنيد.

تمرين 1: کاربرد کليد Ctrl را در حين ترسيم هر يک از کمان‌ها بررسي کنيد.
 Spiral 2-6 ابزار

براي ترسيم خطوط مارپيچ از اين ابزار استفاده مي‌شود.
Spiral 1-2-6 روش کار با ابزار

1- از منوي بازشوي Line در جعبه ابزار روي ابزار  Spiral کليک كنيد.
2- روي قس��مت دلخواهي از صفحه کليک ک��رده و عمل درگ را انجام دهيد. مي‌توانيد 

نحوه ترسيم مارپيچ را تغيير دهيد.
Spiral 2-2-6 تنظيمات ابزار

1- روي اب��زار Spiral دابل‌کلي��ک کنيد ت��ا کادرمحاوره Spiral مطابق ش��کل 4-6 ظاهر 
شود.
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در اين کادر محاوره گزينه‌هايي وجود دارد که روي مارپيچ و نوع آن اثر مي‌گذارند.
2- گزينه Spiral type  نوع مارپيچ را تعيين مي‌کند )شکل 6-5(.

                   	                

شکل 5-6 انواع مارپيچ 	Spiral شکل 4-6 کادرمحاوره                 

ب��ا انتخاب مارپيچ گسترش��ي )Expanding(، مارپيچ به صورت گس��ترش يافته ترس��يم 
مي‌شود يعني فاصله ميان حلقه‌ها از مرکز به سمت خارج به تدريج افزايش مي‌يابد.

در مارپيچ غيرگسترش��ي )Non-expanding( که به آن مارپيچ ساده هم مي‌گويند فاصله 
ميان حلقه‌ها يکسان است.

گزينه‌هاي بعدي با توجه به نوع مارپيچ تغيير مي‌کنند.
Expansion: اي��ن گزينه وقتي ظاهر مي‌ش��ود که مارپيچ از نوع گس��ترش يافته انتخاب 

ش��ده باشد. در اين قسمت به وس��يله حرکت دادن دکمه لغزنده يا وارد کردن عدد در کادر 
مقابل Expansion، مقدار فاصله بين حلقه‌هاي مارپيچ برحسب درصد تعيين مي‌شود )شکل 

 .)6-6

 

Expansion شکل 6-6 مقايسه مقادير وارد شده در کادر

Draw by: اين كادر بازشو داراي دو حالت انتخابي است: 

 • 	Number of با انتخاب اين حالت در هر دو ن��وع مارپيچ، گزينه : Rotationsحال�ت
rotations ظاهر مي‌ش��ود که با اس��تفاده از دکمه لغزنده يا وارد کردن عدد در کادر 

مربوطه مي‌توان تعداد حلقه‌هاي مارپيچ يا تعداد چرخش‌هاي آن را تعيين کرد.
غيرگسترشي، فاصله بين حلقه‌ها  • حالت Increments: با انتخاب اين گزينه در مارپيچ 	
در کادر Increment Width  وارد مي‌ش��ود که س��بب رسم مارپيچ با  فواصل يکسان 



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
128

 Starting( در چرخش‌ها خواهدشد. درمارپيچ‌گسترشي، شعاع‌آغازين براي‌رسم‌مارپيچ
radius( تعيين مي‌شود.  

• Draw from: اين كادر بازشو چگونگي آغاز ترسيم مارپيچ را مشخص مي‌کند که در 	

آن ســه حالت انتخاب وجود دارد که در صورت انتخاب حالت Center نقطه شــروع 
مارپيچ از مرکز خواهد بود و با انتخاب حالت Edge نقطه شــروع مارپيچ از لبه و در 

حالت Corner نقطه شروع مارپيچ از گوشه خواهد بود )شکل 6-7(.
      پيکان‌هاي رسم شده در مارپيچ، نقطه شروع و جهت رسم آن‌ها را نشان مي‌دهند.

  Draw fromشکل 7-6 مقايسه سه حالت انتخابي در منوي بازشو

• Direction: با انتخاب آيکن  مارپيچ در خلاف جهت عقربه‌هاي ساعت و با فعال 	

کردن آيکن  مارپيچ در جهت عقربه‌هاي ساعت ترسيم مي‌شود.
روي دکمه OK کليک کنيد.

مثال 2: شــکل 1-8-6 را رسم کنيد ســپس آن‌را در طراحي‌حاشيه ترسيم‌شده 
درشكل 2-8-6 به كار بريد.      

                   
شکل 1-8-6                                    شکل 6-8-2

1- روي ابزار Spiral دابل کليک کنيد تا کادرمحاوره Spiral ظاهر شود.
2- نوع مارپيچ را غيرگسترشي )ساده( انتخاب کنيد.

3- در منوي بازشوDraw by  نوع ترسيم مارپيچ را Rotations )پيچشي( انتخاب کنيد.
4- در کادرNumber of rotations  تعداد چرخش‌هاي مارپيچ را 4 قرار دهيد.

5- در قسمت Direction آيکن  را انتخاب کنيد تا مارپيچ در خلاف جهت عقربه‌هاي 
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ساعت ترسيم شود.
6- روي OK کليک کنيد.

7- شکل را روي صفحه رسم کنيد.
 )Pointer( 3-6 ابزار انتخاب

 FreeHandواقع در جعبه ابزار )شکل 12-6(، يکي از کاربردي‌ترين ابزارها در Pointer ابزار
MXa است و در موارد زير از آن استفاده مي‌شود:

 نكته: اگر ابزار ديگري از ToolBox انتخاب شده‌باش��د، فش��ردنك‌ليد Ctrl سبب‌ 
انتخاب‌ ابزار Pointer  مي‌شود.

1-3-6 انتخاب، جابه‌جايي و حرکت دادن موضوعات گرافيکي 

1- ب��ه کمک اب��زار Pointer روي موضوع مورد نظر کليک کنيد؛ در اين حالت نقاطي در 
کناره‌هاي شکل ظاهر مي‌شود و موضوع مطابق شکل 9-6 به حالت انتخاب درمي‌آيد.

2- با كمك ماوس به ‌آرامي درگ کنيد، در ‌اين ‌حالت اشاره‌گر ‌ماوس به ‌شکل يک‌ پيکان 
(. حال مي‌توانيد مانند ش��کل 10-6 پيش‌نمايشي از  ‌چهار‌طرفه نمايش داده مي‌ش��ود )

حرکت موضوع انتخاب شده را ببينيد.
3- كليد ماوس را در محل دلخواه رها کنيد. شکل به محل موردنظر انتقال مي‌يابد. 

                                     
شکل 9-6 انتخاب شکل با ابزار Pointer        شکل 10-6 پيش‌نمايشي از حرکت شکل انتخاب شده

 نكته: براي تنظيم پيش‌نمايش حركت موضوعات هنگام درگ آن‌ها، بايد در كادر 
متن��ي Preview drag در كادر محاوره Preferences در زبان��ه Redraw مقداري را وارد كنيد. 
توجه داشته باشيد وارد كردن عدد بزرگ سبب آهسته شدن پيش‌نمايش حركت موضوعات 

خواهد شد.
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مثال 3: شکل 16-6 را رسم کنيد و سپس آن را به محل ديگري منتقل كنيد.
 

1- شکل را با استفاده از ابزار Pen  رسم کنيد. 
2- حال شکل را با ابزار Pointer انتخاب کنيد.

براي اين کار ابتدا ابزار Pointer را از جعبه ابزار انتخاب کرده، س��پس روي ش��کل 6-16 
کليک کنيد.                                                               

 شکل 11-6 ترسيم شکل   

3- حال شکل انتخاب شده را تغيير مکان دهيد.
ب��راي اين منظور با كمك ماوس به آرامي درگ کنيد )در اين حالت اش��اره‌گر ماوس به 
ش��کل يک پيکان چهار طرفه نمايش داده مي‌ش��ود( و در محل مورد نظر کليد ماوس را رها 

کنيد، شکل به محل جديد انتقال مي‌يابد.
2-3-6 جابه‌جايي گره‌هاي يک مسير 

 1- نق��اط روي مس��ير را که مي‌خواهيد جابه‌جا ش��وند ب��ا اب��زار Pointer  انتخاب کنيد 
)شكل 6-12(.

2- نقط��ه مزب��ور را به موقعيت جديدي انتقال دهيد، بدين ترتيب ش��کل مس��ير تغيير 
مي‌کند )شكل 6-13(.

 

شکل 12-6  انتخاب گره روي مسير توسط ابزار Pointer         شکل 13-6 جابه‌جايي گره‌هاي يک مسير
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3-3-6 تغيير اندازه موضوعات گرافيکي

1- با ابزار Pointer روي شکل مورد نظر دابل کليک کنيد. با انجام اين کار دستگيره‌هاي 
تغيير شکل )Transform handles( در اطراف شکل ظاهر مي‌شود.

                                                                   

شکل 14-6 ظاهر شدن کادر مرزي

2- با قرار دادن ماوس روي اين دس��تگيره‌ها و درگ به س��مت داخل يا خارج مي‌توانيد 
اندازه)Scale(  شکل را تغيير دهيد )شكل 6-15(.

شکل 15-6 تغيير مقياس تصوير

3- با قرار دادن ماوس روي اين دس��تگيره‌ها و چرخش اش��اره‌گر مي‌توانيد ش��کل را در 
جهت دلخواه بچرخانيد.

مثال 4: آرم شكل 16-6 را رسم کنيد.
 

1- براي رسم آرم بايد از ابزار Pen استفاده کنيد و در نقاط گوشه شکل، استفاده از کليد
Alt  را فراموش نکنيد.

2- با ابزار Pointer  روي ش��کل مورد نظر دابل کليک کنيد تا دستگيره‌هاي تغيير شکل، 
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در اطراف شکل ظاهر شود )شکل 6-17(.
3- حال با درگ ماوس به سمت داخل، شکل را کوچک کنيد.

                     

شکل 16-6       شکل 17-6 ظاهر شدن دستگيره‌هاي تغييرشکل

4-3-6 انتخاب چندين موضوع گرافيکي به صورت همزمان

1- به وس��يله ابزار Pointer و نگه داشتن کليدShift ، مي‌توان چندين موضوع را با هم در 
حالت انتخاب قرار داد.

2- با انتخاب ابزار Pointer و کشيدن کادري توسط ماوس به دور همه موضوعات مي‌توان 
چندين موضوع را انتخاب کرد )شكل 6-18(.

شکل 18-6 انتخاب چند موضوع گرافيکي با يکديگر

 مثال 5: شکل‌هاي 19-6 را رسم کنيد.
1- براي رسم اين اشکال از ابزار Pen و Bezigon و براي رسم دايره‌هاي موجود در شکل 

از ابزار Ellipse به همراه کليد Shift استفاده کنيد.
2- کليه اشکال 19-6 را با هم انتخاب کنيد.

شکل 6-19 

دو روش براي اين کار وجود دارد:
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روش اول: مي‌توانيد به وس��يله ابزار Pointer و نگه داش��تن کليد Shift روي هر موضوع 
کليک کنيد و آن‌ها را با هم در حالت انتخاب قرار دهيد.

روش دوم: مي‌توانيد ابزار Pointer را انتخاب کرده توس��ط ماوس به دور همه موضوعات 
کادري رسم کنيد. در اين حالت تمام موضوعات در حالت انتخاب قرار مي‌گيرند.

5-3-6 حذف موضوعات گرافيکي

1- موضوع گرافيکي را با ابزار Pointer انتخاب کنيد.
2- کليدDelete  روي صفحه کليد را فشار دهيد.

 توجه: با استفاده از گزينه Clear  واقع در منوي Edit  مي‌توانيد موضوع‌ يا موضوعات 
انتخاب ‌شده‌ را حذف کنيد.

با دابل کليک روي ابزار Pointer کادر محاورهPointer Tool  ظاهر مي‌شود.

Pointer Tool شکل 20-6 کادر محاوره

هنگام انتخاب اش��کال گرافيکي توس��ط ابزار  Pointer بايد اشکال کاملًا درون کادر رسم 
شده توسط اين ابزار قرار گيرند تا انتخاب شوند، اما فعال کردن گزينه Contact sensitive از 
کادر محاوره Pointer Tool باعث مي‌ش��ود موضوعاتي هم که فقط قس��متي از آن‌ها در کادر 

رسم شده توسط ابزار Pointer قرار گرفته، به حالت انتخاب درآيند.

Contact sensitive شکل 21-6 عملکرد گزينه

 FreeHand روش‌هاي مختلفي براي انتخاب موضوعات گرافيکي در  Pointerعلاوه بر ابزار
MXa وجود دارند که عبارتند از:

1- فرم�انAll  )کليد ميانبر Ctrl+A(: از فرم��ان Edit→Select→All براي انتخاب همه 



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
134

موضوع��ات موجود در صفحه به‌کار مي‌رود. اين فرمان موضوعات خارج از صفحه گرافيکي را 
در حالت انتخاب قرار نمي‌دهد.

 :)Ctrl+Shift+A  کليد ميانبر(  All In Document 2- فرمان
فرم��انSelect→All In Document از منوي Edit براي انتخاب تمام موضوعاتي که در کل 
 FreeHand س��ند وجود دارند، به‌کار مي‌رود )شكل 22-6(. )توجه داشته ‌باشيد که اسناد در

مي‌توانند شامل چندين صفحه باشند.(

شکل 22-6 انتخاب تمام موضوعات داخل سند

3- فرم�انNone  )کليد ميانبر Ctrl+D(: فرم��ان Select→None  از منوي Edit باعث 
مي‌شود موضوعات گرافيکي انتخاب شده، از حالت انتخاب خارج شوند. 

4- فرم�ان Invert Selection: فرم��ان Select→Invert Selection از من��وي Edit ب��راي 
معک��وس ک��ردن موضوعات انتخابي در داخل صفحه به‌کار م��ي‌رود. به طوري كه موضوعات 
انتخابي از  حالت ‌انتخاب خارج‌ش��ده و س��اير موضوعات به‌حالت انتخاب در مي‌آيند )شك��ل 

.)6-23

Invert Selection شکل 23-6 نتيجه استفاده از فرمان

5- فرمان Subselect: فرمان Select→Subselect از منوي Edit باعث مي‌شود همه اجزاي 
قرار گرفته در يک گروه به حالت انتخاب درآيند. همچنين در صورت اجراي اين فرمان روي 
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يک مسير انتخاب شده، گره‌ها و دستگيره‌هاي کنترلي آن مسير نمايان مي‌شوند.

 توج�ه: براي انتخ��اب يک موضوع خ��اص از ميان چند موض��وع موجود در يک 
گ��روه به جاي اجراي فرمان Subselect، مي‌توانيد از ابزار Subselect موجود در جعبه ابزار نيز 

استفاده کنيد.
    

شکل 24-6 انتخاب تمام اجزاي موجود در يک شکل يا مسير    

 نكت�ه: اب��زار Pointer  کل مجموعه گروه را انتخاب مي‌کند و اجزاي گروه از اين 
طريق انتخاب نمي‌شوند، براي انتخاب اجزاي يک گروه، از ابزار Subselect  استفاده کنيد.

Subselect شکل 25-6 ابزار

Subselect شکل 26-6 انتخاب يک جزء از يک گروه توسط ابزار

6- فرمان Superselect: انتخاب گزينه Select→Superselect از منوي Edit باعث مي‌شود 
اگر موضوعي )قس��متي( از يک گروه توسط Subselect انتخاب شده باشد، کل گروه به حالت 

انتخاب درآيد. با انتخاب فرمان Superselect دستگيره‌هاي شکل ناپديد مي‌شوند.
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Superselect شکل 27-6 عملکرد فرمان

تمرين 2: پنج مدل برگ را به دلخواه رسم كنيد و روش‌هاي انتخاب را روي آن 
بررسي كنيد.

تمرين 3: تصاوير 28-6 را رسم کنيد.

شکل 6-28       

 Freeform 4-6  ابزار

ابزار Freeform )تغيير ش��کل آزاد( داراي کاربردهاي بس��ياري است و در جعبه‌ابزار قرار 
دارد. ب��ه کم��ک اين ابزار مي‌توان گره‌ها را در مس��يرها به راحتي جابه‌جا کرد و مس��يرهاي 
ترس��يم ش��ده را به اش��کال دلخواه ويرايش کرده و تغيير ش��کل داد. اين ابزار با هل دادن، 
کش��يدن، افزودن گره يا حذف گره از مس��يرها به ويرايش و تغيير ش��کل آن‌ها مي‌پردازد و 

شکل جديدي را به وجود مي‌آورد.
علاوه بر تغيير ش��کل مس��يرها از طريق نقاط گره، اگر با اس��تفاده از ابزار Freeform در 
نقطه‌اي از صفحه  در خارج از مس��ير کليک کنيد و كليد ماوس را پايين نگه داريد، اشاره‌گر 
ماوس به يک دايره تبديل مي‌ش��ود و اگر آن را به لبه‌هاي مسير نزديک کنيد، خطوط آن را 

به سمت بيرون هل مي‌دهد.
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Freeform شکل 29-6 استفاده از ابزار

اب��زار Freeform داراي دو حالت Push/Pull وReshape Area  اس��ت. گزينه Push/Pull به 
ش��ما امکان مي‌دهد تا به منظور افزودن پاره‌خط‌هاي جديد به يک مسير، آن‌ها را بکشيد يا 

به داخل هل دهيد. انتخاب گزينهReshape Area  باعث تغيير شکل موضوع مي‌شود.

 مثال 6: شکل الف را رسم کرده سپس با ابزار Freeform آن را به شکل ب تبديل 
کنيد )شکل 6-30(.

1- ابت��دا ابزار Rectangle را از جعبه اب��زار انتخاب کرده، کليد Shift را پايين نگه داريد و 
روي صفحه يک مربع رسم کنيد. 

2- اکن��ون مي‌توانيد با اس��تفاده از اب��زار Freeform که از جعبه اب��زار انتخاب کرديد با 
کشيدن و هل دادن اضلاع مربع، شکل مورد نظر را ايجاد کنيد. 

شکل 6-30 

Push/Pull 1-4-6 تنظيم عمليات ابزار

 Freeform Tool در جعبه ابزار دابل کليک کنيد تا کادر محاوره Freeform 1- روي گزينه
مطابق شکل 31-6 باز شود.

2- از قسمت Tool Operation گزينه Push/Pull را انتخاب کنيد.
3- در قس��مت Push Settings با اس��تفاده از کادر Size  اندازه ابزار و با اس��تفاده از کادر 
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Precision ميزان حساسيت ابزار را تعيين کنيد. 

4- در قسمت Pull Settings نوع کشيدن مسير براي ابزار Freeform تعيين مي‌شود.

                                 

Push Settings شکل 32-6 تنظيمات قسمت          Freeform Tool شکل 31-6 کادر محاوره

 ، By Lengthدو حالت براي انتخاب وجود دارد. با انتخاب حالت  Bend5- در كادر بازش��و
ابزار Freeform مس��يرها را براس��اس پهنايي که توسط دکمه لغزندهLength  تعيين مي‌شود، 
 تغيير مي‌دهد. انتخاب Between Points فقط قس��متي از مس��ير را که بين گره‌ها قرار دارد، 

مي‌کشد.   

                                                         

Length شکل 34-6 تنظيمات دکمه لغزنده         Pull Settings شکل 33-6 تنظيمات قسمت

 Push/Pull 2-4-6 اصلاح موضوعات در حالت

1- موضوعي را که مي‌خواهيد اصلاح شود، برگزينيد.
2- اشاره‌گر ماوس را در موقعيت‌هاي زير قرار دهيد:

• کوچک در  	s اش��اره‌گر ماوس را مس��تقيماً روي مرز موضوع قرار دهيد تا يک شکل
کنار آن ظاهر ش��ود. اين شکل نشان مي‌دهد که در حالت کشيدن )Pull( هستيد و 

تنها کافي است لبه موضوع مربوطه را به داخل يا خارج درگ کنيد.
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Pull و Push شکل 35-6 نمايش اشاره‌گر در حالت

• کوچک در کنار  	o اش��اره‌گر ماوس را به داخل يا خارج موضوع انتقال دهيد تا شکل
آن ظاهر شود. اين شکل نشان مي‌دهد که شما در حالت )Push( هستيد.

3- براي اصلاح موضوع، ماوس را بکشيد؛ در حالت Push دايره‌اي ظاهر مي‌شود که اندازه 
آن را با اس��تفاده از کادر Size در قس��مت Push Settings تنظيم کرده‌ايد. وجود يک پيکان 

نشان دهنده اين است که در حالت Pull قرار داريد.
• اثر هل‌دادن يا کشيدن مسيرها به‌صورت ظريف‌تري انجام مي‌شود  	Reshape درحالت
که براي ترس��يم جزييات بيش��تر تصاويري مثل موي سر، س��اقه گياهان و ... مفيد 

خواهند بود.

Pull و Push شکل 36-6 نمايش اشاره‌گر هنگام اصلاح شکل در حالات

Reshape Area 3-4-6 تنظيم عمليات گزينه

 Freeform Tool در جعب��ه ابزار دابل کليک کنيد تا کادر محاوره Freeform 1- روي‌اب��زار
باز شود.

2- از قسمتTool Operation  گزينه Reshape Area را برگزينيد )شكل 6-37(.       
3- در قس��مت Settings، براي تنظيم اندازه ن��وک ابزار از کادر Size و براي تنظيم ميزان 
يا مدت زمان کش��ش ابزار از کادر  Strength اس��تفاده کنيد. گزينه Precision  تعداد گره‌هاي 

لازمي را که در طول مسير تحت تأثير قرار مي‌گيرد، تعيين مي‌کند )شكل 6-38(.
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Settings شکل 38-6 تنظيمات قسمت        Freeform Tool شکل 37-6 کادر محاوره

شکل 39-6 استفاده از ابزار Reshape Area براي اصلاح شکل

 نكته: هر قدر مقدار Precision بيش��تر باش��د، حساسيت ابزار شما به جابه‌جايي 
ماوس بيشتر شده و پس از استفاده از ابزار، تعداد نقاط گره بيشتري ايجاد مي‌شود.

  Push/Pull آن را بين دو حالت  Freeform هنگام استفاده از ابزار Alt  توجه: کليد 
و Reshape Area جابه‌جا مي‌کند.

تمرين 4: اش��کال 40-6 را رس��م کرده و تصاوير شماره 1 را به تصاوير شماره 2 
تبديل کنيد. 

'            

شکل 6-40 
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 Knife 5-6 ابزار
اب��زار Knife موجود در جعبه اب��زار، مانند چاقو عمل مي‌کند. اين ابزار موضوعات را برش 
مي‌زند و حفره‌هايي درون آن‌ها به وجود مي‌آورد و حتي مي‌تواند بخش��ي از اش��کال را پاک 

کند.
Knife 1-5-6 تنظيمات ابزار

1- در جعب��ه اب��زار روي ابزار Knife داب��ل کليک کنيد تا کادر مح��اوره Knife Tool باز 
شود.

2- در قسمت Tool Operation با استفاده از گزينه Freehand  مي‌توانيد برش‌هاي موجي 
 Straight شکل ايجاد کنيد يا بر اساس حرکت ماوس شکل را برش بزنيد، اما با انتخاب گزينه

مي‌توانيد موضوعات را به‌طور خطي مستقيم و صاف برش بزنيد.

                
Straight و   Freehand در حالت  Knifeشکل 42-6 نحوه برش با ابزار      Knife Tool  شکل 41-6 کادرمحاوره

3- در قس��مت Width مي‌توانيد فاصله بين برش‌ها يا پهناي نوک چاقو را هم به صورت 
دستي و هم با اهرم کناري آن تنظيم کنيد )شكل 6-43(.

شکل 43-6 فاصله برش

 نكته: زماني که مي‌خواهيد شکل خود را به صورت مسير بسته ببريد، بهتر است 
پهنا را صفر بدهيد تا دو شکل بريده شده به هم بچسبند و از هم جدا نشوند.
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4- گزينه Close cut paths در قس��مت Options باعث مي‌ش��ود مسيرهاي برش خورده، 
بس��ته شوند )شك��ل 44-6(. گزينه Tight fit نيز سبب مي‌ش��ود ابزارKnife  دقيقاً از حرکت 

ماوس پيروي کند.

Close cut paths      شکل 44-6 عملکرد گزينه

Knife 2-5-6 استفاده از ابزار

1- موضوعي را که مي‌خواهيد برش بزنيد، انتخاب کنيد.
2- ابزار Knife را روي موضوعات بکشيد.

  Alt از کليد Straight و Freehand توج�ه: براي جابه‌جايي س��ريع بين دو حال��ت 
استفاده کنيد. 

مثال 7:  شکل 45-6 را رسم کنيد.
 Ellipse و براي رسم چشم‌ها از ابزار Bezigon و Pen 1- براي‌ رس��م اين شکل از ابزارهاي

استفاده کنيد.
2- ش��کل را به صورت موجي شکل، برش بزنيد به طوري که فاصله بين برش‌ها 3 باشد 

و پس از برش مسيرهاي ايجاد شده بسته باشند.	           

 شکل 6-45 

ب��راي اي��ن منظور ابتدا در جعبه ابزار روي ابزار Knife داب��ل کليک کنيد تا کادر محاوره 
Knife Tool باز ش��ود، سپس در قسمت Tool Operation گزينهFreehand  را انتخاب کنيد تا 

برش‌ها به صورت موجي ش��کل ايجاد شود. بعد در قسمت Width فاصله بين برش‌ها را برابر 
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3 قرار دهيد و در قسمت Options گزينه Close cut paths را انتخاب کنيد تا مسيرهاي برش 
خورده، بسته شوند و در انتها ابزار Knife را روي تصوير بکشيد.

تمرين 5: شكل 46-6 را ايجاد کرده و برش‌هاي لازم را انجام دهيد.                            

شکل 6-46 

 توج�ه: ب��راي رنگ‌آمي��زي موضوعات و اشك��ال مي‌تواني��د در جعبه اب��زار، ابزار 
را ب��راي رن��گ خطوط دور شك��ل و Fill Color   را براي رنگ‌آميزي    StrokeColor

داخل شكل استفاده كنيد1.

 Eraser 6-6 پاک کردن مسير با ابزار
با استفاده از ابزار Eraser مي‌توانيد قسمت‌هايي از مسير انتخابي يا اشکال را پاک کنيد.

 Eraser 1-6-6 پاک کردن مسير انتخابي با ابزار

1- شکل يا مسير مورد نظر را انتخاب نماييد.
2- از جعبه ابزار Tools روي ابزار Eraser کليک کنيد.
3- ابزار Eraser را روي مسير مورد نظر درگ نماييد.

Eraser 2-6-6 تنظيم گزينه‌هاي ابزار

در جعبه ابزارTools  روي ابزار Eraser دابل کليک كنيد.
در قسمت Min و Max مي‌توانيد با وارد كردن عددي بين 0 تا 72 يا با حركت نوار لغزنده 

حداقل و حداكثر پهنا را تعيين نماييد.

1- با روش‌هاي ديگر رنگ‌آميزي در واحدكار 7 آشنا خواهيد شد. 
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Eraser شکل 47-6 کادر تنظيمات ابزار

تمرين 6: ش��کل 48-6 را رسم و سپس با تنظيم پهناي پاك‌كن، قسمت‌ مياني 
شكل را پاك كنيد.

شکل 6-48

 Lasso 7-6 انتخاب اشکال با  ابزار
مي‌توان توسط ابزارهايSubselect، Pointer  و  Lassoو کليک روي اشکال، آن‌ها را انتخاب 

نمود. 
ابزارهاي Pointer و Subselect به ش��ما اين امکان را مي‌دهند تا با کليک روي ش��کل يا 
درگ روي ش��کل يا نقطه به صورت مس��تطيل آن را انتخاب نماييد اما با ابزارLasso  مي‌توان 

به صورت آزاد )Freeform( اشکال يا نقاط مورد نظر را انتخاب كرد.
Lasso 1-7-6 تنظيمات ابزار

با دابل کليک روي ابزار Lasso کادرمحاورهLasso Tool  باز مي‌شود )شکل 49-6(. هنگام 
انتخاب اش��کال گرافيکي توس��ط ابزار Lasso توجه داشته باشيد كه اشکال کاملًا درون کادر 
 Contact رس��م ش��ده توس��ط اين ابزار قرار گيرند تا انتخاب ش��وند، اما فعال کردن گزينه
sensitive از کادر مح��اوره Lasso Tool  باع��ث مي‌ش��ود موضوعاتي انتخاب ش��وند كه فقط 

قسمتي از آن‌ها )نه همه اجزاي شكل( درون كادر Lasso قرار گرفته است.

Lasso Tool شکل 49-6 کادر
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در شكل 50-6 انتخاب با ابزار Lasso در هنگام فعال‌بودن گزينه Contact sensitive نشان‌ 
داده‌شده‌است.

Contact sensitive در هنگام فعال بودن گزينه Lasso شکل 50-6 نحوه عملكرد ابزار

 Connector 8-6 ابزار
به منظور اتصال اش��کال به يکديگر توسط اين ابزار مي‌توان خطوط اتصال دهنده را بين 

آن‌ها ترسيم كرد.

شکل 51-6 استفاده از خطوط اتصال 

هنگام��ي که اش��کال متصل به ه��م را در پنج��ره Documents حرک��ت دهيد، خطوط 
Connector به طور خودکار نسبت به وضعيت جديد تنظيم مي‌شوند.

1-8-6 رسم يک خط اتصال بين دو شئ 

1- صفحه‌جديدي ايجاد کرده و دو شکل در قسمت‌هاي مختلف صفحه رسم کنيد.
2- از جعبه ابزار Tools روي‌ ابزار Connector کليک كنيد.

3- مکان‌نماي ماوس را )که ش��کل آن تغيير کرده اس��ت( روي يکي از اشکال قرار دهيد 
كه مي‌خواهيد خط اتصال‌دهنده از آنجا ش��روع شود. حال يک دايره کوچک کنار آن نمايان       

مي‌شود. 
4- در اين حالت کليک کرده و ماوس را به س��مت بالا، پايين يا وجوه شك��لي بكشيد كه 

مي‌خواهيد به آن متصل شويد.
5- پس از مشاهده دايره كوچك، كليد ماوس را رها كنيد. يک خط به شکل دوم ترسيم 



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
146

مي‌شود.

 )Start( مي‌توانيد تنظيمات مربوط به نقاط ابتدا Object نكته: با اس��تفاده از پنل 
و انتهاي )End( خطوط Connector را انجام دهيد.

2-8-6 تغيير اندازه و تغييرشكل خط اتصال دهنده 

براي تغيير اندازه خط اتصال دهنده، هنگامي كه ابزار Connector در حال انتخاب است، 
مکان‌نما را روي خط قرار دهيد تا به شکل پيکان دو سر به همراه علامت بعلاوه ديده شود، 

سپس خط را به دلخواه درگ کنيد، در اين صورت شكل خط و اندازه آن تغيير ميك‌ند.

 توجه: هنگام جابه‌جايي اش��ياء توس��ط ابزار انتخاب، خط اتص��ال دهنده به طور 
خودكار تغيير شكل مي‌دهد تا دو شئ را به هم وصل كند.

تمرين 7: شكل 52-6 را رسم كنيد.

شکل 6-52

 Edit 9-6 برخي از فرمان‌هاي منوي
همان‌طورکه می‌دانيد منوی Edit به منظور کارهای ويرايشی نظير کپی، برش و چسباندن 
يک ش��ئ روی صفحه به‌کار می‌رود. در اين بخش به فرمان‌های تخصصی ويرايشی پرداخته 

شده است.
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Edit شکل 53-6 منوي
Cut Contents 1-9-6 فرمان

اين گزينه براي جدا کردن موضوعاتي که داخل هم قرار گرفته‌اند، اس��تفاده مي‌ش��ود. به 
عبارت ديگر اين گزينه عکس عمل Paste Contents را انجام مي‌دهد. براي اجراي اين گزينه 

ابتدا بايد فرمانPaste Contents را انجام دهيد.
Paste Contents  فرمان

اين فرمان در نس��خه FreeHand MXa موجود است و باعث كپي كردن و چسباندن يك 
شكل به درون يك مسير يا شكل ديگر مي‌شود به طوري كه شكل چسبانده شده در لبه‌هاي 

مسير برش بخورد.
به عبارت ديگر چسباندن شئ در داخل شئ ديگر به شما امکان می‌دهد تا اشيای مزبور 
را به نحوی پر کنيد که تمام بخش‌های خارج از آن‌ها ديده نش��ود. اين ش��ئ پر ش��ده، يک 
مس��ير برش )Clipping Path( يا ماس��ک ناميده می‌ش��ود. برای انجام ماسک‌گذاری اشياء به 

روش زير عمل کنيد:
1- ابتدا بايد تصوير يا اشيای مورد نظر را روی شيئی قرار دهيد که به عنوان مسير برش 

عمل می‌کند، سپس آن‌ها را انتخاب کنيد )شكل 6-54(.
2- ب��ا اس��تفاده از فرمان Edit→Cut  اش��ياء را در کليپ‌بورد ق��رار دهيد، در اين صورت 

مطابق شکل 73-6 فقط مسير روی صفحه می‌ماند.
3- حال مسير برش را انتخاب نماييد سپس فرمان Edit→Paste Contents  را اجرا كنيد 

تا اشياء در مسير برش چسبانده شوند )شکل 6-56(.
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شکل 54-6 قرار گرفتن اشياء روی مسير برشی    شکل 55-6 نمايش مسير پس از انتقال اشياء به کليپ‌بورد

 نكت�ه: اگر در پن��ل Object روي گزينه Content كليك كنيد يک دس��تگيره در 
ش��کل ظاهر می‌شود که با درگ اين دس��تگيره در جهت‌های مختلف، اشياء در مسير برش 

جابه‌جا می‌شوند.

       	

شکل 56-6 نمايش نتيجه فرمان Paste Contents      شکل 57-6 نمايش دستگيره در مسير برشی

حال فرمان Cut Contents را اجرا نماييد، مش��اهده ميك‌نيد كه اشك��ال از مس��ير برشي 
خارج مي‌شوند.

Cut Contents شکل 58-6 نمايش اجراي فرمان

 )Clipping Path( براي حذف مس��ير برش��ي Cut Contents نكته: در واقع فرمان 
بهك‌ار مي‌رود.

Paste Special 2-9-6 فرمان

اين گزينه براي چسباندن شئ مورد نظر از يك برنامه كاربردي به برنامهFreeHand  بهك‌ار 
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مي‌رود.
براي انجام اين عمل مراحل بعد را انجام دهيد:

1- موضوع مورد نظر در برنامه كاربردي را كپي كنيد.
2- در برنامه FreeHand از مس��ير Edit→Special  فرمان Paste Special را اجرا كنيد. كادر 

محاوره Paste Special باز خواهد شد )شكل 6-59(.

Paste Special شکل 59-6 كادرمحاوره

3- از كادر  As:فرمت موردنظر را انتخاب كرده و دكمه OK را كليك كنيد.
تمرين 8: شك��لي را كه در برنامه فتوشاپ رس��م كرديد، كپي كنيد و سپس در 

برنامه FreeHand آن را Paste Special نماييد.
 Duplicate  3-9-6 فرمان

در برنام��ه FreeHand  فرماني در اختيار ش��ما قرار مي‌گيرد ��كه موضوعات مورد نظر را 
ب��ه نحوي كپي ميك‌ن��د كه در كليپ‌بورد قرار نمي‌گيرد و اصطلاحاً به آن مضاعف كردن هم 

مي‌گويند. براي انجام فرمان Duplicate مراحل بعد را انجام دهيد:
1- موضوع مورد نظر را انتخاب كنيد.

2- از من��وي Edit گزين��ه Duplicate را برگزيني��د ي��ا مي‌توانيد همزم��ان كليدتركيبي 
Alt+Ctrl+D را بفشاريد. در اين صورت يك كپي از شكل ايجاد مي‌شود به طوري كه دورتر از 

شكل اصلي قرار مي‌گيرد. سه بار عمل Duplicate انجام شده است.
Clone  4-9-6 فرمان

اين گزينه درس��ت روي خود موضوع انتخابي يک رونوشت از شئ ايجاد مي‌کند و معادل 
كليدي آن Ctrl+Shift+D اس��ت. در اين صورت مي‌توان به كمك كليد Shift شكل كپي شده 

را در راستاي شكل اصلي جابه‌جا كرد.

تمرين 9: شك��ل 60-6 را رس��م كرده و تفاوت فرمان‌ه��اي Duplicate ،Copy و 
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Clone را بررسي كنيد.

شکل 6-60

 مث�ال كاربردي: در ادامه مثال كاربردي واح��د كار 5، فايلProject. fh11 را كه 
قبلًا ايجاد كرده‌ايد، باز كنيد و موارد بعد را انجام دهيد. 

1- با استفاده از ابزار Subselect روي نقطه لنگر پايين ضلع سمت راست چهارگوش كليك 
 كنيد تا انتخاب شود. نقاط لنگر پس از انتخاب به صورت مربع توخالي نمايش داده مي‌شوند 

)شکل 6-61(.
2- اكنون در پنل Object مش��خصات گره انتخاب ش��ده نمايش داده مي‌شود. با انتخاب 
آيكن نقطه منحني در اين پنل، نقطه گوشه به يك نقطه منحني تبديل مي‌شود. حال گزينه
Automatic  را هم فعال كنيد تا خطوط متصل به نقطه انتخاب شده به كمان تبديل شوند.

3- نقطه را با اس��تفاده از ابزار Pointer كمي به داخل شك��ل منتقل كنيد تا كمان، شكل 
مناس��ب خ��ود را پيدا كند. براي اينك‌ه نقطه در زاوي��ه 45 درجه حركت كند، كليد Shift را 

نيز پايين نگه داريد.

                      

شكل 61-6                                         شكل 62-6                                  شكل 6-63

4- با ابزار Ellipse يك بيضي با ابعاد دلخواه ترسيم كنيد. 
5- در زبان��ه Object ابع��اد 22/5×22/5 را ب��راي قطرهاي بيض��ي وارد كنيد تا بيضي به 
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داي��ره‌اي با قطر 22/5 تبديل ش��ود. با اس��تفاده از اب��زار Pointer يا با اس��تفاده از كليدهاي 
جهت‌دار صفحه كليد دايره را حركت داده و بر رأس بالا و سمت چپ مستطيل از قبل ترسيم 

شده، مماس کنيد )شکل 6-64(.

شكل 6-64 

6- تغييرات را ذخيره كنيد.
واژه‌نامه

Createايجادکردن

Connectorاتصال‌دهنده

Concaveمقعر

Directionمسير، جهت

Expansionگسترش

Eraserپاک‌کن

Incrementافزايش

Knifeچاقو

Lassoکمند

Pointerاشاره‌گر

Radiusشعاع

Rotationچرخش

Spiralمارپيچ

Straightيکسره، مستقيم

Subselectزير انتخاب

خلاصه مطالب 
• اس��تفاده  	Arc ب��راي ترس��يم کمان )باز، بس��ته، محدب و مقعر( ي��ا منحني از ابزار
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مي‌شود.
• استفاده کنيد. 	Spiral براي ترسيم خطوط مارپيچ از ابزار

به منظور انتخاب، جابه‌جايي و حرکت دادن و تغيير اندازه موضوعات  • 	 Pointer  از ابزار
گرافيکي استفاده مي‌شود.

 • 	All براي انتخاب همه موضوعات موجود در صفحه به‌کار مي‌رود و فرمان All  فرم��ان
In Document ب��راي انتخاب تمام موضوعاتي که در کل س��ند وج��ود دارند، به‌کار 

مي‌رود.
• فرمان None موضوعات گرافيکي انتخاب شده را از حالت انتخاب خارج ميك‌ند.	

• براي معکوس کردن موضوعات انتخابي در داخل صفحه و  	Invert Selection  فرم��ان
فرمان Subselect باعث مي‌شود همه اجزاي قرار گرفته در يک گروه به حالت انتخاب 
درآيند. همچنين انتخاب فرمان Superselect باعث مي‌شود اگر موضوعي )قسمتي( از 

يک گروه توسط  Subselect انتخاب شده باشد، کل گروه به حالت انتخاب درآيد.
• مي‌توان گره‌ها را در مس��يرها به راحت��ي جابه‌جا کرد و  	Freeform ب��ه کمک اب��زار

مسيرهاي ترسيم شده را به اشکال دلخواه ويرايش کرده و تغيير شکل داد.
، مانند چاقو عمل مي‌کند. اين ابزار موضوعات را برش مي‌زند و حفره‌هايي  • 	Knife ابزار

درون آن‌ها به وجود مي‌آورد و حتي مي‌تواند بخشي از اشکال را پاک کند.
• مي‌توانيد قس��مت‌هايي از مسير انتخابي يا اشکال را پاک  	Eraser با اس��تفاده از ابزار

کنيد.
و کليک روي اش��کال آن‌ها را  • 	 Lasso و  Subselect ، Pointer مي‌توان توس��ط ابزارهاي

انتخاب كرد. 
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- براي ترس��يم کم��ان )باز، بس��ته، محدب و مقعر( ي��ا منحني از ابزار Arc اس��تفاده 
مي‌شود.

2- ابزارSpiral  با هل دادن، کش��يدن، افزودن گره يا حذف گره از مس��يرها به ويرايش و 
تغيير شکل آن‌ها مي‌پردازد و شکل جديدي را به وجود مي‌آورد.

3- براي ترسيم خطوط مارپيچ از ابزار Subselect استفاده کنيد.
4- اب��زار Knife، موضوعات را برش مي‌زند و حفره‌هاي��ي درون آن‌ها به وجود مي‌آورد و 

حتي مي‌تواند بخشي از اشکال را پاک کند.
معادل گزينه هاي سمت‌ راست را از ستون سمت‌ چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Alt                                                         .5- اين ابزار مانند چاقو عمل مي‌کند
 6- از اين ابزار به منظور انتخاب، جابه‌جايي و حرکت دادن موضوعات گرافيکي اس��تفاده 
Knife                                                                                              .مي‌شود
7- براي جابه‌جايي سريع بين دو حالت Freehand و Straight از اين کليد استفاده کنيد.                                                                                                                                            
                               Pointer                                                                                                    
8- به کمک اين ابزار مي‌توان مسيرهاي ترسيم شده را به اشکال دلخواه ويرايش کرده و 
 Freeform                                                                               .تغيير شکل داد

گزينه صحيح را انتخاب کنيد.

9- توسط ابزار Spiral چه عملي را مي‌توان انجام داد؟
ب- رسم مارپيچ الف- ايجاد سايه محو براي موضوع گرافيکي 	

د- رنگ‌آميزي خطوط پيرامون                                  ج- رنگ‌آميزي داخل موضوع گرافيکي      	
                                                                موضوع گرافيکي

10- چه مواقعي از ابزار Arc استفاده مي‌شود؟
ب- مقعر کردن شکل  الف- سه بعدي کردن شکل 	

د- رسم کمان 		 ج- قرينه کردن شکل
11- براي رسم کمان باز هنگام استفاده از ابزار Arc از کدام گزينه استفاده مي‌شود؟
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Create Flipped Arc -ب               	Create Open Arc -الف
Create Arc -د 	Create Concave Arc -ج
12- از ابزارKnife به چه منظور استفاده مي‌شود؟

ب- قرينه کردن تصاوير 		 الف- چرخاندن تصاوير
د- جابه‌جا کردن گره‌ها 		 ج- برش زدن تصاوير

13- کدام‌يک از عمليات زير توسط ابزار Pointer انجام مي‌گيرد؟
		         ب- جابه‌جا کردن تصوير الف- تغيير اندازه تصوير

ج- انتخاب چند تصوير همزمان            د- تغيير اندازه، جابه‌جايي و انتخاب هم‌زمان 
                                                    چند تصوير

13- ب��راي ب��رش تصاوير به صورت خط ص��اف کدام‌يک از گزينه‌ه��اي موجود در کادر 
محاوره Knife Tool بايد فعال باشد؟

Tight fit -د      	  Width -ج    	Straight -ب         Freehand -الف
14- فرمان ................... كپي شكل را روي خودش قرار مي‌دهد.

Duplicate -د     	  Clone -ج   	 Contents Cut‍ -ب         	 Copy‍‍-الف
در جاي خالي عبارت مناسب را بنويسيد.

15- براي انتخاب اجزاي يک گروه، از ابزار....................استفاده کنيد.
16- به وسيله ابزار Pointer و نگه داشتن کليدShift ، مي‌توان ........................ .

17- ابزار Connector به منظور ......................... مورد استفاده قرار مي‌گيرد.
18- براي تغيير جهت کمان در راستاي افقي و عمودي، پس از ترسيم، کليد .................. 

را نگه داريد.
به سؤالات زير پاسخ تشريحی دهيد.

19- تفاوت بين مارپيچ گسترشي و غيرگسترشي چيست؟
20- کاربرد ابزارPointer  را نام ببريد.

21- دو روش جابه‌جايي و انتقال موضوعات را نام ببريد.
22- براي تغيير شکل موضوع از کدام گزينه Freeform استفاده مي‌شود؟

23- تفاوت فرمان Cut Contents و Duplicate در چيست؟
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آزمون عملي 
1- شکل‌هاي زير را رسم كنيد سپس به‌وسيله ابزار Pointer آن‌ها را تغيير اندازه دهيد.

2- ش��کل‌هاي زير را رس��م نماييد سپس به‌وسيله ابزارهاي انتخاب قسمتي از آن‌ها را به 
دلخواه انتخاب کنيد.

3- س��ه كپي از شك��ل‌ فيل را در اطراف آن قرار دهيد )يك كپي ب��ا گزينه Duplicate و دو 
.)Clone كپي با فرمان

4- يک کمان به صورت قوس بسته يک چهارم دايره رسم كنيد.
5- با استفاده از ابزارهاي Arc و Spiral درياي مواج را ترسيم كنيد.
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كليات
در مبح��ث رنگ در FreeHand به دو بخ��ش بايد توجه کرد، يکي ترکيب و تضاد رنگ‌ها 
براي ايجاد يک اثر هنري و ديگري ش��ناخت س��اختار و مواد رنگ‌هاس��ت؛ چرا که تنها در 
صورت استفاده صحيح از سيستم مدل‌هاي رنگ، مي‌توان خروجي مناسبي از اثر تهيه کرد.

م��دل رنگ، روش‌ه��اي گوناگون ارائه رنگ روي کاغذ و صفح��ه نمايش را بيان مي‌کند؛ 
به طور کلي مدل‌ها براي معرفي رنگ‌ها اس��تفاده مي‌ش��ود. در اين واحد کار ابتدا به بررسي 
ان��واع مدل‌هاي رنگ پرداخته و س��پس نحوه ايجاد و رنگ‌آمي��زي موضوعات گرافيکي گفته 

مي‌شود.
1-7 مدل‌هاي رنگ و کاربردهاي آن‌ها

چش��م انسان رنگ‌ها را براس��اس طول موج نوري که به آن مي‌رسد، درک مي‌کند. رنگ 
سفيد، نوري است که همه رنگ‌هاي اصلي طيف رنگ را در برمي‌گيرد.

چندين مدل رنگ در FreeHand وجود دارد که اساس کار همه آن‌ها طيف نور يا انعکاس 
نور تابيده شده از جسم رنگي است.

 نكت�ه: مدل‌هاي رنگ در FreeHand، اس��اس تفکي��ک رنگ براي صنعت چاپ و 
ذخيره‌سازي اسناد در قالب‌هاي مختلف گرافيکي است.

 RGB مدل
طيف نور مرئي از س��ه رنگ اصلي قرمز )Red(، س��بز )Green( و آبي )Blue( تشکيل شده 

است و رنگ‌ها در اين مدل از ترکيب اين سه رنگ حاصل مي‌شوند )شکل 7-1(. 
ب��راي ايجاد تصوير در تلويزيون، صفحه نمايش يا انتش��ار در صفحات وب از مدل رنگي 

RGB استفاده مي‌شود. در مدل RGB دانستن نکات زير ضروري است:

1- هر يک از رنگ‌ها با عددي بين 0 تا 255 نشان داده مي‌شوند.
2- رنگ سفيد در اين مدل به معناي آن است که هر سه رنگ اصلي به طور کامل با هم 

ترکيب شده‌اند.
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FreeHand در RGB شكل 1-7 مدل رنگ

3- رنگ سياه در RGB عدم وجود نور براي چشم انسان است، يعني اين که هر سه مؤلفه 
رنگ صفر باشند.

4- رنگ‌هاي از نوع RGB رنگ‌هاي افزايشي هستند؛ چرا که اگر سه رنگ اصلي همزمان 
با هم جمع شوند و به نقطه‌اي بتابند، رنگ سفيد را نتيجه مي‌دهند.

RGB شكل 2-7 نمايش مدل رنگ

 CMYK مدل
اين مدل رنگ بر اس��اس جوهرهاي چاپ که روي کاغذ س��فيد جذب مي‌ش��وند، ساخته 
مي‌ش��ود؛ به عبارت ديگر بازگش��ت رنگ به سوي چشم اس��ت که تصوير را مي‌سازد )شکل 

.)7-2
رنگ‌ها در مدل CMYK از ترکيب چهار رنگ انعکاسي ساخته مي‌شود که عبارتند از:

آبي فيروزه‌اي )Cyan(، ارغواني )Magenta(، زرد )Yellow( و سياه )BlacK(. رنگ سفيد در 
اين مدل يعني اين که هر چهار رنگ مقدارش صفر باشد و نور را منعکس کند.
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FreeHand در  CMYKشكل 3-7 نمايش مدل رنگ

 توجه: در مدل CMYK تمامي رنگ‌ها از تركيب چهار رنگ اصلي ساخته مي‌شوند 
)شکل 7-4(.

CMYK شكل 4-7 نمايش مدل رنگ

در مدل CMYK بايد به نکات زير توجه داشته باشيد: 
1- م��دل CMYK در صفحه نمايش هرگز به صورت صحيح ديده نمي‌ش��ود، زيرا صفحه 
نمايش منبع توليد رنگ RGB اس��ت و تصاوي��ر و رنگ‌هايي كه در FreeHand براي چاپ در 
نظر گرفته مي‌ش��وند؛ بايد در مدل CMYK پردازش ش��وند تا با جوهرهاي چاپ س��ازگاري 

داشته باشند.
2- به رنگ‌هاي از نوع CMYK رنگ‌هاي کاهش��ي نيز مي‌گويند که از ترکيب کامل همه 
آن‌ها با يکديگر رنگ س��ياه ساخته مي‌ش��ود و اگر تمام رنگ‌ها از هم کم شوند سطح سفيد 

کاغذ نمايان مي‌شود و نور را منعکس مي‌سازد.
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	HLS مدل
م��دل HLS يک��ي از انواع سيس��تم رنگ RGB اس��ت. اين مدل رنگ ش��امل نوع و مايه 
 رن��گ )Hue(، مي��زان روش��نايي )Lightness( و اش��باع يا غلظت رنگي )Saturation( اس��ت

)شکل 7-5(.

FreeHand MX در HLS شکل 5-7 نمايش مدل رنگ

در اينجا Hue، رنگ پايه را بر اس��اس چرخه رنگ مش��خص مي‌کند و مقدار آن بر اساس 
 L .درجه و عددي بين صفر تا 360 اس��ت که مش��خص کننده رنگ روي چرخه رنگ اس��ت
معرف درصد نور و روش��ني رنگ اس��ت که 0% معرف رنگ سياه و 100% نشانه رنگ سفيد 

است.
S ميزان خلوص رنگ است، رنگ‌هاي خالص رنگ‌هايي هستند که هيچ مقدار خاکستري 
ندارند و غلظت آن‌ها 100% اس��ت. هرچه به مرکز چرخه رنگ نزديک ش��ويم درصد غلظت 

رنگ کاهش مي‌يابد. 
تمرين 1:  بررسي کنيد، به چه دليل مدل رنگ CMYK براي صفحه‌ها و سندهاي 

وب مناسب نيست؟  

تمرين 2: مدل System Color Picker را بررسي کنيد.

2-7 پنل‌هاي رنگ 
FreeHand ابزارهاي��ي را ب��راي رنگ‌آمي��زي به ص��ورت پنل در نظر گرفته اس��ت. براي 

رنگ‌آميزي مسيرهاي بسته معمولاً از پنل  Color Mixer و  Swatches استفاده مي‌شود.
اين دو پنل به روش‌هاي زير در صفحه نمايش ظاهر مي‌شوند:

Window 1- انتخاب پنل‌ها از منوي



Free Hand پیمانه مهارتی : کاربر
161واحد کار هفتم: توانایی کار با رنگ و ویرایش آن 

2- کلي��ک روي آيکن  براي باز کردن پن��ل Color Mixer و کليک روي آيکن  
Main از نوار ابزار اصلي يا  Swatches براي باز کردن پنل

3- کليد ميانبر Shift+F9 پنل Color Mixer و Ctrl+F9 پنل Swatches را در دسترس قرار 
مي‌دهد.

 Color Mixer 1-2-7 ايجاد رنگ با پنل

اين پنل كه با عنوان Mixer ديده مي‌شود براي ساختن رنگ‌هاي ترکيبي مورد نياز به‌کار 
مي‌‌رود. 

Color Mixer شکل 6-7 پنل

در پايين پنل، رنگ ايجاد ش��ده و اصلي مطابق شکل 6-7 قابل مشاهده است، در سمت 
چپ اين پنل مي‌توانيد از چهار حالت مختلف براي ميکس يا ترکيب کردن رنگ‌ها اس��تفاده 
کنيد که پيش از ش��روع به س��اختن رنگ‌ها لازم اس��ت؛ حالت )mode( رن��گ مورد نظر را 
تعيي��ن کنيد. اين حالت‌ها عبارتن��د از HLS ،RGB ،CMYK وColor  System )رنگ‌هاي آماده  

.)Windows

 Main را با استفاده از نوار ابزار  Color Mixerتمرين 3: نمايش و عدم نمايش پنل
در صفحه نشان دهيد.

CMYK کار با رنگ
همان‌طورکه گفته ش��د براي کارهاي چاپي از مدل CMYK استفاده مي‌شود، رنگ مورد 

نظر را مي‌توانيد هم به صورت عددي و هم با استفاده از دكمه لغزنده کنار آن ايجاد کنيد.
رنگ س��اخته ش��ده در نوار پايين پنجره قابل مش��اهده اس��ت. حال مي‌توانيد رنگ را از 

جوهردان، درگ کرده و روي موضوع مورد نظر قرار دهيد )شکل 7-7(.
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شکل 7-7 نحوه رنگ‌‌آميزي موضوع

RGB کار با رنگ
براي کارهاي نمايش��ي و اينترنتي از مدل رنگ RGB اس��تفاده مي‌کنند. نحوه استفاده از 

رنگ RGB مانند رنگ CMYK است.
 HLSکار با رنگ

همان‌طورکه قبلًا گفته ش��د، مدل HLS يکي از انواع سيس��تم رنگ RGB اس��ت و ميزان 
غلظ��ت و روش��نايي و مايه رنگ را از طري��ق دکمه لغزنده يا به ص��ورت درصدي با درج در 

کادرهاي عددي مشخص مي‌کند.
System Color Picker  کار با رنگ

اگر بخواهيد از رنگ‌هايي که براي سيستم عامل در نظـر گرفته شده استفاده کنيد،
System Color Picker امکان استفاده از 48 رنگ اصلي ويندوز را فراهم مي‌کند.

تمرين 4: با اس��تفاده از پنل Color Mixer، رنگي با مدل RGB بسازيد که درصد 
رنگ آن مطابق شکل 8-7 باشد. 

شکل 7-8

Swatches 2-2-7 اضافه کردن رنگ به پنل

در پايي��ن پنل Mixer، دکم��ه Add to swatches قرار دارد که با کليک روي آن مي‌توانيد 
رنگ س��اخته ش��ده را به پنل Swatches اضافه کنيد يا روي رنگ ساخته شده کليک راست 
 Add to Swatches را انتخاب کنيد در اين صورت کادر محاوره Add to swatches کرده و گزينه
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مطابق شکل 9-7 ظاهر مي‌شود.
در کادر محاوره Add to Swatches شماره‌هاي رنگ انتخابي و نمونه رنگ آن نمايش داده 

مي‌شوند که مي‌توانيد شماره را پاک کرده و نامي براي اين رنگ انتخاب کنيد.

Add to Swatches شکل 9-7 کادرمحاوره

هم چنين نوع رنگ را مي‌توانيد از بين دو گزينه Process )رنگ‌هاي پردازشي يا ترکيبي( 
 Swatches رنگ موردنظر به پنل ، Add تک رنگ( انتخاب کنيد و با کليک روي دکمه( Spot و

اضافه مي‌شود.

 توجه: مي‌توانيد رنگ ساخته شده را از روي نوار رنگي در پايين پنل Mixer درگ 
کرده و مستقيماً آن را به پنل Swatches اضافه کنيد.

• رنگ‌هايي هس��تند که با استفاده از رنگ‌هاي فيروزه‌اي، ارغواني،  	Process رنگ‌هاي
زرد و سياه ساخته مي‌شوند.

• رنگ‌هايي هستند که با استفاده از رنگ‌ها و جوهرهاي خاصي ساخته  	Spot رنگ‌هاي
مي‌ش��وند. براي روش��ن شدن مطلب مثلًا اگر به رنگ سبز يک مجله چاپ شده نگاه 
کنيد؛ متوجه خواهيد شد که آن رنگ، ترکيبي از رنگ‌هاي فيروزه‌اي و زرد است در 
صورتي که اگر اين رنگ س��بز به صورت نقطه‌اي )Spot( باشد فقط به وسيله جوهر 

خالص سبز ايجاد مي‌شود.
رنگ‌هاي Spot بيش��تر در کاره��اي تک‌رنگ، دورنگ و ايجاد رنگ‌ه��اي ويژه نظير رنگ 

مهتابي و متاليک استفاده مي‌شود. 
تمرين 5: رنگ ايجاد ش��ده در تمرين 4 را ب��ا در نظر گرفتن آن به صورت رنگ 

پردازشی به ليست رنگ‌هاي پنل Swatches اضافه کنيد.
)Change Attribute Color( 3-7 تغيير خصوصيت رنگ‌ها

اگر خصوصيات رنگ‌هايي که در رنگ‌آميزي موضوعات از آن استفاده کرده‌ايد، تغيير داده 
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ش��ود؛ اين تغييرات در رنگ موضوعات هم اثر خواهد گذاش��ت. در پنل Color Mixer دکمه
Change Attribute Color اي��ن امکان را فراهم مي‌کند که بتوانيد خصوصيت رنگ‌ها را تغيير 

بدهيد )شکل 7-10(.	

Color Mixer در پنل Change Attribute Color شکل 10-7 دکمه

 مثال 1: خصوصيت رنگ شکل 11-7 را با استفاده از پنل Color Mixer به رنگي 
که ايجاد کرده‌ايد، تغيير دهيد.

 Color Mixer در پنل  C :34 و M :27 ، Y :0 ، K :0 و مش��خصات CMYK 1- رنگي با مدل
ايجاد کنيد.

2- شکل 11-7 را رسم کنيد.

 شکل 7-11

3- ش��کل را ب��ا رنگ م��دل RGB که مش��خصات آن G:200 ، B:255 و R:255 اس��ت، 
رنگ‌آميزي کنيد.

4- روي دکم��ه  Change Attribute Colorکلي��ک کنيد تا خصوصيت رنگ RGB به رنگ 
CMYK  تبديل شود.

تمرين 6: چرخه رنگ را با مد CMYK ايجاد كنيد )با طراحي دلخواه(.
 )Tints( 4-7 ايجاد تناليته‌هاي رنگ

 Window→Tints واقع ش��ده که مي‌ت��وان آن را از طريق Mixer اي��ن پنل در کنار پنل
روي صفح��ه ظاه��ر کرد. اين پنل، تناليته يا ته رنگ‌هايي با درصدهاي 10% تا 90% از رنگ 
اصل��ي را ارائ��ه مي‌دهد و امکان انتخاب و افزودن آن‌ها را به پنل Swatches براي کاربر فراهم 
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مي‌سازد )شکل 7-12(.

Tints شکل 12-7 پنل
ب��ه عن��وان مثال فرض کنيد ي��ک رنگ نارنجي ب��ا ترکيب 45% ارغوان��ي و 100% زرد 
ساخته‌ايد اما مي‌خواهيد اين رنگ را با نسبت‌هاي‌کمتري از آن در صفحه امتحان کنيد. اين 
امر در پنل Color Mixer مستلزم صرف وقت زيادي است، درحالي که در پنل Tints مي‌توانيد 

نسبت‌هاي متفاوتي از يک رنگ را در صفحه امتحان و رنگ دلخواه را انتخاب کنيد.
1-4-7 روش ايجاد ته‌رنگ )تناليته( يک رنگ 

1- رنگ دلخواهي را در Color Mixer ايجاد کنيد.
2- در پنل Tints درصد ته‌رنگ را با يکي از روش‌هاي زير انتخاب کنيد:

• تنظيم درصد رنگ با استفاده از دکمه لغزنده ته‌رنگ	
• تايپ درصد مورد نظر در کادر ته‌رنگ 	
• کليک روي يکي از نمونه‌هاي ته‌رنگ 	

3- پ��س از ايجاد ته‌رنگ‌ها مي‌توانيد آن‌ها را در پن��ل Swatches ذخيره کنيد. مي‌توانيد 
از طريق دکمه Add to Swatches در پنل Tints يا از طريق منوي بازش��وي رنگ‌ها و انتخاب 

گزينه Add to Swatches رنگ را به پنل Swatches اضافه کنيد.

 توج�ه: هنگامي ک��ه رنگي را به پنل Swatches مي‌افزاييد ي��ا به عبارتي آن را به 
مجموعه رنگ‌هاي FreeHand اضافه مي‌کنيد؛ اين رنگ در منوي رنگ‌ها در پنل Tints قابل 

دسترسي است.

 G:152 ،B:189 از رنگي با مشخصات Color1 مثال 2: ته رنگ 40 درصدي به نام
و R:243 ساخته و ذخيره کنيد.
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براي ايجاد اين رنگ مراحل زير را انجام دهيد:
1- ابتدا پنل Color Mixer را باز کرده و دکمه RGB را انتخاب کنيد.

2- عددهاي رنگ را در کادرهاي مربوطه وارد کنيد.
3- زبان��ه Tints رابرگزيده و 40% را درکادرته‌رنگ واردکني��د يا روي‌نمونه40% ته‌رنگ، 

کليک کنيد.
4- روي دکمه  Add to Swatches در پنل Tints کليک کنيد.

5- در کادر مح��اوره  Add to Swatches ش��ماره رنگ را پاک ک��رده و نام Color1 را وارد 
کنيد؛ س��پس دکم��ه Add را کليک کنيد. در اي��ن صورت رنگ در پن��ل Swatches ذخيره 

مي‌شود.
تمرين 7: عمليات زير را انجام دهيد:

 Color رسم کرده و با استفاده از پنل paint1 به نام ،A4 1- شکل 14-7 را در يک صفحه
Mixer و Tints رنگ‌آميزي کنيد.

2- رنگي با مشخصات M : 70 ،Y : 80 ،K : 0 و C : 2 ايجاد کنيد، سپس آن را به ليست 
رنگ‌ها اضافه کنيد.

3- رنگي با مش��خصات G :200 ، ‌B : 8 و R : 16 ايجاد کنيد، س��پس ته‌رنگ‌هايي از اين 
رنگ با درصدهاي 80، 60 و 10 ايجاد کنيد و به ليست رنگ‌ها بيفزاييد.

4- رنگي با مش��خصات G: 90 ،B: 50 و R: 155 تعريف کنيد، س��پس غلظت آن را %80 
و روشنايي آن را نيز به 75% تغيير دهيد.

شکل 7-13

تمرين 8: طيف رنگ يا تناليته‌‌هاي مختلف رنگ آبي را ترسيم كنيد.

شکل 14-7 تناليته‌هاي رنگ آبي
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 Swatches 5-7 پنل
 Swatches پنل ،FreeHand MXa يکي از پرکاربردترين پنل‌ها، براي رنگ‌آميزي اشکال در

است )شکل 7-15(. 

Swatches شکل 15-7 پنل

پس از تعريف يک رنگ در Color Mixer براي استفاده مجدد آن در رنگ‌آميزي طرح‌هاي 
ديگر، بايد آن را درSwatches  ذخيره کرد.

از طريق يکي از روش‌هاي ذکر شده در بخش 2-7، پنلSwatches  باز مي‌شود. 
در اين پنل فهرس��تي از رنگ‌هاي س��اخته ش��ده و رنگ‌هاي مورد استفاده در سند، قرار 
گرفته است. يکي از رنگ‌هاي پيش‌فرض در پنل Swatches رنگ Registration ناميده مي‌شود. 
اين رنگ طوري تعريف ش��ده اس��ت که در تمام صفحات، چاپ خواهد ش��د و براي يک کار 
هنري معمولي نبايد از اين رنگ اس��تفاده ش��ود زيرا در چاپ، جوهر زيادي مصرف مي‌کند. 
معمولاً رنگ Registration به صورت سياه نشان داده مي‌شود ولي مي‌توانيد رنگ آن را تغيير 

دهيد. يکي از کاربردهاي اين رنگ، علامت‌گذاري براي برش زدن )Trim( صفحات است.

 توج�ه: براي تغيير رنگ موضوعات و ني��ز رنگ‌آميزي موضوعات جديد مي‌توانيد 
بدون س��اختن دوباره آن‌ها در Color Mixer از نمونه‌هاي موجود در پنل Swatches اس��تفاده 

کنيد.

 Swatches 1-5-7 رنگ‌آميزي به وسيله پنل

1- شکل مورد نظر را ترسيم کرده و آن را به حالت انتخاب در‌آوريد.
2- پنل Swatches را باز کنيد.

3- از رنگ‌هاي ليست شده در اين پنل )Color List(، رنگ موردنظرتان را انتخاب کرده و 
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آن را به روي شکل درگ کنيد يا رنگ را درگ کرده و روي دکمه نشان داده شده در شکل 
15-7 رها کنيد تا داخل موضوع رنگ‌آميزي شود.

 نكته:ب��ا نگ��ه داش��تن کلي��د Alt و کلي��ک روي رن��گ م��ورد نظر در ليس��ت 
 رن��گ پن��ل Swatches جزيي��ات رن��گ به ص��ورت CMYK ي��ا RGB نمايش داده مي‌ش��ود 

)شکل 7-16(.

Swatches شکل 16-7 نمايش جزييات رنگ در پنل

تمرين 9: رنگي با مشخصــات G : 195 ،B : 140 و R : 243 با استفـاده از پنـل 
Color Mixer  ايجاد کرده، سپس آن را به نام Color2 به ليست رنگ‌هاي Swatches اضافه 

کنيد، ترتيبي دهيد که جزييات رنگ نمايش داده شود.
2-5-7 اعمال رنگ )خط - پرکننده( به موضوع 

عملکرد دکمه‌هاي بالاي پنل Swatches به شرح زير است:
• اين گزينه براي رنگ‌آمي��زي داخل موضوع به‌کار مي‌رود که روش  	:  Fill دکم�ه

ديگر استفاده از آن به صورت زير است: 
1- ابتدا موضوع را انتخاب کنيد سپس روي دكمه Fill كليك كنيد.

2- روي يکي از نمونه رنگ‌هاي موجود در ليست Swatches کليک کنيد تا رنگ انتخاب 
ش��ده، داخل شکل قرار گيرد. انتخاب گزينه None از ليست رنگ‌هاي Swatches، رنگ داخل 

شکل را خالي مي‌کند.
آميزي خطوط دور موضوع اس��تفاده  • دکم�ه Stroke  : از اي��ن گزينه ب��راي رنگ‌	
مي‌ش��ود و روش‌هاي اس��تفاده از آن مانند دکمه Fill است. انتخاب گزينه None از 
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ليست رنگ‌ها، خط دور موضوع را محو مي‌کند.
• را به داخل  	Swatches رنگ انتخاب ش��ده از ليس��ت پنل :   Fill & Stroke دکمه
مسير انتخاب شده و هم به خط دور موضوع مي‌دهد. انتخاب گزينه None از ليست 

رنگ‌ها منجر به‌محوکامل موضوع‌مي‌شود اما مسير هم‌چنان قابل انتخاب است. 
 • 	 Swatchesدکمه تکثير رنگ  : براي کپي از يک رنگ کافي اس��ت، رنگ را از پنل

به سمت اين دکمه درگ کنيد.
تمرين 10: ش��کل‌هاي 17-7 و 18-7 را رس��م کرده و رنگ‌هاي داده ش��ده را با 
استفاده از پنل Color Mixer ايجاد کرده و به وسيله پنل Swatches به خط دور شِکل 7-17 
رنگ 1، به داخل شکل 17-7 رنگ 2 و به دور و داخل شکل 18-7 رنگ 3 را اعمال کنيد. 

رنگ 1: مدل RGB، رنگ سفيد
 RGBرنگ2: مدل

CMYK رنگ3: مدل

              
CMYK شکل 18-7  مدل                                   RGB شکل 17-7  مدل          

3-5-7 ايجاد، حذف، جابه‌جايی و کپی کردن رنگ

با استفاده از فرمان‌هاي منوي کنترل در پنل Swatches مي‌توانيد رنگ جديدي به ليست 
اضاف��ه کرده و از رنگ‌هاي موجود نس��خه کپي تهيه کرده، رنگ را از ليس��ت حذف يا رنگ 
ديگ��ري را جايگزي��ن آن کنيد. با کليک روي منوي کنت��رل  در پنل Swatches، منويي 
ظاهر مي‌ش��ود که حاوي تعدادي فرمان و يك س��ري مجموعه رنگ )آلبوم رنگ( است، اين 

فرمان‌ها عبارتند از:
کند. • New: رنگ ساخته شده در پنل Color Mixer را به پنل Swatches اضافه مي‌	

• به کار  	Swatches ب��راي تهيه کپي و تکثير رنگ انتخاب ش��ده در پن��ل :Duplicate

مي‌رود.
• Remove: انتخاب اين گزينه باعث حذف رنگ انتخابي از پنل Swatches مي‌شود.	

• اين گزينه، رنگ انتخاب ش��ده را جايگزين يکي از نمونه رنگ‌هاي موجود  	:Replace
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در ليست رنگ‌‌هاي Swatches مي‌کند.
روش اجراي جايگزيني رنگ 

1- از ليست پنل Swatches ، رنگي را که مي‌خواهيد جايگزين کنيد، برگزينيد.
2- از من��وي کنترل��ي پنل Swatches گزين��ه Replace را انتخاب کنيد ت��ا کادر محاوره

Replace Color  باز شود.

3- از منوي بازش��وي Color  library )کتابخانه رنگ( يک مجموعه رنگ را انتخاب کرده 
و از داخ��ل آن رنگ مورد نظر را برگزينيد يا از منوي بازش��وي Color List رنگ مورد نظر را 

انتخاب کنيد تا عمل جايگزيني انجام گيرد.
4-5-7 پنهان و آشکار کردن نام رنگ

 Show/Hide گزينه ،Swatches براي آشکار و مخفي کردن نام رنگ‌ها در ليست رنگ‌هاي
names که از طريق منوي کنترل آن قابل دسترس است به‌کار مي‌رود )شکل 7-19(.

Swatches شکل 19-7 پنهان کردن نام رنگ در پنل

تغييرنام رنگ 
براي تغيير نام نمونه رنگ انتخاب شده در پنل Swatches، روي نام رنگ دابل کليک کنيد 

تا علامت چشمک‌زن مکان‌نما ظاهر شود و نام جديد را تايپ کنيد.
تمرين 11: ش��کل 20-7 را رسم کرده آن را با رنگ سفيد مدل RGB رنگ‌آميزي 
کني��د و ترتيب��ي دهيد که رنگ G:152 ،B :189 و R:243 که ب��ا نام color1 در مثال 2 ايجاد 

کرده‌ايد، جايگزين آن شود و نام رنگ را تغيير داده و Color3  بگذاريد.

شکل 7-20
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5-5-7 تبديل رنگ‌هاي CMYK و RGB به يکديگر	

 Make RGB و Make CMYK و بالعکس فرمان‌ه��اي RGB به CMYK ب��راي تبدي��ل رنگ
به‌کار مي‌روند که در منوي کنترلي پنل Swatches قرار دارند.

• Make CMYK: براي تبديل رنگ‌هايRGB  به رنگ‌هاي CMYK به‌کار مي‌رود.	

• به‌کار مي‌رود که به‌صورت  	RGB به  CMYKبه‌منظور تبدي��ل رنگ‌هاي :Make RGB

 ديده مي‌شود.
 CMYK را ک��ه در تمرين 11 ايجاد کرده‌اي��د به مدل Color3 تمري�ن 12: رنگ

تبديل کرده و نام آن را Color4 بگذاريد.
	Process و Spot 6-5-7 ايجاد رنگ‌هاي

 Add و دکمه Color Mixer همان‌طور که در بخش 1-2-7 گفته ش��د با اس��تفاده از پنل
 Swatches مي‌توانيد رنگ پردازش��ي و نقطه‌اي بس��ازيد. در منوي کنترلي پنل to swatches

فرمان‌هاي تبديل رنگ پردازشي و نقطه‌اي قراردارد که عبارتند از:
• را به رنگ  	 Swatchesانتخاب ش��ده در پن��ل )Process( رنگ پردازش��ي :Make spot

نقطه‌اي )Spot( تبديل مي‌کند.
• را  	Swatches انتخاب اين گزينه، رنگ نقطه‌اي انتخاب ش��ده در پنل :Make process

به رنگ پردازشي تبديل مي‌کند.

 نكته: رنگ‌هايي که با اس��تفاده از RGB يا HLS تعريف شده‌اند، يک آيکن سه 
رنگ کوچک  در سمت راست نام آن‌ها قرار دارد )شکل 7-21(. 

شكل 7-21

در ش��کل 21-7 از بالا به پايين: رنگ پردازش��ي CMYK، رن��گ نقطه‌اي CMYK، رنگ 
.RGB رنگ نقطه‌اي  ،RGB پردازشي

 توجه: اس��امي رنگ‌هاي پردازش��ي در پنل Swatches  به صورت ايتاليک مشاهده 
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مي‌شوند و رنگ‌هاي Spot  به صورت معمولي نشان داده مي‌شوند.

تمرين 13: رنگ Color4 را که در تمرين ايجاد کرده‌ايد، به رنگ نقطه‌اي تبديل 
کنيد.

6-7 آشنايي با انواع پالت‌هاي رنگ 

در برنام��ه FreeHand ب��راي رنگ‌آمي��زي موضوعات، علاوه بر پالت رنگ سيس��تم عامل 
Windows، پالت‌ه��اي متعددي وجود دارد مانن��د Web Safe 216 که 216 رنگ در مجموعه 

رنگ آن وجود دارد و در مجموعه رنگ‌هاي کتابخانه رنگ با نام Web Safe Color قراردارد؛ نام 
تعدادي از پالت‌ها که در زمان صادر کردن تصوير با فرمت Gif تنظيمات آن قابل دسترس��ي 

است، در ادامه نشان داده شده است.
WebSafe 216 -2 			  Exact Palette -1       

Color 64 -4	WebSnap Adaptive 256, 128, 16 -3       
Color 16 -6 			  Color 32 -5       

Grays -7       
• را  	Swatches امکان اضافه کردن بيش از يک پالت به پنل ،Wizard بعضي تنظيمات

فراهم مي‌کند.
Library 7-7 استفاده از جدول رنگ‌هاي فتوشاپ و رنگ‌هاي

FreeHand MXa به‌‌طور پيش‌فرض داراي مجموعه رنگ‌هاي )Library Color( متعددي از 

جمله رنگ‌هاي آماده  PANTONE است که مي‌توانيد رنگ مورد نظر را انتخاب کرده و آن را 
به رنگ‌هاي Swatches اضافه کنيد. اين رنگ‌ها از نوع Coated و UnCoated اس��ت. به عبارت 
ديگر اين گونه رنگ‌هاي آماده و استاندارد، مخصوص چاپ روي کاغذهاي بدون پوشش براق 

)UnCoated( يا پوشش‌دار براق )Coated( است.

 توجه:ب��راي انتخاب چند رنگ از مجموعه رنگي ي��ا آلبوم رنگ مي‌توانيد با کليد 
Shift رنگ‌هاي متوالي و کليد Ctrl رنگ‌هاي مجزا از هم را انتخاب کنيد )شکل 7-22(.
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شکل Library 7-22 يا مجموعه رنگ

اگر بخواهيد از جدول رنگ فتوشاپ استفاده کنيد، به طريق زير عمل کنيد:
1- مسير Xtras→Colors→Import RGB Color Table را اجرا کنيد.

2- در کادر محاوره Open فايل ACT فتوش��اپ )جدول رنگ مورد نظر( را مشخص کرده 
و رنگ‌هاي آن را به پنل Swatches وارد کنيد.

 توجه:دربعضي‌از نسخه‌هاي‌فتوش��اپ محل ذخيره‌س��ازي جدول رنگ در پوش��ه 
Presets\Optimized Colors يا Presets\Save for Web Settings  است.

توانيد  • با فرمان Import RGB Color Table علاوه بر استفاده از جدول رنگ فتوشاپ مي‌	
يك مجموعه رنگ ذخيره شده پوشه Palettes واقع در برنامه FreeHand را به ليست 

رنگ‌‌هاي موجود در پنل Swatches اضافه کنيد. 

 نكته: پسوند فايل‌هاي جدول رنگ فتوشاپ Act است.

1-7-7 اضافه کردن و صادر کردن رنگ 

ازديگرفرمان‌ه��اي منوي کنترل در پنل Swatches، فرمان Import وExport اس��ت که به 
شرح زير هستند:

 • Import: به منظور فراخواني ليس��ت ذخيره ش��ده در پنل Swatches به‌کار مي‌رود،	

همچنين با اس��تفاده از اين فرم��ان مي‌توان رنگ‌هاي آم��اده )مجموعه رنگ( مثل 
رنگ‌هاي PANTONE  را به پنل Swatches اضافه کرد.
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• اگ��ر بخواهيد دقيقاً رنگ‌هايي را که در طراحي اس��تفاده کرده‌ايد و به پنل  	:Export

Swatches افزوديد در سند ديگري نيز استفاده کنيد، مي‌توانيد ليست رنگ را با اين 

فرمان ذخيره کرده و با فرمان Import آن‌ها را بازيابي کنيد. به عبارت ديگر با فرمان 
Export مي‌تواني��د يک آلبوم رنگ يا کتابخانه‌اي از رنگ‌هاي سفارش��ي ايجاد کنيد 

)شكل 7-23(.

شکل 23-7 کادر ساختن آلبومي از رنگ‌ها

تمري�ن 14: آلبوم رنگي ب��ا نام Class-Color و نام فايل دلخ��واه ايجاد كنيد كه 
حاوي 2 رنگ س��بز و صورتي از نوع RGB و  3 رنگ آبي و زرد و بنفش از نوع CMYK و يك 

رنگ نارنجي از نوع رنگ‌هاي آماده ويندوز باشد.
 Swatches8-7 مديريت ليست رنگ‌ها در پنل

در برنامه FreeHand مي‌توانيد به صورت زير، مديريت رنگ‌ها را انجام دهيد:
•مرتب کردن رنگ‌ها بر اساس نام آن‌ها 	

•پنهان و آشکار کردن نام رنگ 	
•حذف رنگ‌هايي که در طرح آماده چاپ استفاده نمي‌شود. 	

بعضي از اين کارها در بخش 2-7 گفته شده است، در ادامه به نحوه مرتب‌سازي رنگ‌ها 
بر اساس نام و حذف رنگ‌هايي که در طرح آماده چاپ استفاده نمي‌شود، مي‌پردازيم.

Sort Color List By Name فرمان
براي اجراي فرمان به طريق زير عمل مي‌شود:

• را اجرا کنيد. 	Xtras→Colors→Sort Color List by Name مسير
با استفاده از اين فرمان رنگ‌هاي پنل Swatches برحسب نام مرتب مي‌شوند. 

Unused Named Colors  فرمان
براي اجراي فرمان به طريق زير عمل مي‌شود:
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1- بررسی کنيد موضوعي در وضعيت انتخاب نباشد.
2- رنگ يا رنگ‌هاي مورد نظر را انتخاب کنيد.

3- مسيرXtras→Delete→Unused Named Colors  را اجرا کنيد.
با استفاده از اين فرمان رنگ‌هاي پنل Swatches که در طرح ترسيم شده استفاده نشده‌اند، 

از فهرست رنگ‌ها حذف مي‌شوند.
  Stroke & Fill Color 7-9

هر شئ از يک خط دور )Stroke( و پرکننده درون شئ  )Fill( تشکيل شده است.
رنگ‌آميزي خط دور و درون موضوع ترسيمي

مي‌تواني��د  • 	 Swatches و Tint ،Color Mixer ب��ا اس��تفاده از درگ رن��گ از پنل‌ه��اي
پرکننده درون شئ )Fill( و خط دور )Stroke( موضوع‌هاي ترسيم شده را رنگ‌آميزي 

کنيد )شکل 7-24(.

 

Mixer و Tint ،Swatches شکل 24-7 رنگ‌آميزي موضوع ترسيمي با استفاده از پنل

( نيز امکان  • پن��ل Object و منوي بازش��وي پالت رنگ  در جعبه ابزار )شك��ل 7-25	
رنگ‌آميزي را فراهم مي‌کنند.

شکل 25-7 رنگ‌آميزي موضوع ترسيمي با استفاده از پالت رنگ در جعبه ابزار

در پن��ل Object )شك��ل 26-7( ب��راي رنگ‌آمي��زي داخ��ل و پيرامون ش��ئ ترس��يمي 
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مي‌توانيد:
1- روي دکمه Add Fill براي رنگ‌آميزي داخل موضوع ترس��يمي و دكمه Add Stroke براي 

رنگ پيرامون موضوع ترسيمي کليک کنيد.
2- گزينه Basic را برگزينيد، با کليک روي کادر رنگي پايين پنل Object، رنگ مورد نظر خود 

را انتخاب کنيد.

Object در پنل Fill شکل 26-7 گزينه‌هاي

 توجه: درگ ابزار قطره‌چکان و برداش��تن رنگ از يک ش��ئ به ش��ئ ديگر س��بب 
رنگ‌آميزي موضوعات ترسيمي مي‌شود.

 Color Mixer حرفه‌اي‌ترين روش رنگ‌آميزي به اين صورت است که رنگ ساخته شده در
ي��ا Tints را به پنل Swatches اضافه کنيد، س��پس نمونه رن��گ موردنظر را از درون اين پنل 
به موضوع انتخاب ش��ده نسبت دهيد. اين روش به شما اجازه مي‌دهد که هميشه بر رنگ‌ها 
کنترل داشته باشيد و هرگونه تغيير در خصوصيات رنگ‌ها منجر به ايجاد همان تغييرات در 

رنگ‌هاي موضوعات خواهد شد.

تمرين 15: پرچم ايران را ترسيم و رنگ‌آميزي كنيد.

تمرين 16: 
1- طرح يك منظره ساده را رسم كرده و رنگ‌آميزي نماييد.
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2- رنگ‌هاي سبز را با استفاده از فرمان Replace به رنگ زرد تغيير دهيد.
10-7 اصول ويرايش رنگ

در برنام��ه FreeHand مي‌توانيد رنگ‌هاي کار آماده چاپ را با روش‌هاي مختلف ويرايش 
کنيد. روشن و تيره کردن رنگ‌ها، اضافه و کم کردن درصد ميزان رنگ، ايجاد جلوه خاکستري 
و تک رنگ، تبديل رنگ‌ها به طيف خاکستري و تغيير رنگ‌ها در طرح و اثر آماده چاپ شما 

از موارد ويرايش رنگ است.
1-10-7 کنترل مقدار رنگ 

با استفاده ازColor Control  مقدار درصد رنگ‌ها در مدل‌هاي RGB،CMYK  و HLS کم يا 
زياد مي‌ش��ـود و نام اصـلي رنگي که تغييـر يافتـه در پنـل Swatches باقي مي‌مـاند. گزينـه

Color Control  براي کنترل دقيق رنگ‌ها به‌کار مي‌رود.

 نكت�ه: اگ��ر بخواهيد رنگ تغيير يافته ب��ا Color Control در پنل Swatches قرار 
گيرد، بايد براي آن نامي در نظر بگيريد.

Color Control شکل 27-7 تغيير رنگ شئ با استفاده از

Color Control روش استفاده از
براي استفاده از Color Control به ترتيب زير عمل کنيد:

1- شئ گرافيکی را انتخاب کنيد.
 Color Control را اجراکني��د تا كادرمحاوره Xtras→Colors→Color Control 2- مس��ير

باز شود.
3- يکي از مدل‌هاي رنگ CMYK ، RGB يا HLS را برگزينيد.
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4- براي مشاهده تغييراتي که در رنگ ايجاد مي‌کنيد؛ Preview را انتخاب کنيد.
5- ب��راي تغييرميزان‌رنگ، دكمه ‌لغزنده مربوط ‌به آن را درگ کرده يا عددهاي ‌موردنظر 

را وارد کنيد.
6- براي اعمال تغييرات روي OK کليک کنيد.

- است. • محدوده مورد نظر براي مدل‌هاي رنگ بين 100%+ تا %100	
- است. • ميزان Hue: از360%+ تا %360	

• اس��ت که نشان دهنده عدم  پيش‌فرض موارد تش��کيل‌دهنده مدل‌هاي رنگ عدد 0	
تغيير در رنگ است.

             	

CMYK شكل 29-7 تنظيم رنگ در حالت 		                  شکل 28-7 انتخاب شكل

س��ه حالت رنگ در كادر محاوره Color Control وج��ود دارد كه مي‌توانيد از آن‌ها براي 
تنظيم رنگ‌ها استفاده كنيد )شكل 7-29(.

 نكت�ه: مي‌تواني��د رنگ را در يك حالت تعري��ف و در حالت ديگري آن را تنظيم 
كنيد.

با توجه به اين که رنگ‌هاي قرمز، سبز و آبي از سيستم RGB و آبي Cyan، ارغواني، زرد 
و س��ياه از سيس��تم CMYK دوبه‌دو مکمل يکديگر هستند، براي کم يا زياد کردن يک رنگ 
مي‌ت��وان رن��گ مکمل آن را کم يا زياد کرد. به طور مثال ب��راي کم کردن رنگ آبي در يک 
شکل مي‌توان به مقدار رنگ زرد که رنگ مکمل آن در چرخه رنگ است، اضافه کرد يا براي 
زياد کردن رنگ س��بز در تصوير مي‌توان از ميزان رنگ ارغواني که مکمل آن اس��ت کم کرد. 

اعداد مثبت به مقدار رنگ اضافه ميك‌ند و اعداد منفي رنگ را كاهش مي‌دهد.
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مثال 3: شكل 30-7 را رسم كرده و آن را به دلخواه رنگ كنيد.

شكل 7-30

1- ميزان اشباع رنگ را كم كرده و روشنايي شكل را افزايش دهيد. 
2- براي  اين كار  بايد  فرمانXtras→Colors→ Color Control  را اجرا كنيد. در كادرمحاوره 
Color Control زبانه HLS را انتخاب كرده س��پس با تنظيم دکمه لغزنده مربوط به S ميزان 

 اش��باع رنگ را ��كم و با تنظيم دکمه لغزنده مربوط به L روش��نايي شك��ل را افزايش دهيد‌ 
)شكل 7-31(.

HLS شكل 31-7 تنظيم رنگ در حالت

تمرين 17: شك��ل 32-7 را رس��م كرده و آن را رنگ‌آميزي كنيد؛ با استفاده از 
Color Control رنگ آن را تغيير دهيد.
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شكل 7-32

2-10-7 تبديل رنگ شئ به خاکستري 

براي تبديل رنگ موضوعات به خاكستري از فرمان: 
Xtras→Colors→Convert to Grayscale استفاده كنيد.

روش تبديل رنگ به خاكستري
1- موضوع يا موضوعات مورد نظر را انتخاب كنيد.

2- مس��ير Xtras→Colors→Convert  to Grayscale را اجرا كنيد. رنگ شكل خاكستري 
مي‌شود.

    	  	        

Grayscale شكل 34-7 نتيجه حاصل از تأثير فرمان     	شكل 33-7 انتخاب موضوع گرافيكي

 تمرين 18: شك��ل 34-7 را رس��م و به دلخواه رنگ‌آميزي كنيد، سپس رنگ آن 
‌را خاکستري کنيد.

شكل 7-35
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3-10-7 تيره و روشن کردن رنگ 

با استفاده از گزينه Colors در منوي Xtras مي‌توانيد مقدار رنگ را با هر بار اعمال فرمان، 
يک درجه تيره يا روشن کنيد. 

 نكت�ه: م��وارد Saturate، Darken، Lighten وDesaturate به رنگ‌هاي spot اعمال 
نمي‌شود.

روش اجرا:
1- ابتدا شئ را انتخاب کنيد.

2- مس��ير Xtras→Colors را انتخاب ک��رده و يکي از موارد زير را با توجه به تغييری که 
مي‌خواهيد در رنگ ايجاد کنيد، برگزينيد.

Lighten Colors: رنگ شئ انتخابي را يك درجه روشن‌تر مي‌کند.

Darken Colors: به رنگ سياه شئ، اضافه كرده و آن را تيره‌تر مي‌کند.

Saturate Colors: ميزان غلظت رنگ )اشباع رنگ( را افزايش مي‌دهد.

Desaturate Colors: رنگ را تيره و كدر كرده و اشباع آن را کم مي‌کند.

 نكت�ه: م��وارد گفته ش��ده تا زماني اعمال مي‌ش��ود که رنگ، ب��ه بالاترين ميزان 
تأثيرش برسد.

Lighten Colors مثال 4: فرمان
1- موضوع گرافيكي مورد نظر را انتخاب كنيد.

2- فرمان Xtras→Colors→Lighten Colors را اجرا كنيد. با هر بار اجراي اين فرمان رنگ 
شكل يك درجه روشن‌تر مي‌شود.

Darken Colors مثال 5: فرمان
1- موضوع گرافيكي مورد نظر را انتخاب كنيد.
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2- فرمان Xtras→Colors→Darken Colors را اجرا كنيد. با هر بار اجراي اين فرمان رنگ 
شكل يك درجه تيره‌تر خواهد شد.

شكل 7-36

تمرين 19: شكل 37-7 را رسم و به دلخواه رنگ كنيد سپس شكل را دو درجه 
تيره‌تر كنيد.

شكل 7-37

Saturate Colors مثال 6: فرمان 
1- موضوع گرافيكي مورد نظر را انتخاب كنيد.

2- فرم��ان Xtras→Colors→Saturate Colors را اجرا كني��د. با هر بار اجراي اين فرمان 
غلظت رنگ شكل يك درجه بيشتر مي‌شود )شكل 7-37(.

              	                  

Saturate Colors شكل 38-7 انتخاب‌موضوع‌گرافيكي         شكل 39-7 نتيجه‌حاصل‌از‌تأثير‌فرمان

Desaturate Colors مثال 7: فرمان 
1- موضوع گرافيكي را كه مي‌خواهيد اشباع رنگ آن كم شود، انتخاب كنيد.

2- فرمانXtras→Colors→Desaturate Colors  را چند بار اجرا كنيد تا اشباع رنگ شكل، 
كم‌تر شود.
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شكل 40-7 انتخاب موضوع گرافيكي

 نكته: براي ادامه اشباع رنگ يا خارج کردن رنگ‌ها از حالت اشباع در صورت لزوم 
فرمان مزبور را چندبار تکرار کنيد.

 تمرين 20: 
1- رنگينك‌مان را اجرا كنيد.
2- درجه اشباع را كم كنيد.

3- تناليته‌هاي سه رنگ اصلي را تا 10 درجه بسازيد.
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		 واژه‌نامه
Convertتبديل كردن، معکوس کردن

Coatedپوشش براق

Cyanآبي فيروزه‌اي

Darkenتيره‌تر

Desaturateكم كردن اشباع رنگ

Exactدقيق

Grayscaleخاكستري

Magentaارغواني

Mixerمخلوط‌کن

Pickerانتخاب کننده

Presetsتنظيم شده، پيش تنظيمات

Randomizeاتفاقي، تصادفي

Xtrasاضافي

Swatchنمونه

Trimبرش زدن صفحات

خلاصه مطالب
• به ترتيب براي چاپ يا  	HLS و RGB ،CMYK س��ه مدل رن��گ FreeHand در برنامه
کارهاي نمايشي و وب در نظر گرفته شده‌اند. در مدل‌هاي رنگ امکان حذف، اضافه، 

تغيير نام و ويرايش رنگ‌ها وجود دارد.
•دانس��تيد که می توانید رنگ‌هاي کار آماده چاپ را با روش‌‌هاي‌مختلف به‌اين‌ش��رح  	
ويرايش کنيد: 1- روش��ن و تيره ک��ردن رنگ‌ها 2- اضافه و کم کردن درصد ميزان 
رنگ 3- ايجاد جلوه خاکس��تري و تک رنگ 4- تبديل رنگ‌ها به طيف خاکس��تري 

5- تغيير رنگ‌ها در طرح و اثر آماده چاپ
•از ديگر موارد بررس��ي شده در اين واحد کار مديريت ليست رنگ مي‌باشد از جمله:  	
1- مرتب کردن رنگ‌ها بر اساس نامشان 2- پنهان و آشکار کردن نام رنگ 3- حذف 

رنگ‌هايي که در طرح آماده چاپ استفاده نمي‌شود. 
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- پنل Color Mixer براي ساختن رنگ‌هاي ترکيبي مورد نياز به کار مي‌رود. 
2- در مدل RGB، هر يک از رنگ‌ها با عددي بين 0 تا 100 نشان داده مي‌شوند.

3- پنل تناليته ته‌رنگ‌هايي با درصدهاي 10% تا 90% از رنگ اصلي ارائه مي‌دهد. 
4- رنگ‌هاي Spot رنگ‌هايي هس��تند که با اس��تفاده از رنگ‌هاي فيروزه‌اي، ارغواني، زرد 

و سياه ساخته مي‌شوند. 
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Replace   .به‌کارمي‌رود Swatches 5- براي تهيه کپي و تکثير رنگ انتخاب شده در پنل
                     Duplicate    .مي‌شود Swatches 6- انتخاب اين گزينه باعث حذف رنگ انتخابي از پنل
7- اين گزينه، رنگ انتخاب ش��ده را جايگزين يکي از نمونه رنگ‌هاي موجود در ليس��ت 
Remove                                                                  .مي‌کند Swatches رنگ‌هاي

گزينه صحيح را انتخاب کنيد.

8- اگ��ر بخواهي��د رنگ موضوع انتخاب ش��ده اش��باع‌تر ش��ود از كدام فرمان اس��تفاده 
ميك‌نيد؟

Saturate Colors -ب 	Desaturate Colors -الف
Lighten Colors -د 		 Darken Colors -ج

9- با استفاده از كدام فرمان مي‌توان رنگ موضوع انتخاب شده را تيره‌تر كرد؟
	 Darken Colors -ب 	 Convert to Grayscale -الف

 Desaturate Colors -د 	 	 Lighten Colors  -ج
10- کدام‌يک از گزينه‌هاي زير، از موارد ويرايش رنگ نيست؟

Color Control  -ب 	Desaturate Colors  -الف
Websafe 216  -د 		 Lighten Colors  -ج

11- کدام دکمه در پنل Swatches، رنگ انتخاب ش��ده از ليست پنل Swatches را هم به 
داخل مسير انتخاب شده و هم به خط دور موضوع مي‌دهد؟

الف-                  ب-                  ج-                     د-  
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 Swatches 12- با نگه داشتن کليد ......... و کليک روي رنگ موردنظر در ليست رنگ پنل
جزييات رنگ به صورت CMYK يا RGB نمايش داده مي‌شود. 

Alt+Shift -د               Ctrl -ج                Alt  -ب               Shift -الف
13- رنگ پايه، اشباع رنگ و ميزان روشنايي رنگ، در اين حالت رنگ تنظيم مي‌شود.

CMYK  و HLS  -د               HLS  -ج           RGB  -ب            CMYK  -الف
14-  براي آشکار و مخفي کردن نام رنگ‌ها در ليست ‌رنگ‌هاي Swatches، از اين گزينه‌ 

استفاده مي‌شود.
 Restore-ب                   Remove Color -الف

Show color -د 	  Show/Hide names  -ج

در جاي خالي عبارت مناسب را بنويسيد.

15- در مدل ........... تمامي رنگ‌ها از تركيب چهار رنگ اصلي ساخته مي‌شوند.
16- به رنگ‌هاي از نوع CMYK رنگ‌هاي .......... نيز مي‌گويند.

17- فرمان ....................... تمام رنگ‌هاي اس��تفاده ش��ده در س��ند را كه داراي هيچ نامي 
نيستند، به پنل Swatches اضافه كرده و به آن‌ها يك نام اختصاص مي‌دهد. 

18-  ميزان Hue ........ تا .......... است. 
19- رنگ‌ه��اي Spot بيش��تر در کاره��اي ................. و ................... و ايجاد رنگ‌هاي ويژه 

نظير رنگ مهتابي و متاليک استفاده مي‌شود.
 

به سؤالات زير پاسخ تشريحی دهيد.

20- چه مواقعي از گزينه Lighten Colors استفاده مي‌شود؟
21- رنگ‌هاي مکمل سيستم RGB و CMYK را نام ببريد.

22- کدام مدل رنگ بر اس��اس جوهرهاي چاپ که روي کاغذ س��فيد جذب مي‌ش��وند، 
ساخته مي‌شود؟

23- رنگ‌هاي Spot و Process چه تفاوتي با يكديگر دارند؟
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آزمون عملي
1- پوس��تري به مناسبت برپايي نمايشگاه كتاب طراحي كنيد كه شكل روبه‌رو به عنوان 

آرم اين پوستر باشد.

2- شكل زير را رسم و رنگ‌آميزي كنيد سپس رنگ‌هاي به‌کار رفته در تصوير را به پالت 
Swatches اضافه کنيد و فرمان Randomize Named Color را روي آن اجرا کنيد.

3- شکل‌هاي زير را رسم و با استفاده از پالت‌هاي رنگ آن‌ها را رنگ‌آميزي کنيد.

             

4- شکل‌هاي بعد را رسم کرده و رنگ‌هاي آن‌ها را به پالت Swatches اضافه کنيد، سپس 
نام رنگ‌هاي پالت را مرتب و درجه رنگ شکل‌ها را روشن‌تر کنيد.

       



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
188

5- كارت پستالي به صورت دو برگي و به مناسبت »روز مادر« با ابعاد دلخواه طراحي كنيد.
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كليات
نرم‌افزار FreeHand امکانات مختلفي را براي پرکردن اشکال و طرح‌ها در اختيار شما قرار 

مي‌دهد که اين پرکننده‌ها در جذاب‌تر شدن پروژه‌هاي هنري تأثير به‌سزايي دارند.
همان‌ط��ور ک��ه در واحد كار قبل گفته ش��د از گزين��ه Fill براي پر ک��ردن رنگ داخل 
موضوعات و مس��يرها اس��تفاده مي‌ش��ود. اما علاوه بر رنگ‌ها مي‌ت��وان از طرح‌ها و الگوهاي 
ديگري نيز براي پر کردن داخل موضوعات استفاده کرد. البته رنگ الگوها و طرح‌ها بر اساس 

رنگ انتخاب شده در پنل Swatches تعيين مي‌شود.
Object در پنل Add Fill 1-8 دکمه

در FreeHand MXa خ��واص Fill و Stroke در پن��ل Object ق��رار گرفته‌ان��د و به صورت 
مستقل ديده نمي‌شوند.

Fill زيرمجموعه‌اي از پنل Object اس��ت که با باز ش��دن پنل Object مطابق ش��کل 8-1 

.)Ctrl+F3 روي صفحه ظاهر مي‌شود )کليد ميانبر

Object در پنل Fill  شکل 1-8 گزينه‌هاي

در پنل Object روي دکمه‌اي که ش��بيه س��طل رنگ اس��ت، کليک کنيد تا گزينه‌هاي 
تنظيمي مربوط به رنگ‌هاي داخل موضوعات ظاهر شود.

در اين قسمت تعيين مي‌شود که موضوع موردنظر با يکي از رنگ‌هاي پنل Swatches پر 
شود )حالت Basic( يا از طرح‌ها و الگوهاي ديگري براي پرکردن داخل شکل استفاده شود.

5- كارت پستالي به صورت دو برگي و به مناسبت »روز مادر« با ابعاد دلخواه طراحي كنيد.
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 توجه: فعال بودن گزينه OverPrint سبب مي‌شود که رنگ انتخاب شده با رنگ‌هاي 

زيرين خود ادغام شود، مثلًا اگر رنگ شکل آبي فيروزه‌اي )سايان( باشد و رنگ زمينه آن زرد 
باشد در چاپ، شکل به رنگ سبز چاپ مي‌شود.

Add Fill نحوه استفاده از دکمه
1- ب��ا کليک روي دکمه Add Fill در پنل Object گزينه‌هاي‌تنظيمي مربوط به Fill ظاهر 

مي‌شود.
2- شکل يا متن مورد نظر را انتخاب کنيد.

3- از منوي بازش��وي انواع Fill )پر کننده داخل ش��کل(، يکي از گزينه‌هاي آن را انتخاب 
نماييد.

در اين بخش به شرح گزينه‌هاي منوي بازشوي انواع Fill مي‌پردازيم.
2-8 انواع طرح‌ها

 Basic 8-2-1

اين ‌نوع طرح به‌منظور رنگ‌آميزي يکدست و خالص خط‌دور و محتواي داخل موضوعات 
‌انتخابي به‌کار‌ مي‌رود.

 Basic روش‌هاي اعمال طرح
• اعمال طرح Basic با استفاده از منوي بازشو Fill در پنل Object )شكل 8-2(.	

• كه همان انتخاب ‌رنگ از پالت ‌رنگ 	Tools با استفاده از جعبه ابزار Basic اعمال طرح
Fill  است.

• صورت  	Swatches با اس��تفاده از انتخ��اب رنگي كه از پن��ل  Basic اعم��ال رنگ نوع
مي‌گيرد.

تمرين 1: ش��کل 2-8 را كه چرخه دوازده رنگ پيشنهادي ايتن است ترسيم كرده 
و رنگ‌آميزي نماييد.
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شکل 8-2

 Color مي‌توانيد ب��ا درگ رنگ از پنل‌هاي Fill از انواع Basic نكت�ه: در ص��ورت انتخاب طرح 
Tints ،Mixer يا Swatches به داخل پالت رنگ Fill، شکل را رنگ‌آميزي کنيد.

Gradient 8-2-2

منظور از Gradient، طيف رنگي اس��ت که از يک رنگ ش��روع و به رنگ‌هاي ديگر تبديل 
مي‌شود.

گاهي اوقات براي زيبايي در رنگ‌آميزي ترس��يماتي نظير رنگ‌آميزي آسمان، خورشيد، 
رنگين‌کمان، سايه، افق و موارد ديگر نياز به اين نوع طرح است.

Gradient روش اعمال
1- از من��وي بازش��وي انواع Fill در پن��ل Object، گزين��ه Gradient را برگزينيد. در اين 

صورت گزينه‌هاي تنظيمي آن ظاهر مي‌شود )شکل 8-3(.

 Gradient شکل 3-8  گزينه‌هاي تنظيمي 

2- از منوي بازشوي Gradient type مي‌توانيد انواع شيب‌هاي گراديان را انتخاب کنيد.
Gradient انواع

• به کمک نوار رنگي اين قس��مت مي‌توان انواع رنگ‌ها را به  	:)Linear( ش�يب خطي
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صورت تدريجي و خطي در يکديگر محو کرد همچنين به ش��يب گراديان، زاويه داد 
و بر موضوع انتخابي اعمال کرد )شکل 8-4-1(.

گزينه‌هاي کنترلي اين طيف براي تعيين محل ش��روع )Start(، زاويه دس��تگيره و درصد 
طول گراديان در Handle1  و انتخاب رنگ‌هاي مختلف در طيف به‌کار مي‌رود.                                                    

شكل 8-4-1

 نكته: با اس��تفاده از دستگيره‌هاي Gradient )يک نقطه شروع و يک نقطه پايان( 
روي ش��کل، مي‌توانيد محل ش��روع، زاويه و طول گراديان را به‌طور دستي تنظيم کنيد. اين 

دستگيره‌ها همچنين با نگه داشتن کليد Ctrl     ظاهر مي‌شوند )شكل 8-5-1(.
ج

 توجه: اگر دستگيره‌هاي گراديان را نمي‌بينيد، روي ابزار Subselect يا Pointer دابل كليك كنيد 

و در كادر محاوره باز شده گزينه Show Fill Handles را فعال نماييد.

، رنگ داخل موضوع  • 	Gradient با انتخاب اين نوع :)Radial( شيب کروي يا شعاعي
انتخاب ش��ده از مرکز ش��روع مي‌شود و يک کره ايجاد مي‌کند، اين شيب يک شيب 

مدور است )شکل 8-4-2(.

شكل 8-4-2

اعمال  • 	 Gradient تغيير رنگي که در اين نوع :)Contour( ش�يب انعکاسي يا تابعي
مي‌شود بر اساس شکل مسيري است که انتخاب کرده‌ايد )شکل 8-4-3(.
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گزينه‌هاي کنترلي مانند طيف‌هاي قبلي اس��ت و گزينه Taper جهت تنظيم ميزان نفوذ 
رنگ‌هاي طيف در يکديگر به كار مي‌رود.

شکل 8-4-3

اين نوع طيف مانند طيف رنگ خطي است با اين  • 	 :)Logarithmic( شيب لگاريتمي
تفاوت که تغيير رنگ‌ها به طور نامساوي صورت مي‌گيرد )شکل 8-4-4(.

اين طيف نيز مانند طيف رنگ شعاعي است، با اين  • 	 :)Rectangle( شيب مستطيلي
تفاوت که طيف از مرکز شروع و يک مستطيل ايجاد مي‌کند )شکل 8-4-5(.

تغيير رنگ در اين طيف به شکل، حالت برجستگي شبيه  • 	 :)Cone( شيب مخروطي
هرم يا يک مخروط سه بعدي مي‌دهد )شکل 8-4-6(.

          

شکل 4-4-8                       شکل 5-4-8                    شکل 8-4-6

1- از منوي بازش��وي Behavior type مي‌توانيد نحوه پرش��دن ش��کل را توس��ط گراديان 
تنظيم کنيد. اين گزينه‌ها عبارتند از: Normal )معمولي(، Repeat )تکرار(، Reflect )انعکاس( 

و Auto Size )اندازه اتوماتيک(.
 2- در کادره��اي Start مي‌تواني��د مختص��ات x و y نقط��ه ش��روع را مش��خص کني��د 

)شکل 8-5(.
3- در کادرهاي Handle مي‌توانيد زاويه گراديان و فاصله بين دورنگ يا طول گراديان را 

به طور دلخواه تنظيم کنيد )شکل 8-5(.
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شکل 5-8 گزينه‌هاي گراديان

4- در پايي��ن پنل Object، يک نوار رنگي وجود دارد که رنگ‌هاي موجود در طيف رنگ 
را نمايش مي‌دهد. به طور پيش‌فرض گراديان‌ها حاوي دو رنگ هس��تند که مي‌توانيد تعداد 

رنگ‌ها را تغيير داده و اضافه کنيد.
در ابت��دا و انتهاي نوار رنگي، دو مرب��ع قرار دارد که نمايانگر رنگ ابتدا و انتهاي گراديان 
اس��ت. براي تغيير رنگ، روي مربع‌ها کليک کنيد تا پالت رنگ باز ش��ده و از داخل آن رنگ 

موردنظر خود را انتخاب کنيد.

 نكت�ه: براي اضافه کردن رنگ مي‌توانيد روي ه��ر کدام از مربع‌ها کليک کرده و 
آن را به س��مت داخل نوار رنگي درگ کنيد و براي حذف يک رنگ، کافي اس��ت مربع را به 

خارج از پنل درگ کنيد.

مثال 1: ش��کل 6-8 را با اس��تفاده از انواع Gradient نشان داده شده، رسم کنيد 
 

)رنگ دلخواه(.

شکل 8-6
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1- از خط‌کش‌ها و Guides براي رسم دقيق استفاده کنيد.
2- ابتدا طراحي و ترسيمات شکل را انجام دهيد.

3- کوه‌ها و دامنه آن را انتخاب کرده و گراديان خطي را به رنگ دلخواه، روي آن اعمال 
کنيد.

4- خورش��يد را به حالت انتخاب درآورده و طيف رنگ ش��عاعي براي آن در نظر بگيريد، 
سپس خط دور آن را حذف کنيد.

5- شعاع‌هاي خورشيد را با گراديان لگاريتمي رنگ کنيد.
6- ام��واج دريا را با گرادي��ان خطي رنگ کنيد. به نوار رنگي، رن��گ اضافه کرده و آن را 

تغيير دهيد.
7- جزيره را انتخاب کرده و گراديان انعکاسي را به آن اعمال کنيد.

8- پايه چتر را با گراديان مستطيلي و سر آن را با گراديان مخروطي رنگ کنيد.
تمرين 2: 

 
1- يك برش پرتقال را با توجه به گراديانت‌ها طراحي كنيد.

2- شكل 7-8 را رسم کرده و با گراديان‌هاي مناسب رنگ کنيد.

شکل 8-7

3- تصويري از پاييز را رسم كرده و با گراديان‌هاي مناسب رنگ‌آميزي كنيد.
Textured 8-2-3

پرکننده Textured تصاوير گرافيکي آماده‌اي هستند که به جاي رنگ دادن به موضوعات 
به آن‌ها نماي بافت مي‌دهند. اين پرکننده‌ها در صفحه مانيتور قابل رؤيت نيستند و تنها در 

کارهاي چاپي مشاهده مي‌شوند.
)بافت( • 	 Textured روش اعمال

1- گزينه Textured را از منوي بازشوي انواع Fill انتخاب کنيد، در اين صورت گزينه‌هاي 
تنظيمي آن ظاهر مي‌شود )شکل 8-8(.
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Fill از انواع Textured شکل 8-8 گزينه

2- از منوي بازش��وي انواع بافت‌ها، بافت موردنظر خود را انتخاب کنيد که در اين حالت 
در پنجره پيش نمايش، بافت انتخابي نشان داده مي‌شود.

3- امکان تغيير رنگ بافت انتخابي نيز در فهرست Color اين گزينه وجود دارد.
4- در ش��کل انتخاب ش��ده به جاي مشاهده بافت، يک سري حرف c مي‌بينيد که شکل 
را پر کرده است )شكل 9-8(. همان‌طور که گفته شد اين پرکننده‌ها در چاپ قابل مشاهده 

هستند.

شکل 9-8 نمايش بافت در صفحه نمايش

 توجه: روش کار با گزينه Custom از انواع Fill نيز مشابه Textured است.
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Pattern 8-2-4

پرکننده‌هاي Pattern، الگوهايي هستند که مي‌توانيد در ترسيمات به جاي رنگ از آن‌ها 
استفاده کنيد. اين الگوها را مي‌توان پيكسل به پيكسل و به سادگي ويرايش نمود تا به صورت 
دلخواه درآيند. الگوهاي اعمال ش��ده به موضوعات بلافاصله توس��ط مانيتور قابل مش��اهده 

هستند.
• 	Pattern روش اعمال

1- موضوع ترسيمي را انتخاب کنيد.
2- گزين��ه Pattern را از منوي بازش��وي انواع Fill برگزيني��د. در اين صورت، گزينه‌هاي 

تنظيمي الگوها ظاهر مي‌شوند )شکل 8-10(.
3- براي مش��اهده و انتخاب Pattern موردنظر از دکمه لغزنده اين کادر محاوره اس��تفاده 
کرده و يک الگو را انتخاب کنيد. با کليک روي هر Pattern مي‌توانيد پيش‌نمايش��ي از آن را 

در کادر سمت چپ دکمه لغزنده کادر محاوره مشاهده کنيد. 
4- در س��مت چ��پ کادر پيش‌نمايش، کادر ويرايش قرار دارد ک��ه با کليک کردن روي 

پيکسل‌ها يا خانه‌هاي آن مي‌توانيد الگوي مورد نظر را ويرايش کنيد.
5- رنگ Pattern را مي‌توانيد از ليست رنگ‌هاي موجود در فهرست Color تغيير دهيد.

 توجه: به منظور طراحي الگوي جديد مي‌توانيد با اس��تفاده از دکمه Clear، الگوي 

پيش‌فرض را پاک کرده و يک صفحه خالي ايجاد کنيد.

شکل 10-8 گزينه‌هاي Pattern و نمونه‌هايي از چند شکل پر شده با الگو
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 توج�ه: دکمه Invert، نقاط يا پيکس��ل‌هاي س��ياه را به س��فيد و بالعکس تبديل 

مي‌کند.

 نكت�ه: موضوعاتي که در پش��ت پرکننده Pattern ق��رار مي‌گيرند، از طريق فضاي 
سفيد Pattern قابل مشاهده نيستند.

 نكته: براي قرار دادن موضوع انتخابي در پش��ت س��اير اشکال، گزينه زير را به‌کار 
ببريد.

Modify→Arrange→Send to back

تمري�ن 3: ش��کل 11-8 را با اس��تفاده از الگوهاي نمايش داده ش��ده، طراحي 
کنيد.

شکل 8-11

PostScript 8-2-5

به منظور پرکردن اش��کال با الگوهاي مبتني بر بردارهاي رياضي از PostScript اس��تفاده 
مي‌ش��ود. اش��کالي که با اين نوع طرح پر مي‌ش��وند؛ زماني قابل مشاهده مي‌شوند که با يک 
  Object در پنل Fill از منوي بازشوي انواع PostScript چاپ ش��وند. گزينه PostScript چاپگر

قابل انتخاب است.
Custom  8-2-6

اي��ن گزينه در منوي بازش��وي انواع Fill، قرار دارد که ليس��تي از الگوهاي آماده را براي 
پر کردن داخل ش��کل نش��ان مي‌دهد )شکل 12-8(. در اين صورت با انتخاب هر يک از اين 
الگوها، موضوع انتخاب ش��ده با آن پر مي‌ش��ود. همچنين رنگ الگوها را مي‌توانيد با انتخاب 
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رنگ از پنل Swatches تغيير دهيد.

 توجه: الگوهاي آماده گزينه Custom توس��ط مانيتور قابل ديدن نيس��تند و بعد از 

چاپ قابل مشاهده خواهند بود.

 Custom Fills 8-12 شکل

  Tiled  8-2-7

نوع ديگري از طرح‌هاي پرکننده که براي پرکردن موضوعات از ترس��يمات ديگر استفاده 
مي‌کند، گزينه Tiled است. همچنين گاهي اوقات در طراحي لازم است که يک شکل از قبل 
طراحي ش��ده در داخل يک طرح ديگر تکرار ش��ود مانند جعبه دستمال کاغذي، کاغذ کادو، 
س��اک دس��تي يا تکرار آرم يک ش��رکت در زمينه برگه‌هاي تبليغاتي آن شرکت و نيز موارد 

ديگر.
براي ايجاد و اعمال اين پرکننده مراحل زير را انجام دهيد:

1- ش��کلي را که مي‌خواهيد جهت تکرار در موضوع ديگر اس��تفاده کنيد، ترسيم کرده و 
.)Ctrl+C( از آن کپي بگيريد

 توجه: مي‌توانيد يک متن را نوشته، سپس به موضوع تبديل کرده و در شکل ديگر 

تکرار کنيد.
1- موضوعي که مي‌خواهيد باTiled  پر شود، انتخاب کنيد.

2- از منوي بازش��وي ان��واع Fill  گزينه Tiled را برگزيني��د و روي دکمه Paste in  کليک 
کنيد. ش��کل کپي شده در کادر پيش نمايش ظاهر ش��ده و موضوع با آن پر مي‌شود )شکل 
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.)8-13
3- براي تغيير اندازه پرکننده Tiled از کادرهاي x و y در قسمت مقياس)Scale( استفاده 
کنيد، با دادن مقادير کوچک‌‌تر يا بزرگ‌تر از 100 ابعاد پرکننده کوچک‌تر يا بزرگ‌تر مي‌شود. 
ب��ه منظور تغيي��ر مقياس يکنواخت پرکنن��ده، در هر دو کادر x  و y مقادير يکس��اني به‌کار 

بريد.
 y و x 4- ب��راي جابه‌ج��ا کردن پرکننده مي‌توانيد مقادير مثبت و منف��ي را در کادرهاي

مربوط به Offset وارد کنيد.

              

شکل 13-8 گزينه Tiled و نمونه‌اي از تأثير آن

5- براي زاويه‌دار کردن پرکننده يا چرخش آن مي‌توانيد از اهرم چرخش اس��تفاده کنيد 
يا زاويه دقيق را در کادر Angle وارد کنيد.

 نكته: طرح‌هاي پرکننده Tiled حتماً بايد برداري باش��ند و شامل تصاوير گرافيکي 
پيکسلي نمي‌شوند.

تمرين 4: کاغذ کادو نشان داده شده در شکل 14-8 را به ابعاد 18×30 سانتي‌متر 
طراحي کنيد.
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شکل 8-14

Lens 8-2-8

با استفاده از اين پرکننده مي‌توان ظاهر شکل را با معکوس کردن رنگ‌ها، تغيير شفافيت، 
رنگ، روشني، تيرگي يا بزرگنمايي تغيير داد.  

براي اعمال اين پرکننده مراحل زير را انجام دهيد:
1- گزينه Lens )لنز( را از منوي بازشوي انواع Fill انتخاب کنيد، در اين صورت گزينه‌هاي 

تنظيمي آن ظاهر مي‌شود )شکل 8-15(.

شکل 15-8 گزينه‌هاي پر کننده عدسي

2- يکي از شش نوع پرکننده Lens را به دلخواه انتخاب نماييد.
ب��ا توجه به نوع لنز انتخاب ش��ده گزينه‌هاي متفاوتي ب��ه منظور تغيير تنظيمات نمايش 
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داده مي‌شوند.
3- براي‌ لنزهاي Transparency و Monochrome با استفاده از منوي بازشو با کادر رنگ، 

مي‌توان رنگي را انتخاب نمود.
4- در‌ لنز Magnify براي تنظيم بزرگنمايي شکل زير لنز مقدار بين 1 تا 20 را وارد کرده 

يا دكمه لغزنده را جهت تنظيم مقدار درگ نماييد.
5- در‌ لنزه��اي Lighten ،Transparency و Darken با وارد نمودن مقادير دلخواه يا درگ 

کردن دكمه لغزنده مي‌توان تنظيمات زير را انجام داد:
• )کاملًا  براي پر کننده Transparency، حدود مقادير بين صفر )کاملًا شفاف( تا 100	

کدر( مي‌باشد )شكل 8-16(.
• مس��ير لنز را از س��فيد کاملًا  براي پر کنندهLighten ، مقدار صفر، بي‌اثر و عدد 100	

پر مي‌کند )شكل 8-17(.
• مس��ير لنز را از مشکي کاملًا  براي پر کنندهDarken ، مقدار صفر، بي‌اثر و عدد 100	

پر مي‌کند )شكل 8-18(.

                   

شکل 16-8                       شکل 17-8                             شکل 8-18

به‌منظ��ور نمايش دس��تگيره در مرکز لنز انتخاب ش��ده، گزين��ه Centerpoint را انتخاب 
نماييد در اين صورت با استفاده از ابزار Pointer مي‌توانيد نقطه مرکز را جابه‌جا كنيد.

 نكته: به منظور بازگرداندن نقطه مرکز به مرکز لنز کليد Shift را پايين نگه داشته 
و روي نقطه کليک كنيد.

انتخاب گزينه Objects Only باعث مي‌شود تا لنز مورد نظر تنها روي شکل انتخاب شده 
تأثير داشته باشد و روي نواحي انتخاب نشده تغييري ايجاد نکند.

انتخاب گزينه Snapshot باعث مي‌شود تا زماني که روي هر قسمت از شکل انتخاب شده 
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لنز را قرار دهيد، تصويري از آن قسمت گرفته شود.
کليک کنيد، پرکننده داخل موضوع  • 	 Object در زبانه Remove Item اگ��ر روي دکمه

حذف مي‌شود.
تمرين 5: ش��کل 19-8 را رسم كنيد و قس��متي از آن را به‌صورتي که در شکل 

مشاهده مي‌نماييد طوري تصويربرداري كنيد که بزرگ‌تر نمايش داده شود.

شکل 8-19

Object در پنل Add Stroke 3-8 دکمه
منظور از Stroke ضخامت خطوطي است که دور موضوعات را احاطه مي‌کند، Stroke نيز 
يکي از زير مجموعه‌هاي پنل Object اس��ت که خطوط دور مسيرها را کنترل مي‌کند )شکل 

.)8-20

Object در پنل Stroke شکل 20-8 گزينه‌هاي

در منوي بازش��وي انواع Stroke علاوه بر گزينه Basic، طرح‌هاي ديگري نيز براي رس��م 
خط��وط دور مس��يرها وج��ود دارد که همه اين خطوط با اس��تفاده از پن��ل Swatches قابل 

رنگ‌آميزي هستند.
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 )Stroke( نحوه استفاده از خط دور
1- تصوير دلخواهي رسم کرده و آن را انتخاب کنيد. 

2- روي دکمه Add Stroke از پنل Object کليک کنيد.

3- از من��وي بازش��وي انواع Stroke يک��ي از گزينه‌هاي Stroke را انتخاب کنيد )ش��کل 
21-8( که در اين صورت، تنظيمات پنل Object براس��اس نوع خط دور انتخاب شده، تغيير 

مي‌کند.      

Stroke شکل 21-8 گزينه‌هاي منوي

 Basic 1-3-8 گزينه

با نسبت دادن رنگ از پنل Swatches به دور موضوعات، خطوط با رنگ ساده رنگ‌آميزي 
مي‌شوند. 

 توج�ه: با اس��تفاده از جعبه رنگ  Stroke در جعبه اب��زار Tools نيز مي‌توانيد رنگ 

خط دور را انتخاب کنيد.
Stroke گزينه‌هاي کنترلي خطوط مرزي موضوعات در

• ب��ا کليک روي مربع رنگي، امکان انتخاب هم��ه رنگ‌ها براي خط دور  جعب�ه رنگ:	
مسير فراهم مي‌آيد؛ همچنين با باز کردن منوي بازشوي کنار آن، رنگ‌هاي موجود 

در پنل Swatches نشان داده مي‌شوند.
هاي زيري��ن آن ادغام  • Overprint: ب��ا انتخ��اب اين گزين��ه رنگ خط دور ب��ا رنگ‌	

مي‌شود.
• با انتخاب ان��دازه موردنظر برحس��ب واحد  	:Width من�وي بازش�و
اندازه‌گيري صفحه، از ليس��ت موجود در اين قس��مت مي‌توانيد ضخامت خط دور را 

تغيير دهيد يا عددي بين صفر تا Point( 288( را در کادر مربوطه تايپ کنيد.
• وضعي��ت انتهاي خطوط‌مس��ير يا نوع گوش��ه‌هاي خط را  	:  Cap

تعيين مي‌کند.
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  Capانواع شيوه‌هاي
• Butt: انتهاي خط دور را با خط مستقيم پايان مي‌دهد.	

• Round: انتهاي خط دور را با منحني ختم مي‌کند.	

• Square: انتهاي خط دور را با مربع پايان مي‌دهد.	

                                            

شکل 22-8 انواع شيوه‌هاي Cap اعمال شده به مسير

• وضعيت و ش��کل محل تلاقي پاره‌خط‌ها با يکديگر در اين  	:  Join

قسمت تعيين مي‌شود.

 توجه: براي ديدن تفاوت‌هاي موجود در انواع ش��يوه‌هاي Join، بزرگنمايي خط يا 

عرض خط دور را افزايش دهيد.

 Join انواع شيوه‌هاي
براي اعمال هر کدام از شيوه‌ها روي آيکن مربوطه کليک کنيد )شکل 8-23(. 

شکل 23-8 شيوه‌هاي Join اعمال شده به مسير

• Miter: در محل تقاطع دو پاره‌خط، گوشه نوک تيز ايجاد مي‌کند.	

• Round: در محل تلاقي دو پاره‌خط، منحني تشکيل مي‌دهد.	

• Bevel: محل تلاقي دو پاره‌خط را برش مي‌زند، اصطلاحاً پخ مي‌کند.	

• )نوع تيز(  	Miter وقت��ي براي نقاط تلاق��ي پاره‌خط‌ها، گزينه :  Miter

انتخاب مي‌شود؛ عدد داده شده دامنه کشش تيزي را تعيين مي‌کند.
• ب��ا اس��تفاده از اين من��وي بازش��و مي‌توانيد  	:Dash ان�واع 
 ان��واع خ��ط را از لح��اظ خط‌چين ي��ا نقطه‌چين ي��ا ترکيب��ي از اي��ن دو و .... تعيين کنيد

)شکل 8-24(.
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Arrowheads و dash شکل 24-8 انواع

با استفاده از اين منوي بازشو مي‌توان انواع پيکان‌ها را  • 	 :Arrowheads منوي بازش�و
براي ابتدا و انتهاي خط انتخاب شده، تعيين کرد. 

Brush 2-3-8 گزينه

با اس��تفاده از اين گزينه مي‌توان نوع خط دور را بر اس��اس ان��واع قلم‌هاي موجود تغيير 
داد. اي��ن قلم‌ه��ا قبلًا توس��ط فرمان Brush در من��وي Modify ايجاد ش��ده‌اند و داراي انواع 
طرح‌هاي گرافيکي زيبا هس��تند. اين قلم‌ها در منوي بازشوي مربوطه که شامل انواع طرح‌ها 

و الگوهاست قابل مشاهده و انتخاب هستند.
بعد از انتخاب قلم موي موردنظر، مي‌توانيد براي انتخاب نمونه‌هاي ديگر قلم روي دکمه 

Options کليک کنيد تا منويي مطابق شکل 25-8 باز شود.

Options شکل 25-8 منوي مربوط به دکمه
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با انتخاب گزينه Import مي‌توانيد از ليس��ت فايل‌هاي مربوط به قلم‌هاي آماده يك فايل 
را انتخاب كنيد.

در کادر محاوره Import Symbols مي‌توانيد قلم مورد نظر را انتخاب و وارد ليست مجموعه 
قلم‌ها کنيد. حال خطوط دور شکل انتخاب شده با طرح قلم انتخابي طراحي مي‌شود )شکل 

.)8-27
: اين گزينه براي تعيين اندازه قلم به‌کار مي‌رود.

 نكته: مي‌توانيد با استفاده از گزينه New مربوط به دکمه Options يک قلم جديد 
تعريف کنيد.

  

Brush شکل 26-8 کادرانتخاب نوک قلم‌مو                                 شکل 27-8 نحوه تأثير گزينه

 نكته: براي تبديل يک موضوع ترسيمي انتخاب شده، به قلم‌مو کافي است فرمان 
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زير را اجرا کنيد:
Modify→Brush→Create Brush 

Custom 3-3-8 گزينه

اين گزينه امکان انتخاب‌مدل‌ها و شکل‌هاي‌آماده را براي خطوط دوراشکال فراهم‌مي‌سازد 
)شکل 28-8(. اين مدل‌ها در مانيتور قابل مشاهده نيستند و فقط در چاپ ديده مي‌شوند. 
• بلندي يا طول ش��کل‌هاي آماده را تعيين مي‌کند و کادر  	Length در اين بخش کادر

Spacing فاصله بين شکل‌‌هاي آماده Custom را تنظيم مي‌کند.

Stroke در انواع Custom شکل 28-8 گزينه

Pattern 4-3-8 گزينه

الگوهاي از قبل آماده‌اي هس��تند که مي‌توانيد آن‌ها را ويرايش کرده و به صورت دلخواه 
درآوريد و به لبه‌ها و خطوط دور موضوعات نسبت دهيد.

 Postscript 5-3-8 گزينه

 اين گزينه به ش��ما امکان مي‌دهد تا از الگوهاي مبتني بر بردارهاي رياضي براي خطوط 
دور اشکال استفاده کنيد.

 نكت�ه: ب��ا انتخاب گزين��ه   از پن��ل Swatches، خ��ط دور مس��ير )Stroke( حذف 
مي‌شود.

تمرين 6:
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1- شکل 29-8 را طراحي کرده و به عنوان قلم‌مو تعريف کنيد.  
2- براي افزايش مهارت کار با انواع Stroke، شکل 30-8 را رسم کنيد. 

           

                                         شکل 29-8                                       شکل 8-30

      Eye Dropper4-8 ابزار
اين ابزار براي نمونه‌برداري از رنگ موضوعات و اس��تفاده در رنگ‌آميزي موضوعات ديگر 

کاربرد دارد.
تمرين 7: از رنگ قس��مت دلخواه شکل 31-8 )سمت چپ( نمونه‌برداري کرده و 

شکل سمت راست را با آن رنگ کنيد. 

شکل 31-8 نمونه برداري از رنگ شکل

Create 5-8 فرمان
با اس��تفاده از فرمان‌هاي موجود در من��وي Xtras مي‌توانيد روي كار جلوه‌هايي به وجود 
آوريد كه كار زيباتر به نظر برس��د. اين منو شامل س��ه فرمان Emboss ، Blend و Trap است 

)شكل 8-32(.

Create شكل 32-8 فرامين موجود در منوي
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Blend 1-5-8 فرمان

از اين فرمان براي ترکيب کردن يا به هم رس��اندن دو موضوع انتخابي اس��تفاده مي‌شود. 
چون اين فرمان از گزينه‌هاي Combine نيز است بنابراين در واحد كار 10 با جزييات بيشتر 

آن آشنا خواهيد شد.
Emboss 2-5-8 فرمان

با اس��تفاده از اين فرمان مي‌توان انواع جلوه‌هاي برجسته‌سازي را روي موضوعات انتخاب 
شده نمايش داد.

Emboss روش كار با فرمان
1- موضوع گرافيكي مورد نظر را انتخاب كنيد.

2- فرم��انXtras→Create→Emboss  را اجرا كنيد. كادر محاوره Emboss مطابق شك��ل 
33-8 ظاهر مي‌شود.

3- از پنج نوع جلوه مربوط به برجس��تگي كه ش��امل Ridge ، Chisel، Deboss، Emboss و 
Quilt مي‌شود، يكي را انتخاب كنيد )شكل 8-34(.

 Emboss شكل 33-8 كادر محاوره

شكل 34-8 انواع برجستگي

4- در شك��ل 35-8 نتيجه حاصل از تأثير انواع جلوه‌هاي برجس��تگي نش��ان داده شده 
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است.
5- در منوي بازشوي Vary دو گزينه Contrast وColor  قرار دارد )شكل 8-36(.

    

Vary شكل 35-8 نتيجه حاصل از تأثير انواع جلوه‌هاي برجستگي            شكل 36-8 گزينه

6- کادر و دکم��ه لغزن��ده Depth عمق فرورفتگي يا ضخامت برجس��تگي را در لبه‌هاي 
موضوع گرافيكي انتخاب شده تعيين ميك‌ند.

7- با استفاده از کادر Angle مي‌توانيد سايه را با زاويه دلخواه‌ روي‌شكل ايجاد كنيد.
8- انتخ��اب گزينه Soft Edge باعث مي‌ش��ود ک��ه جلوه برجس��تگي در لبه‌هاي موضوع 

گرافيكي انتخاب شده، هموارتر و نرم‌تر نشان داده شود.
9- براي مش��اهده نحوه تأثيرگذاري تنظيمات روي موضوع گرافيكي انتخاب شده، روي 

دكمه Apply كليك كنيد و اگر از نتيجه راضي هستيد روي دكمه OK كليك كنيد.

 مثال 2: شكل 37-8 را رسم كنيد و به آن برجستگي با سايه‌اي به رنگ قرمز و 
		 لبه‌هاي نرم و هموار بدهيد.

شكل 8-37

پس از رسم، براي دادن جلوه برجستگي به شكل ابتدا آن را انتخاب كنيد، سپس فرمان 
 Vary در منوي‌ بازش��وي Emboss را اج��را كنيد. در كادر محاوره Xtras→Create→Emboss
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گزينه Color را انتخاب كنيد و رنگ را در قس��متShadow  مطابق شك��ل 38-8 قرمز قرار 
دهيد. براي هموار بودن سايه بايد گزينه  Soft Edge فعال باشد.

                                                                                                                                                                                                                                 

شكل 38-8 تنظيم رنگ قرمز براي ايجاد سايه                  شكل 8-39

Trap 3-5-8 فرمان

اين فرمان هنگام چاپ گرفتن از يک کار، اس��تفاده مي‌ش��ود. زماني که تصويري با رنگ 
سياه روي تصاوير رنگي ديگر قرار گرفته باشد، اين فرمان رنگ‌هاي زير ناحيه سياه را حذف 

مي‌کند به صورتي که در مصرف جوهر پرينتر صرفه‌جويي مي‌شود.
همچنين اين فرمان رنگ‌ها را به شكل مناسب روي هم قرار مي‌دهد به طوري كه هنگام 

چاپ، زمينه كاغذ معلوم نباشد. 

Trap شكل 40-8 كادر محاوره

Distort 6-8 فرمان
زيرمن��وي Distort ش��امل دو فرمان Add Points و Fractalize اس��ت كه به منظور اضافه 
کردن گره‌هاي جديد روي مسير و تغيير شكل دادن موضوعات گرافيكي انتخاب شده به كار 

مي‌روند )شكل 8-41(.
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Distort شكل 41-8 گزينه

Add Points 1-6-8 فرمان

با اجراي اين فرمان مي‌توانيد تعداد گره بيش��تري به مس��ير يا موضوع گرافيكي انتخاب 
شده، اضافه كنيد.

براي استفاده از فرمان Add Points مراحل زير را انجام دهيد:
1- موضوع دلخواهي را انتخاب كنيد.

2- فرمـان Xtra→Distort→Add Points را اجـرا كنيد يا روي ‌آيكـن  از نـوار ابزار
Xtra Operations كليك كنيد.

در اي��ن ص��ورت نقاط جديدي بي��ن يك جفت از نقاط موجود اضافه مي‌ش��ود )شك��ل 
.)8-42

Add Points شكل 42-8 شكل سمت راست، نتيجه اجراي فرمان

Fractalize 2-6-8 فرمان

ب��ا اس��تفاده از اين فرمان مي‌توان الگوهاي س��اده يا پيچيده‌اي را ايج��اد كرد. معمولاً از 
اجراي مكرر فرمان Fractalize روي يك موضوع، الگوهاي جالبي ايجاد مي‌شود.

 مثال 3: 1- يك ستاره مطابق شكل 43-8 رسم و آن را انتخاب كنيد.

شكل 43-8 رسم و انتخاب شكل

 2- فرم��ان Xtras→Distort→Fractalize را 3 ب��ار اجرا��كرده و نتيجه‌را مش��اهده ك‌نيد 
)شكل 8-44(.
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Fractalize شكل 44-8 نتيجه 3 بار اجراي فرمان

تمرين 8: شكل 45-8 را رسم كرده و فرمان Fractalize را 5 بار روي آن اعمال 
كنيد.

 
شكل 8-45

 مث�ال كاربردي: در ادامه مثال كاربردي واحد كار پيش��ين مراحل زير را انجام 

دهيد:
1- اکنون براي ايجاد كارت ويزيت صفحه جديدي باز كنيد. 

2- ابعاد كارت ويزيت 5×9 سانتي‌متر است، اما چون مي‌خواهيم واحد صفحه را ميلي‌متر 
در نظر بگيريم، ابعاد صفحه را به‌صورتw = 50 وh = 90 وارد کنيد. 

3- با اس��تفاده از ابزار Zoom صفحه را در حال��ت بزرگنمايي قرار دهيد تا كار در صفحه 
براي شما آسان‌تر شود.

     ، w = 50 و  h = 7 ،Object 4- چهارگوش��ي در صفحه رس��ـم كنيد و ابعـاد آن را در پنل
x =0 و y = 83 قرار دهيد، سپس داخل چهارگوش را با رنگ سياه پر كنيد.

شكل 8-46
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5- تغييرات را در فايلProject.fh11  ذخيره كنيد.
واژه‌نامه

Bevelکج کردن، اريب

Blendآميختن، مخلوط‌کردن 

Brushقلم‌مو

Combineترکيب‌کردن

Coneمخروطي‌شکل‌کردن

Eye dropperقطره‌چکان

Gradientطيف رنگ

Hatchهاشورزدن

Lensلنز، عدسي

Magnifyذره‌بين

Miter limitگردکردن خط

Patternالگو

Reductionکاهش

Removeحذف‌کردن

Transparencyشفافيت

خلاصه مطالب 

• براي پر کردن رنگ داخل موضوعات و مسيرها استفاده  	Object در پنل Fill از گزينه
مي‌شود.

• ب��راي رنگ‌آميزي خط دور و محتواي داخ��ل موضوعات انتخابي به‌کار  	Basic ط��رح
مي‌رود.

، طيف رنگي اس��ت که از يک رنگ ش��روع و به‌رنگ‌هاي ديگر  • 	Gradient منظ��ور از
تبديل مي‌شود.

• تصاوير گرافيکي آماده‌اي هس��تند که به موضوعات نماي بافت  	Textured پرکنن��ده
مي‌دهند. 
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، الگوهايي هس��تند که مي‌توانيد در ترسيمات به جاي رنگ از  • 	Pattern پرکننده‌هاي
آن‌ها استفاده کنيد. 

 • 	Tiled ليستي از الگوهاي آماده را براي پر کردن داخل شکل و گزينه Custom گزينه
از طرح‌هاي پرکننده است و زماني به كار مي‌رود که در طراحي لازم است يک شکل 

از قبل طراحي شده در داخل يک طرح ديگر تکرار شود.
•با اس��تفاده از پر کننده لنز مي‌توان ظاهر ش��کل را با معکوس کردن رنگ‌ها، تغيير  	

شفافيت، رنگ، روشني، تيرگي يا بزرگنمايي، تغيير داد.  
• منظور از Stroke ضخامت خطوطي است که دور موضوعات را احاطه مي‌کند.	

• براي نمونه‌برداري از رنگ موضوعات و اس��تفاده در رنگ‌آميزي  	Eye dropper اب��زار
موضوعات ديگر کاربرد دارد.

• مي‌توان انواع جلوه‌هاي برجسته‌سازي را روي موضوعات  	Emboss با استفاده از فرمان
انتخاب شده نمايش داد.

رنگ‌ها را به شك��ل مناس��ب روي هم قرار مي‌دهد به طوري كه هنگام  • 	Trap  فرمان
چاپ،  زمينه كاغذ معلوم نباشد.
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- پرکنن��ده Gradient تصاوي��ر گرافيک��ي آماده‌اي هس��تند که به ج��اي دادن رنگ به 
موضوعات به آن‌ها نماي بافت مي‌دهند.

2- از گزينه Fill براي پرکردن رنگ داخل موضوعات و مسيرها استفاده مي‌شود.
3- اب��زار Eye dropper ب��راي نمونه‌برداري از رنگ موضوعات و اس��تفاده در رنگ‌آميزي 

موضوعات ديگر کاربرد دارد.
4- طيف مخروطي مانند طيف رنگ خطي اس��ت؛ با اين تفاوت که تغيير رنگ‌ها به طور 

نامساوي صورت مي‌گيرد.
معادل گزينه هاي سمت ‌راست را از ستون سمت ‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

5- با انتخاب اين نوع Gradient، رنگ داخل موضوع انتخاب شده از مرکز شروع مي‌شود 
و يک کره ايجاد مي‌کند. اين شيب يک شيب مدور است.                           شيب تابعي

6- تغيير رنگي که در اين نوع Gradient اعمال مي‌ش��ود براساس شکل مسيري است که 
انتخاب کرده‌ايد.                                                                            شيب کروي
  Trap      .7- با استفاده از اين فرمان مي‌توان الگوهاي ساده يا پيچيده‌اي را ايجاد كرد
                                  Fractalize                 .8- اين فرمان هنگام چاپ گرفتن از يک کار، استفاده مي‌شود

گزينه صحيح را انتخاب کنيد.

9- در قسمت Fill براي پرکردن مسير انتخاب شده از الگوهاي آماده، کدام گزينه استفاده 
مي‌شود؟

Postscript -ب 		 Tiled -الف
Pattern -د 		 Gradient -ج

 Fill 10- ب��راي اعمال طيف رنگي در داخل اش��کال انتخاب ش��ده از ک��دام گزينه انواع
استفاده مي‌شود؟

 Gradient-ب 		 Basic -الف
 Postscript  -د 		 Textured -ج
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11- کدام‌يک از پرکننده مسيرها روي صفحه نمايش ديده نمي‌شود؟
 Pattern-ب 		 Textured -الف

د- گزينه‌هاي الف و ج صحيح هستند. 		 Custom -ج
12- گزينه Cap در قسمت Stroke چه کاربردي دارد؟

ب- تعيين گردي گوشه‌هاي موضوعات  الف- تعيين نوع زاويه بين دو خط	
د- تعيين رنگ انتخابي خطوط در مسيرها  ج- تعيين وضعيت انتهاي خطوط	

13- براي رنگ برداري از کدام ابزار استفاده مي‌شود؟
Stroke -د   	  Postscript -ج 	Lens  -ب 	 Eye Dropper-الف

14- کدام نوع Gradient در شکل زير به‌کار رفته است؟
الف- خطي   
ب- تابعي   	
ج- کروي    
د- مخروطي

در جاي خالي عبارت مناسب را بنويسيد.

15- ضخامت خطوطي كه دور موضوعات را احاطه كرده است .............. ناميده مي‌شود.
16- از فرم��ان ........................ ب��راي ترکيب کردن يا به هم رس��اندن دو موضوع انتخابي 

استفاده مي‌شود.
17- با استفاده از فرمان Emboss مي‌توان ................. را روي موضوعات نمايش داد.

به سؤالات زير پاسخ تشريحی دهيد.

18- براي حذف ضخامت خطوط مسيرها چه بايد کرد؟
19- چگونه مي‌توان به جاي رنگ، موضوعات را از الگوها و بافت‌ها پر کرد؟

20- با انتخاب کدام گزينه مي‌توان قلم از قبل تعريف شده را به خطوط موضوعات نسبت 
داد؟

آزمون عملي
1- غروب خورشيد )در كنار دريا( را ترسيم كنيد و تأثير Lens را در آن بررسي كنيد.

2- براي شعر زير تصويرسازي كنيد. توجه داشته باشيد كه از انواع پركننده‌هاي گرافيكي 
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نظي��ر طيف رنگ، باف��ت، الگوهاي آماده، تكرار طرح، جلوه برجسته‌س��ازي و تغيير شك��ل 
موضوعات گرافيكي )Fractalize( در ترسيم استفاده كنيد.

دو تا كفتر
نشسته‌اند روي شاخه سدر كهنسالي

كه روييده غريب از همگنان در دامن كوه قوي پيكر
پس از اين كوه تشنه دره‌اي ژرف است،

در او نزديك غاري تار و تنها، چشمه‌اي روشن
ازينجا تا كنار چشمه راهي نيست.

                                                           "اخوان ثالث"
3- شكل يك دكمه )Button( را با عنوان START  براي شروع اجراي يك برنامه طراحي 

كنيد سپس با استفاده از جلوه برجستگي مناسب، فشرده شدن دكمه را نمايش دهيد.
4- شکل زیر را رسم کرده و به عنوان طرح روي جعبه دستمال کاغذي به ابعاد 20×30 

قرار دهيد.

5- طراحي برچس��ب )Label( روي CD را به‌طوري‌که در ش��کل نش��ان داده شده، انجام 
دهيد.
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كليات
يک��ي از موارد مهم��ي که در طراحي اهميت دارد، حروف‌نگاري و تايپ متون اس��ت. در 
طراحي موضوعاتي نظير کاتالوگ، س��ربرگ، طرح بس��ته‌بندي و ... علاوه‌ بر تصوير، نيازمند 
عناصر متني نيز هستيد.   FreeHand توانايي‌هاي بسياري در زمينه تايپ، ترازبندي و ايجاد 
جلوه‌ه��اي بصري دارد و يکي از ويژگي‌هاي برجس��ته اين برنام��ه، کيفيت بالاي چاپ متون 

نسبت به نرم‌افزارهاي پيکسلي است. 
در  FreeHandنمي‌توان متون فارس��ي را تايپ کرد، بنابراين کاربران بايد براي دسترسي 

به امکان تايپ فارسي از برنامه‌هاي جانبي استفاده کنند.
Text 1-9 ابزار

ب��ه ط��ور كل��ي در برنام��ه FreeHand MX متن به دو ص��ورت س��اده و پاراگرافي ايجاد 
مي‌شود. 

1-1-9 نگارش متن ساده

براي شروع به تايپ متن ساده مراحل زير را دنبال کنيد:
1- صفحه جديدي ايجاد کرده و ابزار متن )Text( را از جعبه ابزار انتخاب کنيد.

2- در محل موردنظر از صفحه کليک کنيد تا مکان‌نماي چش��مک‌زن به همراه خط‌کش 
ويژه تايپ نمايان شود )شکل 9-2(.

   		                   

شکل 2-9 متن ساده 	Text شکل 1-9 انتخاب ابزار              

 نكت�ه: خط‌ک��ش متن براي افزاي��ش دقت عمل در هنگام تاي��پ از طريق منوي 
View   Text Rulers يا کليد ميانبر /  +  Ctrl   قابل دسترسي است.

3-  اکنون مي‌توانيد متن موردنظر را تايپ کنيد يا متن تايپ ش��ده در برنامه ديگري را 
وارد اين محل کنيد.
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4- براي خاتمه دادن به کار تايپ کافي است توسط ابزار Pointer  در نقطه‌اي خارج 
از محيط تايپ، کليک کنيد.

2-1-9 نگارش متن پاراگرافي

براي ايجاد متن پاراگرافي به صورت زير عمل كنيد:
1- ابزار Text را از جعبه ابزار انتخاب كنيد.

2- يک کادر مس��تطيل با درگ ماوس )بلوک متن( ايجاد کنيد. فاصله كش��يدن ماوس 
اندازه بلوك متني را تعيين ميك‌ند. 

 3- پ��س از ره��ا ك��ردن م��اوس بل��وك متن��ي و خطك‌ش مت��ن را مش��اهده ميك‌نيد 
)شكل 9-3(.

4- متن را تايپ کنيد. 

شکل 3-9 متن پاراگرافي

3-1-9 اعمال تنظيمات روي متن 

مي‌توانيد قبل يا بعد از تايپ متن تنظيمات مختلفي را روي متن اعمال کنيد، براي اين 
منظور كيي از سه روش بعد را برگزينيد:

 Text 1- استفاده از نوار ابزار



Free Hand پیمانه مهارتی : کاربر
223واحد کار نهم: توانایی کار با متن 

Text شکل 4-9 نوار ابزار

براي ظاهر کردن اين نوار ابزار در بالاي صفحه، دو روش وجود دارد:
• 	Window→Toolbars→Text انتخاب گزينه
• 	Text کليک راست در محدوده خالي نوار ابزارهاي ديگر و انتخاب گزينه

Text 2- استفاده از منوي
تنظيمات متون، جلوه‌هاي ويژه متن و ساير فرامين در اين منو قرار دارند.

 Object 3- استفاده از پنل
با انتخاب ابزار Text و کليک روي صفحه يا انتخاب متن نوشته شده، گزينه‌هاي کنترلي 
آن ب��ه طور خودکار در پنل Object ظاهر مي‌ش��وند. اين پن��ل کامل‌ترين تنظيمات را براي 

کنترل متون سطري و پاراگرافي در خود جاي داده است )شکل 9-5(.       

     شکل 5-9 پنل Object مربوط به خواص متن
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2-9 انتخاب و تنظيمات متن  
قبل از تايپ متن مي‌توانيد تنظيماتي نظير تغيير اندازه و نوع قلم را انجام دهيد و در صورتي 

که بخواهيد بعد از تايپ متن به ويرايش آن بپردازيد، بايد ابتدا متن را انتخاب  کنيد.
روش‌هاي انتخاب متن

1-2-9 انتخاب محدوده‌اي از متن

1- توس��ط ابزار Pointer روي متن دابل کليک کنيد تا علامت چشمک‌زن در متن ظاهر 
شود.

2- با استفاده از كليد  Shift در محلي که مي‌خواهيد انتخاب متن تمام شود، کليک کنيد 
يا با کشيدن نشانگر ماوس روي متن، آن را به حالت انتخاب درآوريد.  

2-2-9 انتخاب کل متن 

توس��ط ابزار Pointer روي متن کليک کنيد تا دس��تگيره‌هاي کنترلي در اطراف آن ظاهر 
شود در اين صورت کل متن در حالت انتخاب قرار مي‌گيرد.

پ��س از انتخاب متن مي‌توانيد تنظيماتي نظير تغيير نوع و اندازه قلم را روي متن اعمال 
کنيد.

3-2-9 تنظيمات متن 

تغيير تنظيمات از طريق يکي از روش‌هاي ذکر ش��ده در بخش 3-1-9 انجام‌پذير اس��ت 
که به طور نمونه با اس��تفاده از پنل Object به توضيح آن مي‌پردازيم. توجه داشته باشيد که 

دکمه Character  در حالت انتخاب باشد.
• قلم‌   موردنظر را انتخاب  	Object در پنل Font  Nameتغيير نوع قلم: از منوي بازشوي

کنيد. تعداد ‌اين قلم‌ها به تعداد فونت‌هاي نصب شده در ويندوز بستگي دارند.  
• اندازه قلم را تعيين  	Object در پنل Type Size تغيير اندازه قلم: از منوي بازش��وي

کنيد.
 : Text از منوی Size نکته: در انتخاب گزینة 

• ( اندازه قلم یک سایز  	Ctrl + Shfit + , ( یا فش��ردن کلید smaller با اس��تفاده از گزینة
کوچکتر می شود.

• ( اندازه قلم یک سایز  	Ctrl + Shfit + . ( یا فش��ردن کلید smaller با اس��تفاده از گزینة
کوچکتر می شود.
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. • با استفاده از گزینة other برای تایپ اندازه دلخواه به کار می رود	

	
 

		                  شکل 7-9 تغيير اندازه قلم                  شکل 6-9 تغيير نوع قلم

مي‌توانيد ب��ا وارد کردن مق��دار مثبت يا منفي  • تغيي�ر فاصله بين ح�روف کلمات: 	
برحس��ب درصد در کادر Kerning واقع در پنل Object، فاصله بين حروف را افزايش 

يا کاهش دهيد.

شکل 9-8

•اگر دس��تگيره‌هاي کنترلي وسط در س��مت چپ يا راست کادر را بکشيد، مي‌توانيد  	
فاصله بين حروف متن )Kerning( را افزايش يا کاهش دهيد )شکل 9-9(.

شکل 9-9 تغيير فاصله بين حروف متن

 ، • 	Object در پنل Baseline Shift انتقال خط مبنا: با وارد کردن مقادير مثبت در کادر
حرف به بالاي خط مبناي مربوط به متن منتقل مي‌شود و مقادير منفي، حرف را به 
پايين خط مبنا انتقال مي‌دهد.شکل10-9 نحوه عملکرد اين کادر را نشان مي‌دهد.

شکل 9-10
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4-2-9 اعمال رنگ به متن

براي اين منظور عمليات زير را انجام دهيد:
1- متن موردنظر را انتخاب کنيد.

2- رنگ موردنظر را از ابزارهاي رنگ واقع در جعبه ابزار Tools برگزينيد.
اب��زارFill Color ، داخل متن و اب��زار Stroke Color، خطوط پيرامون متن را رنگ مي‌کند. 
براي مش��اهده تغييرات رنگ بهتر است اندازه متن را بزرگ کنيد )توضيحات بيشتر در مورد 

انواع روش‌هاي رنگ‌آميزي در واحد کار 7 ذکر شده است(. 

 مثال 1: براي بالا بردن توانايي عمليات روي متن، مراحل زير را انجام دهيد:
1- صفحه جديدي به اندازه A5 با واحد سانتي‌متر ايجاد کنيد.

2- نوار ابزار Text را نمايش دهيد.
3- قل��م Arial  را از من��وي Text→Font انتخ��اب کرده و اندازه 36 را ب��راي آن تعيين 

کنيد.
FreeHand MX is Vector based drawing                   .4- جمله روبه‌رو را تايپ کنيد

5- با استفاده از پنل Object سبک قلم را پررنگ )Bold( کنيد.
6- با استفاده از پنل Object فاصله ميان حروف کلمه FreeHand را 10% افزايش و کلمه 

Vector را 20-% کاهش دهيد، سپس به حالت اوليه بازگرديد.

7- کل سطر را در زير سطر جاري کپي کنيد.
8- ب��ا اس��تفاده از نوار ابزار Text ان��دازه قلم کلمه drawing س��طر دوم را به 14 کاهش 

دهيد.
 Object يا قلم نازک را از پنل Plain را از سطر اول انتخاب کرده و سبک Vector 9- کلمه

برگزينيد.

تمرين 1: براي كلمه "خرد" طراحي حروف كنيد.
 Text 3-9 منوي

با اس��تفاده از من��وي Text و زيرمنوهاي آن مي‌توانيد علاوه ب��ر تنظيمات مربوط به نوع 
فونت، اندازه، سبك )Style( و ترازبندي متن، جلوه‌هاي ويژه‌اي نيز به متن اعمال كنيد.
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)Text Effects( 1-3-9 جلوه‌هاي متن

در FreeHand MXa ب��راي زيبات��ر و هنري ش��دن کار از جلوه‌هاي ويژه متني اس��تفاده 
مي‌شود. روش‌هاي دسترسي به اين جلوه‌‌ها به صورت زير است:

• 	Text در منوي Effect استفاده از گزينه
• 	Object در پايين پنل Effect استفاده از منوي بازشوي

Object واقع در پنل Effect شکل 11-9 گزينه‌هاي موجود در منوي

Inline 1-1-3-9 جلوه
اين جلوه براي رسم خط يا قاب، دور حروف متن انتخابي به‌کار مي‌رود. گاهي در طراحي 
براي برجسته شدن متن يا تمايز بهتر حروف از زمينه زير آن، لازم است از اين جلوه استفاده 

شود.
ايجاد جلوه Inline روي متن

1- متن موردنظر را برگزينيد.
  Effectرا از منوي بازشوي Inline را انتخاب کنيد )گزينه Text→Effect→Inline 2- گزينه
 در پن��ل Object برگزيني��د.( تا کادر مح��اوره Inline Effect روي صفحه نمايش ظاهر ش��ود 

)شکل 9-12(.
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Inline Effect شکل 12-9 کادر محاوره

اين کادر شامل قسمت‌هاي زير است:
• Count: تعداد خطوطي را که در اطراف حروف متن قرار مي‌گيرد، تعيين مي‌کند.	

• Stroke: در اين قسمت ضخامت و رنگ خط دور متن تعيين مي‌شود.	

، فاصل��ه بين خط دور تا لبه حروف  • 	Width ب��ا اين گزينه در قس��مت :Background

تعيين مي‌ش��ود و با انتخاب رنگ در اين قس��مت، فضاي بين خط تا حروف از اين 
رنگ پر مي‌شود.

تمرين 2:
1- در چه صورت خط به دور حروف مي‌چسبد؟

2- متن شكل 13-9 را تايپ کنيد.

شکل 9-13

 Highlight 2-1-3-9 جلوه
اين جلوه يک کادر رنگي در پشت متن انتخابي قرار مي‌دهد که به منظور شاخص کردن 
متن ب��ه کار مي‌رود. با اجراي اين گزينه از مس��ير Text→Effect→Highlight، کادر محاوره 

مربوط به اين جلوه روي صفحه نمايش ظاهر مي‌شود )شکل 9-14(.
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شکل 14-9 کادر محاوره Highlight Effect  و دو نمونه کاربرد اين جلوه

اين کادر شامل قسمت‌هاي زير است:
• مح��ل قرار‌گيري کادر را در زير متن به صورت عددي تعيين کرده، اعداد  	:Position

مثب��ت ‌کادر را از مت��ن بالات��ر مي‌برد و اعداد منف��ي کادر را پايين‌ت��ر از متن قرار 
مي‌دهد.

اي��ن منوي بازش��و کادر رنگي زمينه را به صورت خطوط هاش��ور مش��خص  • 	 :Dash

مي‌کند.
توس��ط گزينه‌هاي اين قسمت مي‌توانيد ضخامت، رنگ پس‌زمينه يا هاشور  • 	 :Stroke

را تعيين کنيد.

 توجه: گزينه Overprint روشي است براي جبران خطاي ترکيب رنگ که در زمان 
چاپ رخ مي‌دهد.

 Shadow3-1-3-9 جلوه
يک��ي ‌ديگر از جلوه‌هاي ‌جالب��ي که مي‌توانيد روي‌ متن و حروف اعمال‌ کنيد، س��ايه‌دار 
‌کردن آن‌هاس��ت. با اجراي گزينه Text→Effect→Shadow کادرمحاوره Shadow Effect ظاهر 

مي‌شود )شکل 9-15(.

شکل 15-9 کادرمحاورهShadow Effect  و تأثير آن روي متن
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اين کادر شامل گزينه‌هاي زير است:
• محل دقيق قرار گرفتن سايه براساس محورهاي مختصات  	y و x در کادرهاي :Offset

تعيين مي‌شود.
• در اين قسمت رنگ سايه تعيين شده و توسط دکمه لغزنده ميزان تيرگي و  	:Color

روشني سايه تنظيم مي‌شود.
مثال 2: جلوه‌هاي نشان داده شده در شکل 16-9 را اعمال کنيد.

شکل 9-16

1- ابتدا متن را تايپ کنيد به طوري که اندازه قلم 120 باشد.
2- کل متن را انتخاب کرده و جلوه Highlight را با تنظيمات ش��کل 17-9 به آن اعمال 

کنيد.
3- ح��روف C و R را جداگان��ه انتخاب کرده، جلوه Shadow را همراه با تنظيمات ش��کل 

17-9 به آن‌ها اعمال کنيد.

شکل 9-17

 Strikethrough 4-1-3-9 جلوه
اين جلوه خطي رسم ميك‌ند كه از روي متن مي‌گذرد. 

با اجراي گزينه Text→Effect→Strikethrough کادر محاوره اين جلوه مطابق شکل 9-18 
نمايش داده مي‌شود كه در اين شکل، جلوه نقطه‌چين و خط، نشان داده شده است.      
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شکل 18-9 کادر محاوره Strikethrough Effect  و تأثير آن روي متن

اين کادر محاوره شامل قسمت‌هاي زير است:
• Position: محل قرار‌گيري خط را در روي متن تعيين مي‌کند.	

• Dash: نوع خط را تعيين مي‌کند.	

• Stroke: در اين قسمت ضخامت و رنگ خط تعيين مي‌شود.	

 Underline 5-1-3-9 جلوه
 از اـين جلــوه بــراي کشيدن خط در زير متن استفـاده مـي‌شود. بدين منظور کافي است گزينـه
"Text→Effect→Underline را انتخاب کنيد تا کادر محاوره آن مطابق شکل 19-9 ظاهر شود. در 

ش��کل 19-9 دو نوع جلوه زيرخط به صورت خط- نقطه و خط، نش��ان داده شده است. کليه 
گزينه‌هاي کنترلي اين کادر مانند تنظيمات کادر محاوره Strikethrough Effect است.

شکل 19-9 کادر محاوره Underline Effect  و تأثير آن روي متن

 Zoom 6-1-3-9 جلوه
يک��ي از جلوه‌هايي که تا حد زيادي در زيباي��ي متن و حروف در يک کار تبليغاتي تأثير 
مي‌گ��ذارد، جلوه Zoom اس��ت که اين جلوه به متن و عبارت حالت پرس��پكتيو س��ه بعدي 
مي‌بخشد. براي اعمال اين جلوه کافي است گزينه Text→Effect→Zoom را انتخاب کنيد تا 

کادر محاوره آن مطابق شکل 20-9 ظاهر شود.
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شکل 20-9 کادر محاوره Zoom Effect  و تأثير آن روي متن

اين کادر محاوره شامل قسمت‌هاي زير است:
کوچکي حالت سه ‌بعدي را برحسب در‌صد تعيين  • Zoom To: اين قس��مت بزرگي و 	

مي‌کند. به عبارت ديگر درصد بزرگنمايي و پخش‌شدگي جلوه سه بعدي را مشخص 
مي‌کند.

قرار دارند که توس��ط آن‌ه��ا مي‌توانيد محل  • 	 y و x در اي��ن قس��مت دو کادر :Offset

دقيق قرار‌گيري اين جلوه را تعيين کنيد. اعداد بزرگ‌تر به عمق س��ه بعدي حروف 
مي‌افزايد.

• From: اين قسمت رنگ شروع جلوه سه بعدي را مشخص مي‌کند.	

• To: اين قسمت رنگي را تعيين مي‌کند که جلوه سه بعدي به آن خاتمه ميي‌ابد. 	

رنگ در حالت پيش‌فرض از سياه به سفيد است.

 توج�ه: انتخاب گزينه None از مس��ير Text→Effect هر نوع جلوه متني را از بين 

مي‌برد.

تمرين 3:
1- مت��ن Working with text blocks را تايپ‌کرده، س��پس اثرجلوه‌هاي ‌متني ‌را روي ‌آن 

بررسي‌کنيد.
2- طرح زير را همراه با جلوه‌هاي متني آن رسم کنيد )شکل 9-21(.
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 شکل 9-21 

 Attach To Path2-3-9 گزينه
يکي از جلوه‌هاي هنري در طراحي، متصل کردن متن به مس��ير رس��م ش��ده اس��ت؛ از 
اين ويژگي براي پيچ و تاب دادن متون در مس��يرهاي منحني، بيضي و نظير اين‌ها اس��تفاده 

مي‌شود. براي اين منظور مراحل بعد را انجام دهيد:
1- متن موردنظر را تايپ کرده و به وسيله ابزار Pen مسير دلخواهي را روي ‌صفحه رسم 

کنيد )از اشکال دايره، بيضي، چند ضلعي و ... نيز مي‌توان استفاده کرد(.
2- ابتدا متن را انتخاب کرده، سپس کليد Shift را نگه داريد و مسير را برگزينيد.

3- دستورText→Attach To Path  را اجرا کنيد يا روي آيکن  از نوار ابزار Text کليک 
 کنيد. در اين صورت متن به مسير مي‌چسبد و با آن تراز مي‌شود و مسير حذف خواهد شد 

)شکل 9-22(.

شکل 22-9 نحوه اتصال متن به مسير     

 Text on a path در س��اختار درختي بخش Object نكت�ه: در صورت��ي كه در پنل 
را انتخاب كنيد، گزينه Show Path ظاهر مي‌ش��ود‏، ب��ا فعال كردن اين گزينه مي‌توانيد پس 
از اجراي فرمان Attach To Path مس��ير را همراه متن داشته باشيد و از حذف آن جلوگيري 

كنيد.

تمرين 4: طرح شكل 23-9 را رسم کنيد.
براي حرکت دادن متن در امتداد مس��ير، ابتدا با ابزار Pointer مسير را انتخاب کنيد؛ در 
اين صورت يک مثلث سفيد رنگ کوچک ظاهر مي‌شود. اکنون مي‌توانيد مثلث کنار متن را 

بکشيد تا متن در امتداد مسير حرکت کند.
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         شکل 23-9                               شکل 24-9 نمايش مثلث كنار متن

 نكته: کليد ميانبر گزينه Ctrl+Shift+Y ،Attach To Path است.

 Detach From Path3-3-9 گزينه

براي جدا كردن متن از مس��ير، فرمان Detach From Path در منوي Text يا آيکن  
در نوار ابزار Text را انتخاب كنيد.

 توجه: براي تغيير جهت متن در روي مسير كافي است كليد Alt را نگه داشته و با 

 Modify→Alter Path→Reverse Direction مسير را انتخاب كنيد سپس فرمان Pointer ابزار
را اجرا كنيد )شكل 9-25(.

شکل 25-9 تغيير جهت متن

 مثال 3: شکل 26-9 را رسم کنيد.
1- صفحه جديدي را باز کنيد.

2- عبارت زير را تايپ کنيد.
Macromedia Freehand MX With Attach To Path

3- ابزار رسم ستاره را انتخاب کرده و يک ستاره سه پر رسم کنيد.
4- اکن��ون روي ابزار Pointer کليک کرده و کليد Shift را پايين نگه داريد و روي متن و 

ستاره کليک کنيد تا هر دو انتخاب شوند.
5- ح��ال فرمان Attach To Path را از منوي Text يا از نوار ابزار Text اجرا کنيد. با انجام 
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اين عمل متن به مسير مي‌چسبد.

شکل 9-26

تمرين 5: آرم زير را طراحي کنيد.

 شکل 9-27 

تمرين 6: كي بروش��ور تبليغاتي در كاغذ A4 براي "هنرس��تان كاردانش گلشن" 
طراحي كنيد و آرم شكل 27-9 را در آن استفاده كنيد.

Convert To Path 4-3-9 گزينه

گاهي اوقات در هنگام طراحي لازم است يک متن از حالت نوشته خارج شده و به مسير 
يا ش��کل تبديل ش��ود. در اين صورت خصوصيات يک شکل را پيدا مي‌کند. براي اين منظور 

مراحل زير را انجام دهيد: 
1- متن موردنظر را تايپ کرده و آن را انتخاب کنيد.

2- از منوي Text گزينه Convert To Path يا آيکن  را از روي نوار ابزار Text انتخاب 
کنيد، در اين صورت متن به مسير يا موضوع تبديل مي‌شود )شکل 9-28(.

شکل 9-28
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 توجه: کليد ميانبر اين گزينه Ctrl+Shift+P  است.

 نكته: پس از تبديل متن به مس��ير، متن تمام خصوصيات متني خود را از دست 
مي‌دهد و ديگر قابل ويرايش )نظير تغيير قلم( نخواهد بود.

•ب��راي تغيير دادن و جابه‌جايي ح��روف به صورت جداگانه در مت��ن مي‌توانيد متن  	
 ungroup آن را Modify تبديل شده به مسير را انتخاب کرده، سپس از طريق منوي
ک��رده يا کليد Alt را در هنگام کليک روي هر مس��ير مج��زا نگه داريد تا يک حرف 

انتخاب شود، سپس بعد از اعمال تغييرات دوباره آن‌ها را Modify→Group کنيد. 
 تمرين 7: نشانه‌هاي بعدي را رسم کنيد.

شکل 9-29

Editor 5-3-9 گزينه

به منظور ويرايش متون و نوشته‌ها مي‌توانيد به دو صورت عمل کنيد: 
1- روي متن تايپ ش��ده توس��ط ابزار Pointer دابل کليک کنيد ت��ا علامت مکان‌نماي 

چشمک‌زن ظاهر شود، در اين صورت مي‌توانيد به اصلاح متن بپردازيد.
 Text روي متن کليک کنيد تا انتخاب ش��ود، س��پس از منوي Pointer 2- ابت��دا با ابزار
گزين��هEditor  را اجرا کنيد يا روي آيکن  از نوار ابزار Text کليک کنيد. در اين صورت 

کادر محاوره Text Editor ظاهر مي‌شود و مي‌توانيد متن را به سادگي ويرايش کنيد.
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 توجه: اگر به وس��يله ابزار انتخ��اب subselect  روي متن دابل کليک کنيد، کادر محاوره 

Text Editor  به‌طور خودکار باز مي‌شود.

• انتخاب ش��ود، متن به اندازه واقعي نمايش نميي‌ابد يعني در  	12Pt Black اگر گزينه
حقيقت متن کوچک مي‌شود تا تمامي آن در صفحه قابل مشاهده باشد.

• انتخاب ‌ش��ود، باعث نمايش کاراکتره��اي مجازي و  	Show Invisibles اگ��ر گزين��ه
غيرقابل‌چاپ مثل Space ،Tab و Enter مي‌شود )‌شکل 9-30(.

Text Editor شکل 30-9 محيط

 Flow Inside Path6-3-9 گزينه

از اين گزينه براي قرار دادن متن در داخل ش��کل يا درون يک مس��ير استفاده مي‌شود، 
به طوري که متن، قالب محيط شکل را به خود مي‌گيرد. اين جلوه بيشتر براي زيباتر کردن 

ترکيب‌بندي متن و شکل در طراحي کاتالوگ و بروشور به‌کار مي‌رود.
نحوه اجراي اين گزينه به صورت زير است: 
1- متن پاراگرافي دلخواهي را تايپ کنيد.

2- شکل يا مسيري را ترسيم کنيد.
3- شکل و متن موردنظر را با هم انتخاب کنيد.

4- از منوي Text گزينه Flow Inside Path يا آيکن  را از نوارابزار Text انتخاب ‌کنيد 
)شکل 9-31(.                             
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Flow Inside Path شکل 31-9 تأثير فرمان 

 توجه: کليد ميانبر اين گزينه Ctrl+Shift+U است.

نکاتي در مورد کادر لينک
ب��ه مربع کوچکي که در پايين، س��مت راس��ت کادر متن قرار گرفت��ه، کادر لينک گفته 

مي‌شود.
يک��ي از کاربردهاي آن زماني اس��ت که متن در کادر مت��ن جاي نمي‌گيرد و داخل کادر 
لين��ک داي��ره توپر قرار مي‌گي��رد. در اين حال��ت مي‌توانيد با کليک روي داي��ره توپر داخل 
کادر لينک و کش��يدن آن به طرف ش��کل ديگر، ادامه متن را در آن شکل وارد کنيد )شکل 

.)9-32

شکل 9-32

•در صورتي که کادر لينک سفيد باشد، نشان دهنده اين است که کل متن در شکل  	
جا گرفته و قابل مشاهده است )شکل 33-9 سمت راست(.

•در صورتي که يک دايره توپر در داخل کادر لينک وجود داش��ته باش��د نشانگر اين  	
است كه متن موجود در داخل کادر جا نمي‌گيرد يا به عبارتيOverflow  است )شکل 
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33-9 سمت چپ(.
‌در کادر لينک وجود داش��ته باش��د، نشانگر اين است که  • در صورتي که علامت 	

کادر به کادر يا شکل ديگري مرتبط يا لينک شده است )شکل بالا 9-32(.

         

شکل 9-33

تمرين 8: شكل زير را با استفاده از قابليت Flow Inside Path طراحي کنيد.

 

شکل 9-34

 Flow Around Selection 9-3-7

به منظور قرار دادن متن پاراگرافي در اطراف يک ش��کل رس��م ش��ده يا وارد شده به‌کار 
مي‌رود )شکل 9-35(. 
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Flow Around Selectionشکل 35-9 تأثير فرمان

روش کار به صورت زير است: 
1- ابزار تايپ را انتخاب کرده و با انجام عمل درگ يک کادر مستطيلي براي نوشتن متن 

پاراگرافي روي صفحه ايجاد کنيد، سپس متن موردنظر را  داخل آن تايپ كنيد.
2- يک تصوير را وارد FreeHand کرده يا يک ش��کل دلخواه را ترس��يم کنيد. بهتر است 
ش��کل را رنگ کنيد تا تغيير مشخص‌تر شود، سپس شکل را به محلي که قرار است در متن 

قرار گيرد، منتقل کنيد. توجه داشته باشيد كه شكل جلوي بلوك متني قرار گيرد.
 Flow Around Selection فرمان Text 3- متن و ش��کل را با هم انتخاب کرده و از منوي
 را برگزيني��د ي��ا روي ‌آيکن در نوار ‌ابزار Text کليک‌ کني��د. در ‌اين ‌صورت کادرمحاوره

Flow Around Selection ظاهر مي‌شود.

4- در ب��الاي اي��ن کادر محاوره دو دکمه براي تعيين وضعيت قرارگيري ش��کل در متن 
و ح��ذف اين ويژگي وجود دارد. در اين کادر مي‌توانيد با انتخاب آيکن Text Wrap )س��مت 
راست( و با استفاده از کادرهاي موجود در قسمت  Standoff)فاصله متن از شكل( فاصله‌هاي 

چپ، راست، بالا و پايين متن از شكل را تعيين كنيد )شکل 9-36(.
5- روي‌دكمه OK كليك‌كنيد. متن به‌طور خودكار در‌ اطراف ‌ش��كل قرارمي‌گيرد )شكل 

.)9-35

 توجه: براي حذف اين ويژگي ابتدا موضوع را انتخاب کنيد، سپس از کادر محاوره

Flow Around Selection دکمه Remove Text Wrap را برگزينيد.
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Flow Around Selection شکل 36-9 کادر محاوره

Remove Transforms 9-3-8

 اجراي گزينه Text→Remove Transforms سبب حذف برخي از جلوه‌هاي متن انتخابي نظير
Attach To Path و Flow Inside Path مي‌ش��ود و مت��ن ب��ه حال��ت اوليه خ��ود باز مي‌گردد. 

 Scale ،Skew ،Rotate اعمال شده به متن مانند )Transform( همچنين همه تغيير شكل‌هاي
و Reflect بجز Move را حذف ميك‌ند.

براي انجام اين عمل مراحل زير را پيگيري كنيد:
1- با استفاده از ابزار Pointer بلوك متني را انتخاب كنيد.

2- گزينه Remove Transforms  را از منوي Text برگزينيد.

 Remove هايي ك��ه در جعبه ابزار وجود دارد ب��ا فرمانTransform نكت�ه: كلي��ه 
Transforms حذف مي‌شود.

Special Characters 9-3-9

درج كاراكترهاي ويژه در هنگام تايپ متن سبب كنترل نماي متن مي‌شود.

شکل 9-37

براي استفاده از كاراكترهاي ويژه مراحل بعد را انجام دهيد:
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1- در محل مورد نظر در متن، كليك كنيد تا نقطه درج مشخص شود.
2- گزينــه Text→Special Character را انتخاب كرده ســپس از زير منوي ظاهر شــده 

كاراكتر ويژه را برگزينيد.
Spelling 10-3-9 گزينه

اگر بخواهيد اطمينان يابيد كه متن سند موردنظر از لحاظ املايي صحيح است، مي‌توانيد 
.)Text→Spelling(استفاده نماييد )Spelling( از غلط‌گير كلمات تايپ شده

شكل 9-38
Leading 11-3-9 فرمان

گاهــي بــراي زيبايي متن يا کمبود فضا لازم اســت به تنظيم فاصله ســطرها در متون 
پاراگرافــي بپردازيــد. براي اين منظــور از منوي Text  گزينــه Leading  را انتخاب کنيد يا 
دستگيره‌هاي کنترلي وسط در سمت بالا يا پايين کادر انتخاب متن را بکشيد تا فاصله بين 

       			  سطرها کاهش يا افزايش يابد.

شکل 9-39

در اين گزينه سه زيرمجموعه به صورت زير وجود دارد:
• Solid: با توجه به ‌اندازه‌ فونت انتخاب شده در‌متن‌جاري، فاصله را به‌صورت ‌خودکار 	

تنظيم ‌ميک‌ند. 
• Auto: فاصله سطرها را 120% بيشتر از حالت Solid در نظر مي‌گيرد.	
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• ظاهر مي‌شود  Other: با انتخاب اين گزينه کادر محاوره Leading مطابق شکل 9-40	

که مي‌توان با اس��تفاده از گزينه‌هاي منوي بازش��وي آن براي س��طرها فاصله ايجاد 
کرد.

شکل 9-40

• به ميزان عدد وارد شده، به فاصله سطرها مي‌افزايد. اين گزينه معادل  	:Extra گزينه
علامت + در نوار ابزار Text  است.

• فاصله س��طرها را دقيقاً بر اس��اس عدد وارد شده تنظيم مي‌کند. اين  	:Fixed گزينه
گزينه نيز معادل علامت = در نوار ابزار Text  است.

 • گزين�ه Percentage: فاصل��ه را 100% در نظر مي‌گيرد. اع��داد کوچک‌تر از %100	
باع��ث کاهش فاصله و اعداد بزرگ‌تر از 100% منجر به افزايش فاصله س��طر جاري 

مي‌شوند. اين گزينه معادل علامت % در نوار ابزار Text  است.

 نكت�ه: از گزين��ه Leading  در پنل Object  مربوط به Text نيز براي تغيير فاصله 
بين خطوط متن استفاده مي‌شود )شکل 9-41(.

شكل 9-41

Convert Case 12-3-9 فرمان

ب��ه کم��ک اين گزينه مي‌توانيد حالت حروف انگليس��ي را از بزرگ به کوچک يا برعکس 
تبدي��ل کني��د. اين تبديل مي‌توان��د روي همه حروف صورت گيرد ي��ا از قواعد جدول 9-1 

پيروي کند. 
گزينه Convert Case را از منوي Text انتخاب کنيد. منو شامل اين زيرمجموعه‌هاست:
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جدول 9-1

 Upper.کل حروف متن انتخاب شده را به حروف بزرگ انگليسي تبديل مي‌کند

 Lower.کل حروف متن انتخاب شده را به حروف کوچک انگليسي تبديل مي‌کند

Small Caps
حروف کوچک متن انتخاب شده را به حروف بزرگ با اندازه کوچک تبديل مي‌کند )به طور 

پيش‌فرض 75% اندازه فونت جاري است(.

 Title.حروف ابتداي همه کلمات را در متن انتخاب شده به حروف بزرگ تبديل مي‌کند

 Sentence
متن انتخاب شده را به عنوان يک جمله در نظر مي‌گيرد و فقط حرف اول جمله را به حرف 

بزرگ تبديل مي‌کند.

Settings
در اين گزينه مي‌توان توسط دکمه Add کلمه‌اي را وارد ليست کرد تا در صورت تغييرات متن 

توسط گزينه Convert Case بدون تغيير باقي ‌بماند و کلمه‌ موردنظر تغيير نکند.

             

تمرين 9:
1- جملات زير را تايپ کنيد.

To copy from another application and paste into FreeHand,
to specify a size for small caps.                                        

2- حرف اول کلمات دوم و پنجم سطر اول را به حروف بزرگ تبديل کنيد.
3- کليه حروف کلمهFreeHand  را به حروف بزرگ تبديل کنيد.

4- نخستين حرف کلمه اول سطر دوم را به حرف بزرگ تبديل کنيد.
5- ح��روف ابت��داي کلمات س��طر دوم را بجز کلمهsize  و caps به ح��روف بزرگ تبديل 

کنيد.
6- فاصله بين 2 سطر را دقيقاً 40 تعيين کنيد.

Object در پنل Text Block 9-4
در صورتي كه متني نوش��ته باش��يد در پنلObject  بخش��ي به نام  Text Blockبه صورت 
س��اختار درختي نمايان مي‌ش��ود. با كليك روي اين بخش، كنترل‌هايText Block  مطابق با 

شكل 42-9 نشان داده مي‌شوند.
فيلدهاي Dimensions به صورت زير تنظيم مي‌شوند:

• l: موقعيت لبه چپ بلوك متني را كنترل ميك‌ند.	
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• t: موقعيت لبه بالايي بلوك متني را كنترل ميك‌ند.	
اين فيلدها به شما امكان مي‌دهند تا بلوك متني را به محل خاصي جابه‌جا كنيد.

عرض بلوك متني را تنظيم ميك‌ند. • 	 :w
ارتفاع بلوك متني را تنظيم ميك‌ند. • 	 :h

اين فيلدها براي تغيير اندازه بلوك متني به كار مي‌روند.
اگر به بلوك متن حاش��يه داده‌ايد براي اضافه كردن فضاي س��فيد بين متن و حاشيه از 

قسمت Inset استفاده كنيد. 

Object در پنل  Block Text  9-42شکل

left( l( از س��مت چپ، t )top( بالا، r )right( س��مت راس��ت و b )bottom( پايين حاشيه 
ايجاد ميك‌ند.

 : وقتي اين آكين برجس��ته است يعني در حالت انتخاب نيست، براي تنظيم عرض 
بلوك متني در حالت اندازه ثابت )Fixed-Size( به كار مي‌رود.

وقتي اين آكين به صورت فرورفته يعني در حالت انتخاب است، براي تنظيم عرض بلوك 
متني در حالت گسترش خودكار )Auto-Expand( استفاده مي‌شود.

 : وقتي اين آكين برجسته است و در حالت انتخاب نيست، براي تنظيم ارتفاع بلوك 
متني در حالت اندازه ثابت )Fixed-Size( به كار مي‌رود.

وقت��ي اين آكي��ن در حالت فرورفته و در وضعيت انتخاب ق��رار دارد، براي تنظيم ارتفاع 
بلوك متني در حالت گسترش خودكار )Auto-Expand( استفاده مي‌شود.

• به شما امكان مي‌دهد كه حاشيه بلوك متن  	Display border فعال بودن كادر علامت
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را مشاهده كنيد ولي خط دور )Stroke( ايجاد نميك‌ند.

 توجه: براي اعمال حاش��يه به بلوك متني انتخاب شده، روي Add Stroke در پنل

Object  كليك كنيد، سپس كيي از انواع خط دور را براي حاشيه برگزينيد.

FreeHand MXa 5-9 فارسي‌نويسي در
يکي از مسايلي که کاربران فارسي زبان FreeHand با آن مواجه هستند؛ نوشتن متون به 

زبان فارسي است، زيرا در اين برنامه امکان فارسي‌نويسي وجود ندارد.
براي فارسي نوشتن در FreeHand MX ابتدا بايد در يک برنامه فارسي‌نويس، متن موردنظر 

.)Paste( بچسبانيد FreeHand را تايپ کنيد، سپس متن را کپي کرده و در
براي اين منظور مراحل زير را دنبال کنيد:

1- برنامه فارسي‌ساز را اجرا کنيد و متن موردنظر را تايپ کنيد )شکل 9-43(.
2- متن تايپ شده را انتخاب کرده و آن را کپي )Ctrl+C( کنيد.

3- برنامه FreeHand را باز کرده و ابزار تايپ متن را از جعبه ابزار انتخاب کنيد.
4- روي صفحه کليک کنيد تا علامت مکان‌نماي چشمک‌زن ظاهر شود، اکنون متن کپي 

.)Ctrl+V( شده را در صفحه بچسبانيد
توجه داش��ته باشيد که نام فونت در FreeHand بايد همان نام فونت در برنامه فارسي‌ساز 

باشد.

شکل 9-43  



Free Hand پیمانه مهارتی : کاربر
247واحد کار نهم: توانایی کار با متن 

FreeHand MX شکل 44-9 نمايش متن فارسي در محيط 

 مث�ال كاربردي: در ادامه مثال كاربردي واحد كار پيش��ين مراحل زير را انجام 
دهيد:

1- فايل Project.fh11 را باز كنيد.
2- با اس��تفاده از ابزار Text عبارت متني ش��كل را در كارت به رنگ دلخواه تايپ كنيد، 

سپس آدرس و تلفن مورد نظر خود را در كارت وارد كنيد.
3- فايل را ذخيره کنيد.                                                           

شكل 9-45
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واژه‌نامه
Attachمتصل‌کردن، الصاق‌کردن

Effectجلوه

Pathمسير

Plainساده، عادي

Positionموقعيت

Spellهجيك‌ردن

Specialمخصوص، ويژه

	
	
	

خلاصه مطالب 
• مي‌توانيد از قابليت تايپ متن به عنوان يک برنامه واژه‌پرداز  	FreeHand به‌طور‌کلي در

يا يک برنامه صفحه‌بندي استفاده کنيد.
•موارد زير از قابليت‌هاي اين نرم‌افزار براي انجام عمليات روي متن است: 	

• تغيير تنظيمات متن از جمله اندازه و نوع قلم 	
• 	)Leading( تغيير فاصله بين حروف و سطرها
• 	Effect ايجاد جلوه‌هاي متني با استفاده از گزينه
• 	)Attach To Path( قرار دادن متن در داخل يا خارج يک مسير
• 	)Flow Inside Path( قرار دادن متن در داخل يک موضوع يا مسير
• 	 )Convert To Path( تبديل متن انتخابي به موضوع يا مسير
• 	)Special Characters( درج كاراكترهاي ويژه در متن
• 	)Spelling( غلط‌گيري كلمات تايپ شده
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- گزينه Leading از نوار ابزار Text، براي تغيير نوع قلم به کار مي‌رود.
2- جلوه Zoom براي سه بعدي کردن حروف در متن به كار مي‌رود.

Spelling -3 بررسي ميك‌ند كه متن سند موردنظر از لحاظ املايي صحيح است يا خير.

En Dash -4 فاصله‌اي معادل نصف عرض اندازه فونت در متن درج ميك‌ند.

معادل گزينه هاي سمت ‌راست را از ستون سمت ‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

                                Flow Around Selection                     .است  FreeHand 5- ويرايشگر متن در برنامه
Attach To Path          .6- جلوه‌هاي متني را حذف و آن را به حالت اوليه برمي‌گرداند
Remove Transform                                     .7-  متن را روي مسير قرار مي‌دهد

 Text Editor                                     .8- متن را در اطراف كي مسير قرار مي‌دهد
گزينه صحيح را انتخاب کنيد.

9-گزينه Strikethrough چه کاربردي دارد؟
ب- در روي متن خط رسم مي‌کند. الف- در زير متن  خط ايجاد مي‌کند.	

د- متن را به مسير مي‌چسباند. ج- در پشت متن خط رسم مي‌کند.	
10-گزينه Plain در بخش Text از پنل Object چه عملي را انجام مي‌دهد؟
ب- ايجاد سبک مايل براي قلم  الف- ايجاد سبک پر رنگ براي قلم 	

د- ايجاد سبک مايل و پررنگ براي قلم ج- ايجاد سبک قلم نازک و معمولي	
11- براي چسباندن متن به يک مسير منحني از کدام فرمان استفاده مي‌شود؟

Text از منوي Attach To Path -ب              	Edit از منوي Pointer -الف
د- کشيدن متن روي مسير	 	Text از منوي Detach From Path -ج

12- ک��دام گزينه به منظ��ور ايجاد فاصله بين س��طرها با مقدار دلخواه کاربر اس��تفاده 
مي‌‌شود؟

 Text→Leading→Solid -ب       	 Text→Leading→Other -الف
Text→Leading→Settings -د          	Text→Leading→Auto -ج

13- کدامي‌ک از جلوه‌هاي زير براي حروف متن سايه ايجاد مي‌کند؟
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Shadow -د           	Highlight -ج  	Zoom -ب     	 Inline -الف
14- کدام گزينه براي قرار دادن متن درون يک مسير بسته استفاده مي‌شود؟

 Ctrl+Shift+U -ب 	  Flow Inside Path -الف
د- گزينه‌هاي الف و ب صحيح هستند. 		 Attach  To Path -ج

15- فرمان Convert Case  در منوي Text به چه منظور استفاده مي‌شود؟
الف- تنظيم فاصله سطرها در متن پاراگرافي

ب- تبديل نوع کلمات متن
ج- تبديل حروف کوچک و بزرگ به يکديگر در متون انگليسي

د- تبديل مسير به متن 
16- گزينه Title در Convert Case چه کاربردي دارد؟

الف- براي بزرگ کردن حروف با اندازه کوچک استفاده مي‌شود. 
ب- حرف اول همه كلمات متن انتخابي را بزرگ و بقيه را کوچک مي‌کند.

ج- حروف متن انتخابي را به حروف کوچک تبديل مي‌کند.
د- حرف اول جملات را بزرگ مي‌کند.

17- گزين��ه .............. ح��رف اول جم�الت را ب��زرگ و بقيه را به ح��روف کوچک تبديل 
مي‌کند.

Sentence -ب           		   Upper -الف
Lower -د 	                     Small Caps -ج

در جاي خالي عبارت مناسب را بنويسيد.

 Leading 18- علام��ت % در ايجاد فاصله بين س��طرها مع��ادل ................... از گزينه‌هاي
است.

19- گزينه Convert To Path  ..............................  تبديل ميك‌ند.
به سؤالات زير پاسخ تشريحی دهيد.

FreeHand MX -20 از چند طريق خصوصيات متون را کنترل مي‌کند؟

Stroke Color -21 در متن چه کاربردي دارد؟

22- آيا تغيير اندازه متني که به مسير تبديل شده، تأثيري در کيفيت آن دارد؟ چرا؟
23- گزين��ه Fixed چگون��ه فاصل��ه بين س��طرها را تنظيم مي‌کند و از چ��ه طريق قابل 
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دستيابي است؟
24- کدام جلوه به متن حالت س��ه بعدي مي‌دهد و آيا جلوه‌هاي ويژه )Effect( علاوه بر 

متون براي ساير موضوعات نيز قابل اجراست؟
آزمون عملي

1- نشانه‌هاي زير را ترسيم کنيد.

 

2- كي جلد مجله با مشخصات زير طراحي كنيد.
مجله علمي به نام "راهي به سوي فردا" در كاغذ A4 طراحي كنيد.

•با رعايت نكات صفحه‌آرايي، نام مجله، تعداد صفحه، قيمت، ش��ماره چاپ و دو مورد  	
از عناوين مقالات داخل مجله را در محل مناسب روي جلد بنويسيد.

•كي نشانه مرتبط با موضوع مجله نيز براي آن طراحي كنيد و در محل مناسب قرار  	
دهيد.
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كليات
در اين واحد کار به بررس��ي امکانات ويرايشي   FreeHand و تکنيک‌هاي اصلاح ترسيمات 
خواهيم پرداخت. عمليات اصلاحي نه تنها پس از پايان ترس��يم مورد استفاده قرار مي‌گيرد، 
بلک��ه در حي��ن انجام کار نيز به آن نياز پيدا خواهيد ک��رد چون با کپي کردن، ادغام و برش 
زدن اجزاي موجود مي‌توان به س��رعت اجزاي ديگر را ايجاد کرد، بدون اين که مس��تقيماً به 

ترسيم آن‌ها بپردازيم.
Group 1-10 گزينه

هنگامي‌که توس��ط ابزارهاي ترسيمي اش��کالي را ايجاد مي‌کنيد، اجزاي اين شکل‌ها هر 
يک منفرد بوده و مس��تقلًا قابل ويرايش يا جابه‌جايي هس��تند. ش��ما مي‌توانيد براي‌ حفظ 
ش��کل موضوع گرافيکي، جا‌به‌جايي دقيق تمامي عناصر يا انتخاب راحت‌تر موضوعات، آن‌ها 

را گروه‌بندي کنيد.
1-1-10 گروه‌بندي موضوعات

1- موضوع موردنظر را توسط ابزار Pointer انتخاب کنيد )شکل 10-1(.
2- فرمانModify→Group  را اجرا کنيد، در اين صورت اش��کال به جاي گره‌هاي متعدد 

و مجزا داراي چهار گره مي‌شوند )شکل 10-2(.

     

 شکل 1-10 انتخاب شکل       شکل 2-10 گروه‌بندي يک شکل

 نكته: با کليد ترکيبي Ctrl+G نيز مي‌توان موضوعات گرافيکي را گروه‌بندي  کرد.
وقتي يک موضوع گروه‌بندي ش��ده را انتخاب مي‌کنيد، اهرم‌هاي کنترلي در اطراف کل 
گروه ظاهر مي‌شوند و امکان تغيير اندازه، جابه‌جايي و تکثير کل اشکال گروه شده را فراهم 
مي‌کنند. در اين حالت نيز با ابزار Subselect مي‌توان قس��متي از اجزاي يک گروه را انتخاب 

کرد.
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 نكت�ه: به منظور لغو گروه‌بندي كي موضوع فرم��ان Modify→Ungroup را اجرا 
كنيد.

 مثال 1: 
1- سه شکل ساده رسم کنيد.

2- توسط ابزارPointer  و نگه داشتن کليد Shift هر سه شکل را انتخاب کنيد.
3- فرمان Modify→Group  را اجرا کنيد تا همه ترسيمات در قالب يک موضوع واحد با 

هم در يک گروه قرار ‌گيرند.
تمرين 1:

1- اش��کال 3-10 را رسم کرده، س��پس هر کدام را به‌صورت جداگانه در يک گروه قرار 
دهيد.

شکل 10-3

Ungroup 2-10 گزينه
درصورتي‌که موضوعات را در يک گروه قرار داده باشيد، به‌طور مجزا قابل انتخاب نيستند. 
ممکن است بخواهيد آن‌ها را تغيير داده و روي جزييات آن‌ها بيشتر کار کنيد، بنابراين براي 
انتخاب و جداس��ازي قسمت‌هاي مختلف موضوع مورد نظر بايد آن‌ها را از حالت گروه خارج 

.  )Modify→Ungroup(كنيد
تمرين 2:

1- آرمي نظير شکل 4-10 رسم کنيد. 

شکل 10-4 
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2- تمام شکل را انتخاب کرده و تصوير را گروه‌بندي کنيد.
3- يک کپي از تصوير را 60 درجه بچرخانيد.

4- تصوير را از حالت گروه خارج کرده و رنگ گوش��ه بالاي س��مت راست تصوير را قرمز 
کنيد. 

 Lock 3-10 گزينه
گاهي اوقات که چندين موضوع روي يکديگر يا درون هم رسم شده‌اند، هنگام انتخاب، به 
اش��تباه انتخاب مي‌شوند. براي جلوگيري از اين امر، برخي از موضوعات بايد به طور ثابت در 
صفحه قرار گيرند تا امکان تغيير مکان يا ويرايش نداشته باشند. براي رسيدن به اين هدف، 
مي‌توانيد موضوع گرافيکي را قفل کنيد. هدف از اين کار، جابه‌جا نش��دن موضوع و اطمينان 

از عدم انتقال و ويرايش آن است.
1-3-10 قفل کردن يک موضوع گرافيکي

1- موضوعي را که مي‌خواهيد قفل شود، انتخاب کنيد.
2- فرمانModify→Lock  را اجرا کنيد. آيکن  )Lock( در نوار ابزارInfo  نشان‌مي‌دهد 

که موضوع قفل شده است. 
موضوعات گرافيکي قفل شده فقط قابل انتخاب و كپي هستند.

 نكته: با کليد ترکيبي Ctrl+L مي‌توان موضوعات گرافيکي را در صفحه قفل کرد.

 مثال 2: شکل 5-10 را رسم کنيد.
1- ابتدا تصوير سيب را به همراه سايه آن رسم کنيد.

2- براي تغيير ش��کل دقيق س��ايه، تصوير اصلي را انتخاب کرده و سپس با فشردن کليد 
ترکيبي Ctrl+L، آن را قفل کنيد.

شکل 10-5
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 Unlock4-10 گزينه
اگر بخواهيد روي موضوعات گرافيکي قفل شده، ويرايشي انجام دهيد، بايد آن را از حالت 

قفل خارج کنيد.
1-4-10 خارج کردن قفل يک موضوع گرافيکي

1- موضوعي را که مي‌خواهيد از حالت قفل خارج شود، انتخاب کنيد.
2- فرمانModify→Unlock  را اجرا کنيد. 

 نكت�ه: با کليد ترکيبي Ctrl+Shift+L مي‌توان موضوعات گرافيکي را از حالت قفل 
خارج کرد.

Join 5-10 گزينه
معمولاً خطوطي که پش��ت سرهم با ابزارLine  ترسيم مي‌شوند، باز هستند. در اين مواقع 

براي اتصال دو پاره‌خط به يکديگر، از فرمانJoin  استفاده مي‌شود.
همچنين براي اين که دو يا چند مس��ير به صورت واحد يا اصطلاحاً يک مس��ير تركيبي 

درآيند، مي‌توانيد از فرمان Join  استفاده کنيد.
1-5-10 اتصال دو پاره‌خط به يکديگر 

1- دو پاره‌خطي را که مي‌خواهيد به هم متصل شوند، انتخاب کنيد.
2- فرمانModify→Join  را اجرا کنيد.

        

  شکل 6-10 انتخاب دو پاره‌خط      شکل 7-10 اتصال دو پاره‌خط

2-5-10 ايجاد يک مسير تركيبي 

1- مس��يرهاي گرافيکي را که مي‌خواهيد به صورت واحد درآيند، انتخاب کنيد )ش��کل 
.)10-8

  

   شکل 8-10 انتخاب مسير

2- فرم��انModify→Join  را اجرا کنيد، در صورتي كه مس��ير مرکب، روي هم افتادگي 
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داشته باشد مي‌توان نوع هم‌پوشاني بخش‌هاي روي هم افتاده را با گزينه Even/odd fill واقع 
در پنل Object کنترل کرد )شکل 10-9(.

شکل 9-10 ايجاد مسير تركيبي

 توج�ه: رن��گ مس��ير تركيبي از رنگ اولين مس��ير تبعيت مي‌کند. اولين مس��ير 
موضوعي است که قبل از همه ترسيم شده است.

 نكته: با کليد ترکيبي Ctrl+J مي‌توان عمل اتصال را انجام داد.

تمرين 3: چند مس��ير رسم کرده و داخل آن‌ها را با رنگ‌هاي متفاوت پر کنيد، 
سپس آن‌ها را به صورت مسير تركيبي درآوريد و به رنگ مسير مرکب دقت کنيد. 

Split 6-10 گزينه
از اين گزينه براي شکس��تن موضوعات بس��ته، جدا کردن گره‌ها از يکديگر، جدا کردن 
خطوط به هم چس��بيده‌اي که با ابزار Pen و Bezigon ترسيم شده‌اند و جدا کردن موضوعات 

Join شده، استفاده مي‌شود.

1-6-10 جدا کردن دو پاره‌خط از يکديگر

 1- با ابزار Pointer روي نقطه اتصال‌دهنده دو خط )گره( کليک ‌کنيد تا گره انتخاب شود
)ش��کل 10-10(. وقت��ي يک گره انتخاب مي‌ش��ود، به صورت چهارگ��وش توخالي يا دايره 

توخالي ديده مي‌شود.
2- فرم��انModify→Split  را اجرا کني��د. پاره‌خط‌ها در نقاط عطف )همان گره‌ها( از هم 

جدا مي‌شوند )شکل 10-11(.

            

Split شکل 10-10 انتخاب گره                شکل 11-10 جدا کردن خطوط‌ متصل با فرمان



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
258

3- سپس در فضاي خالي كليك و بعد گره‌ها را از هم جدا كنيد.
4- حال مي‌توانيد هر پاره‌خط را به تنهايي ويرايش کنيد.

 
 نكته: با کليد ترکيبي Ctrl+Shift+J مي‌توان عمل Split  را انجام داد.

Arrange 7-10 فرمان
فرمان Arrange که در منويModify  قرار دارد، براي تعيين‌ موقعيت موضوعاتي که روي 

يکديگر قرار مي‌گيرند، استفاده مي‌شود و داراي چهار گزينه است:
• ب��راي ق��رار دادن موض��وع انتخابي روي تم��ام موضوعات به کار  	:Bring To Front

مي‌رود.
• موض��وع انتخ��اب ش��ده را به ان��دازه يک موضوع ب��ه جلو انتقال  	:Move Forward

مي‌دهد.
• موضوع يا موضوعات انتخاب شده را به اندازه يک موضوع به عقب  	:Move Backward

مي‌برد.
• موض��وع ي��ا موضوعات انتخاب ش��ده را زير تم��ام موضوعات قرار  	:Send To Back

مي‌دهد.
Align 8-10 گزينه

به وس��يله اين گزينه مي‌توانيد چندين موضوع را نس��بت به هم يا نس��بت به صفحه در 
راستاي دلخواه قرار دهيد، به طوري که نسبت به يکديگر مرتب و هم تراز به نظر برسند.

Align 1-8-10 استفاده از زير منوي

1- موضوعاتي را که مي‌خواهيد هم تراز شوند، مطابق شکل 12-10 انتخاب کنيد.

شکل 12-10 انتخاب اشکال

2- در زير منوي حاصل از اجراي فرمان Modify→Align يکي از گزينه‌هاي زير را انتخاب 
کنيد:
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• تمام موضوعات انتخاب شده را نسبت به بالاترين شکل و از بالا با هم تراز مي‌کند  	:Top 

)شکل 10-13(.
• تمام موضوعات انتخاب شده را نسبت به پايين‌ترين شکل و از پايين با هم  	:Bottom

تراز مي‌کند )شکل 10-14(.

                                  

	Bottom شکل 14-10 اعمال گزينه              Top شکل 13-10 اعمال گزينه                   

• خ��ط افقي مرکزي را نس��بت به بالاترين و پايين‌ترين لبه‌هاي  	:Center Horizontal

تصاوير مش��خص ک��رده و تمام موضوعات انتخاب ش��ده را در جهت افقي هم مرکز 
مي‌کند )شکل 10-15(.

• خط عمودي مرکزي را نسبت به منتهي‌اليه لبه‌هاي راست و چپ  	:Center Vertical

تصاوي��ر تعيين کرده و تمام موضوعات انتخاب ش��ده را در جهت عمودي هم مرکز 
مي‌کند )شکل 10-16(.

                    	                         

Center Vertical شکل 16-10 اعمال گزينه     Center Horizontal  شکل 15-10 اعمال گزينه          

• تمام موضوعات انتخاب شده را نسبت به اولين تصوير از سمت چپ و در امتداد  	:Left

لبه چپ، با هم تراز مي‌کند )شکل 10-17(.
• تمام موضوعات انتخاب ش��ده را نس��بت به اولين تصوير از سمت راست و در  	:Right

امتداد لبه راست، باهم تراز مي‌کند )شکل 10-18(.

      		                                    

Right شکل 18-10 اعمال گزينه             Left شکل 17-10 اعمال گزينه

تمرين 4: اش��کال 19-10 را رس��م کرده و آن‌ها را نس��بت به هم، تراز راس��ت 
کنيد.
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شکل 10-19

Align 2-8-10 استفاده از پنل

1- موضوعاتي را که مي‌خواهيد هم تراز شوند، انتخاب کنيد.
2- گزينه Align را از منوي Window برگزينيد تا پنلAlign  مطابق شکل 20-10 ظاهر 

شود.

Align شکل 20-10 پنل

3- ب��ا اس��تفاده از من��وي بازش��وي Horizontal مطابق ش��کل 21-10، هم‌ترازي افقي 
موضوعات را تنظيم کنيد. 

4- ب��ا اس��تفاده از منوي بازش��وي Vertical مطابق ش��کل 22-10، هم‌ت��رازي عمودي 
موضوعات را تنظيم کنيد.

5- اگ��ر مي‌خواهي��د موضوعات با صفحه هم‌تراز ش��وند، گزين��ه Align to page را فعال 
کنيد.

6- روي دکمه Apply کليک کنيد تا موضوعات به محل مورد‌نظر انتقال يابند.
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شکل 21-10 گزينه‌هاي موجود در منوي 

  Horizontal بازشوي

شکل 22-10 گزينه‌هاي موجود در منوي 

  Vertical بازشوي

 مثال 3: شكل 23-10 را رسم كرده و نسبت به هم كاملًا هم مركز كنيد.
1- براي اينك‌ه دايره‌ها هم مركز شوند ابتدا آن‌ها را انتخاب كنيد.

2- از منويWindow  گزينه Align را برگزينيد.                                        

شكل 10-23

 Horizontal 3- سپس از كادر محاوره ظاهر شده مطابق شكل 24-10 در منوي بازشوي
و Vertical گزينه Align center را انتخاب كنيد.

4- پس از انجام تنظيمات، شكل 23-10 به صورت زير تراز مي‌‌شود )شكل 10-25(.
           

             

Align شكل 25-10 هم ‌ترازي از طريق پنل                 Align شكل 24-10 كادر محاوره        



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
262

 )Transform( 9-10 تغيير در اشياء
هنگامي كه كي ش��ئ را ايجاد ميك‌نيد ممكن اس��ت بخواهيد شكل آن را تغيير دهيد. با 

جابه‌جايي و تغيير شكل اشياء مي‌توانيد شكل‌هاي ساده را به پيچيده تبديل كنيد.
در FreeHand روش‌هاي متنوعي براي تغييرش��كل اش��ياء وجود دارد، نظير تغيير شكل 
به‌صورت دس��تي يا وارد كردن مقادير عددي براي به‌دس��ت آوردن نتايج دقيق‌تر كه در اين 

بخش به بررسي آن‌ها مي‌پردازيم.
 )Scale( 1-9-10 تغيير مقياس

براي ‌ايجاد تغيير ‌در‌ مقياس يا اندازه موضوعات س��ه روش وجود دارد که برحس��ب نياز 
مي‌توان از آن‌ها استفاده کرد.

Scale استفاده از ابزار
اين ابزار واقع در مجموعه ابزار Rotate در جعبه ابزار قرار دارد.

 نكته: استفاده از كليد Shift  هنگام تغيير مقياس باعث مي‌شود که تناسب شکل 
به هم نخورد.

Pointer استفاده از ابزار
1- توس��ط ابزار Pointer روي موضوع دابل کليک کنيد تا دس��تگيره‌هاي تغيير مقياس 

)اندازه( ظاهر شوند.
2- با درگ ماوس به داخل يا خارج، شکل را کوچک يا بزرگ کنيد.

 Transform استفاده از پنل
1- موضوع موردنظر را انتخاب کنيد.

2- از منوي Window پنل Transform را انتخاب كنيد.
3- در پنل Transform مطابق شکل 26-10 روي آيکن Scale کليک کنيد.

4- درصد تغيير مقياس )اندازه( موضوع را در کادرScale %  وارد کنيد.
5- فعال کردن گزينهUniform  باعث مي‌شود که تغيير اندازه طول شکل نسبت به عرض 

آن به صورت متناسب انجام شود.
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Transform از زبانه Scale شکل 26-10 گزينه

 نكت�ه: اگ��ر گزين��ه Uniform  را غيرفعال کنيد، کادره��اي  vوh براي وارد کردن 
درصدهاي مربوط به تغيير مقياس )اندازه( موضوع باز مي‌شوند. در اين حالت براي دستيابي 
 v افقي( و ( h مقاب��ل Scale ب��ه ي��ک مقياس غيريکنواخ��ت، مقادير موردنظر را در قس��مت

)عمودي( وارد کنيد.
 Center 1- براي تغييرمکان نقطه تغيير مقياس از مرکز، مختصات موردنظر را در قسمت

مقابل x و y وارد کنيد.
2- اگر مي‌خواهيد هنگام تغيير مقياس ش��کل، اندازه تمام اجزاي چس��بيده به شکل نيز 

تغيير کند، گزينهContents  را فعال کنيد.
 )Stroke( 3- اگر مي‌خواهيد هنگام تغيير مقياس شکل، مقياس خط رسم شده دور شکل

نيز با شکل تغيير کند، گزينه Strokes را فعال کنيد.
 )Tiled( فعال باش��د مقياس تمام زمينه‌ها مانند كاشيك‌اري Fill 4- در صورتي كه گزينه

تغيير ميي‌ابد.
5- گزينه Strokes را فعال كنيد تا اندازه خطوط دور به همراه مسير تغيير كند.
6- کادر Copies به منظور تکثير و تغيير اندازه شکل تکثير شده به کار مي‌رود.

7- روي دکمه Scale کليک کنيد )يا کليد Enter را بفشاريد(.

 توج�ه: اس��تفـاده از کـ��ادر Copies در ابـزار Transform منجر به ايجاد اش��کال 

گرافيکي جالبي در کنار هم مي‌شود.

تمرين 5: مقياس شكل را طوري تغيير دهيد كه شكل دو برابر شود و متناسب 
اندازه طول و عرض شكل تغيير نكند.
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شکل 10-27
)Move( 2-9-10 جابه‌جايي اشكال

كيي از راه‌هاي جابه‌جايي اش��كال استفاده از پنل Transform است. در اين پنل دكمه‌اي 
به نام Move قرار دارد که موضوعات را با استفاده از مقياس جابه‌جا مي‌کند. 

با استفاده از اين پنل ضمن جابه‌جا کردن موضوع، امکان تکثير آن نيز وجود دارد )شكل 
                   .)10-28

                  

Transform از پنلMove  شکل 28-10 انتخاب دكمه 

 نكته: اگر هنگام درگ شئ با استفاده از ابزار Pointer كليد Alt را نگه داريد كي 
كپي از شئ ايجاد مي‌شود.

 توجه: تفاوت اس��تفاده از پنل Transform نسبت به پنل Object هنگام جابه‌جايي 

موضوعات در اين است که اعداد در پنل Transform نسبي هستند يعني موضوع را به اندازه 
عددي که در قسمت x و y وارد کرده‌ايد )نسبت به موقعيت کنوني موضوع( جابه‌جا مي‌کند، 
اما در پنل Object مقادير ورودي مطلق هستند، يعني مقادير ورودي هميشه نسبت به نقطه 

صفر خط‌کش محاسبه مي‌شوند.
تمري�ن 6: آرم 29-10 را طراح��ي کرده و آن را يک بار با پنل Object  و يک بار 

با پنل Transform به اندازه دلخواه در صفحه جابه‌جا کنيد.
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شکل 10-29
)Rotate( 3-9-10 چرخش

بيش��تر مواقع هنگام رس��م اشکال، لازم اس��ت براي رسيدن به ش��کل موردنظر تمام يا 
قس��متي از شکل را بچرخانيد. براي چرخش موضوعات از چند روش استفاده مي‌شود که به 

شرح آن‌ها مي‌پردازيم:
استفاده از دستگيره‌هاي تغيير شکل

1- ب��ا ابــ��زار Pointer روي ‌مــوض��وع ‌مــورد‌نظر دابل‌کليک ‌کنيــد تا دس��تگيره‌هاي 
تغييرشکل )Transform handles( ظاهر شوند.

2- اش��اره‌گر ماوس را به دس��تگيره‌ها نزدي��ک کنيد، در اين صورت اش��اره‌گر ماوس به 
فلش‌هاي چرخش��ي تبديل مي‌شود. حال با چرخش اشاره‌گر ماوس، موضوع انتخاب شده به 

اندازه دلخواه دوران مي‌کند.

                 

شکل 30-10 دستگيره‌هاي تغيير شکل       شکل 31-10 چرخش اشکال به کمک دستگيره‌هاي تغيير شکل

 نكته: با استفاده از کليد Shift  چرخش با زاويه 45 درجه انجام مي‌شود.

 Rotate نحوه استفاده از ابزار
1- با ابزار Pointer روي ‌موضوع ‌موردنظر کليک‌ کنيد تا شکل انتخاب شود.

2- ابزار Rotate را از جعبه ابزار انتخاب کنيد.
3- در ي��ک ‌نقطه کليک‌ک��رده و كليد‌ ماوس را نگه‌ داريد تا خ��ط ‌راهنماي ‌تعيين‌کننده 
راستاي چرخش ظاهر شود. اکنون با حرکت دادن ماوس مي‌توانيد شکل را درجهات مختلف 
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بچرخانيد.

     

Rotate شکل 33-10 مراحل انجام کار با ابزار      	Pointer شکل 32-10 انتخاب با ابزار

 نكت�ه: اگر مي‌خواهيد به طور همزمان چند موضوع را با هم چرخش دهيد، بهتر 
است ابتدا آن‌ها را با کليد ترکيبي Ctrl+G  در يک گروه قرار دهيد.

 توجه: هنگام‌ اس��تفاده از ‌ابزار Rotate نقطه کليک به‌منزله محور‌ چرخش اس��ت، 

بنابراين اگر مي‌خواهيد ش��کل را به دور خودش بچرخانيد، بهتر است نقطه کليک در حوالي 
مرکز شکل باشد.

 نكته: نگه داش��تن کليد Shift هنگام چرخش باعث مي‌شود که شکل با زاويه 45 
درجه بچرخد.

مثال 4: شکل 34-10 را رسم کنيد.
1- به منظور رسم اين شکل مي‌توانيد از ابزار Bezigon براي رسم خطوط صاف و از ابزار 

Pen براي رسم خطوط منحني استفاده کنيد.

2- شکل را با استفاده از ابزار Rotate به اندازه دلخواه بچرخانيد.                          

شکل 10-34

ب��راي اي��ن کار ابتدا با ابزار Pointer روي موضوع موردنظر کليک کنيد تا ش��کل انتخاب 
شود، سپس ابزار Rotate را از جعبه ابزار برگزينيد و در يک نقطه کليک کرده، كليد ماوس را 
نگه داريد تا خط راهنماي تعيين کننده راس��تاي چرخش ظاهر شود. اکنون با حرکت دادن 
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ماوس شکل را در جهات مختلف بچرخانيد.

 نكته: در هنگام چرخاندن شکل، هر قدر که اشاره‌گر ماوس از مرکز دوران دورتر 
باشد، تغيير زاويه با گام‌هاي آهسته‌تري صورت مي‌پذيرد.

 Transformاستفاده از پنل
اين روش دقيق‌تر از روش‌هاي قبل است، زيرا در اين روش از مقياس استفاده مي‌شود.

1- موضوع مورد نظر را انتخاب کنيد.
2- گزينه  Modify→Transform→Rotateرا برگزينيد.    

3- پنل Transform در حالي كه دكمه Rotate انتخاب شده باز مي‌شود.
4- زاويه‌اي که مي‌خواهيد موضوع را برحس��ب آن بچرخانيد به صورت عدد در قس��مت
‌Rotation angle تاي��پ کني��د و با انتخاب گزينه‌ه��ايContents  و Fills مش��خص کنيد که 

محتويات موضوع، همراه با آن چرخانده شود.
5- براي تغيير دادن مرکز چرخش، مختصات مورد نظر خود را در قس��مت Center وارد 

کنيد.
6- روي دکمه Rotate کليک کنيد.

Transform شکل 35-10 پنل

 نكته: اگر در کادرCopies  عدد صفر را وارد کنيد، خود شکل با زاويه موردنظر چرخش  مي‌کند 
اما اگر عددي غير از صفر وارد کنيد، ش��کل اصلي بدون چرخش باقي مي‌ماند و کپي‌هاي ايجاد ش��ده با زاويه 

دلخواه چرخش مي‌کنند.
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 ، Window→Transform مي‌توانيد از  Transform نكت�ه: براي ظاهر کردن پن��ل 
کليد ميانبرCtrl+Mي  ا دابل کليک روي ابزار Rotate  در جعبه ابزار استفاده کنيد.

 توجه : برای دوران در خلاف جهت عقربه های س��اعت می توانید یک عدد منفی 
در کادر Rotating angle وارد کنید.

مثال 5: شکل 36-10 را رسم کنيد.
1- براي ايجاد ش��کل 36-10 ابتدا با ابزار Ellipse يک بيضي عمودي رس��م کنيد، سپس 
از قسمت Modify→Transform  گزينه Rotate را انتخاب کنيد.                                                            

شکل 10-36

2- در كادر متن��ي Rotation angle عدد 20 را وارد کرده و در كادر متني Copies عدد 8 
را درج کنيد، سپس روي دکمهRotate  کليک کنيد.
تمرين 7: اشکال 37-10 را رسم کنيد.

شکل 10-37
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 )Reflect( 4-9-10 قرينه‌سازي

براي ايجاد قرينه از يک موضوع يا انعکاس آن روي يک س��طح، از ابزار Reflect اس��تفاده 
کنيد. اين ابزار در مجموعه ابزارRotate  در جعبه ابزار قرار دارد.                                

Reflect استفاده از ابزار
1- موضوعي را که مي‌خواهيد قرينه کنيد، برگزينيد.

2- ابزار Reflect را از جعبه ابزار انتخاب کنيد.
3- اش��اره‌گر ماوس را روي صفحه قرار داده و در نقطه‌اي که مي‌خواهيد شکل در اطراف 
آن قرينه ش��ود، کليک کنيد )نقطه تغيير ش��کل(. در اين حالت كلي��د ماوس را رها نکنيد، 
به اين ترتيب يک خط از محل اش��اره‌گر به س��مت خارج گس��ترش ميي‌ابد )اين خط محور 

بازتابش ناميده مي‌شود(.
 4- وقتي موضوع قرينه شده در موقعيت دلخواه ‌شما قرارگرفت، كليد ماوس را رها کنيد 

)شکل 10-39(.

        

                      شکل 38-10 محور بازتابش                                 شکل 39-10 قرينه موضوع انتخاب شده

 نكت�ه: اگر هنگام اس��تفاده از ابزار Reflect کلي��د Shift را پايين نگه داريد، باعث 
مي‌شود قرينه‌سازي در زواياي 45، 90 و 180 درجه صورت گيرد.

 نكت�ه: اگر هنگام اس��تفاده از اب��زار Reflect کليد Alt را پايي��ن نگه داريد، باعث 
مي‌شود از موضوع انتخاب شده کپي گرفته شود و سپس قرينه‌سازي صورت گيرد.

مثال 6: ش��کل 40-10 را رس��م کرده، س��پـس قرينه آن را مطابق شکل ايجاد 
کنيد. 

1- ابتدا تصوير يک ماهي را مطابق شکل 41-10 رسم کنيد.
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2- ابزار Reflect را از جعبه ابزار انتخاب کرده و اشاره‌گر ماوس را روي صفحه قرار دهيد 
و در نقطه‌اي که مي‌خواهيد شکل در اطراف آن قرينه شود، کليک کنيد. در اين حالت كليد 
م��اوس را رها نکنيد و با حرکت دادن ماوس و حرک��ت محور بازتابش هنگامي که قرينه در 
جاي مشخص شده در شکل 40-10 قرار گرفت، کليد Alt را نگه داشته )براي ايجاد کپي از 

شکل( سپس كليد ماوس را رها کنيد.

           	  

		 شکل 10-41                        شکل 40-10 ترسيم شکل به همراه قرينه

Transform استفاده از پنل
1- موضوعي را که مي‌خواهيد قرينه کنيد، برگزينيد.

2- روي دكمه Reflect از پنل Transform کليک کنيد. شکل 42-10 ظاهر مي‌شود.

Transform از پنل Reflect شکل 42-10 دكمه

 Reflect axis 3- زاويه چرخش موضوع را برحسب درجه براي قرينه شدن، در مقابل‌ کادر
وارد کنيد.

4- براي جابه‌جايي نقطه تغيير ش��کل از مرکز موضوع، مختصات موردنظر را در قس��مت 
Center مقابل کادرهاي x و y وارد کنيد.

  Copies 5- براي اين که خود شکل را همراه با قرينه آن داشته باشيد، کافي است در کادر
شکل 42-10 عدد 1 را وارد کنيد.
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تمرين 8: شکل 43-10 را رسم کنيد.

      

 شکل 10-43 

 Skew 5-9-10 ابزار

از ابزار Skew واقع در گروه ابزارهاي Rotate در جعبه ابزار، براي مورب کردن موضوعات و 
 Transform زياد دقيق نيست ولي پنل Skew مورب کردن متون استفاده مي‌شود.کارکرد ابزار

به علت اين که تغييرات را با مقياس انجام مي‌دهد، دقيق‌تر عمل مي‌کند. 
براي مورب کردن )کج کردن( موضوعات از دو روش استفاده مي‌شود:

 Skew استفاده از ابزار
1- موضوعي را که مي‌خواهيد مورب کنيد، برگزينيد.

2- در جعبه ابزار، ابزارSkew  را انتخاب کنيد س��پس اش��اره‌گر ماوس را در نقطه‌اي که 
مي‌خواهي��د موض��وع را از آن نقطه کج کني��د، قرار دهيد )به اين نقطه، نقطه تغيير ش��کل 

مي‌گويند( و كليد ماوس را رها نکنيد )شكل 10-44(.

         

شکل 44-10 انتخاب شکل

3- اش��اره‌گر را دورتر از نقطه تغيير ش��کل بکشيد. با انجام اين عمل، شکل، مطابق شكل 

45-10 تغيير پيدا مي‌کند.

Skew شکل 45-10 مورب کردن شکل با ابزار
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Transform استفاده از پنل
1- موض��وع موردنظر را برگزينيد، س��پس در پن��ل Transform روي دكمه Skew کليک 

کنيد.
2- در کادر h از قسمت Skew angles  زاويه افقي و در کادر v زاويه عمودي را براي مقدار 

کج شدن  وارد کنيد.
  Center3- براي جابه‌جايي نقطه تغيير شکل از مرکز شکل، مختصات جديد را در قسمت

وارد کنيد.
4- روي دکمه Skew کليک کنيد.

Transform شکل 46-10 پنل

Combine 10-10 فرمان‌هاي
در FreeHand MXa قابليت تركيب ساده و پيچيده اشكال و مسيرها وجود دارد كه در زير 
 Modify→Combine فرمان ،Combine به آن‌‌ها اشاره شده است. براي دسترسي به گزينه‌هاي

را انتخاب كنيد.
Blend 1-10-10 فرمان

از اين فرمان براي ترکيب کردن يا به هم رس��اندن دو يا چند موضوع انتخابي اس��تفاده 
مي‌ش��ود. در صورتيك‌ه دو موضوع مختلف را انتخاب كرده، س��پس اين فرمان را اجرا کنيد، 
بين موضوعات انتخاب شده اشکالي ايجاد ‌مي‌شود؛ به‌طوري که به نظر مي‌رسد موضوعي به 

تدريج و طي چند مرحله به موضوع ديگر تبديل شده است.
 Blend استفاده از فرمان

 1- دو ي��ا چن��د موضوع گرافيک��ي را که مي‌خواهي��د باهم ترکيب‌ش��وند، انتخاب کنيد 
)شکل 10-47(.

2- فرمان Modify→Combine→Blend را اجرا کنيد )شکل 10-48(.
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همان‌طور که در شکل 49-10 مشاهده مي‌کنيد، با استفاده از کادر متني Steps  مي‌توان 
تعداد مراحل تبديل موضوعات انتخابي در فرمان Blend را تنظيم کرد.

کادر Range، محدوده توليد اشکال مياني بين دو موضوع انتخاب شده را براساس درصدي 
از فاصله ميان دو موضوع اصلي تعيين مي‌کند.

                                        

Blend شکل 48-10 نتيجه حاصل از فرمان      Blend شکل 47-10 دو موضوع گرافيکي انتخاب شده براي

 

Blend هنگام استفاده از فرمان Object شکل 49-10 پنل

 نكته: با کليد ترکيبي Ctrl+Shift+B مي‌توان عمل Blend   را انجام داد.

مثال 7: شکل 50-10 را با استفاده از Blend رسم کنيد.
1- يک دايره با ابزار Ellipse رسم کنيد.

2- يک بيضي در وسط دايره ترسيم کنيد.
3- بيضي و دايره را باهم انتخاب کنيد.

4- فرمان Modify→Combine→Blend را اجرا کنيد.     
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شکل 10-50

5- در پنل Object در کادر Steps عدد 15 را وارد کنيد.

 توجه: براي جدا کردن موضوعات ترکيبي تکرار ش��ده )Blend( مي‌توانيد دو بار از 

فرمان Modify→Ungroup يا کليد تركيبي Ctrl+Shift+G  استفاده کنيد.

تمرين 9: دو شکل بعد را در صفحه ترسيم و رنگ‌آميزي کرده )شکل 10-51(، 
سپس اعمال ‌زير را انجام دهيد:

1- دستور Blend را روي آن‌ها اجرا کنيد.
2- رنگ هر يک از شکل‌ها را تغيير داده و تغييرات را مشاهده کنيد.

3- تعداد مراحل تبديل دو شکل به يکديگر را 10 قرار دهيد. 

  

شکل 10-51 

Join Blend To Path  2-10-10 فرمان

از اين فرمان براي فرم دادن موضوعات Blend شده استفاده مي‌شود. وقتي دو موضوع را 
توسط فرمان Blend با هم ترکيب مي‌کنيد شکل‌هاي مياني، بين دو موضوع و در يک راستا 
تش��کيل مي‌ش��وند. براي اين که بتوانيد اشکال مياني را با يک مسير دلخواه هم تراز کنيد از 

فرمان Join Blend To Path استفاده کنيد.
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Join Blend To Path استفاده از فرمان
1- دو موضوع گرافيکي مانند ش��کل 52-10 ترس��يم کرده و آن‌ها را با دستور Blend با 

هم ترکيب کنيد.
2- يک مسير دلخواه رسم کنيد )شکل 10-53(.

	                               

شکل 52-10 دو شکلBlend  شده                           شکل 53-10 رسم مسير

3- هر دو موضوع را انتخاب کنيد.
4- فرمان Modify→Combine→Join Blend To Path را اجرا کنيد )شکل 10-54(.

Join Blend To Path شکل 54-10 اعمال

تمرين 10: شكل 55-10 را ترسيم كنيد.

 Join Blend To Path شکل 55-10 نتيجه فرمان
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 توجه: براي جدا کردن موضوعات Blend ش��ده از يک مس��ير، مي‌توانيد از گزينه 

Split در منوي Modify استفاده کنيد.

Union 3-10-10 فرمان

اين فرمان براي ترکيب يا يکپارچه کردن چند مس��ير يا موضوع گرافيکي و تبديل آن‌ها 
به يک موضوع واحد به‌کار مي‌رود. اين مس��يرها طوري با هم ترکيب مي‌ش��وند که خطوط 
مشترک بين آن‌ها حذف مي‌شوند. با کمک اين توانايي، مي‌توانيد مسيرهاي پيچيده‌اي را با 

استفاده از اشکال ساده توليد کنيد.
Union استفاده از فرمان

1- دو ـي��ا چنـد موض��وع را که روي هـم قرار گرفته‌اند، مطابق ش��کل 56-10 انتخاب 
کنيد.

2- فرمان Modify→Combine→Union را اجرا کنيد.   

 توجه: رنگ درون مس��ير ترکيب ش��ده، از رنگ اوليـن مسيـري که تـرسيم شده 

تبعيت خواهد کرد )شکلي که نسبت به بقيه اشکال عقب‌تر قرار گرفته است(.

                           

Union شکل 57-10 نتيجه حاصل از فرمان      Union شکل 56-10 انتخاب اشکال براي فرمان

 نكته: چنانچه مس��يرها با يکديگر هم‌پوشاني نداشته باشند، نتيجه فرمان Join  و 
Union يکسان بوده و منجر به توليد يک مسير يکپارچه خواهد شد.
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تمرين 11: اش��کال 58-10 را رس��م ک��رده و فرم��ان Union را روي آن‌ها اجرا 
کنيد.

شکل 10-58

Divide 4-10-10 فرمان

اين فرمان قس��مت‌هاي مش��ترک موضوع��ات را برش مي‌دهد و از آن يک ش��کل مجزا 
مي‌سازد. در واقع نواحي مشترک از هم جدا مي‌شوند، بدون آن که موضوعات اصلي حذف شوند؛ 

همچنين موضوعات به قطعات کوچک‌تر تقسيم مي‌شوند.
Divide استفاده از فرمان

1- دو يا چند موضوع را که روي هم قرار گرفته‌اند مطابق شکل 59-10 انتخاب کنيد.
2- فرمان Modify→Combine→Divide را اجرا کنيد )شکل 10-60(‌.   

                                                     

Divide شکل 59-10 انتخاب سه شکل                   شکل 60-10 اعمال فرمان

Crop 5-10-10 فرمان
اين فرمان قس��مت‌هاي مشترک موضوعات گرافيکي را برش مي‌دهد. وقتي دو يا چند مسير 
را که با يکديگـر هم‌پوش��انـي و تـداخل دارند، انتخاب كرده و فرمان Crop را روي آن‌هـا اجرا 
کنيد، قسمت‌هايي از مسيرهاي زيرين که به داخل مسير بالايي نفوذ کرده، باقي مي‌مانند و ساير 
قسمت‌ها که در خارج از مرزهاي شکل بالايي واقع شده‌اند، حذف مي‌شوند. در واقع موضوعــي 
که روي ش��کل يا اش��کال ديگر قرار گرفته به عنوان يک چاقو عمل مي‌کند تا قس��مت‌هايي از 
موضوعات زير که خارج از تصوير بالايي قرار گرفته‌اند، حذف ش��وند و فقط بخش‌هاي مش��ترک 
 Union عمل مي‌کند، با اين تفاوت که Union عکس فرمان Crop اش��کال باقي بمانند. فرمـان
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ويژگي رنگي مس��يرها را تغيير مي‌دهد اما Crop عمل برش را با حفظ رنگ‌هاي اوليه مس��ير‌ها 
انجام مي‌دهد.

 Crop استفاده از فرمان
1- موضوعات متنوعي را به همراه موضوعي که در بالاي آن‌ها قرار دارد، انتخاب کنيد.

2- فرمان Modify→Combine→Crop   را اجرا کنيد )شکل 10-62(.

 	   
Crop شکل 62-10 نتيجه حاصل از اجراي فرمان 	شکل 61-10 انتخاب موضوعات گرافيکي  

3- فقط قس��مت‌هايي از موضوعات انتخاب ش��ده باقي مي‌مانند كه اش��كال زيرين آن با 
شكل بالا تداخل داشته باشد.

Intersect 6-10-10 فرمان

اج��راي اين فرمان روي مس��يرهايي که ب��ا هم تداخل دارند، موجب مي‌ش��ود که فصل 
مشترک موضوعات حفظ شده و ساير قسمت‌ها حذف شود.

Intersect استفاده از فرمان
1- موضوعاتي را که با هم تداخل دارند، رسم و انتخاب کنيد )شکل 10-63(.

2- فرمان Modify→Combine→Intersect  را اجرا کنيد )شکل 10-64(.

                                            
Intersect شکل 63-10 رسم و انتخاب دو شکل متداخل            شکل 64-10 نتيجه حاصل از فرمان

 توجه: تفاوت بين دس��تور Crop و Intersect  در اين اس��ت که فرمان Crop فصل 

 Intersect مش��ترک شکل‌ها را با ش��کل بالايي نگه مي‌دارد و بقيه را حذف مي‌کند اما فرمان
باعث مي‌ش��ود که فصل مش��ترک همه موضوع��ات باقي بماند. تفاوت بين دس��تور Crop و 
Intersect  در ش��کل 65-10 به‌صورت تصويري نشان داده شده است. توجه داشته باشيد كه 
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در اين شكل ابتدا مربع، سپس ستاره و بالاترين شكل بيضي رسم شده است.

Intersect و Crop شکل 65-10 تفاوت

 مثال 8:
1- كي س��تاره، دايره و ش��ش ضلعي متداخل )ش��كل 65-10( رس��م كرده، آن‌ها را به 

دلخواه رنگ كنيد.                                                                 

شكل 10-66

2- ش��كل قبل را انتخاب ك��رده، دس��تور Modify→Combine→Intersect را اجرا كنيد 
)شكل 67-10(. شكل 66-10 را انتخاب كرده و دستور Modify→Combine→Crop را اجرا 

كنيد )شكل 10-68(.

         Intersect شكل 67-10 نتيجه حاصل از تأثير فرمان

3- به تفاوت دو فرمان Crop و Intersect دقت كنيد.
                                                                 

Crop شكل 68-10 نتيجه حاصل از تأثير فرمان   
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Punch 7-10-10 فرمان

با استفاده از اين فرمان مي‌توانيد توسط موضوعي که در رو قرار گرفته بخشي از موضوع 
ديگر را که در زير قرار دارد، حذف کنيد. دو شکل را روي هم قرار دهيد به طوري که شکل 
بزرگ‌تر زير قرار بگيرد، سپس فرمان Punch را اجرا کنيد، مي‌بينيد که قسمت‌هاي مشترک 
دو ش��کل حذف مي‌شوند. بدين وسيله حفره‌اي به اندازه و فرم شکل بالايي در شکل‌ پاييني 
ايجاد ش��ده و شکل رويي حذف مي‌شود. اگر ش��کلي که در رو قرار دارد با شکلي که در زير 

واقع است، هم‌پوشاني داشته باشد، شکل زير برش مي‌خورد.
 Punch استفاده از فرمان

 1- موضوعات��ي‌را ک��ه همه يا قس��متي از آن‌ها روي‌هم ق��رار گرفته‌ان��د، انتخاب کنيد 
)شکل 10-69(.

2- فرمان Modify→Combine→Punch را اجراکنيد )شکل 10-70(.

   		                              

Punch شکل 70-10 پس از اعمال فرمان      Punch شکل 69-10 موضوعات گرافيکي براي اجراي فرمان     

3- موضوع بالايي روي موضوع پاييني، سوراخ ايجاد مي‌کند.

 توج�ه: در هنگام كار با متن )Text( ابتدا بايد متن به موضوع گرافيكي )مس��ير( تبديل 

 ش��ده‏، س��پس فرم��ان Join روي آن اعمال ش��ود، پس از آن مي‌ت��وان فرمان ‍��‍Punch را اجرا كرد 
)شكل 10-71(.

شکل 71-10 نمايش اعمال فرمان Punch روي متن

در شکل 72-10 مي‌توانيد نتيجه حاصل از سه فرمان Punch ، Crop و Union را مشاهده 
کنيد.
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Punchو Union ،Crop شکل 72-10 مقايسه فرمان‌هاي

 Punch تمرين 12: شکل 73-10 را با استفاده از سه شکل الف، ب، ج و با فرمان
رسم کنيد.

                                  )الف(                    )ب(                   )ج( 

شکل 10-73

Alter Path 11-10 ويرايش مسير با فرمان‌هاي
هنگامي كه با استفاده از روش‌هاي مختلف، مسيرهايي را ايجاد كرديد، مي‌توانيد آن‌ها را 
به روش‌هاي گوناگون اصلاح كنيد يا تغيير ش��كل دهيد. براي دسترسي به فرمان‌هاي مزبور 

مسير زير را اجرا كنيد:
Modify →Alter Path

Correct Direction 1-11-10 فرمان

در اي��ن واحد كار اص��ول ادغامك‌ردن موضوعات گرافيك��ي را آموختيد. هنگامي كه چند 
 Even/odd با هم ادغام مي‌ش��وند، مي‌توانيد با اس��تفاده از گزينه Join موضوع توس��ط فرمان
fill موجود در پنل Object )ش��كل 74-10( رنگ قسمت‌هاي روي هم افتاده )هم‌پوشاني( را  
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تعيين كنيد.
اگر اين گزينه فعال باش��د قس��مت‌هاي روي هم افتاده ش��فاف ديده مي‌شوند و اگر اين 
گزينه فعال نباش��د، قس��مت‌هاي روي هم افتاده، هم رنگ بقيه قسمت‌هاي شكل مي‌شوند 

)شكل 10-75(.

                

        شكل 74-10 گزينه Even/odd fill                شكل 75-10 نتيجه حاصل از فعال و غيرفعال بودن

Even/odd fill گزينه                                               Object موجود در پنل               

حال اگر گزينه Even/odd fill فعال باشد اما قسمت‌هاي روي هم افتاده شكل‌ها به صورت 
شفاف ديده نشوند با اجراي فرمانCorrect Direction  قسمت‌هاي روي هم افتاده موضوعات 
گرافيكي ادغام ش��ده و ش��فاف مي‌ش��وند. اين فرمان را مي‌توانيد به كي��ي از روش‌هاي بعد 

انتخاب كنيد:
• 	 Modify→Alter Path→Correct Direction

• 	 Xtras→Cleanup→ Correct Direction

• 	Xtra Operations انتخاب آكين  از نوار ابزار
 Reverse Direction2-11-10 فرمان

هنگامي که مس��يري را ترس��يم مي‌کنيد، جهت مس��يرهاي ايجاد شده به همان ترتيبي 
است كه نقاط لنگر را ايجاد ميك‌نيد. اولين نقطه‌اي كه ايجاد مي‌شود شروع مسير و آخرين 
نقطه، انتهاي مس��ير خواهد بود. گاهي اوقات لازم مي‌ش��ود كه در رسم موضوعات گرافيكي، 
جهت مسيرها را تغيير دهيد؛ براي اين كار از فرمان  Reverse Direction استفاده كنيد. براي 

اجراي اين فرمان كيي از روش‌هاي زير را برگزينيد.
• 	Modify→Alter Path→Reverse Direction

• 	Xtras→Cleanup→Reverse Direction

• 	Xtra Operations انتخاب آكين  از نوار ابزار
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روش تغيير جهت مسير
1- مسيري را كه مي‌خواهيد جهت آن تغيير کند، انتخاب كنيد )شكل 10-76(.

2- فرم��ان Modify→Alter Path→Reverse Direction را اج��را كني��د؛ نتيجه حاصل در 
شكل 77-10 نمايش داده مي‌شود.

                    

Reverse Direction  شكل 77-10 نتيجه حاصل از فرمان       شكل 76-10 انتخاب مسير          	

 تمرين 13: شكل 78-10 را ترسيم كرده و  به 79-10 تبديل كنيد.

                    
                                                 

                   

 Reverse Direction  شكل 78-10                     شكل 79-10 نتيجه حاصل از فرمان                

 توج�ه: ب��راي معكوس كردن ن��وك فلش ابت��دا و انتهاي خط��وط متصل كننده 

)Connector( فرمانReverse Direction بهك‌ار مي‌رود.

Remove Overlap 3-11-10 فرمان

اي��ن فرمـ��ان نواحي را كه در كي مس��ير روي هـم قـرار مي‌گيـرن��د، حذف ميك‌ند. به 
عبارت ديگر فرمانRemove Overlap  مس��ير را طوري تغيير مي‌دهد تا نواحي كه با كيديگر 

هم‌پوشاني دارند، حذف شوند. براي اجراي اين فرمان كيي از روش‌هاي بعد را برگزينيد.
• 	Modify→Alter Path→Remove Overlap

• 	Xtras→Cleanup→Remove Overlap

Xtra Operations انتخاب آكين  از نوار ابزار      
Remove Overlap استفاده از فرمان

1- موضوع موردنظر را انتخاب كنيد )شكل 10-80(.
2- فرمان Modify→Alter Path→Remove Overlap را اجرا كنيد. نواحي‌ که روي‌هم قرار 

گرفته‌اند مطابق شكل 81-10 حذف مي‌شوند.



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
284

                                                      

Remove Overlap شكل 81-10 نتيجه حاصل از فرمان                 شكل 10-80 	

 نكت�ه: بايد توجه داش��ت که موضوع پس از اجراي فرم��ان Remove Overlap به 
صورت يکپارچه خواهد شد.

در اين حالت بخش‌هاي شفاف محصور در داخل مسير به اشکال قابل انتخاب و ويرايش 
تبديل مي‌ش��وند. چنين به نظر مي‌آيد که اين موضوعات که کاملًا هم رنگ مس��ير هستند، 
روي مس��ير قرار گرفته و فرمان Punch به صورت خودکار روي موضوع و مس��ير اجرا ش��ده 

است.
مثال 9:

  
1- ابتدا شکل 82-10 را ترسيم و انتخاب کنيد.

2- فرمان Remove Overlap را اجرا کنيد )شکل 10-83(.
3- مي‌توانيد با ابزار Subselect قس��مت داخلي ش��کل را نيز انتخاب و جدا کنيد )ش��کل 

.)10-84

                                          

شکل 82-10                       شکل 83-10                         شکل 10-84

Simplify 4-11-10 فرمان

در بعضي مس��يرها معمولاً تعداد زيادي گره اضافي قرار دارد كه باعث مي‌ش��ود س��رعت 
پردازش و چاپ مسير طولاني شود و در هنگام اصلاح و ويرايش مسير نيز با مشكلاتي مواجه 
شويد. در اين صورت مي‌توانيد با استفاده از فرمانSimplify  تعداد گره‌هاي اضافي موجود در 
مسير را كم كنيد تا مسير ساده‌تر و هموارتر شده و ويرايش آن نيز آسان‌تر شود. براي اجراي 

اين فرمان كيي از روش‌هاي بعدي را برگزينيد.
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• 	Modify→Alter Path→Simplify

• 	Xtras→Cleanup→Simplify

• 	Xtra Operations انتخاب آكين  از نوار ابزار
Simplify روش استفاده از فرمان

1- موضوع موردنظر را كه مي‌خواهيد تعداد گره‌هاي آن كم ش��ود، انتخاب كنيد )ش��كل 
.)10-85

شكل 85-10 انتخاب مسير

2- فرم��ان Modify→Alter Path→Simplify را اجرا كني��د، كادرمحاوره Simplify مطابق 
شكل 86-10 ظاهر مي‌شود.

Simplify شكل 86-10 كادرمحاوره

3- در اين كادر محاوره با اس��تفاده از دکمه لغزنده موجود مي‌توانيد ش��دت تأثير فرمان 
را روي مس��ير انتخاب ش��ده تغيير دهيد. هرچه اين مقدار بيشتر باشد، نقاط بيشتري حذف 

مي‌شوند.
4- براي ديدن نتيجه كار قبل از بستن كادرمحاوره روي دكمه Apply کليک كنيد و اگر 

نتيجه رضايت‌بخش بود روي دكمه OK كليك كنيد )شكل 10-87(.

Simplify شكل 87-10 نتيجه حاصل از فرمان

 Xtras→Distort→AddPoints نكته: براي اضافهك‌ردن نقاط بيشتر به مسير، از فرمان 
استفاده كنيد.
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 مثال 10:
1- كي چند ضلعي مطابق شكل 88-10 رسم كنيد.

شكل 88-10 رسم چند ضلعي

 2- ب��ا اس��تفاده از فرم��ان Add Points به ش��كل رس��م ش��ده، نقاط��ي را اضافه كنيد 
)شكل 10-89(.

 Add Points  شكل 89-10 نتيجه حاصل از تأثير فرمان

را كاه��ش دهي��د  نق��اط روي ش��كل  Simplify تع��داد  فرم��ان  از  اس��تفاده  ب��ا   -3 
)شكل 10-90(.

Simplify شكل 90-10 نتيجه حاصل از تأثير فرمان

Expand Stroke 5-11-10 فرمان

اجراي اين فرمان روي مسيرهاي بسته، باعث افزايش ضخامت خطوط دور مسير مي‌شود 
به طوري كه ش��كل، به كي ش��كل تركيبي )Composite Path( تبديل خواهد شد. همچنين 
اجراي اين فرمان، مسيرهاي باز را به بسته تبديل مي‌كند و باعث گسترش ضخامت خط دور 
مي‌ش��ود، ضخامت خط از 1 تا 50 قابل تنظيم اس��ت و اين ضخامت در واقع به وس��يله كي 

مسير بسته ايجاد مي‌شود. 
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مي‌توان پس از اجراي فرمان Expand Stroke، روي مس��يري که به موضوع تبديل ش��ده،  
ويرايش‌هاي مربوط به موضوعات )از قبيل تمامي گزينه‌هاي منوي بازشو در Fill( را اجرا کرد. 

براي اجراي اين فرمان كيي از روش‌هاي زير را برگزينيد.
• 	Modify→Alter Path→Expand Stroke

• 	Xtras→Path Operations→Expand Stroke

Xtra Operations انتخاب آكين  از نوار ابزار        
Expand Stroke روش استفاده از فرمان

1- مسيري را كه مي‌خواهيد تغيير دهيد، انتخاب كنيد )شكل 10-91(.

شكل 91-10 انتخاب مسير

 2- فرم��ان Modify→Alter Path→Expand Stroke را اج��را كني��د.كادر محاوره ش��كل
92-10 ظاهر مي‌شود.

Expand Stroke شكل 92-10 كادر محاوره

تمرين 14: شكل 93-10 را رسم كرده و فرمان Expand Stroke را روي آن اجرا 
كنيد.

شكل 10-93
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Inset Path   6-11-10 فرمان

با استفاده از اين فرمان مي‌توان در اطراف مسيرهاي انتخاب شده، به تعداد دلخواه مسير 
اضافي ايجاد کرد. اين مسيرها متحدالمرکز بوده و مي‌توانند به سمت درون يا بيرون موضوع 

انتخاب شده، ايجاد شوند. 
ب��ه عبارت ديگر فرمان Inset Path كپي‌هاي متع��دد از كي موضوع را ايجاد ميك‌ند. اين 
كپي‌ها مي‌توانند كوچ‌كتر يا بزرگ‌تر از موضوع اوليه باش��ند. براي اجراي اين فرمان كيي از 

روش‌هاي بعد را برگزينيد.
• 	Modify→Alter Path→Inset Path

• 	Xtras→Path Operations→Inset Path

• 	Xtra Operations انتخاب آكين  از نوار ابزار
Inset Path   روش استفاده از فرمان

1- موضوع گرافيكي موردنظر را انتخاب كنيد )شكل 10-94(.
2- فرمان Modify→Alter Path→Inset Path را اجرا كنيد. كادر محاوره ش��كل 10-95 

ظاهر مي‌شود.
3- در کادر Steps تعداد مسيرهايي )كپي‌ها( را كه مي‌خواهيد بر اساس مسير اصلي ايجاد 

شوند، تعيين كنيد.
4- منوي بازشوي Steps داراي سه حالت انتخابي است:

حالت Uniform: باعث مي‌شود فاصله ميان مسيرها كينواخت باشد.
حالت Farther: با اس��تفاده از اين حالت هرچه از موضوع گرافيكي انتخاب ش��ده دورتر 

مي‌شويد، فواصل بين مسيرها بيشتر مي‌شود.
حالت Nearer: با اس��تفاده از اين حالت هرچه از موضوع گرافيكي انتخاب ش��ده دورتر 

مي‌‌شويد، فواصل بين مسيرها كمتر مي‌شود. 

                              

Inset Path شكل 94-10 انتخاب موضوع گرافيكي     شكل 95-10 كادر محاوره
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شكل 96-10 تفاوت بين اين سه حالت را نشان مي‌دهد.

Uniform حالت                                 Farther حالت                              Nearer حالت  

Steps شكل 96-10 تفاوت بين حالات موجود در منوي بازشوي

1- در کادر Inset  مي‌توان مش��خص کرد كه مس��يرهاي اضافه شده، در خارج از شكل يا 
داخل شكل قرار گيرند. اگر مقدار وارد شده در اين کادر مثبت باشد، مسيرهاي اضافه شده، 
داخل ش��كل و اگر منفي باشد، خارج از ش��كل قرار خواهند گرفت. همچنين در اين قسمت 

فاصله ميان مسيرها را نيز مي‌توان كنترل كرد. 
 در شكل 97-10 نمونه‌هايي از تأثيرات فرمان  Inset Path   را روي موضوع گرافيکي واقع در شکل
94-10 ب��ه هم��راه تنظيمات��ي که باي��د در کادر محاوره Inset Path وارد ش��ود، مش��اهده 

مي‌کنيد.
   

 

Inset Path شكل 97-10 نمونه‌هايي از اثر فرمان

2- روي دكمه OK كليك كنيد.
مثال 11:

 
1- شكل 98-10 را رسم كنيد.

2- دو رونوش��ت از ش��كل 98-10 ايجاد كنيد به طوري كه خارج از ش��كل قرار گيرند و 
همان طور كه از شكل اصلي دور مي‌شوند فواصل آن‌ها كمتر شود.
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 Modify→Alter ب��راي اي��ن كار ابت��دا ش��كل 98-10 را انتخاب كنيد، س��پس فرم��ان
Path→Inset Path را اجرا كنيد. در كادر محاوره Inset Path براي تنظيم تعداد كپي‌ها مقدار 

Steps را براب��ر 2 قرار دهيد و حال��ت Nearer را برگزينيد، همچنين مقدار Inset را 10- قرار 

دهيد، نتيجه حاصل به صورت شكل 101-10 خواهد بود.

                  	                      

Inset Path شكل 98-10                    شكل 99-10 نتيجه حاصل از فرمان

 Mirror 12-10 انعكاس اشياء با ابزار
بـا استفاده از اين ابزار مي‌توان قرينه )انعكاس( يک موضوع انتخاب شده را در جهت‌هاي 
افق��ي، عمودي يا چرخش��ي ايجاد کرد. براي اس��تفاده از اين ابزار كي��ي از روش‌هاي بعد را 

انتخاب كنيد.
• ابزار Mirror را از جعبه ابزار انتخاب كنيد.	

را  • از مس��ير Window→Toolbars نوار ابزار Xtra Tools را باز كرده س��پس ابزار  	
برگزينيد.

Mirror 1-12-10 روش کار با ابزار

1- روي اب��زار Mirror دابل کليک کنيد تا کادر محاوره Mirror مطابق ش��کل 10-100 
باز شود.

Mirror شکل 100-10 کادر محاوره

2- منوي بازشوي موجود در Mirror، شامل حالات زير براي قرينه‌سازي است: 
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• قرين��ه عم��ودي يعني ش��ئ را از س��مت‌ چپ ‌به ‌راس��ت ‌نش��ان ‌مي‌دهد  	:Vertical"

)شکل 10-101(.
• Horizontal: قرينه افقي يعني شئ را از بالا به پايين‌ نشان مي‌دهد. 	

• Horizontal & Vertical: قرينه افقي و عمودي.	

شکل 101-10 قرينه عمودي

Multiple: موضوعات‌را نسبت ‌به محورهاي مختلف قرينه ‌مي‌کند. در اين حالت مي‌توانيد 

از دکم��ه لغزن��ده موجود در کادر محاوره Mirror براي تنظيم تعداد محورهاي قرينه‌س��ازي 
استفاده کنيد.

 نكته: نگه داشتن كليد Alt  باعث مي‌شود تا هنگام استفاده از ابزار Mirror محور 
قرينه‌سازي دوران كند.

تمرين 15: ش��کل 102-10 را رسم کنيد و با ابزار Mirror شكل 103-10 را به 
دست آوريد.

                                                      

     شکل 102-10                                     شکل 103-10 رسم شکل

مث�ال كاربردي: فايل Project مثال کارب��ردي را باز کنيد. حال مي‌خواهيم آرم 
 

را كامل كنيم.
1- به صفحه ترسيم آرم بازگرديد و ترسيم آرم را از واحدكار ششم ادامه دهيد.
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2- از دايره كي كپي تهيه كرده، سپس پنلTransform  را ظاهر كنيد. در اين پنل دكمه 
Scale را فعال كنيد تا گزينه‌هاي Scale  در دسترس قرار گيرند.

3- در كادر Scale مقدار 42% را وارد كنيد تا دايره دوم به اندازه 58% كوچ‌كتر شود.

شكل 10-104

4- دايره‌ه��ا را انتخ��اب ك��رده و از حالت گروهي خارج كنيد تا نقاط لنگر ظاهر ش��وند. 
 Modify نقاط لنگر دايره‌ه��ا را انتخاب كنيد و از منوي Shift و كليد Subselect توس��ط اب��زار
چند بار فرمان Split را اجرا كنيد تا دايره‌ها در نقاط لنگر شكس��ته و به چهار قطعه تقس��يم 
ش��وند. نيمك‌ره پايين و قطعات سمت راست هر دو دايره را حذف كنيد تا شکل 105-10 به 

دست آيد.
5- اکنون هر دو كمان را انتخاب کرده و از منوي Modify فرمان Join را انتخاب كنيد و 
در پنل Object گزينه Closed را فعال كنيد تا طرف ديگر كمان‌ها نيز به كيديگر چسبيده و 

كي شكل بسته حاصل شود.                       
6- هر دو ش��كل را انتخاب كنيد و از من��وي Modify→Combine فرمان Union را اجرا 
كنيد تا كي مس��ير واحد به وجود آيد، سپس ش��كل را انتخاب کرده از پنل Swatches رنگ 
سياه را براي دكمهFill  انتخاب كنيد تا شكل از رنگ سياه پر شود. اکنون دكمه Stroke را در 

پنل Swatches فعال و None را انتخاب كنيد تا خط دور شكل حذف شود.

              

شكل 105-10                      شكل 10-106

7- شكل 107-10 را انتخاب كنيد و با استفاده از فرمان Edit→Clone كي كپي از شكل 
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ايجاد كرده و با استفاده از ابزار Mirror آن را به شكل 108-10 تبديل كنيد.

	

 شكل 107-10                                  شكل 10-108

8- حال با استفاده از خطوط راهنما و ابزار Pen شكل 109-10 را رسم كنيد.
9- داخل ش��كل را س��ياه رنگ كنيد. مطابق ش��كل 110-10 دو دايره در قس��مت‌هاي 

مشخص شده در شكل رسم كنيد و آن‌ها را نيز با رنگ سياه پر كنيد.

               

شكل 109-10                                              شكل 10-110

10- تغييرات را ذخيره كنيد.

واژه‌نامه
Cropبرش

Divideتقسيم کردن

Intersectاز وسط قطع کردن

Lockقفل کردن

Punchسوراخ کردن

Splitاز هم جدا کردن

Ungroupاز گروه خارج کردن

Unionپيوند، اتحاد

خلاصه مطالب 
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• باعث اتصال دو خط به يکديگر مي‌شود. 	Join فرمان
• براي شکستن موضوعات بسته و جدا کردن خطوط و گره‌ها از يکديگر و جدا  	Split از فرمان

کردن موضوعات Join شده استفاده مي‌شود.
• استفاده کرد. 	Rotate به منظور چرخش موضوعات تحت زاويه‌اي خاص مي‌توان از ابزار

• استفاده مي‌شود. 	Reflect براي ايجاد قرينه يا انعکاس يک موضوع گرافيکي از ابزار
• براي مورب کردن موضوعات استفاده مي‌شود. 	Skew از ابزار

• براي ترکيب گوناگون اشکال به کار مي‌روند. 	Union و Blend گزينه‌هاي
• براي قرار دادن موضوع ترکيب ش��ده روي مس��ير اس��تفاده   	Join Blend To path از گزينه

مي‌شود.
• قس��مت مش��ترک موضوعات را ب��رش مي‌دهد و از موضوع��ات اصلي جدا  	Divide گزينه

مي‌کند.
• براي به‌دست آوردن قسمت‌هاي مشترک موضوعاتي که روي يکديگر  	Intersect از گزينه

قرار دارند، استفاده مي‌شود. 
• ش��کلي را که روي بقيه اش��کال قرار دارد همراه با قس��مت مشترک آن با  	Punch گزينه

اشکال زير حذف و باقي اشکال را حفظ مي‌کند.
• قسمت مشترک موضوعات را برش مي‌دهد. 	Crop گزينه

• براي ايجاد تصوير قرينه و آينه اشکال از ابزار Mirror استفاده مي‌شود.	
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- فرمان Split قسمت مشترک موضوعات را برش مي‌دهد.
2- کاربرد فرمان Group گروه کردن موضوعات است.

3- فرمان Expand Stroke در اطراف كي ش��ئ به سمت داخل، كپي‌هاي متعددي ايجاد 
ميك‌ند.

4- عملكرد فرمان Mirror با Rotate كيسان است.
معادل گزينه هاي سمت ‌راست را از ستون سمت ‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

    Punch. براي به‌دست آوردن قسمت‌هاي مشترک موضوعاتي که روي يکديگر قرار دارند
شکل روي بقيه اشکال را همراه با قسمت مشترک آن با اشکال زير، حذف و باقي اشکال 
     Crop                                                                                   .را حفظ مي‌کند
     Reverse Direction                              	.قسمت مشترک موضوعات را برش مي‌دهد
                   Intersect                                                     	 اصلاح جهت قرارگيري مسيرها

گزينه صحيح را انتخاب کنيد.

9- فرمانSplit  برعکس کدام فرمان عمل مي‌کند؟
Align -د 	Divide -ج 	Crop -ب 	Join -الف

10- براي حذف روي هم افتادگي موضوعات از كدام فرمان استفاده ميك‌نيد؟
Remove Overlap  -ب 		 Simplify  -الف
Correct Direction‍ -د 		 Delete -ج

11- براي هم تراز کردن موضوعات نسبت به يکديگر، از کدام گزينه استفاده مي‌شود؟
Join -د 	  Divide -ج 	Crop -ب 	Align -الف

12- ازکدام‌گزين��ه براي واحد‌کردن چند ش��کل و تبديل آن‌ها به يک موضوع اس��تفاده 
مي‌شود؟

Ungroup -د 	Union -ج 	Lock  -ب 	Punch -الف
13- براي خارج کردن موضوع گرافيکي از حالت قفل، از کدام فرمان استفاده مي‌شود؟ 

Lock -د 	Unlock -ج 	Union -ب 	Join -الف
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14- براي اتصال دو خط به يکديگر از کدام فرمان استفاده مي‌شود؟
Join -د     	         Blend -ج       	Split -ب    	Align -الف

15- كدام فرمان باعث افزايش ضخامت خطوط دور شكل مي‌شود؟
Union    -د 	Intersect -ج 	Expand Stroke -ب 	Inset Path -الف

16- براي برش قس��مت‌هاي مش��ترك موضوعات، بدون حذف موضوعات اصلي از کدام 
فرمان استفاده مي‌شود؟

Punch -د            	Crop  -ج       	Split -ب      	Divide -الف
17- براي انتخاب اجزاي يک گروه از کدام ابزار استفاده مي‌شود؟

	Subselect -ب 	 	Group -الف
Pen -د 	 	Pointer -ج

در جاي خالي عبارت مناسب را بنويسيد.

18- هنگام اس��تفاده از فرمان ............ رونوشت‌هاي ايجاد شده در داخل‌ شكل اصلي قرار 
مي‌گيرند.

19- براي قرينه‌‌سازي موضوعات به صورت افقي هنگام استفاده از ابزار Mirror از گزينه 
......... استفاده مي‌شود.

20- ابزار .............. موضوعات را مورب ميك‌ند.
به سؤالات زير پاسخ تشريحی دهيد.

21- بعد از قفل کردن يک شکل چه اعمالي را نمي‌توان روي شکل انجام داد؟
22- فرمان Blend چه عملي را انجام مي‌دهد؟

23- چگونه مي‌توان موضوعات گرافيکي داخل صفحه را نسبت به هم، تراز افقي کرد؟
24- فرمانJoin  Blend To Path چه عملي را انجام مي‌دهد؟

25- از ابزارReflect  در چه مواقعي استفاده مي‌شود؟
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 آزمون عملي
1- اشکال زير را با استفاده از ابزارهاي اين واحد كار رسم کنيد.

 
2- شکل الف را ترسيم کرده، سپس آن را با يک فرمان به شکل ب تبديل کنيد.

بالف 

3- با استفاده از ابزارهاي مناسبي كه در اين واحد كار با آن‌ها آشنا شده‌ايد به سليقه خود 
در كي صفحه‌ به اندازه A3 در مورد رش��ته‌هاي گرافيك، كامپيوتر و تعمير موبايل هنرستان 

خود تبليغ كنيد.
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کليات 
در واحدكاره��اي قبل با پنل Object  آش��نا ش��ديد اين پنل نه تنها کنترل بيش��تري بر 
موضوع��ات مختلف دارد، بلکه امکان اف��زودن جلوه‌هاي ويژه )Special effect( به موضوعات را 

نيز دارا است.
Add effect 1-11 اضافه کردن جلوه‌هاي ويژه با استفاده از

با اس��تفاده از گزينه Add effect موج��ود در پنل Object مي‌توان خصوصيات و جلوه‌هاي 
ويژه‌اي را به اشکال اضافه نمود.

شئ، مراحل زير را انجام دهيد: • 	 Stroke يا Fill به منظور افزودن جلوه‌هاي ويژه به
1- موضوع مورد نظر را انتخاب نماييد.

2- در پن��ل Object روي دکم��ه Add effect کلي��ک کرده و از منوي ظاهر ش��ده جلوه 
موردنظر را انتخاب کنيد)شكل 11-1(.

Add effect شکل 1-11 گزينه‌هاي
•به منظور حذف جلوه ويژه از موضوع انتخابي، مراحل بعد را انجام دهيد: 	

1- در پنل Object جلوه ويژه را انتخاب نماييد.
2- سپس در همان پنل روي دکمه  )Remove item( کليک کنيد.

در اين‌جا به شرح گزينه‌هاي موجود درAdd effect  مي‌پردازيم:

 توجه: برخي از جلوه‌ها به صورت ابزار در نوار ابزار Xtra Tools قرار دارند.

Bend 1-1-11 جلوه
اين گزينه در شکل‌ها و مسيرهاي رسم شده، پيچ و خم و اعوجاج ايجاد مي‌کند، به طوري 
که با کشيدن نقاط محيط به سمت نقطه مرکز يا دور نمودن اين نقاط از مرکز، پاره‌خط‌هاي 
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مسير به سمت داخل يا خارج منحرف مي‌شوند و حالت شکل تغيير پيدا مي‌کند.
Bend تنظيم گزينه‌هاي

1- گزينه Bend را از منوي Effect انتخاب کنيد. 
2- دکم��ه لغزن��ده مربوط به گزينه Size، ميزان فاصله نق��اط از مرکز يا ميزان خميدگي 

اعمال شده به شئ را تعيين ميك‌ند. 
•مقادي��ر مثبت، نقاط را از مرکز دورتر و در محل تلاقي كمان‌ها نقاط نوك تيز ايجاد  	

ميك‌ند.
•مقادي��ر منف��ي، نقاط را به مرکز نزديک‌تر و انتهاي كمان‌ها را به مركز ش��ئ متصل  	

‌مي‌نمايد )شکل11-3(.   

Bend شکل 2-11 کادر محاوره

Bend شكل اصلي    مقادير مثبت در جلوه    Bend مقادير منفي در جلوه

شکل 11-3

3- با ويرايش مختصات نقاط x و y مي‌توان مکان نقطه مرکز را تغيير داد.

تمرين 1: ش��کل 4-11 را رس��م كرده و جلوه Bend را روي Stroke دور ش��کل 
اعمال نماييد )نتايج حاصل از تغيير مقدار Size را مشاهده كنيد(.
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شکل 11-4

Duet 2-1-11 جلوه

اين جلوه يک يا چند مدل مش��ابه از ش��کل ساخته، آن‌ها را با يکديگر ترکيب مي‌کند تا 
يک شکل پيچيده واحد ايجاد نمايد.

مي‌توان تعداد مدل‌هاي مش��ابه را که ايجاد مي‌ش��وند تعيين كرد و مش��خص نمود که 
مدل‌هاي مشابه چرخش يابند يا انعکاس يافته شکل اوليه باشند.

Reflect شكل اصلي             گزينه              Rotate گزينه

شکل 11-5

براي اعمال جلوه Duet روي موضوع مورد نظر مراحل زير را انجام دهيد:
1- پس از انتخاب موضوع موردنظر، از منوي Effect)شکل 1-11( گزينه Duet را انتخاب 

كنيد.
2- به منظور ايجاد تصوير منعکس ش��ده از تصوير اوليه گزينه Reflect  را انتخاب نماييد 

)شکل 11-6(.
3- به منظور ايجاد کپي چرخش يافته حول نقطه مرکز گزينه Rotate  را انتخاب كنيد.
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Duet شکل 6-11 تنظيم خصوصيات جلوه

4- براي تنظيم موقعيت نقطه مركزي جلوه و جهت اش��کال، مختصات x و y را اس��تفاده 
نماييد.

5- براي تعيين تعداد کپي‌ها از شکل بايد تعداد موردنظر را در کادر Copies وارد كرد.
6- اگر بخواهيد ش��کل اوليه با ش��کل‌هاي ايجاد شده به‌طور خودکار متصل شوند گزينه 

Joined را در حالت انتخاب قرار دهيد.

7- اگر كپي‌ها نزدكي به هم هس��تند گزينه Closed باعث بس��تن اش��کال ايجاد شده يا 
مسيرهاي باز مي‌شود.

8- براي ش��فاف نمودن نواحي همپوش��اني بين كپي‌ها، گزينه Even/Odd fill را انتخاب 
كنيد.

 مثال 1: براي درك بيشتر جلوه Duet مراحل زير را انجام دهيد:
1- شکل 7-11 را رسم نماييد.

2- گزينه Duet را از منوي Add effect انتخاب کنيد. تصوير منعکس شده از شکل اصلي 
همراه با خود شکل به صورت زير ايجاد مي‌شود.

3- از قس��مت Style گزينه Rotate را انتخاب کرده، در کادر Copies عدد 6 را وارد نموده 
و گزينه Joined را انتخاب کنيد در اين صورت شکل 9-11 به‌وجود مي‌آيد.
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    شکل 7-11                           شکل 8-11                                                   شکل 11-9                                            

4- گزينه Closed را برگزينيد تا شکل 10-11 ايجاد شود.

      

شکل 11-10

تمرين 2: شکل 11-11را ايجاد كنيد.

شکل 11-11

Expand path 3-1-11 جلوه

اين جلوه مس��ير را پهن نموده و طرح کلي )Outline( شکل حاصله را ايجاد ميك‌ند. اين 
جلوه تنها ظاهر مسير را تغيير مي‌دهد و باعث تغيير خود مسير نمي‌شود.
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Expand Path شکل 12-11 نمايش 
به منظور اعمال جلوه Expand Path روي موضوع موردنظر، مراحل زير را انجام دهيد:

 Expand 1- پس از انتخاب موضوع موردنظر، از منوي ظاهر ش��ده )ش��کل 1-11( گزينه
Path را انتخاب كنيد.

2- تنظيمات موردنظر را اعمال نماييد:
باعث گس��ترش مس��ير به س��مت  • 	    Inside only انتخاب گزينه Direction در من��وي
درون و گزينه Outside only باعث گس��ترش مس��ير به سمت بيرون مي‌شود. گزينه 
"Both مس��ير را به‌ط��ور كيس��ان به هر دو ط��رف درون و بيرون گس��ترش مي‌دهد 

)شکل 11-13(.

Direction شکل 13-11 گزينه‌هاي منو

• را مي‌توان وارد نمود. هرچه مقدار وارد شده در  در کادر متني Width مقادير 0 تا 50	
اين قسمت کمتر باشد، مسير کمتر گسترش ميي‌ابد. از دكمه لغزنده در اين قسمت 

نيز براي تنظيم اندازه مسير گسترش يافته استفاده مي‌شود. 
• با عملکرد بقيه گزينه‌ها در واحد كار 9 آشنا شده‌ايد.	

  Ragged4-1-11جلوه
اي��ن جلوه با افزودن نقاط تصادفي جديد، ظاهر ش��کل را تغيي��ر داده و ظاهري ناهموار، 

صاف يا يکدست به شکل مي‌دهد. اين جلوه شبيه ابزار Roughen كار ميك‌ند.

Both شکل اصلی      گزینه       Inside only گزینه     outside only گزینه                 
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Ragged شکل 14-11 جلوه

به منظور اعمال جلوه Ragged روي موضوع موردنظر مراحل زير را انجام دهيد:
1- پس از انتخاب موضوع موردنظر از منوي ظاهر ش��ده )شکل 1-11( گزينه Ragged را 

انتخاب نماييد.
2- تنظيمات موردنظر را اعمال نماييد:

• يا با كمك لغزنده آن مي‌توان فاصله نقاط افزوده ش��ده تا‌ ش��کل اصلي‌  	Size در كادر
را تغيير داد.

• در قسمت Frequency مي‌توان تعداد نقاط افزوده را تعيين نمود.	
• تعداد  	 Copyدر صورتي که بخواهيد از ش��کل موردنظر کپي ايجاد كنيد در قس��مت

کپي‌هاي مورد نظر را وارد نماييد.

Ragged شکل 15-11 تنظيمات جلوه

• كيي از گزينه‌هاي  Edgeكه در زير بيان شده انتخاب كنيد:	
• انتخاب گزينه Rough ، نقاط گوشه تيز را اضافه مي‌کند )شكل 11-16(.	
• انتخاب گزينه Smooth، نقاط انحنادار را اضافه مي‌کند )شكل 11-16(.	

• به صورت يکنواخت اعمال  	Ragged باعث مي‌ش��ود تا جلوه Uniform انتخاب گزينه
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شود.

شكل 11-16

تمرين 3: شکل‌هاي زير را با استفاده از جلوه‌هاي Ragged و Expand Path ايجاد 
کنيد.

شکل 11-17

  Sketch 5-1-11 جلوه
اين جلوه نمايي از مسير را شبيه‌سازي مي‌کند که به نظر مي‌رسد شکل مورد نظر با مداد 

و به سرعت طراحي شده است.

اعمال جلوه Sketch در صورت                                    شكل اصلي                       اعمال جلوه Sketch در صورت
               بسته بودن خطوط دور شكل                                                                               باز بودن خطوط دور شكل 

Copies با Sketch شکل 18-11 اعمال جلوه

به منظور اعمال جلوهSketch  روي موضوع موردنظر، مراحل زير را انجام دهيد:
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1- پس از انتخاب موضوع موردنظر، از منوي ظاهر شده گزينهSketch  را انتخاب كنيد.
2- تنظيمات موردنظر را اعمال نماييد.

• باعث مي‌شود که اختلاف شکل با شکل  	Amount وارد کردن عدد بزرگ‌تر در قسمت
اوليه بيشتر شود.

• وارد  	Copy براي ايجاد کپي از ش��کل ايجاد ش��ده، تعداد کپي موردنظر را در قسمت
كنيد. در اين صورت مسيرهاي جديدي به وجود مي‌آيند كه به طور تصادفي با ساير 

كپي‌ها متفاوتند )شكل 11-19(.

شکل 19-11 مثال‌هايي از تنظيم كادر كپي روي دو شكل

انتخاب گزينه Closed باعث مي‌ش��ود تا نقاط انتهايي شکل ايجاد شده به يکديگر متصل 
شوند و شکل بسته ايجاد شود. 

Close غيرفعال بودن گزينه   		 Close فعال بودن گزينه                  

شکل 11-20

  Bevel and Emboss6-1-11 جلوه
جلوهBevel  باعث مي‌ش��ود لبه‌هاي ش��کل به حالت برجسته نمايش داده شوند و با جلوه 

Emboss  مي‌توان شکل يا متن را به صورت برجسته نمايش داد.

ب��ا انتخاب جل��وه  Bevel and Emboss )ش��کل 1-11( زيرمنويي به‌ص��ورت بعد نمايان 
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مي‌شود. 
• باعث مي‌ش��ود تا لبه‌هاي ش��کل به ترتيب به  	Outer Bevel و Inner Bevel انتخ��اب

سمت درون و بيرون شکل متمايل شوند و به حالت برجسته نمايش داده شوند.

 
شکل 22-11                                                                       شکل 11-23  

• مي‌ت��وان تنظيم��ات زير را انج��ام داد:  	Object در پن��ل Outer Bevel ب��ا انتخ��اب 
)شکل 11-24(

•از پالت رنگ مي‌توان رنگ مورد‌‌نظر براي برجستگي به سمت خارج شكل‌ را انتخاب  	
نمود.

• در ليست بازشوي Width مقدار مورد نظر براي پهناي برجستگي‌ را وارد نماييد.	
• ميزان روشني و تيرگي سايه‌ها را  	Contrast مقادير تعيين ش��ده در ليست بازش��وي

معين مي‌کند.
مي‌توان مقاديري براي تأثير بر صافي برجستگي، بدون  • 	  Softness در ليس��ت بازشوي
تأثي��ر ب��ر پهناي آن وارد كرد. ب��ه عبارت ديگر هر خط ضخيم در س��ايه‌زني حذف 

مي‌شود.
• مي‌توان با وارد کردن مقدار موردنظر، زاويه تابش نور را  	Angle در ليس��ت بازش��وي

تنظيم نمود.
• در ليست بازشوي Edge shape شکل لبه را مي‌توان به دلخواه انتخاب كرد.	

• پيش‌تنظيم‌هايي براي تغيير ظاهر ش��ئ وجود  	 Button Presetدر ليس��ت بازش��وي
دارد.
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شکل 11-24

 Raised اس��تفاده كرد. اگر گزينه Emboss براي برجس��ته کردن ش��کل مي‌توان از جلوه
Emboss را انتخاب کنيد کادر شکل 25-11 نمايش داده مي‌‌شود.

Raised Emboss شکل 25-11 تنظيمات جلوه

• مقدار مشخص شده در ليست بازشوي Width، اندازه عمق را تعيين مي‌کند.	
• ميزان روشني و تيرگي سايه‌ها را  	Contrast مقدار تعيين ش��ده در ليست بازش��وي

معين ‌‌مي‌کند.
مي‌توان مقاديري براي تأثير بر صافي برجستگي، بدون  • 	 Softness  در ليست بازش��وي

تأثير بر پهناي آن وارد كرد.
• مي‌توان با وارد کردن مقدار مورد نظر يا استفاده از عقربه کشويي،  	Angle در قسمت

زاويه تابش نور را تنظيم نمود.
در شكل 26-11 نمونه‌هايي از جلوه Emboss نشان داده شده است.
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شکل 11-26

در Inset Emboss برجسته‌ســازي به نحوي است كه گويي شئ در صفحه فشار داده شده 
است.

در Raised Emboss برجسته‌سازي به نحوي است كه گويي شئ از صفحه بالاآمده   است.

تمرين 4: شکل 27-11 را طوري رسم كنيد که برجسته به نظر آيد.

شکل 11-27
Blur 7-1-11 جلوه

اين جلوه جزييات تصوير را تيره و تار ميک‌ند. اين جلوه دو حالت دارد.
حالــتBasic ، جلوه غيرمتمرکز به شــکل مي‌دهد و حالــت Gaussian ظاهري مبهم به 
 شــکل مي‌دهد به طوري که به نظر مي‌آيد از پشت شيشه نيمه مات به شکل نگاه ميک‌نيد 

)شکل 11-28(.

شکل 11-28

پس از اعمال جلوه Blur در کادر نمايش داده شــده )شــکل 29-11( به منظور تعيين 
ميزان مات شدن شکل، عدد مورد نظر را وارد كنيد.
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     Blur شکل 29-11 تنظيمات جلوه

تمرين 5: ش��کل 30-11 را رس��م كرده و جلوه Gaussian Blur را روي آن اعمال 
كنيد.

شکل 11-30

Shadow and Glow 8-1-11 جلوه
براي ايجاد سايه دور شکل از جلوه Shadow استفاده مي‌شود و جلوه Glow درون يا بيرون 

شکل هاله ايجاد مي‌نمايد )شکل 11-31(.
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Glow و Shadow شکل 31-11 نتيجه حاصل از تأثير جلوه

به منظور اعمال جلوه Shadow روي شکل مراحل زير را انجام دهيد:
 Shadow andش��کل 1-11( گزينه( Effect 1- پس از انتخاب موضوع مورد نظر، از منوي

Glow  را انتخاب كرده سپس كيي از جلوه‌هاي زير منوي مربوطه را برگزينيد.

) • Drop Shadow: جلوه ‌را به‌گونه‌اي ايجاد‌ ميك‌ند كه به شئ سايه‌ مي‌دهد )شكل11-32	

جلوه به‌گونه‌اي اس��ت كه گويي سوراخي از شئ در صفحه به‌وجود  • 	 :Inner Shadow

آمده است )شكل 11-32(.
• Glow: در بخش بيروني شئ درخشندگي يا هاله ايجاد ميك‌ند )شكل 11-32(.	

• Inner Glow: در درون شئ درخشندگي ايجاد ميك‌ند )شكل 11-32(.	

Glowو Shadow شکل 32-11 اعمال جلوه‌هاي

2- تنظيمات موردنظر را اعمال كنيد.
• رنگ موردنظر براي ايجاد سايه يا هاله را انتخاب نماييد. 	Color از قسمت

• تنظيم كنيد. 	 Offsetميزان فاصله سايه از لبه شئ را در ليست بازشوي
• عدد  	Opacity به منظور تعيين ميزان ش��فافيت س��ايه يا هاله در ليس��ت بازش��وي

موردنظر را وارد نماييد.
•براي اين‌که س��ايه يکدس��ت و نرم روي تصوير اعمال ش��ود به طوري که پهناي آن  	
تغيير نکند مي‌توان در ليست بازشوي Softness عدد موردنظر را وارد نمود. به عبارت 

ديگر براي اعمال تارشدگي به لبه سايه استفاده مي‌شود.
• را تنظيم  	Angle براي تعيين زاويه تابش نور بر جسم، عدد موجود در ليست بازشوي

كنيد.
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Shadow and Glow شکل 33-11 تنظيمات جلوه

• را  	Knock Out ،در تنظيمات جلوه س��ايه براي پنهان كردن شئ و باقي ماندن سايه
انتخاب كنيد )شكل 11-34(.

 Shadowدر انواع حالات جلوه Knock Out شکل 34-11 تنظيم گزينه

تمرين 6: ش��کل 35-11 را رس��م كنيد. )به جلوه‌هاي اعمال ش��ده روي شکل 
توجه کنيد.(

شکل 11-35
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Sharpen 9-1-11 جلوه

اين جلوه با تنظيم Contrast پيکسل‌هاي همجوار در شکل، وضوح يا تيزي لبه‌هاي شکل 
را افزايش مي‌دهد )شکل 11-36(.

Sharpen شکل 36-11 نتيجه حاصل از تأثير جلوه

به منظور اعمال جلوهSharpen  روي موضوع موردنظر مراحل زير را انجام دهيد:
1- پ��س از انتخاب موض��وع موردنظر، از منوي Effect )ش��کل 1-11( جلوه Sharpen را 

انتخاب كنيد، سپس از زيرمنوي آن گزينه‌هاي زير را برگزينيد. 
2- تنظيمات موردنظر را اعمال كنيد. )شکل 11-37(

• در ليست بازشوي Amount  ميزان شدت اعمال جلوه را تعيين کنيد.	
• براي  	Pixel Radius انتخاب ش��ده باش��د از ليست بازشوي Unsharp mask زماني که
تنظيم اندازه ناحيه‌اي استفاده كنيد كه جلوه Sharpen به آن اعمال شده باشد. اعداد 

بالاتر به معناي اعمال جلوه كمتري به تصوير است.

Sharpen شکل 37-11 تنظيمات جلوه

Transparency 10-1-11جلوه

با اس��تفاده از اين جلوه مي‌توان تمام يا قس��متي از رنگ داخل شکل يا خط دور شکل را 
به صورت واضح يا نيمه کدر نمايش داد.
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شکل 11-38

با انتخاب گزينهTransparency  زيرمنوي زير نمايش داده مي‌شود )شکل 11-39(.

شکل 11-39

• تمام شکل را به‌طور يکنواخت شفاف مي‌نمايد. به‌طوريك‌ه  	Basic Transparency جلوه
موضوعات ديگر از زير آن ديده شوند.

• با كش��يدن  	Transparency با انتخاب اين جلوه مي‌توان ميزان ش��فافيت را در کادر
دكمه لغزنده تعيين نمود.

• موضوع را از داخل به سمت بيرون محو ميك‌ند به‌طوريك‌ه محو شدن  	Feather جلوه
در  لبه‌هاي شکل صورت مي‌گيرد.

 • در کادر Radius براي تعيين شعاع محوشدگي )Transparency( از مرکز شکل، عدد	
موردنظر را وارد ‌نماييد. 

ه��اي موجود در  • جل��وه Gradient Mask باع��ث محو ش��دن موضوع به صورت طيف‌	
FreeHand، مي‌ش��ود. رنگ س��فيد 100% شفافيت و رنگ مش��کي 100% تاري را 

توليد مي‌کند.
تمري�ن 7: پرچم ايران را رس��م كنيد و بين رنگ‌ه��ا را Transparency كنيد تا 

رنگ‌ها بدون مرز باشند.
Envelope 2-11 فرمان

فرمان Envelope امکان فرم‌دهي به تصاوير و نوشته‌ها را فراهم مي‌نمايد. با استفاده از اين 
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دستور مي‌توان ظاهر شکل را تغيير داد. 
براي اجراي اين دستور از منوي Modify گزينه Envelope را انتخاب نماييد در اين صورت 
 Envelope زيرمنوي��ي نمايش داده مي‌ش��ود که ش��امل گزينه‌هاي مورد اس��تفاده در فرمان

است.

 Envelope نوار ابـزار Window → Toolbars → Envelope نكته: با انتـخاب ‌گزينـه

 نمـايش ‌ميي‌ابد.

)شکل 11-40(.

Envelope شكل 40-11 نوار ابزار

با کليک روي منوي بازشوي موجود در اين نوار ابزار، ليست اشکال مختلف نمايش داده 
مي‌شود. براي تغيير يا فرم‌دهي شکل مراحل بعد را انجام دهيد:

1- شکل موردنظر را انتخاب كنيد.
2- روي آيک��ن Create  در ن��وار ابزار Envelope کليک نماييد. گره‌ها و اهرم‌هايي در 
اطراف ش��کل نمايش داده مي‌شود و شما مي‌توانيد با استفاده از ابزارهاي تغيير مسير، ظاهر 

شکل را به صورت موردنظر تغيير دهيد. 

 مثال 2:
1- شکل 44-11 را رسم نماييد.

2- از منوي بازشوي نوار ابزار Envelope گزينه Heart را انتخاب كنيد.

   شکل 41-11                شکل 42-11 انتخاب گزينه Heart                    شکل 11-43
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3- روي آيکن )Create(  يا گزينه Envelope→Create از منوي Modify کليک کنيد. 
شکل به اين صورت نمايش داده مي‌شود.

يا   Remove نكت�ه: براي حذف تمام تغييرات انجام ش��ده روي ش��کل، آيکن 
گزينه Envelope→Remove از منوي Modify را کليک كنيد.

 Envelope→Show Map يا گزينه  Show Map توج�ه: با کليک روي آيک��ن 

از منوي Modify مي‌توانيد س��اختار و خطوط نقش��ه فرم اعمال ش��ده را مشاهده كرده و در 
صورت نياز آن را تغيير دهيد.

1-2-11 اعمال يک مسير دلخواه روي تصوير به‌عنوان Envelope)پوشش( 
1- مسير موردنظر را رسم نموده روي گزينه Edit→Copy کليک نماييد.

2- شکلي را که مي‌خواهيد مسير موردنظر به عنوان Envelope به آن اعمال شود، انتخاب 
کنيد.

 3- روي دکم��ه Paste as envelope  از ن��وار‌ اب��زار Envelope كلي��ك كنيد يا گزينه
 Envelope→Paste as envelope را از منوي Modify اجرا كنيد.

در اين صورت Envelope به شكل موردنظر‌ اعمال مي‌شود )شكل 11-44(.

شكل 44-11 اعمال مسير به متن

2-2-11 ذخيره‌سازي مسير اعمال شده به شکل
هنگامي كه كي Envelope جديد ايجاد كرديد ممكن اس��ت بخواهيد آن را ذخيره كنيد 
تا روي اش��ياي ديگر اعمال كنيد. به منظور ذخيره‌س��ازي مس��ير اعمال شده به شئ مراحل 

زير را انجام دهيد:  
1- شکلي را انتخاب كنيد که داراي Envelope مورد نظر شما براي ذخيره است. 

 Envelope→save as ياگزينه Envelope از نوار اب��زار  save as preset 2- روي دکم��ه
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preset از منوي Modify کليک كنيد.

3- کادر محاوره New Envelope نمايش داده مي‌ش��ود )ش��کل 45-11(. در كادر متني 
Name نام موردنظر را درج نموده و روي دكمه OK کليک نماييد تا مسير موردنظر به عنوان 

يک فرم به بالاي منوي بازشوي موجود در نوار ابزار Envelope اضافه شود.

شکل 11-45

 نكته: به منظور حذف يک فرم از منوي بازش��وي نوار ابزار Envelope، نام فرم را 
 Envelope→Delete يا گزينه  Delete preset از ليس��ت انتخاب كرده س��پس روي دکمه

preset از منوي Modify کليک كنيد.

3-2-11 استفاده از يک فرم Envelope براي ساخت مسير 
پس از ايجاد كي Envelope مي‌توانيد آن را به مسير تبديل كنيد. در اين صورت تغييرات 
قابل اعمال  روي مس��ير را مي‌توانيد روي آن فرم اعمال نماييد. براي اين منظور مراحل زير 

را انجام دهيد:
1- ش��کل موردنظر که فرم Envelope را روي آن اعمال نموده‌ايد، انتخاب کنيد )ش��کل 

.)11-46
 Modify از منوي Envelope→Copy as Path يا گزينه  Copy as Path 2- روي دکمه

کليک نماييد.
3- از منوي Edit گزينه Paste را انتخاب كنيد )ش��کل 47-11(. مي‌توانيد كي زمينه يا 

خط دور به مسير اضافه نماييد.

      

		       شکل 11-47                                 شکل 11-46

 نكته: براي حذف پوشش )Envelope( از روي شکل به‌طوري که تغييرات اعمال شده 
به ش��کل حفظ ش��ود، روي دکم��ه  Release  يا گزين��ه Envelope→Release  از منوي 

Modify کليک كنيد.
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  Fisheye Lens3-11 ابزار
با اس��تفاده از اين ابزار مي‌توان به موضوعات انتخاب ش��ده، حالت تقعر يا تحدب داد. به 
عبارت ديگر اين ابزار مانند لنز چش��م ماهي باعث ايجاد اعوجاج در اش��ياء مي‌شود به طوري 

كه اشياء را برجسته مي‌بينيد.
Fisheye Lens 1-3-11 روش کار با ابزار

 Fisheye Lens در جعبه ابزار دابل کليک کنيد تا کادر محاوره Fisheye Lens 1- روي ابزار
مطابق شکل 48-11 باز شود.

         

 Fisheye Lens  شکل 48-11 کادر محاوره

2- با استفاده از ماوس، دکمه لغزنده Perspective را درگ کنيد.
• Convex )محدب( يا اعداد مثبت، شئ را برجسته مي‌کند.	

• Concave )مقعر( يا اعداد منفي، در شئ تورفتگي ايجاد مي‌کند.	

3- روي دکمه OK کليک کنيد. 
4- روي ش��کل انتخاب شده، کليک کرده و اشاره‌گر ماوس را بکشيد تا در ناحيه دلخواه 

شكل مقعر يا محدب شود.
مثال 3:

 
1- متن Freehand MX را مطابق شکل 49-11 روي صفحه تايپ کنيد.                                                                                           

شکل 49-11 تايپ متن

2- رنگ متن را آبي کنيد.
3- روي متن کليک راست کرده، گزينهConvert To Paths  را انتخاب کنيد تا حالت متن 

به مسير تبديل شود.
4- روي ابزار Fisheye Lens دابل کليک کنيد تا کادر محاوره Fisheye Lens باز شود.

5- در قسمت Perspective نوع لنز را محدب قرار دهيد )شکل 11-51(.



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
320

        

 شکل 50-11 روش تبديل حالت متن به مسير               شکل 51-11 تنظيم محدب بودن جلوه

6- اش��اره‌گر ماوس را روي متن نوش��ته ش��ده در ناحيه‌اي که مي‌خواهيد محدب شود، 
بکشيد تا شکل يک بيضي ايجاد شود )شکل 11-52(.

7- كليد ماوس را رها کنيد تا مطابق شکل 53-11 جلوه ايجاد شود. 
     

             

Fisheye Lens شکل 53-11 نتيجه استفاده از ابزار         Fisheye Lens شکل 52-11 اعمال ابزار

 نكته: كليد Alt را نگه داريد تا اعوجاج از مركز به سمت خارج ايجاد شود.

تمرين 8: اسم خود را بنويسيد و جلوه مقعر به آن بدهيد.
 3D Rotation4-11 ابزار

اين‌اب��زار به‌موضوع��ات گرافيک��ي ام��کان تغيي��ر ش��کل و دوران به صورت س��ه‌بعدي 
)چرخش‌فضايي( را مي‌دهد.

3D Rotation1-4-11 روش کار با ابزار
 3D Rotation 3 در جعبه ابزار دابل کليک کنيد تا کادر محاورهD Rotation 1- روي ابزار
مطابق شکل 54-11 باز شود. در اين کادر مي‌توانيد خصوصيات چرخش را به دلخواه تغيير 

دهيد.

        

  3D Rotation شکل 54-11 کادر محاوره

2- در اين کادر محاوره دو گزينه وجود دارد:
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Easy  )ساده(

Expert )حرفه‌اي( که داراي گزينه‌هاي بيشتري نسبت به Easy است.

3- منوي بازش��و Rotate from نقطه ش��روع چرخش را تعيين مي‌کند که داراي حالات 
زير است:

• محلي را که در آن جا کليک مي‌کنيد به عنوان نقطه  Mouse click )کليک ماوس(:	

چرخش قرار مي‌دهد )شکل 11-55(.

شکل 55-11 انتخاب Mouse click براي نقطه چرخش

• مرکز شکل انتخاب شده را نقطه چرخش دوران قرار مي‌دهد  	:Center Of Selection

)شکل 11-56(.

شکل 56-11 انتخاب Center Of Selection براي نقطه چرخش

• هنگام دوران شکل‌هاي نامسطح، نقطه چرخش  Center Of Gravity )مرکز جاذبه(:	

را در مرکز ثقل شکل قرار مي‌دهد )شکل 11-57(.

شکل 57-11 انتخاب Center Of Gravity  براي نقطه چرخش

نقطه چرخش را در گوش��ه سمت چپ و پايين ناحيه انتخاب شده،  • Origin )مبدأ(: 	

براي دوران قرار مي‌دهد )شکل 11-58(.
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شکل 58-11 انتخاب Origin براي نقطه چرخش

  )Perspective(ميزان چرخش يا اعوجاج تصاوير به صورت پرسپکتيو Distance 4- در کادر
بزرگ و کوچک تنظيم مي‌شود )شکل 59-11(. براي ايجاد اعوجاج بيشتر، اعداد پايين‌تر از 

اين ميزان استفاده مي‌شود.

Distance شکل 59-11 تنظيم کادر

5- اکنون اش��اره‌گر ماوس به ش��کل + درآمده است، آن را روي قسمت موردنظر از شکل 
قرار داده، کليک و درگ کنيد. با حرکت اش��اره‌گر، پيش‌نمايش��ي از چرخش موضوع نمايش 
داده مي‌ش��ود. همان‌طور که مشاهده مي‌کنيد در امتداد محل کليک و حرکت ماوس خطي 
ايجاد مي‌ش��ود که به آن محور چرخش مي‌گويند. براي تعيين ميزان چرخش، کافي اس��ت 

اشاره‌گر را در طول اين محور جابه‌جا کنيد.
6- وقتي چرخش موضوع به دلخواه شما بود، كليد ماوس را رها کنيد.

 توج�ه: اگر در هنگام اس��تفاده از ابزار چرخش س��ه بعدي، کلي��د Shift را به‌طور 
همزمان فشار دهيد چرخش به صورت 45 درجه درمي‌آيد.

در حالت Expert، منوي بازشوي Project from به کادر محاوره 3D Rotation اضافه مي‌شود 
که توس��ط اين منو مي‌توانيد نقط��ه گريز موضوع را هن��گام دوران تنظيم کنيد. گزينه‌هاي 

موجود در اين منو عبارتند از:
Center Of Gravity ،Center Of Selection ،Mouse click و Origin كه توضيح داده ش��ده 

است. همچنين گزينه ديگري در اين منو به‌صورت زير قرار دارد:
 • 	x با انتخاب اين گزينه مي‌توانيد در کادرهاي مربوطه، مختصات :X/Y Coordinates
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و y نقطه گريز را به صورت عددي وارد کنيد.

تمرين 9: ش��کل 60-11 را رسم کرده، س��پس آن را دوران دهيد به طوري که 
نقطه دوران شکل در سمت چپ و پايين شکل قرار گيرد.

شکل  11-60
 Shadow 5-11 ابزار

از اين ابزار براي ايجاد س��ايه در پش��ت موضوعات يا متوني که به مس��ير تبديل شده‌اند، 
استفاده مي‌شود.

1-5-11 روش اعمال سايه
1- موضوعي را که مي‌خواهيد سايه‌دار شود، انتخاب کنيد.

2- ابزار Shadow را از جعبه ابزار انتخاب کرده )ش��کل 61-11( سپس اشاره‌گر ماوس را 
روي شکل قرار داده و به سمت پايين بکشيد تا سايه در زير شکل ايجاد شود

شکل 11-61

3- براي اعمال تنظيمات بيش��تر، روي ابزار Shadow داب��ل کليک کنيد تا کادر محاوره 
Shadow ظاهر شود )شکل 11-62(.

Shadow شکل 62-11 کادر محاوره
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4- در کادر محاوره Shadow ، منوي بازش��وي Type داراي چند حالت انتخابي به ش��رح 
زير است:

                         

 سايه با لبه‌هاي سخت                  سايه با لبه‌هاي نرم                    سايه با بزرگنمايي 

شکل 11-63

هن��گام انتخاب حالت Soft Edge مي‌تواني��د با درگ رنگ به کادر Stroke، رنگ پس‌زمينه 
سايه را تنظيم کنيد که به‌طور پيش‌فرض سفيد است.

همچنين با انتخاب حالت Zoom مي‌توانيد رنگ داخل س��ايه و خط دور س��ايه را تعيين 
کنيد.

5- با انتخاب يکي از حالت‌هاي Hard Edge يا Soft Edge منوي بازش��وي Fill داراي س��ه 
گزينه انتخابي مطابق شکل 64-11 خواهد شد:  

Fill شکل 64-11 حالات موجود در منوي بازشوي
• ب��ا انتخ��اب اين گزينه، س��ايه با رنگ تعيين ش��ده در کادر رنگي زير آن پر  	:Color

مي‌شود.
• با استفاده از دکمه لغزنده يا وارد کردن عدد در کادر مربوطه، سايه‌اي ايجاد  	:Shade

مي‌شود که رنگ آن تيره‌تر از موضوع اصلي است.
• ب��ه کمک دکمه لغزنده ي��ا وارد کردن عدد در کادر مربوطه، س��ايه‌اي ايجاد  	:Tint

مي‌شود که رنگ آن روشن‌تر از موضوع اصلي است.
6- با استفاده از دکمه لغزنده Scale يا وارد کردن عدد در کادر مربوطه، اندازه سايه از 1 

تا 200% تنظيم مي‌شود.

 توجه: مقدار کمتر از 100%، س��ايه‌اي کوچک‌تر از موضوع اصلي و مقدار بيشتر از 
100%، سايه‌اي بزرگ‌تر از موضوع اصلي ايجاد مي‌کند.
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7- در قس��مت Offset با تنظيمx  و y، محل قرار گرفتن س��ايه يا فاصله س��ايه از موضوع 
اصلي تنظيم مي‌شود.

8- روي دکمه OK کليک کنيد، سايه دلخواه روي موضوع اعمال مي‌شود.

  Subselectنكته: پس از اعمال يک سايه به موضوع مي‌توانيد با استفاده از ابزار 
و درگ ماوس سايه را به محل جديدي انتقال دهيد.

مثال 4: شکل 65-11 را رسم کرده، سپس سايه‌اي با لبه‌هاي سخت در آن ايجاد 
کنيد، به‌طوري که سايه از تصوير بزرگ‌تر و رنگ آن روشن‌تر از موضوع اصلي باشد. 

شکل 11-65

1- ابتدا شکل مورد نظر را انتخاب کنيد.
2- روي ابزار Shadow دابل کليک کنيد تا کادر محاوره Shadow باز شود.

3- در منوي بازشوType  نوع سايه را Hard Edge انتخاب کنيد.
4- در منوي بازشو Fill حالت Tint را انتخاب کرده و در کادر مقابل دکمه لغزنده عدد50 

را وارد کنيد.
5- در کادرScale  عدد 120 را وارد کنيد تا سايه از خود شکل بزرگ‌تر باشد.

6- در قسمت Offset  محل قرارگيري سايه را مشخص کنيد.
7- روي دکمهOK کليک کنيد، شکل به‌   دست آمده    مشابه     شکل66-11 خواهد شد.

Shadow شکل 66-11 نتيجه حاصل از اعمال ابزار
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تمرين 10: شکل‌هاي 67-11 را رسم کرده، به نوع سايه‌ها دقت کنيد.

شکل 11-67

 Smudge 6-11 ابزار
با استفاده از اين ابزار مي‌توان به موضوعات بعد، عمق يا جلوه حرکت نسبت داد. همچنين 

کاربرد ديگر اين ابزار، ايجاد سايه براي شکل و متن تبديل شده به مسير است.
 Smudge 1-6-11 روش کار با ابزار

1- ابزار Smudge را از جعبه ابزار انتخاب نماييد.
2- ب��راي اعمال تنظيمات بيش��تر روي ابزار Smudge دابل کلي��ک کنيد تا کادر محاوره 

Smudge مطابق شکل 68-11 ظاهر شود.

Smudge شکل 68-11 کادر محاوره

3- در اي��ن کادرمحاوره براي انتخاب رنگ دلخواه داخل و خطوط دور ش��کل، دو گزينه 
قرار دارد:

براي پر کردن رنگ داخل موضوع گرافيکي به‌کار مي‌رود به ش��رطي که  • 	 :Fill گزينه
قبلًا داخل موضوع با رنگ پر شده باشد.

براي رنگ‌آميزي خط��وط پيرامون موضوع گرافيک��ي رنگي به‌کار  • 	 :Stroke گزين�ه
م��ي‌رود. با اس��تفاده از اين گزين��ه مي‌توانيد رنگ‌هاي دلخ��واه را براي خطوط دور 

موضوع يا سايه انتخاب کنيد.
4- روي دکمه OK کليک کنيد.

5- اش��اره‌گر ماوس ش��بيه به دست مي‌شود، روي ش��کل کليک کرده و آن را به سمت 
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خارج درگ کنيد.
شکل 69-11 استفاده از اين ابزار را روي شکل نشان مي‌دهد.

    

Smudge شکل 69-11 اعمال ابزار

 توجه: براي افزودن س��ايه به اطراف ش��کل يا رسم س��ايه از مرکز شکل به سمت 

خارج، هنگام استفاده از ابزار Smudge کليد Alt را به‌طور همزمان نگه داريد.
مثال 5:

1- با استفاده از ابزار Ellipse يک بيضي مطابق شکل 70-11 رسم کنيد. 
2- روي ابزار Smudge از نوار ابزار دابل کليک کنيد.

3- ب��راي اي��ن که رنگ داخ��ل موضوع را قرمز کني��د، در قس��متFill  در کادر محاوره  
Smudgeرنگ قرمز را برگزينيد.

4- براي اين که رنگ خطوط دور ش��کل س��بز شود در قس��متStroke  در کادر محاوره 
Smudge رنگ سبز را انتخاب کنيد.

5- روي دکمهOK  کليک کنيد.
6- اش��اره‌گر ماوس ش��بيه ‌دست مي‌شود، آن‌را روي ش��کل برده و به سمت خارج درگ 

کنيد )شکل 11-71(.

                              

Smudge شکل 70-11                              شکل 71-11 اعمال ابزار   

تمرين 11: ش��کل 72-11 را رس��م کرده، سپس به وس��يله ابزار Smudge به آن 
بعُد دهيد.
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شکل 72-11 رسم شکل
 Bend 7-11 ابزار

اين ابزار در ش��کل‌ها و مسيرهاي رسم ش��ده، تاب خوردگي ايجاد مي‌کند، به‌طوري که 
پاره‌خط‌هاي مسير به سمت داخل يا خارج  منحرف مي‌شوند.

Bend 1-7-11 تنظيم گزينه‌هاي ابزار

1- ابزار Bend را از نوار ابزار Xtra tools انتخاب کنيد )شکل 11-73(.

Bend   شکل 73-11 انتخاب ابزار

2- روي اب��زارBend  دابل کلي��ک کنيد تا کادر محاوره Bend مطابق ش��کل 74-11 باز 
شود.

Bend شکل 74-11 کادر محاوره

Bend 2-7-11 روش استفاده از ابزار
1- شكل 75-11 را رسم كنيد.

2- روي ابزارBend  دابل کليک کنيد و با حرکت دکمه لغزنده Amount، ش��دت عملکرد 
اين ابزار را روي شکل تعيين کنيد.

3- اش��اره‌گر ماوس )+( را روي ش��کل انتخاب شده قرار دهيد، سپس ماوس را به سمت 
پايين درگ کنيد اکنون لبه‌هاي ش��کل گرد مي‌ش��ود )شکل 76-11- الف(. اگر ماوس را به 

سمت بالا درگ کنيد، لبه‌هاي شکل به صورت تيز درمي‌آيند )شکل 76- 11- ب(.
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 ماوس به سمت بالا کشيده شده                  ماوس به سمت پايين کشيده شده

Bend شکل 75-11 رسم و انتخاب شکل                شکل 76-11 نتايج حاصل از اعمال ابزار

 مثال 6: شکل 77-11 را ايجاد کنيد.
1- ابتدا با ابزار Ellipse و نگه داشتن کليد Shift يک دايره رسم کرده و داخل آن را رنگ 

کنيد )شکل 11-78(.

            

     شکل 77-11               شکل 78-11 رسم دايره

2- ابزار Bend را انتخاب کنيد.
3- با ماوس روي مرکز دايره کليک کرده آن را به س��مت پايين درگ کنيد تا به ش��کل 

موردنظر برسيد.
 Roughen 8-11 ابزار

اين ابزار باعث شکستگي خطوط تشکيل دهنده شکل مي‌شود و مسيرهاي هموار را نوک 
تيز و ناهموار مي‌سازد.

Roughen 1-8-11 تنظيم گزينه‌هاي ابزار

1- ابزار Roughen را از جعبه ابزار انتخاب نماييد.
2- روي ابزار Roughen دابل کليک کنيد تا کادر محاوره Roughen مطابق شکل 11-79 

باز شود.
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Amount  شکل 80-11 نتيجه استفاده از تنظيمات دکمه لغزنده     Roughen شکل 79-11 کادر محاوره    

3- روي دكمهOK  کليک کنيد.
  Roughen 2-8-11 روش استفاده از ابزار

 1- ابت��دا ش��کل دلخواه��ي رس��م کني��د، س��پس اب��زارRoughen  را انتخ��اب کني��د 
)شکل 11-81(.

2- با استفاده از ماوس، ابزار Roughen را در طول موضوع بکشيد.

                    	            	                             

   Roughen  شکل 82-11 نتيجه استفاده از                شکل 81-11 رسم شکل  	

تمرين 12: اشکال 83-11را با استفاده از ابزار Roughen رسم کنيد.

شکل 11-83 

  )Perspective( 9-11 ايجاد پرسپکتيو
 گاهي اوقات لازم است براي واقعي جلوه دادن اشياء يا نشان دادن عمق و حجم در ترسيم‌هاي 

دو بعدي از پرسپکتيو استفاده کنيم.
در FreeHand MXa به سادگي مي‌توانيد فضاي سه بعدي )شبکه شطرنجي سه بعدي( يا 

پرسپکتيو را در يک محيط دو بعدي بازسازي کنيد.
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بدين منظور مراحل زير را دنبال کنيد: 
1- گزينه View→Perspective Grid→Show را انتخاب کنيد.

2- ش��کل يا متن موردنظ��ر را انتخاب کرده و اب��زار پرس��پکتيو را از جعبه‌ابزار انتخاب 
کنيد.

3- اش��اره‌گر را روي اش��ياي موردنظر قرار داده و از کليدهاي جهت‌دار صفحه کليد براي 
قراردادن اش��ياء روي محورهاي پرسپکتيو استفاده کنيد. کليد جهت‌دار را پايين نگه داشته، 

سپس روي موضوع درگ کنيد )شکل 11-84(.

شکل 11-84

• آمده است: زيرمنوي Perspective شامل گزينه‌هايي است كه در جدول 11-1	

  Alt توجه: براي کپي کردن موضوع در حين اس��تفاده از ابزار پرس��پکتيو از کليد 

استفاده کنيد.
جدول 11-1

Show.نماي پرسپکتيو را فعال مي‌سازد

Define Grid)11-85 تنظيم و ويرايش خطوط شبکه و ايجاد نماي جديدي از شبکه )شکل

Previous.براي تعويض نماها به کار مي‌رود

Remove  Perspective.نماي پرسپکتيو شئ را حذف مي‌کند

 Release With
Perspective

جلوه پرسپکتيو را براي موضوع تثبيت مي‌کند به طوري‌که بعد از اجراي اين فرمان پرسپکتيو 
داده شده به شئ، قابل ويرايش نخواهد بود.
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Define Grids شکل 85-11 کادر محاوره

 Extrude 10-11 ابزار
با اس��تفاده از اين ابزار مي‌توان اشکال ايجاد ش��ده در FreeHand را به صورت سه بعدي 

نمايش داد. 

شکل 11-86

به منظور سه بعدي کردن اشکال مراحل زير را انجام دهيد:
1- ابزار Extrude را از جعبه ابزار انتخاب نماييد.

2- اش��اره‌گر ماوس را روي ش��کلي که قرار است س��ه بعدي شود قرار داده و آن را درگ 
كنيد.

شکل 11-87

 Modify→Extrude→Remove نكته: به‌منظور حذف حالت سه بعدي شکل، گزينه 
را انتخاب نماييد.

1-10-11 ويرايش شکل سه بعدي
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به منظور ويرايش جلوه س��ه بعدي اشکال از ابزار Extrude استفاده مي‌شود. اين ابزار دو 
حالت ويرايش دارد: 

حالت 1: امکان ويرايش محل، عمق و نقطه تلاقي را فراهم ميك‌ند.
حالت 2: امکان چرخش اشکال سه بعدي را فراهم مي‌نمايد.  

مث�ال كاربردي: فاي��ل Project مثال كاربردي واحد كار قبل را باز كنيد و مراحل زير را 
انجام دهيد:

1- وارد صفحه ايجاد شده براي كارت ويزيت شويد )شكل 88-11( و نشانه طراحي شده 
در صفحه آرم را در نقطه‌اي از صفحه درج كنيد.

2- آرم را انتخ��اب و گروه‌بن��دي كنيد و از پانل Transform زبانه Scale، نش��انه را %30 
بزرگ‌تر كنيد. اکنون با استفاده از پانل Align  آن را به وسط صفحه منتقل کنيد.

3- س��پس آرم را خاكستري كرده و با اس��تفاده از جلوه Transparency آن را به صورت 
محو در وسط صفحه قرار دهيد. 

 

شكل 11-88

4- كي كپي از آرم ايجاد كرده، آن را با Scale 70% كوچ‌كتر كنيد و در جاي مش��خص 
شده در شكل 88-11 قرار دهيد.

5- طراحي كارت ويزيت به پايان رسيد، سعي كنيد كارت‌هاي زيباتري طراحي كنيد.
واژه‌نامه
Convexمحدب

Edgeلبه

Expertمتخصص
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Expandگسترش

Envelopeپوشش 

Fisheyeچشم ماهي

Glowبرافروختگي

Raggedناصاف، ناهموار

Raisedبرجسته، برآمده 

Releaseرهايي، واگذاري كردن

Roughenزبرکردن، خشن شدن

Sketchطرح ساده

Sharpenنوک تيز کردن 

Smudgeلکه، سياه شدن

خلاصه مطالب 
• در شکل‌ها و مسيرهاي رسم شده، پيچ و خم و اعوجاج ايجاد مي‌کند. 	Bend جلوه

• يک يا چند مدل مش��ابه از ش��کل س��اخته، آن‌ها را ب��ا يکديگر ترکيب  	Duet جلوه
مي‌کند تا يک شکل پيچيده واحد ايجاد نمايد.

• مس��ير را په��ن نم��وده و طرح کلي ش��کل حاصل��ه را ايجاد  	Expand Path جل��وه
مي‌نمايد.

با افزودن نقاط تصادفي جديد، ظاهر ش��کل را تغيير داده و ظاهري  • 	 Ragged جل��وه
ناهموار، صاف يا يکدست به شکل مي‌دهد.

• باعث مي‌ش��ود لبه‌هاي ش��کل به حالت برجسته نمايش داده شوند و با  	 Bevel جلوه
جلوه Emboss ‌مي‌توان شکل يا متن را به صورت برجسته نمايش داد. 

 • جلوه Blur جزييات تصوير را تيره و تار مي‌کند.	
• پيکس��ل‌هاي همجوار در ش��کل، وضوح يا تيزي  	Contrast با تنظيم Sharpen جل��وه

لبه‌هاي شکل را افزايش مي‌دهد.
• مي‌توان تمام يا قسمتي از رنگ داخل شکل يا خط  	Transparency با استفاده از جلوه

دور شکل را به صورت واضح يا نيمه کدر نمايش داد.
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• فرمان Envelope امکان فرم‌دهي به تصاوير و نوشته‌ها را فراهم مي‌نمايد. 	
• مي‌توان به موضوعات انتخاب ش��ده، حالت تقعر يا  	Fisheye Lens با اس��تفاده از ابزار

تحدب داد.
• براي ايجاد س��ايه در پش��ت موضوعات يا متوني که به مسير تبديل  	Shadow از ابزار

شده‌اند، استفاده مي‌شود.
مي‌توان به موضوعات بعد، عمق يا جلوه حرکت نس��بت  • 	 Smudge با اس��تفاده از ابزار
داد. همچنين کاربرد ديگر اين ابزار، ايجاد س��ايه براي ش��کل و متن تبديل شده به 

مسير است.
باعث شکس��تگي خطوط تش��کيل دهنده شکل مي‌شود و مسيرهاي  • 	Roughen  ابزار

هموار را نوک تيز و ناهموار مي‌سازد.
• با ابزار Extrude مي‌توان به اشکال ايجاد شده در FreeHand، جلوه سه بعدي داد.	
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

 1- براي واقعي جلوه دادن موضوعات يا نشان دادن عمق و حجم در ترسيمات دو بعدي از ابزار
3D Rotation استفاده مي‌کنيم.

2- فرمان Envelope امکان فرم‌دهي به تصاوير و نوشته‌ها را فراهم مي‌نمايد.
3- جلوه Duet يک يا چند مدل مشابه از شکل ساخته، آن‌ها را با يکديگر ترکيب مي‌کند 

تا يک شکل پيچيده واحد ايجاد كند.
4- جلوه Blur در شکل‌ها و مسيرهاي رسم شده، پيچ و خم و اعوجاج ايجاد مي‌کند.

معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Bend جلوه                            	5- جزييات تصوير را تيره و تار مي‌کند.             
  Bevel6- در شکل‌ها و مسيرهاي رسم شده، پيچ‌و‌خم و اعوجاج ايجاد مي‌کند.      جلوه
  Emboss 7- باعث مي‌شود لبه‌هاي شکل به حالت برجسته نمايش داده شوند.      جلوه

Blur 8- مي‌توان شکل يا متن را به صورت برجسته نمايش داد.                      جلوه
گزينه صحيح را انتخاب کنيد.

9- هنگام استفاده از ابزار3D Rotation   نقطه چرخش در کدام قسمت تعيين مي‌شود؟
Expert -د             Rotate from -ج 	Easy -ب                 	Distance -الف

10- از کدام گزينه براي محدب کردن اشکال استفاده مي‌شود؟
Shadow -د         	Fisheye Lens -ج 	Smudge -ب 	3D Rotation -الف

11- شکل زير توسط چه ابزاري طراحي شده است؟
Roughen -الف

 Bend -ب
Smudge -ج

Spiral -د
12- با اس��تفاده از کدام جلوه مي‌توان تمام يا قس��متي از رنگ داخل ش��کل يا خط دور 

شکل را به صورت واضح يا نيمه کدر نمايش داد؟
Emboss -د 	     Sharpen -ج	 Transparency-ب 	 Blur -الف
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13- ب��ه منظور اعمال كي مس��ير دلخواه روي تصوير به‌عنوان ي��ک Envelope  از کدام 
گزينه استفاده مي‌کنيم؟

Paste as envelope -د        Save as preset -ج       Show map -ب    Release -الف
در جاي خالي عبارت مناسب را بنويسيد.

14- جل��وه  ........................... مس��ير را په��ن نم��وده و طرح کلي ش��کل حاصله را ايجاد 
مي‌نمايد.

15- جلوه .............................. با افزودن نقاط تصادفي جديد، ظاهر ش��کل را تغيير داده و 
ظاهري ناهموار، صاف يا يکدست به شکل مي‌دهد.

16- جلوه ......................... نمايي از ش��کل را شبيه‌سازي مي‌کند که به نظر مي‌رسد شکل 
مورد نظر با مداد طراحي شده است.

به سؤالات زير پاسخ تشريحی دهيد.

17-  ابزار Roughen چه عملي انجام مي‌دهد؟
18-  تفاوت نوعHard Edge  و Zoom هنگام استفاده از ابزار Shadow چيست؟

19-  در چه مواقعي از ابزارهاي زير استفاده مي‌کنيد؟
  Perspective-الف
3D Rotation -ب

Roughen -ج
20- از ابزار Extrude به چه منظور استفاده مي‌شود؟

آزمون عملي
1- تصوير مقابل را با استفاده از ابزارSmudge  طراحي کنيد.
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2- با استفاده از ابزار Fisheye Lens شکل روبه‌رو را طراحي کنيد.

3- شکل روبه‌رو را رسم کرده، سپس توسط 3D Rotation  تصوير ب را ترسيم کنيد.

 Expand4- در ش��کل ابتدا تصوير س��مت چپ را طراحي کرده سپس با استفاده از جلوه
Path  آن را به شکل سمت راست تبديل کنيد.

  Ragged5- در ش��کل روبه‌رو تصوير سمت چپ را طراحي کرده سپس با استفاده از جلوه
آن را به شکل سمت راست تبديل کنيد.

6- با استفاده از ابزار Shadow شکل‌هاي زير را رسم کنيد.

7- شكل زير را با استفاده از ابزار Envelope ترسيم كرده سپس آن را سه بعدي كنيد.



Free Hand پیمانه مهارتی : کاربر
339واحد کار یازدهم: توانایی استفاده از جلوه های ویژه  



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
340

كليات
با پيچيده‌تر شدن كار هنري نياز به روش‌هاي ديگري براي سازمان‌دهي موضوعات پيش 
 Chart و Graphic Hose و ابزارهاي Style ،Library ،Layers مي‌آيد. در اين واحد کار پنل‌هاي

Tool بررسي مي‌شوند.

 )Layers( 1-12 لايه‌ها
در برنامه FreeHand MXa هنگام ترس��يم طرح‌هاي موردنظر براي آس��ان‌تر کردن کار با 
موضوع‌هاي ترس��يمي، آن‌ها را با اس��تفاده از لايه‌ها از يکديگر مجزا مي‌کنند. اين کار شبيه 
به اين اس��ت که هر موضوع و شئ ترس��يمي در يک صفحه مجزا رسم شود و صفحه‌ها روي 

يکديگر قرار گيرند.

Layer شکل 1-12 مجزاسازي موضوع ترسيمي در پنل

 Layers 1-1-12 کار با پنل

پن��ل Layers، هم��ه لايه‌ه��اي موجود در س��ند ج��اري را نمايش داده و ام��کان اضافه، 
نس��خه‌برداري، مرتب کردن و حذف لايه‌ها را فراهم مي‌کند. با استفاده از اين پنل مي‌توانيد 

لايه‌ها را انتخاب، ايجاد و حذف کنيد.
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  Layersنمايش پنل
براي ظاهر کردن پنل به يکي از روش‌هاي زير عمل کنيد:

• از نوار ابزار Main روي دکمه  کليک کنيد.	
• از طريق منوي Window، مسير Window→Layers را اجرا کنيد.	
• كليد ميانبر F2 را بفشاريد.	

همان‌طورکه در شکل 1-12 نشان داده شده است، در يک سند به صورت پيش‌فرض سه 
لايه وجود دارد که عبارتند از:

لايه Foreground )پيش‌زمينه(
ب��ه لايه‌هايي که در بالاي خط افق��ي جدا کننده قرار مي‌گيرند، لاي��ه پيش‌زمينه گفته 

مي‌شود. موضوع‌هاي ترسيمي که در اين لايه‌ها قرار دارند؛ قابل چاپ هستند.
لايه Guides )خطوط راهنما(

در اين لايه خط‌هاي راهنما که با استفاده از خط‌کش يا ويرايشگر خطوط راهنما در سند 
ايجاد ش��ده‌اند، قرار مي‌گيرند. همچنين مسيرهايي که به خط‌هاي راهنما تبديل شده‌اند، در 
اين لايه قرار دارند )شکل 2-12(. در بخش10-1-12 چگونگي تبديل مسير به خط راهنما 

توضيح داده مي‌شود.
• قرار دارند، چه بالاي خط جدا کننده باش��ند يا در  	Guides موضوع‌هايي که در لايه

پايين آن قرار گيرند چاپ نمي‌شوند.

Guides شکل 2-12 مسير تبديل شده به خط راهنما با استفاده از لايه

لايه Background )پس‌زمينه(
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اي��ن لايه ب��ه صورت پيش‌فرض در زير خ��ط جداکننده قرار مي‌گي��رد و غير قابل چاپ 
است.

 توجه: با درگ و جا‌به‌جايي لايه‌هاي انتخاب ش��ده و انتقال آن‌ها به زير خط جدا 

کننده، يک لايه Background )پس‌زمينه‌( جديد ايجاد مي‌شود.

• هر شئ طراحي‌ شده در سند، درون لايه قرار مي‌گيرد، همچنين  	FreeHand در برنامه
مي‌توانيد مجموعه‌اي از اشياء را در يک لايه قرار دهيد.

2-1-12 ايجاد لايه جديد

با اس��تفاده از پنل Layers مي‌توانيد يک لايه جديد ايجاد کنيد و موضوع ترس��يمي را در 
لايه ايجاد شده قرار دهيد.

 توجه: مي‌توانيد قبل يا بعد از ترسيم موضوع‌هاي گرافيکي، لايه‌هاي مورد نيازتان 

را ايجاد کنيد.
براي ايجاد لايه جديد مراحل زير را انجام دهيد:

1- پنل Layers را باز كنيد.
2- منوي کنترلي پنل لايه را انتخاب کرده و روي گزينه New کليک کنيد.

3-1-12 تغيير نام لايه 

براي تغيير نام لايه به روش زير عمل کنيد:
1- در پنل Layers روي نام لايه مورد نظر دابل کليک کنيد.

2- نام جديد را تايپ و کليد Enter را فشار دهيد يا با ماوس روي پنل كليك كنيد.

 نكته: نام لايه Guides تغيير نمي‌کند.

 Fish در لايه‌اي با نام  C:0 و  M:98 ، Y:100 ، K:0 مثال 1: ش��کل 3-12 را با رنگ 
رسم کرده و فايل را با نام Example12 -1 ذخيره کنيد. 

1- در صفحه کاري مورد نظر، ابتدا پنل Layers را فعال کنيد.
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2- يک لايه جديد از طريق منوي کنترلي پنل ايجاد کنيد )شکل 12-4(.

                             

شکل 3-12                                            شکل 4-12 ايجاد لايه جديد

3- روي نام لايه جديد دابل کليک کرده و نام Fish را درج و کليد Enter را فشار دهيد.
4- شکل 3-12 را رسم و فايل را با نام گفته شده ذخيره کنيد.

4-1-12 انتخاب لايه

در پنل Layers، به لايه‌اي که انتخاب ش��ده و در س��مت راست آن علامت  قرار دارد، 
لايه فعال )Active( مي‌گويند. مراحل کار در انتخاب لايه به شرح زير است:

1- مس��ير Edit→Select→None را اجرا کرده يا کليد Tab را فش��ار دهيد تا ش��يئي در 
وضعيت انتخاب نباشد.

2- روي نام لايه کليک کرده تا علامت  را در سمت راست لايه مشاهده کنيد.

 نكته: اش��ياء و موضوع‌هايي که  ترسيم مي‌کنيد يا در سند Import مي‌شوند؛ در 
لايه Active )فعال( قرار مي‌گيرند.

• همراه با کليک روي نام لايه مورد نظر، تمامي اش��ياي لايه  	 Altبا نگه داش��تن کليد
فعال )Active( در حالت انتخاب قرار مي‌گيرند.

5-1-12 قفل و عدم قفل لايه

در پنل Layers براي محافظت اشياء درون لايه‌ها از تغييراتي که بر ساير لايه‌ها در هنگام 
نمايش محتويات آن‌ها انجام مي‌شود؛ روي علامت  )قفل باز( که در سمت چپ لايه قرار 

دارد کليک کنيد تا لايه قفل شود. بر همين اساس تعاريف زير مطرح مي‌شود:
• قرار دارد. لايه قفل شده )Lock(: لايه‌اي که در سمت چپ آن علامت 	

• قرار دارد . لايه قفل نشده )Unlock(: لايه‌اي که در سمت چپ آن علامت	
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6-1-12 نمايش و پنهان کردن محتويات لايه

 يکي ديگر از امکانات پنل Layers، پنهان کردن محتويات لايه‌ها بدون نياز به حذف لايه‌ها است 
)شکل 12-5(.

شکل 5-12 پنهان کردن محتويات لايه

روش اجرا:
1- لايه مورد نظر را انتخاب کنيد.

2- روي‌علامت P در س��مت چپ لايه کليک کنيد تا‌ علامت ‌برداش��ته ‌شود و محتويات‌ 
لايه ‌پنهان ‌شود.

• کليک مجدد سبب نمايش و آشكار شدن )Visible( لايه مي‌شود.	

 نكته: نگه داش��تن همزمان کليد Ctrl و کليک روي اولين س��تون سمت چپ در 
پنل Layers تمام لايه‌هاي پنل را پنهان مي‌کند.

اگر لايه فعال پنهان باش��د؛ موضوع گرافيکي جديدي که ايجاد مي‌ش��ود نيز نش��ان داده 
نمي‌شود و براي نمايش آن بايد لايه در حالت Visible )آشكار( قرار گيرد.

 توجه: براي ويرايش لايه‌ها، بايد آن‌ها را در وضعيت قفل نشده )Unlock( و نمايش 

)Visible( قرار دهيد.

7-1-12 ايجاد نسخه کپي از لايه موجود

با استفاده از پنل Layers و منوي کنترل آن مي‌توانيد از لايه موجود در پنل، يک نسخه 
کپي تهيه کنيد. روش کار به ترتيب زير است )شکل 12-6(:



Free Hand پیمانه مهارتی : کاربر
   Graphic Hose و Styles  ، 345واحد کار دوازدهم: توانایی استفاده از لایه ها ، سمبل ها

Layers شکل 6-12 منوي کنترلي پنل

1- مس��ير Edit→Select→None را اجرا کرده يا کليد Tab را فش��ار دهيد تا ش��يئي در 
وضعيت انتخاب نباشد.

2- روي نام لايه کليک کنيد.
3- از منوي کنترل در پنل لايه گزينه Duplicate را برگزينيد.

 نكته: لايه Guides حذف نمي‌شود.

تمرين 1:
1- با اس��تفاده از نوار ابزار Main،پنل Layers را آش��کارکنيد و شکل7-12 را در لايه‌اي به نام 

Rainbow1 رسم کرده و آن را با نام T12-1 ذخيره کنيد.

شکل 12-7

2- ي��ک لايه مش��ابه لايه Rainbow1 با نام Rainbow2 ايج��اد، آن را قفل کرده و فايل را 
ذخيره کنيد.

3- لايه Rainbow1 را حذف کنيد.
8-1-12 جابه‌جايي لايه‌ها و محتويات آن‌ها

ب��راي ويراي��ش لايه‌ها مي‌توانيد ترتيب قرار گرفتن آن‌ه��ا را در پنل Layers تغيير دهيد 
يا اش��ياء يک لايه را به لاي��ه ديگر منتقل کنيد و موضوع‌ه��اي گرافيکي لايه‌هاي يک فايل 

FreeHand را کپي کرده و در فايل ديگر، Paste کنيد.
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 توج�ه: اگ��ر گزين��ه Remember layer info در زبان��ه General از کادر مح��اوره

Preferences  انتخاب شده باشد، اطلاعات لايه‌ها در زمان کپي محتويات آن‌ها حفظ مي‌شود 

)شکل 12-8(.

FreeHand در زمان کپي محتويات آن‌ها در سندهاي ديگر ،FreeHandشکل 8-12 تنظيم مربوط به حفظ اطلاعات لايه‌هاي يک سند

•تغيير ترتيب لايه‌ها 	
1- در پنل Layers، نام لايه مورد نظر را انتخاب كنيد.

2- نام لايه را به مكان دلخواه در ليست لايه‌ها درگ كنيد.
3- با رها كردن ماوس، نام لايه از مكان قبلي حذف و در محل جديد پنل Layers ظاهر 

مي‌شود. در اين صورت موقعيت تمام اشياء در سند تغيير ميك‌ند.
•انتقال شئ به لايه مورد نظر 	

1- شئ موردنظر را كه در شكل 9-12 تصوير ماه است، انتخاب كنيد. در اين صورت لايه 
مربوط به شئ انتخاب شده در پنل Layers به طور خودكار انتخاب مي‌شود.

2- لايه مقصد )لايه‌اي كه مي‌خواهيد ش��ئ به آن‌جا منتقل شود( را انتخاب كنيد. بدين 
ترتيب شئ مزبور به لايه جديد انتقال ميي‌ابد. 

   

  شکل 9-12 انتخاب شئ                                     شکل 10-12 انتقال شئ به لايه موردنظر

  Preferencesاگر جابه‌جايي انجام نشد، بررسي کنيد که طبق شکل 11-12در كادر محاوره
گزين��ه Clicking on a layer name moves selected objects در زبانه Panels در حالت انتخاب 
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قرار گيرد تا جا‌به‌جايي اشياء با انتخاب نام لايه انجام شود.
ه��اي گرافيکي مي‌توانيد آن‌ه��ا را جا‌به‌جا  • همان‌طورک��ه گفته ش��د با درگ موضوع‌	

کنيد.

شکل 11-12 تنظيم مربوط به جابه‌جايي لايه‌ها با انتخاب نام لايه

 توجه: نمي‌توان موضوعات را به كي لايه قفل شده، انتقال داد.

 نكت�ه: اگ��ر در زمان جابه‌جاي��ي موضوعات گرافيکي، اش��يايي را که در لايه‌هاي 
جداگانه هس��تند،  با يکديگر Group کنيد، در اين صورت اش��ياء Group شده به لايه فعال 

منتقل مي‌شوند.
ججج

 توج�ه: انتخاب گزين��ه Remember layer info در زبان��ه General از کادر محاوره 

 Join شده به لايه‌هايي مي‌شود که قبل از Split و   Ungroup سبب بازگشت اشياء Preferences

و Group  شدن در آن قرار داشتند.

Guides 9-1-12 کار با لايه

همان‌طور که گفته شد، خط‌هاي راهنما در لايه Guides قرار مي‌گيرند. با استفاده از پنل 
layers مي‌توانيد مسير انتخابي را به خط راهنما و بالعکس تبديل کنيد.

•تبديل مسير )باز يا بسته( به خط راهنما  	

1- مسير مورد نظر را انتخاب کنيد )شكل 12-12(.
2- روي لايه Guides کليک کنيد تا مس��ير، رنگ خط راهنما را به خود بگيرد و مس��ير 

انتخابي نيز با انتقال به لايه Guides، به خط راهنما تبديل شود )شكل 12-13(.
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              شکل 12-12 يک مسير بسته	                شکل 13-12 مسير تبديل شده به خط راهنما

•تبديل خط راهنما به مسير معمولي 	

1- روي مس��ير تبديل ش��ده به خط راهنما يا خط راهنماي ايجاد شده با خط‌کش، دابل 
کليک کنيد.

2- در کادر مح��اوره Guides روي دکم��ه Release کليک کنيد تا خط راهنما به مس��ير 
تبديل شود و در لايه معمولي قرار بگيرد.

10-1-12 ادغام لايه‌ها 

پس از پايان کار در FreeHand مي‌توانيد لايه‌ها را با هم يکي کنيد.
روش اجرا:

1- لايه يا لايه‌هاي مورد نظر را در پنل Layer انتخاب کنيد.
 • 	Shift ب��راي انتخ��اب بيش از يک لايه  همزم��ان با کليک روي لايه‌ه��ا از کليدهاي
يا Ctrl اس��تفاده کنيد؛ کليد Shift، لايه‌هاي پش��ت س��رهم و کلي��د Ctrl، لايه‌هاي 

غيرمتوالي را انتخاب مي‌کند.   
2- گزينه Merge Selected Layers را  از منوي کنترلي پنل Layers برگزينيد.

 توج�ه: در هنگام ادغام لايه‌ها، پايين‌ترين لايه انتخابي به عنوان لايه ادغام ش��ده 

در نظر گرفته مي‌شود.

Foreground ادغام لايه‌هاي 
ب��راي ادغام محتويات لايه‌هاي بالاي خط جدا کننده با لايه Foreground پس از انتخاب 
لايه‌ها به روش��ي که در مطالب قبل گفته ش��ده، روي گزينه Merge Foreground Layers، از 
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منوي کنترل پنل Layers کليک کنيد.

 نكته: لايه Guides با ساير لايه‌ها ادغام نمي‌شود.

 مثال 2: س��ه موض��وع گرافيکي تصوير آدم��ك، ماهي و س��تاره را به ترتيب در 
لايه‌هاي��ي با نام‌هاي fish ،human و Foreground رس��م کرده و آن‌ه��ا را در لايه Fish ادغام 

کنيد.
1- ابتدا در صفحه کاري ايجاد ش��ده، لايه‌اي با نام human رس��م کرده و شکل آدمک را 

در آن رسم کنيد.
2- در لايه‌اي که به نام fish ايجاد کرده‌ايد، ش��کل ماهي و در لايه Foreground س��تاره 

صورتي رنگ را ترسيم کنيد.
3- لاي��ه fish را ب��ه عنوان لايه فعال انتخاب کرده و با فش��ردن همزمان كليد Shift روي 

لايه‌هاي Foreground و human کليک کنيد.
4- با استفاده از گزينه Merge Foreground Layers، از منوي کنترلي پنل Layers لايه‌هاي 

Foreground )پيش‌زمينه( را با يکديگر ادغام کنيد.

 

 Foreground شکل 14-12 ادغام لايه‌هاي

تمرين 2: 
 ،Animal 1 1- ش��کل‌هاي 15-12، 16-12و 17-12را ب��ه ترتي��ب در لايه‌هايي با ن��ام

Animal 2 و Animal 3 ايجاد کنيد.

2- محتويات لايه Animal 1 را به لايه Animal 2 منتقل کنيد.
3- لايه‌هاي Foreground را ادغام کنيد.

4- شکل 18-12 را به خط راهنما تبديل کنيد.
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شکل 15-12          شکل 16-12           شکل 17-12            شکل 12-18

11-1-12 قابل چاپ کردن يا غيرقابل چاپ کردن لايه

همان‌ط��ور که در بخش 1-12 گفته ش��د جابه‌جايي لايه‌ها به بالا و زير‌خط جدا کننده؛ 
به ترتيب س��بب چاپ شدن محتويات آن‌ها و عدم چاپ موضوع‌هاي گرافيکي قرار گرفته در 

لايه موردنظر مي‌شوند.
•ايجاد لايه چاپي 	

1- در پنل Layers با درگ ماوس لايه غيرچاپي را به بالاي خط جداكننده بكشيد.
2- پ��س از انتقال لايه ب��ه بالاي خط جداكننده، تمام اش��ياي موجود در آن قابل چاپ 

مي‌شوند )شكل 12-19(.

شکل 19-12 ايجاد لايه چاپي

ايجاد لايه غيرچاپي
1- در پنل Layers با درگ ماوس لايه موردنظر را به زير خط جداكننده بكشيد.

2- پس از انتقال لايه به زير خط جداكننده، تمام اش��ياي موجود در آن كم‌رنگ ش��ده و 
چاپ نمي‌شوند )شكل 12-20(.
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شکل 20-12 ايجاد لايه غيرچاپي

12-1-12 حالت نمايش چاپي يا خطي محتويات لايه

علامت دايره‌اي که در دومين س��تون سمت چپ پنل Layers قرار دارد )شكل 21-12(؛ 
محتويات لايه را در حالت نمايش يا Preview )چاپي(  و حالت خطي )KeyLine(  نشان 
مي‌دهد. اين علامت دايره‌اي به صورت دو وضعيتي اس��ت و کليک روي آن س��بب تغيير آن 

بين دو حالت مي‌شود.

Keyline شکل 21-12 نمايش لايه به صورت

13-1-12 تغييررنگ لايه‌ها

همان‌طورکه در ش��کل 22-12 نش��ان داده شده است؛ براي تش��خيص آسان‌تر لايه‌ها و 
محتوي��ات آن‌ها و ايجاد تمايز بين لايه‌ها، مي‌توانيد براي ه��ر لايه، رنگي را در نظر بگيريد. 
ب��ه اي��ن صورت كه رنگ را از پنل‌هاي رنگ يا اب��زار رنگ‌آميزي درگ كرده و كليد ماوس را 
روي لاي��ه موردنظر رها كنيد. بدين ترتيب رنگ موضوعات ترس��يمي نيز به رنگ لايه تغيير 

ميك‌ند.
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شکل 12-22
1 Library2-12 پنل

س��مبل‌ها )Symbols( و صفحه‌هاي اصلي )Master Page( براي استفاده در بين سندهاي 
FreeHand، در پنل Library نگهداري مي‌شوند. موارد کاربرد پنل Library به طور خلاصه به 

شرح زير است:
• ايجاد سمبل از اشياء و متن يا سمبلي ترکيبي از متن و شئ	

) • 	Symbols(‌ حذف و اضافه کردن سمبل‌ها يا نمادها
•وارد ک��ردن و ص��ادر ک��ردن س��مبل‌ها و صفحه‌ه��اي اصلي در صفحه‌هاي س��ند  	

FreeHand

• مي‌توانيد بي��ش ‌از يک نمونه از س��مبل‌موردنظر را در  	Library بااس��تفاده از پن��ل
سندجاري به‌کار ببريد. اين نمونه‌ها به‌صورت جداگانه و تکي با ويژگي‌هاي متفاوت، 

در بين سندهاي FreeHand قابل انتقال هستند.
	Library 1-2-12 نمايش پنل

براي نمايش پنل Library به يکي از موارد زير عمل کنيد:
• مسير Window→Library را پيگيري کنيد.	
• در نوار ابزار Main، روي آيکن  )Library(، کليک کنيد.	

در اين صورت پنل Library مطابق با شكل 23-12 باز مي‌شود.

1- کتابخانه
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Libraryشکل 23-12 پنل

2-2-12 ايجاد يک سمبل جديد

همان‌طورکه گفته ش��د، مي‌توانيد از يک موضوع گرافيک��ي، متني يا هر دو آن‌ها که در 
يک گروه قرار گرفته‌اند، براي ايجاد سمبل استفاده کنيد و با Duplicate سمبل‌هاي موجود، 

نمونه‌هايي با ويژگي مشابه نمونه اصلي داشته باشيد.
روش اجرا:

براي ايجاد س��مبل جديد مطابق شکل 24-12، پس از نمايش پنل Library موارد زير را 
اجرا کنيد:

1- شيئي را که مي‌خواهيد از آن يک سمبل ايجاد شود، انتخاب کنيد.
2- يکي از کارهاي گفته شده را انجام دهيد:

• که در پايين پنل قرار دارد کليک کنيد. روي آيکن 	
•شئ مورد نظر را از صفحه کاري به ليست سمبل‌ها درگ کنيد. 	

• را انتخاب کنيد. 	New Graphic گزينه Library از منوي کنترلي پنل
• را اجرا کنيد. 	Modify→Symbol→Convert to Symbol  مسير

• مسير  Modify→Symbol→Copy Symbolرا پيگيري کنيد.	
هر كدام از اين 5 روش كي سمبل جديد ايجاد ميك‌ند.
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شکل 24-12 ايجاد يک سمبل

3-2-12 ايجاد کپي از نمونه اصلي

پس از باز کردن پنل  Libraryبه طريق زير عمل کنيد:
1- از فهرست سمبل‌ها، سمبل مورد نظر را برگزينيد.

2- يکي از دو مورد زير را انجام دهيد )شکل 12-25(:
3- روي گزينه Duplicate از منوي کنترلي پنل کليک کنيد.

4- کليد Ctrl را نگه‌داشته و آن را به ليست سمبل‌ها درگ کنيد.       	   

 شکل 25-12 ايجاد کپي از نمونه اصلي سمبل

Library 4-2-12 پيش‌نمايش سمبل در پنل

روش اجرا:
1- بررس��ي کنيد که از من��وي کنترلي پنل Library گزين��ه Preview در حالت انتخاب 

باشد. 
2- سمبل مورد نظر را از فهرست سمبل‌ها انتخاب کنيد.

3- پيش‌نمايش آن در پنل Library مانند شکل 25-12 قابل مشاهده است.
5-2-12 گروه‌بندي سمبل‌ها

1- يکي از اين دو مورد را اجرا کنيد:
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• روي آيکن  در پايين پنلLibrary  کليک کنيد.	
• گزينه New Group را از منوي کنترل در پنل Library انتخاب كنيد.	

2- نام گروه مورد نظر را وارد کنيد.
3- سمبل‌هاي مورد نظر را به ليست گروه ايجاد شده وارد کنيد )شکل 12-26(. 

شکل 26-12 قرار دادن سمبل‌ها در يک گروه

 توجه: براي انتخاب بيش از يک س��مبل و قرار دادن آن‌ها در ليس��ت گروه مورد 

نظر، از کليد Shift استفاده کنيد.

6-2-12 حذف سمبل‌ها

1- سمبل مورد نظر را انتخاب کنيد.
2- يکي از دو مورد بعد را انجام دهيد:

• قرار دارد، کليک کنيد. 	Library روي آيکن  که در پايين پنل
• را برگزينيد. 	Remove گزينه ،Library از منوي کنترل در پنل

7-2-12 ايجاد نمونه1 از سمبل

يکي ديگر از امکانات پنل Library ايجاد نمونه‌هايي از س��مبل اس��ت که با تغيير سمبل، 
نمونه‌هاي ايجاد شده از آن نيز تغيير مي‌کنند.

روش اجرا:
به يکي از حالت‌هاي گفته شده عمل کنيد )شكل 12-28(:

 1-    Instance 
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• سمبل مورد نظر را از پنل Library به سند درگ کنيد.	
• عمل Copy و Paste يا Duplicate را روي نمونه سمبل موجود، انجام دهيد. 	

شکل 27-12 ايجاد نمونه از سمبل

8-2-12 ويرايش سمبل	

1- براي ويرايش سمبل به ترتيب زير عمل کنيد:
• روي نام سمبل يا پيش‌نمايش آن در پنل Library دابل کليک کنيد.	
• گزينه Edit از منوي کنترلي پنل Library را برگزينيد.	

2- پنجره ويرايش سمبل باز مي‌شود؛ تغييرات دلخواه را روي آن انجام دهيد. 
3- پنجره ويرايش سمبل را ببنديد.

 توجه: در س��مت چپ پنجره ويرايش سمبل، گزينه Auto-Update به صورت پيش‌فرض فعال 

است و امکان اجرا و مشاهده تغييرات را به صورت همزمان فراهم مي‌کند.

 نكته: تغييرات انجام ش��ده روي س��مبل‌ها تا زماني که پنجره ويرايش آن بس��ته نشده است يا 
سند ديگري را فعال نکرده‌ايد، روي آن‌ها اعمال نمي‌شود.

، اگ��ر در کادر ظاهر  • 	Library با درگ يک ش��ئ به محل س��مبل مورد نظ��ر در پنل
ش��ده روي دکمه Replace کليک کنيد، شئ انتخاب ش��ده جايگزين سمبل و همه 

نمونه‌هاي ايجاد شده از آن در سندهاي FreeHand مي‌شود.
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9-2-12 جايگزيني سمبل با اشياء و نمونه‌هاي )Instance( سند

روش اجرا:
1- ابتدا اشياء مورد نظر را انتخاب کنيد )شکل 12-28(.

   

شکل 28-12جايگزيني سمبل با اشياء انتخابي و نمونه‌هاي ايجاد شده از سمبل 

2- سمبل مورد نظر را از پنل Library انتخاب کنيد.
3- يکي از دو مورد زير را اجرا کنيد.

•  روي آيکن    کليک کنيد.	
•  از منوي کنترلي پنل، گزينه Swap را برگزينيد. در اين صورت سمبل با اشياء سند 	

جايگزين مي‌شود )شكل 12-29(.

شکل 29-12 سمبل جايگزين شده با اشياء سند

Release 12-2-10 سمبل

1- در پنل Library سمبل موردنظر را انتخاب کنيد.
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2- مسير Modify→Symbol→Release Instance را پيگيري کنيد.
مثال 3: يک س��ند دوصفحه‌اي با اندازه دلخواه ايجاد کنيد. ش��کل 30-12 را در 

   Library که در پنل Flower به فهرس��ت گ��روه Fl-red صفحه اول رس��م کرده و آن را با نام
ايجاد کرده‌ايد اضافه کنيد؛ س��پس نمون��ه‌اي از آن را در صفحه دوم قرار دهيد و رنگ آن را 

تغيير دهيد.

شکل 12-30

2- فايل دو صفحه‌اي ايجاد کرده و در صفحه اول شکل 30-12 را رسم کنيد.
 Library را از منوي کنترلي در پنل  New Group را فعال کرده و گزينه Library 3- پن��ل

برگزينيد و گروهي با نام Flower در آن ايجاد کنيد.
4- شکل رسم شده را به داخل گروه Flower درگ و نام سمبل را Fl-red قراردهيد.
5- سمبل Fl-red را از پنل Library به صفحه دوم سند درگ کنيد )شکل 12-31(.

6- با استفاده از گزينه Edit در منوي کنترلي پنل، سمبل را ويرايش کرده و رنگ آن را 
تغيير دهيد.

      

 

 

        
شکل 12-31

11-2-12 وارد کردن سمبل‌ها

1- از منوي کنترلي پنل Library ، گزينه Import را اجرا کنيد.
2- فايل��ي که س��مبل م��ورد نظر در آن ق��رار دارد، انتخاب و روي دکم��ه Open کليک 

کنيد.
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 Import س��مبل موردنظر را انتخ��اب و روي دکمه Import Symbols  3- درکادرمح��اوره
کليک کنيد.

12-2-12 صادر کردن سمبل‌ها

1- از منوي كنترل در پنل Library گزينه Export را برگزينيد.
2- سمبل يا سمبل‌هايي را که مي‌خواهيد صادر کنيد، انتخاب کنيد.

3- روي دکمه Export کليک کنيد.
4- در کادر محاوره Export Symbols، فايل FreeHand را که مي‌خواهيد سمبلي در آن به 

کار ببريد، مشخص کرده و پس از وارد کردن نام فايل روي دکمه Save کليک کنيد.
مثال 4: ش��کل 32-12 را رسم کرده و با نام fl-green به فهرست گروه flower که 
در پنل Library ايجاد کرده‌ايد اضافه کنيد؛ س��پس آن‌را به فايلي با نام Example12 -3 صادر 

کنيد.
1- ابتدا شکل 32-12 را رسم و با استفاده از يکي از پنل‌هاي رنگ، رنگ‌آميزي کنيد.

2- پنل Library را از طريق منوي Window فعال کنيد.
3- روي آيک��ن  که در پايين پنل اس��ت کليک ک��رده و گروهي با نام Flower ايجاد 

کنيد.

شکل 12-32

 Fl-green درگ و نام آن را Flower 4- ش��کل رسم شده را انتخاب کرده و به داخل گروه
بگذاريد.

 Example12 -3 در منوي کنترلي پنل، شکل را به فايلي با نام Export 5- با استفاده از گزينه
صادر کنيد.

 FreeHand ايجاد کرده و يکي از سمبل‌هاي برنامه T12 -4 تمرين 3: سندي به نام
را به دلخواه انتخاب کرده و در آن وارد کنيد.

  (Style)3-12 سبك
س��ب‌كهاي گرافيکي و متني آماده، يکي از امکانات مهم برنامهFreeHand  اس��ت که اين 
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موارد به صورت از قبل تعريف ش��ده و آماده در دس��ترس شماست و مي‌توانيد از ويژگي‌هاي 
هر کدام براي ايجاد قالب طرح و سبک مورد نظر استفاده کنيد، اين ويژگي‌ها عبارتند از:

 ) • 	strokes(خط‌هاي دور اشياء
) • 	fills( پرکردني‌هاي داخل موضوع‌هاي ترسيمي

) • 	colors( رنگ‌ها
) • 	effects( جلوه‌ها

• 	Halftone ويژگي‌هاي
س��ب‌كهاي متني نيز امکان قالب‌بندي و پايه‌ريزي سبك متني و پاراگرافي را با توجه به 

ويژگي‌هاي متني موجود، فراهم مي‌کند.

Halftones و Object شکل 33-12 سبك گرافيکي و ويژگي‌هاي پيش‌فرض در پنل

س��بک‌ها )طرح‌ها( همچنين امکان ايجاد تغييرات س��ريع در متن و گرافيک سند جاري 
را فراهم مي‌کنند.

همان‌طورکه مي‌توانيد از الگوهاي آماده )Template( در سند بهره بگيريد، امکان ايجاد و 
ذخيره Style و کاربرد آن در سندFreeHand  نيز وجود دارد.

 توج�ه: اين م��وارد و ويژگي‌ها در پنل‌هاي Object و Halftones  1  قابل دسترس��ي 

1- پنل Halftones براي تنظيم صفحات سفارشي براي اشيايي مانند ته‌رنگ‌ها، طيف رنگ‌ها (Gradients)، تركيبات و تصاوير اسكن شده 
استفاده مي‌شود.
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هستند )12-33(.
 Styles 1-3-12 پنل

پن��ل Styles براي نمايش س��بک و طرح گرافيکي و متني ب��ه‌کار مي‌رود. همچنين براي 
ايجاد يک س��بك جدي��د )new styles(، حذف )remove(، اضافه ))add، تهيه کپي از س��بك 

موجود duplicate(( و براي ويرايش سبك‌ها از پنلObject  و Styles استفاده مي‌شود.

 نكته: اگر ش��ئ يا موضوع گرافيکي در س��ند انتخاب نباش��د و يک سبك از پنل 
Styles در وضعي��ت انتخاب قرار بگيرد؛ آن س��بك به‌ط��ور پيش‌فرض به عنوان خصوصيت 

اشياء ترسيمي جديد، در نظر گرفته مي‌شود.

Styles نمايش پنل
براي نمايش پنل Styles  مسير Window→Styles  را اجرا کنيد.

Styles 1-1-3-12 حالت‌هاي نمايش
ب��راي انتخاب حالت‌هاي نمايش Styles روي من��وي کنترلي پنل Styles کليک کنيد و با 

توجه به حالت نمايشي مورد نظر، يکي از موارد زير را انتخاب کنيد:
• س��ب‌كها به صورت پيش‌نمايش کوچکي از شکل آن‌ها همراه  	:Compact List View

با نام سبك، نشان داده مي‌شود.
• س��ب‌كها به صورت پيش‌نمايش بزرگي از شکل آن‌ها همراه با نام  	:Large List View

سبك، نشان داده مي‌شود.
 • 	Styles سب‌كها به صورت پيش‌نمايش بزرگي از شکل آن‌ها در پنل :Previews Only

نشان داده مي‌شود.
Normal 2-1-3-12 اعمال سبك

هر سند FreeHand همراه با سه سبك Normal پيش‌فرض به صورت زير ارائه مي‌شود:
1- سبك مختص ترسيم اشياي جديد

2- ايجاد متن جديد
 )Normal Connector( 3- اعمال نمودن خطوط متصل كننده جديد

2-3-12 ايجاد يکStyle  جديد
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در اين بخش موارد مختلف ايجاد سبك بررسي مي‌شود:
Normal ايجاد سبك يا طرح جديد بر اساس يک سبک گرافيکي

در حالتي که س��بك نرمال در پنل Styles  انتخاب شده است، طبق شکل 34-12 به اين 
ترتيب عمل کنيد:

1- روي منوي کنترل در پنل Styles کليک کنيد.
2- گزينه New را برگزينيد.

شکل 34-12 ايجاد سبك نرمال

ايجاد سبك جديد بر اساس يک شئ
1- شئ يا متن )موضوع( مورد نظر را انتخاب کنيد.

2- سپس يکي از روش‌هاي زير را انجام دهيد:
• را برگزينيد، س��بك  	New گزينه Styles طب��ق ش��کل 35-12 از منوي کنترلي پنل

ايجاد شده بر اساس موضوع در ليست Style ها ديده مي‌شود.

Styles در منوي كنترلي پنل New شکل 35-12 ايجاد سبك جديد با استفاده از گزينه
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• درگ کنيد  	Styles موض��وع ‌موردنظ��ر را از صفح��ه‌کاري ب��ه فض��اي خال��ي پن��ل 
)شکل12-36(. 

Styles شکل 36-12 ايجاد سبك جديد با درگ شئ به پنل

، پيش‌نمايش ش��يئي را که در س��مت چپ نام آن قرار دارد، به فضاي  • 	Object از پنل
خالي پنل Styles درگ کنيد )شکل 12-37(.

Object شکل 37-12 پيش‌نمايش شئ در پنل

پ��س از ره��ا كردن ماوس ‌اگر در فضاي خالي صفحه كليك كنيد، پنل Object به صورت 
شكل 38-‌12 خواهد شد. 

Object شکل 38-12 پيش‌نمايش سبك ايجاد شده در پنل

Styles ايجاد سبك جديد بر اساس طرح موجود در پنل
1- مس��ير Edit→Select→None را پيگيري کرده يا کليد Tab را فشار دهيد تا شيئي در 

وضعيت انتخاب نباشد.
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2- در پنل Styles، سبكي را که مي‌خواهيد Style جديد بر اساس آن ايجاد شود، انتخاب 
کنيد )شکل 12-39(.

شکل 39-12 شئ رسم شده بر اساس سبك انتخابي

 توجه: اگر ش��يئي در صفحه انتخاب نشده باشد؛ انتخاب يک طرح، سبب مي‌شود که 

خصوصيات سبك انتخابي به صورت پيش فرض به اشياء جديدي که رسم مي‌شوند، داده شود.

1- يکي از موارد ذكر شده را اجرا کنيد:
• گزينه New را از منوي کنترل در پنل Styles انتخاب کنيد.	

• درگ کني��د  	Styles به‌فضاي‌خال��ي پن��ل Object پيش‌نماي��ش س��بك را از پن��ل 
)شکل12-40(.

Object وپيش نمايش آن درپنل Stylesشکل 40-12سبك انتخاب شده در پنل
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Object ايجاد طرح جديد براساس ويژگي‌هاي تنظيم شده در پنل
1- مس��ير Edit→Select→None را پيگيري کرده يا کليد Tab را فشار دهيد تا شيئي در 

وضعيت انتخاب نباشد.
2- ويژگي‌هاي موردنظر را در پنل  Object تنظيم کنيد .

3- يکي از موارد زير را انجام دهيد:
. • پيش نمايش سبك را از پنل  Object به فضاي خالي پنل Styles درگ کنيد	

• گزينه New را از منوي کنترل در پنل Styles انتخاب کنيد.    	
Style 3-3-12 کاربرد

براي اعمال سبک به موضوع انتخاب شده پس از نمايش پنل Styles، يکي از کارهاي زير 
را انجام دهيد:

• Style موردنظر را به شئ انتخاب شده درگ کنيد )شکل 12-41(.	

• به ش��ئ ديگر  	Paste را از موضوع ترس��يمي دلخواه کپي کرده و با انجام عمل Style

اعمال کنيد.
برای نسخه‌برداري از ويژگي‌هاي يک Style به ترتيب گفته شده عمل کنيد:

انتخاب موضوع ترسيمي که مي‌خواهيد از ويژگي‌هاي آن استفاده کنيد.
2- مسير Edit→Special→Copy Attributes را اجرا کنيد )شکل 12-42(.

Styles به شئ انتخاب شده با درگ طرح از پنل Style شکل 41-12 اعمال
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شکل 42-12 کپي سبک شئ مورد نظر

3- انتخاب موضوع ترس��يمي ک��ه مي‌خواهيد ويژگي‌هاي س��بک موردنظر به آن اعمال 
شود.

4- مسير  Edit→Special→Paste Attributesرا اجرا کنيد. مشاهده ميك‌نيد كه سبك به 
شئ اعمال مي‌شود )شكل 12-43(.

شکل 43-12 اعمال سبک يک شئ به شئ ديگر

Style 4-3-12 ايجاد يک کپي از

1- مسير Edit→Select→None را اجرا کرده يا کليد Tab را فشار دهيد تا شئ در وضعيت 
انتخاب نباشد.

2- در پنل Styles سبك مورد نظر را انتخاب کنيد.
 Duplicate يا كليك راس��ت روي سبك موردنظر، گزينه Styles 3- از منوي کنترلي پنل

را برگزينيد )شكل 12-44(.
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شکل 44-12 كپي سبك موردنظر

Style 5-3-12 حذف يک

1- مس��ير Edit→Select→None را پيگيري کرده يا کليد Tab را فشار دهيد تا شيئي در 
وضعيت انتخاب نباشد.

2- در پنل Styles، سبك موردنظر را براي حذف، انتخاب کنيد.
3- گزينه Remove را از منوي کنترل در پنل Style برگزينيد.

 توجه: با کليک راس��ت روي س��بك انتخابي مي‌توانيد، آن را حذف کرده )گزينه 

Remove( يا از آن نسخه کپي ايجاد کنيد )گزينه Duplicate( )شکل 12-45(.

شکل 12-45

Style 6-3-12 وارد کردن و صادر کردن

لازم نيست هر زمان كه كي سند جديد FreeHand را ايجاد ميك‌نيد، سب‌كهاي جديدي 
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 FreeHand تعريف نماييد. به سادگي مي‌توانيد سب‌كهايي را كه قبلًا تعريف كرده‌ايد در اسناد
وارد كرده يا س��بك ايجاد ش��ده را صادر کنيد. با اين تفاوت که به جاي پنل Library از پنل 
Styles اس��تفاده ک��رده و از طري��ق کادر مح��اوره Import Styles و Export Styles وارد کردن 

)Import( و صادر کردن )Export( سب‌كها انجام مي‌شود.
• يا کتابخانه‌ سبک‌ها  	FreeHand براي وارد کردن س��بك به س��ند جاري، از سند‌هاي

كه سبك مورد نظر را دارند، استفاده مي‌شود.
• که از طريق منوي کنترلي در  	Style در ش��کل 46-12 تعدادي از گروه‌هاي متفاوت

پنل Styles قابل دسترسي هستند، نشان داده شده است. 

Style شکل 46-12 فايل گروه‌هاي مختلف

 Styles را در پنل    Crystal Button سبك ،Button Styles تمرين 4: از گروه س��بک
وارد کرده و آن را به شکل‌هاي 47-12 که در صفحه کاري رسم کرده‌ايد، اعمال کنيد.

شکل 12-47

 Graphic Hose 4-12 ابزار
به کمک اين ابزار و با اس��تفاده از ش��کل‌هاي گرافيکي از پيش تعريف ش��ده يا طراحي 
شده توسط خود و کليک يا درگ ماوس روي صفحه، قادر خواهيد بود تا جلوه‌هاي گرافيکي 

جالبي را ايجاد کنيد. 
Graphic Hose 1-4-12 روش کار با ابزار

1- روي ابزار Graphic Hose دابل کليک کنيد تا کادر محاوره Hose مطابق شکل 12-48 
باز شود.

2- با انتخاب گزينهHose  مي‌توان نمونه‌هاي از پيش تعريف ش��ده‌اي مانند گل، ستاره و 
مشابه آن‌ها را براي ايجاد جلوه انتخاب کرد.



Free Hand پیمانه مهارتی : کاربر
   Graphic Hose و Styles  ، 369واحد کار دوازدهم: توانایی استفاده از لایه ها ، سمبل ها

 Graphic Hose مي‌توان يک Hose از منوي بازشو کادر محاوره  New3- با انتخاب گزينه
جديد ايجاد کرد.

• را تغيير داد. 	Graphic Hose مي‌توان نام   Rename با انتخاب گزينه
• جاري يک کپي تهيه کرد. 	Graphic Hose مي‌توان از Duplicate با انتخاب گزينه

(، تعداد  • منوي بازش��وي Contents واقع در پايين کادر محاوره Hose )شکل 12-48	
شکل‌هاي Graphic Hose جاري را نمايش مي‌دهد.

             Hose شکل 48-12 کادر محاوره

 توج�ه: در کادر مح��اورهHose ، تصاوير قرار گرفته در يک نوع ش��کل مي‌توانند حداکثر تا 10 

عدد باشند.

2-4-12 روش ايجاد يک Graphic Hose جديد

1- اين شکل‌ها را طراحي کنيد )شکل 12-49(.

شکل 12-49 

2- روي ابزار Graphic Hose دابل کليک کنيد تا کادر محاوره Hose باز شود.
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3- در منوي بازشوي کادر محاوره Hose گزينه New را انتخاب کنيد.
 4- در کادر محاوره ظاهر ش��ده )شکل 50-12( در کادر متني Name نام مورد نظر براي

Graphic Hose جديد را وارد کرده، سپس روي دکمه Save کليک کنيد.

شکل 50-12 تايپ نام جديد

5- شکل اول را انتخاب کرده سپس کپي کنيد، سپس در کادر محاورهHose  روي دکمه
Paste in  کليک نماييد )شكل 12-51(.

شکل 51-12 کپي شکل در Graphic Hose جديد

6- براي ش��کل دوم و سوم همان مراحل را طي کنيد. از منوي بازشوي Contents تعداد 
اشکال موجود در مجموعه ساخته شده خود را مي‌توانيد مشاهده کنيد. 

7- اکنون با هر بار کليک، شکل‌هاي موجود در Graphic Hose روي صفحه ظاهر مي‌شوند.
  Graphic Hoseمي‌ت��وان تنظيمات مربوط به  Optionsبا انتخاب گزينه Hose درکادرمح��اوره

را انجام داد.
 Graphicتمرين 5: ش��کل‌هاي 52-12 را طراحي کرده و با اس��تفاده از آن‌ها يک

Hose  جديد ايجاد کنيد.

شکل 12-52



Free Hand پیمانه مهارتی : کاربر
   Graphic Hose و Styles  ، 371واحد کار دوازدهم: توانایی استفاده از لایه ها ، سمبل ها

 Chart  5-12 ابزار
  Xtra Toolsواقع در ن��وار ابزار Chart ب��راي ايج��اد نمودار از اب��زاري به نام Freehand در

استفاده مي‌شود.
Chart 1-5-12 روش کار با ابزار

ابزار Chart را انتخاب کنيد و کادري در صفحه بکشيد تا محدوده ترسيم نمودار تعيين شود.
کادر محاوره Chart مطابق شکل 53-12 ظاهر مي‌شود.

در بالاي کادر محاوره Chart، دو آيکن به شرح زير وجود دارد:
آيک��ن داده‌ه��ا  که در ش��کل 54-12 نمايش داده ش��ده و مخص��وص وارد کردن 

اطلاعات است.
آيکن گراف يا نمودار  که در صورت انتخاب آن، شکل 54-12 نمايش داده مي‌شود 

و مي‌توان در اين قسمت شکل‌هاي مختلفي را براي نمودار تعيين کرد.

 

شکل 53-12 کادرمحاوره Chart براي وارد کردن داده

Chart شکل 54-12 نحوه تنظيم نمودار  از کادرمحاوره
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 Chart 2-5-12 نحوه تنظيم نمودار از کادر محاوره

گزينه‌ه��اي اي��ن کادر محاوره، نوع نمودار را از لحاظ ش��کل ظاه��ري و گرافيکي تعيين 
مي‌کنند.

Grouped Column  : نمودار را به صورت ميله‌اي رسم مي‌کند.

Stacked Column  : در اين نوع نمودار، داده‌ها به صورت افزايش��ي با هم مقايس��ه 

مي‌شوند.
Line  : نمودار را به صورت خطي رسم مي‌کند.

Pie : ب��راي ارايه‌داده‌ه��ا به‌عن��وان درصدهاي��ي از کل، از نمودار دايره‌اي اس��تفاده 

‌مي‌شود.
Area  : س��طح اشغال شده توسط هر نمودار از رنگ پر مي‌شود و نحوه قرار گرفتن 

نمودار به صورت افزايش��ي اس��ت. از اين نوع ترسيم آماري براي نمايش داده‌ها در طول يک 
دوره زماني استفاده مي‌شود.

Scatter : داده‌ه��اي هر دو خانه در يک رديف با يکديگر مقايس��ه و به صورت يک 

نقطه در نمودار ظاهر مي‌شوند.

واژه‌نامه
Auto-Updateبه‌روز شدن، به‌صورت خودکار

Chartنمودار

Compactفشرده

Decimalاعشاري، دهدهي

Foregroundپيش‌زمينه
Halftone)در ليتوگرافي( هاف‌تن، تصوير ترام‌دار، )در طراحي( خاکستري ميانه

Layersلايه‌ها

Line Chartنمودارخطي

Parent Styleسبك مبنا، سبك والد، سبك اصلي

Pie Chartنمودار دايره‌اي
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Replaceجايگزين کردن

Scatterپخش کردن

Separatorجداکننده

Symbolsسمبل‌ها

Uniformهم‌شکل، يکسان

خلاصه مطالب
• به‌طور خلاصه به شرح زير است: 	Library موارد کاربرد پنل

• ايجاد سمبل از اشياء و متن يا سمبلي ترکيبي از متن و شئ	
• 	)Symbols( حذف و اضافه کردن سمبل‌ها

•وارد ک��ردن و ص��ادر ک��ردن س��مبل‌ها و صفحه‌ه��اي اصلي در صفحه‌هاي س��ند  	
FreeHand

، ايجاد يک  • 	 )add( اضاف��ه ،)remove( حذف ،)new( براي ايجاد يک س��بك جدي��د
نس��خه کپي از س��بك موجود )duplicate( و براي ويرايش سب‌كها از پنل Object و 

Styles استفاده مي‌شود.

• با استفاده از شکل‌هاي گرافيکي از پيش تعريف شده و با کليک  	Graphic Hose ابزار
يا درگ ماوس روي صفحه، جلوه‌هاي گرافيکي جالبي ايجاد مي‌کند. 

• براي ايجاد نمودارهاي گرافيکي استفاده مي‌شود. 	Chart از ابزار
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

 Background 1- ب��ه لايه‌هاي��ي ک��ه در بالاي خط افق��ي جدا کننده ق��رار مي‌گيرند، لاي��ه
مي‌گويند. 

2- موضوع‌هاي ترسيمي که در لايه Foreground قرار دارند، چاپ شدني هستند.
3- انتخاب گزينه Clicking on a Layer name moves selected objects در زبانه Panels در 

كادر محاوره Preferences سبب جا‌به‌جايي اشياء با انتخاب نام لايه مي‌شود.
4- براي ايجاد سمبل جديد، روي آيکن  که در پايين پنل قرار دارد، کليک کنيد.

5- اگر ش��يئي در صفحه انتخاب نش��ده باش��د؛ انتخاب يک طرح، س��بب مي‌ش��ود که 
خصوصيات طرح انتخابي به صورت پيش‌فرض به اش��ياء جديدي که رس��م مي‌ش��وند، داده 

شود.
 Graphic Hose در کادر محاوره Spacing از منوي بازش��و ،Variable 6- ب��ا انتخاب گزينه

فاصله ميان موضوعات به طور تصادفي تعيين مي‌شود.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

7- اشياء و موضوع‌هايي که  ترسيم مي‌کنيد يا در سند Import مي‌شوند، در اين لايه قرار 
             Remove                                                                                                                  .مي‌گيرند
              Edit         .8- براي ويرايش لايه‌ها، بايد آن‌ها را در وضعيت ......... و ............. قرار دهيد
9- ب��راي ويراي��ش س��مبل گزين��ه ......... از من��و کنت��رل پن��ل Library را برگزيني��د.                                                                                                                                        
     Remove Unused                                                                                         
10- اين گزينه براي حذف يک سمبل در پنل Library و با استفاده از منوي کنترلي اين 
Active                                                                                                        .پنل به‌کار‌ مي‌رود

11- براي حذف طرح‌هايي اس��ت که در س��ند به‌کار نمي‌رون��د و از منو کنترل در پنل 
	Visible-UnLock                                                               انتخاب مي‌شود Styles

گزينه صحيح را انتخاب کنيد.

12- هنگام استفاده از ابزار Chart مقدار اعشار در کدام قسمت تعيين مي‌شود؟
Thousands separator -ب 		 Transpose  -الف
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Column -د 	             Decimal precision -ج
13- هنگام اس��تفاده از ابزار Graphic Hose با انتخاب کدام گزينه مي‌توان از مدل جاري 

يک کپي تهيه کرد؟
Delete -د 	Rename -ج 	Duplicate -ب 	Contents  -الف

14- براي ادغام محتويات لايه‌هاي بالاي خط جدا کننده با لايه Foreground کدام گزينه 
مناسب است؟

Remember Layer Info  -ب          	Merge Foreground Layers  -الف
Merge Selected Layer  -د 	  Move Objects to Current Layer  -ج

15- براي جايگزيني سمبل با اشياء و Instanceهاي سند به‌کار مي‌رود:
الف-             ب-               ج-                د- 

16- در اين حالت، نمايش طرح‌ها به صورت پيش‌نمايش بزرگي از ش��کل آن‌ها همراه با 
نامشان، نشان داده مي‌شود:

	Normal View -ب           	Large List View  -الف
Compact List View  -د 		 Previews Only  -ج

در جاي خالي عبارت مناسب را بنويسيد.

17-  موضوع‌هايي که در لايه ............... قرار دارند، چه بالاي خط جدا کننده باشند يا در 
پايين آن قرار بگيرند، چاپ نمي‌شوند.

18- در س��مت چپ پنجره ويرايش س��مبل، گزينه ............... به صورت پيش‌فرض فعال 
است و امکان اجرا و مشاهده تغييرات را به صورت همزمان فراهم مي‌کند.

19- ب��ه ي��كStyle  که مبناي توليد س��بك‌هاي ديگر قرار داده مي‌ش��ود، س��بك ......... 
مي‌گويند.

20- ه��ر تغيي��ري در س��بك ..........، س��بب تغيير در اس��اس اوليه س��بك‌هاي ............ 
مي‌شود.

به سؤالات زير پاسخ تشريحی دهيد.

21- منظور از لايه قفل شده و قفل نشده، چيست؟
22- علامت + کنار طِرح نشان‌دهنده چيست؟

23- سه مورد از موارد کاربرد پنل Library را بيان کنيد.
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24- چگونه مي‌توان يک Graphic Hose جديد ايجاد کرد؟	

آزمون عملي
1- شکل زير را رسم کرده، آن را با نام Style 12-85 در ليست سب‌كهاي پنل Styles وارد 

کنيد، با استفاده از پنل Object ويژگي‌هاي آن را تغيير دهيد و سبك را Redefine کنيد.

2- شکل‌هاي زير را به ترتيب در لايه‌هايي با نام Design 1 و Design 2 ايجاد كرده و لايه 
Design 2 را پنهان كنيد و لايه Design 1 را در حالت نمايش خطي قرار دهيد و قفل کنيد.

3- شکل زير را رسم کرده، موارد خواسته شده را روي آن انجام دهيد:
• به عنوان يک سمبل در پنل Library قرار دهيد. 	

•ي��ک کپ��ي از آن ايجاد كني��د و در نمونه کپي ش��ده رنگ آن را تغيي��ر دهيد و از  	
س��مبل‌هايي که ايج��اد کرده‌ايد در طراحي ي��ک کاغذ کادو با اندازه A4 اس��تفاده 

کنيد.
• موضوع‌هاي ترسيمي را در لايه‌هاي مجزا قرار دهيد و در پايان کار ادغام کنيد.	

4- توسط تصاوير زير يک Graphic Hose جديد ايجاد کنيد.
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5- نمودار ميله‌اي و دايره‌اي نمرات درس FreeHand خود را در ماه جاري ترسيم کنيد.
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FreeHand 1-13 آشنايي با فرمت‌هاي قابل ورود به نرم‌افزار
در برنام��ه FreeHand، مي‌تواني��د فايل‌هايي با فرمت‌هاي برداري )Vector( و پيكس��لي 
)Bitmap( را به س��ند وارد )Import( کنيد. مهم‌ترين فرمت فايل‌هاي Import ش��ده عبارت 

است از:
، ش��امل عناصر ب��رداري، متن‌ها، لايه‌ها و  • 	 Macromedia Fireworks PNGفايل‌ه��اي

جلوه‌هايي است که در FreeHand ويرايش مي‌شود.
، محتواي گرافيکي -   برداري  • 	CorelDRAW و Illustrator فايل‌هاي گرافيکي برداري در

آن‌ها همانند مسيرها قابل ويرايش‌ هستند.
• مي‌ش��وند به صورت  	Import هنگامي که ،Adobe Photoshop برنامه PSD فايل‌هاي

تصوير تخت و غيرقابل ويرايش هستند.
 • 	QuarkXPress و Adobe PageMaker ،Photoshop که در برنامه‌ه��اي EPS فايل‌هاي

ايجاد شده‌اند.
• که با همان قالب و فرمت اصلي در  	BMP و TGA ،TIFF ،PSD ،GIF ،JPEG فايل‌هاي

سند Import ،FreeHand مي‌شوند.
• فايل‌هاي ديگر RTF وASCII نمونه‌هايي از آن‌ها هستند.	

)Bitmap( 2-13 وارد كردن تصوير طرح بيتي
براي وارد كردن يك كار هنري از نوع طرح بيتي )Bitmap( به FreeHand روش‌هاي زير 

را بهك‌اربريد:
1- همان‌طوركه قبلًا در واحد كار 3 با‌ فرمان Import آش��نا ش��ديد براي وارد كردن يك 

تصوير به برنامه FreeHand از فرمانFile→Import  استفاده مي‌شود.
2- از طريق كپي كردن تصوير و چس��باندن )Paste( مي‌توانيد فايل تصويري موردنظر را 

به برنامه FreeHand وارد كنيد.

 نكته: در هنگام ارسال يا انتقال فايل FreeHand، بايد تصوير وارد شده را به همراه 
آن ارسال كرد.
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ويرايش تصاوير وارد شده
تغيير اندازه تصوير: با استفاده از ابزار Pointer تصوير را انتخاب كرده سپس دستگيره‌هاي 
كنترلي را در جهت موردنظر درگ كنيد. توجه داشته باشيد كه براي حفظ تناسب‌‌هاي افقي 

و عمودي كليد Shift را نگه داريد.

شکل 1-13 نمايش دستگيره‌ها براي تغيير اندازه

 Object تغيير اندازه با استفاده از پنل
1- مي‌توانيد درصدي را در كادر متني x و y براي تغيير اندازه تصوير وارد كنيد )ش��كل 

.)13-2
2- ب��ا وارد ك��ردن مقداري در ك‌ادر متن��ي w )عرض( و h )ارتفاع( ان��دازه تصوير تغيير 

ميك‌ند )شكل 13-2(.

Object شکل 2-13 تغيير اندازه با پنل

تغيير شكل تصاوير Bitmap: براي تغيير شكل تصوير به صورت زير عمل كنيد:
1- روي تصوير وارد‌ شده دابلك‌ليك كنيد.

2- از دستگيره‌هاي ك‌نترلي يا ابزارهاي تغيير شكل جعبه ابزار Tools براي مورب كردن، 
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چرخش، تغيير مقياس و انعكاس تصوير استفاده نماييد.
 BMP به‌ ش��ما امكان مي‌دهد ك‌ه رنگ تصاوير FreeHand :Bitmap تغيير رنگ تصاوير

و Tiff سياه و سفيد يا خاكستري را تغييردهيد.
1- يك تصوير سياه و سفيد يا خاكستري‌ را انتخاب‌ نماييد.

2- نمونه رنگ را از پنل Mixer به سمت‌ تصوير بكشيد ‌)شكل 13-3(.

 

شکل 3-13 تغيير رنگ تصوير خاكستري

 ي��ا نمون��ه رنگ را از پن��ل Mixer به س��مت كادر رنگ در پن��ل Object درگ كنيد
)شكل 13-4(.

Object شکل 4-13 تغييررنگ تصوير خاكستري از طريق پنل

تمرين 1: يك تصوير دلخواه با فرمت jpg را وارد برنامه FreeHand كنيد. س��پس 
عمليات زير را روي آن انجام دهيد.

1- با استفاده از پنل Object اندازه آن را دو‌ برابر كنيد.
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2- ي��ك كپ��ي از تصوي��ر را 180 درجه بچرخانيد و به‌نحوي آن را ق��رار دهيد كه گويي 
انعكاس تصوير در آب است.

Optimize In Fireworks 3-13 كار با فرمان

 Bitmap براي ويرايش تصاوير Fireworks به ش��ما امكان مي‌دهد تا از نرم‌افزار FreeHand

استفاده كنيد. 
با اس��تفاده از برنامه Fireworks مي‌توانيد حجم تصاوير با كيفيت بالا را كم كرده و براي 

انتشار در وب آماده سازيد.

 توجه: Fireworks فايل‌ها را به اس��ناد RGB تبديل ميك‌ند، بنابراين اگر قرار است 

تصويري به عنوان سند CMYK باقي بماند از برنامه Fireworks براي ويرايش تصاوير استفاده 
نكنيد.

دو نوع فايل Fireworks وجود دارد كه مي‌توانند به FreeHand وارد شوند:
1- فايل‌هاي اوليه Fireworks PNG، انواع خاصي از تصاوير پيكس��لي )Bitmap( هس��تند 
كه ش��امل لايه‌ها و اشياي جداگانه مي‌باشند. منظور اين است كه هر شئ به يك آيتم مجزا 
در   FreeHand تبديل مي‌ش��ود كه خط دور، زمينه يا جلوه‌اعمال‌ش��ده به ش��ئ را مي‌توان 

تغيير داد. 
2- فايل‌ه��اي صادرش��ده Fireworks فايل‌هاي TIFF ،JPG ،GIFيا PNG هس��تند كه در
FreeHand به صورت يك تصوير Bitmap قرار مي‌گيرند، يعني نمي‌توانيد اش��ياي مجزا را در 

FreeHand ويرايش كنيد.

1-3-13 فرمت‌هاي تصاوير در وب

فرمت‌های تصويری در اصل روش‌هاي اس��تاندارد برای ذخيره‌س��ازی داده‌های تصويري 
هس��تند. فايل‌هاي گرافيکي Bitmap که فرم��ت JPEG،GIF  و PNG دارند، معمولاً براي وب 
جهان‌گستر استفاده مي‌شوند. چون مي‌توانيد آن‌ها را بسيار فشرده کنيد تا سريع‌تر در اينترنت 

انتقال يافته و جا‌به‌جا شوند؛ به همين دليل توسط اکثر مرورگرها پشتيباني مي‌شوند.

 نكته: فرمت GIF و JPEG و PNG پشتيباني مي‌شوند.
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اس��ت ک��ه ابت��دا آن‌ه��ا را  • ب��راي ايج��اد تصويره��ا در وب، بهتري��ن کار اي��ن 	
بهينه‌سازي1کنيد.

•بهينه‌س��ازي تصويره��اي وب مس��تلزم انتخ��اب فرمتي اس��ت که بهتري��ن رنگ و  	
فشرده‌س��ازي را براي تصوير داشته باشد و حداکثر کيفيت آن را تا حد امکان حفظ 

کند.
•پس از بهينه‌سازي تصوير آنچه اهميت دارد پيش‌نمايش آن‌ها در مرورگرهاي وب و  	

اطمينان از نمايش دقيق آن‌هاست.
• مي‌توانيد در  	 Macromedia Fireworksهمان‌طور كه گفته ش��د با اس��تفاده از برنامه

داخل FreeHand تصويرهاي وب را ويرايش کنيد.
2-3-13 بهينه‌سازي تصويرها

شما مي‌توانيد تصاوير موجود در FreeHand را با استفاده از برنامه Fireworks بهينه‌سازي 
كنيد؛ مانند تغيير فرمت فايل كه يكي از موارد بهينه‌سازي است.

به منظور انجام بهينه‌سازي مراحل زير را انجام دهيد:
1- در سند FreeHand تصوير ‌موردنظر خود را انتخاب كنيد.
2- از منوي Edit گزينه Optimize In Fireworks را ‌برگزينيد.

3- كادر محاوره Find Source نمايان مي‌ش��ود تا مشخص كنيد كه آيا مي‌خواهيد تصوير 
 Fireworks بهينه‌س��ازي كنيد يا خير. س��پس از منوي بازشوي PNG را به صورت فايل اوليه
source files گزينه مورد نظر را انتخاب كنيد )در مورد اين گزينه‌ها در بخش 1-3-13 شرح 

داده شد(.
4- هنگامي كه فايل در كادر محاوره برنامه Fireworks باز مي‌ش��ود مي‌توانيد ويرايش��ات 

بعد را انجام دهيد.

 1- Optimize 
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شكل 5-13 زبانه  Optionsدر كادر محاوره بهينه‌سازي

• كلي��ك كنيد و تنظيم  	Options ب��راي ويرايش تنظيمات بهينه‌س��ازي روي زبان��ه
دلخواهي را تغيير دهيد )شكل 13-5(.

• را  	File ب��راي ويرايش اندازه فاي��ل و تنظيم نواحي اطراف‌ تصوير صادر ش��ده، زبانه
انتخاب كنيد سپس تنظيمات موردنظر را اعمال نماييد.

• براي ويرايش تنظيمات متحرك‌سازي تصوير، زبانه Animation را كليك كنيد.	
5- پس از پايان ويرايش ‌تصوير دكمه Update را كليك كنيد.

در اين صورت تغييرات روي تصوير موجود در FreeHand نيز اعمال مي‌شود كه اصطلاحاً 
به آن Update مي‌گويند. همچنين اگر فايل اوليه PNG را انتخاب كرده باشيد تصوير به‌صورت 
 )Link( به آن متصل FreeHand ذخيره مي‌‌شود. اگر تصوير وارد شده در سند PNG فايل اوليه
ش��ده باشد ترجيحاً بايد در سند FreeHand نيز چسبانده )Embed( شود تا تغييرات روي آن 

انجام شود. همچنين فايل تصويري خارج از FreeHand نيز Update مي‌شود.
 Trace4-13تبديل تصاوير نقشه‌بيتي به برداري توسط ابزار

مي‌توانيد کارهاي هنري آماده يا اس��كن ش��ده را به سند FreeHand وارد کرده و با به‌کار 
بردن ابزارTrace  آن‌ها را به مسير تبديل كنيد. ابزار Trace مي‌تواند اشكال مختلف كار هنري 
از قبيل گرافي‌کهاي ايجاد شده در FreeHand، تصويرهاي Bitmap و متن )Text( را تشخيص 



Free Hand پیمانه مهارتی : کاربر
385واحد کار سیزدهم: توانایی استفاده از تصاویر Bitmap در نرم افزار FreeHand و ویرایش آن ها 

داده و آن‌ها را به مسيرهاي برداري تبديل كند.
هنگامي که تصاوير را براي استفاده در FreeHand، اسكن )Scan( مي‌کنيد، بهتر است که 
 )Trace( .اس��تفاده شود )dpi( بين300 تا600 نقطه در اينچ )Resolution( از درجه وضوحي
تصوير اسكن شده با کيفيتdpi  600، نقاط بسيار زيادي ايجاد مي‌کند. علاوه بر اين تصوير 

با کيفيت بالا نسبت به تصوير با کيفيت پايين به حافظه بيشتري نياز دارد.

 توجه: اگر مقدار حافظه کم باشد، تصوير با حداقل Trace( ،Resolution( مي‌شود.

Trace Tool 1-4-13 تنظيمات ابزار

هنگامي که تصويرهاي Bitmap و اش��ياء ب��رداري )Vector( را Trace مي‌کنيد؛ تنظيمات 
پيش‌ف��رض نتيجه مناس��ب را فراهم مي‌کند ب��دون اين‌که از حافظه سيس��تم بيش از حد 

استفاده کند.

 نكته: قبل از بهك‌ارگيري ابزار Trace بايد گزينه‌هاي آن را تنظيم كنيد. 

همچنين در هنگام اجراي Trace روي موضوع‌هاي گرافيکي، امکان تبديل رنگ‌ها وجود 
دارد و مي‌توانيد تعداد رنگ‌ها، مد )mode( و محدوده رنگ به‌کار رفته در اش��ياء را مش��خص 

کنيد.

 توج�ه: ب��ا خارج ش��دن از برنام��ه FreeHand ، تنظيم��ات Trace Tool در بخش 

Preferences فايل FreeHand ذخيره مي‌شود.

براي تنظيم ابزار Trace به صورت زير عمل كنيد:
روش اجرا:

1- در جعبه ابزار روي ابزار Trace دابل کليک کنيد.   
2- در کادر محاوره Trace Tool از قسمت Color mode مد رنگ را تعيين کنيد.

• اس��ت، مش��خص کنيد؛ رنگ‌هاي اضافي به رنگ‌هاي  تعداد رنگ را که از 2 تا 256	
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نزديک‌تر تبديل مي‌شوند.
 :Colors( را براي تعيين رنگ تصويــر نهايي انتخاب كنيدGrays  يا Colors گزينــه    •

رنگي - Grays: خاكستري(.
•	  Trace را براي تعيين مد رنگ تصويــر نهايي پس از عمل CMYK يا RGB گزينــه 

برگزينيد.

Trace شکل 6-13كادر محاوره تنظيم ابزار

 نكته: براي اضافهک ردن رنگ موارد Import شــده يا Trace شــده به ليست پنل 
 Eyedropper را اجــراک رده يا از ابزار Xtras→Colors→Name All Colors  مســير ،Swatches

استفادهک نيد.

3- مقدار درجه وضوح )Resolution ( را تعيينک نيد.
•	  انتخاب گزينه High ســبب نمايش جزييات بيشتر تصوير مي‌شود. اين نوع Trace با 

سرعت پايين و مصرف زياد حافظه اجرا مي‌شود. 
•	  Trace ســبب نمايشک مترين جزييات تصوير مي‌شود. اين نوع Low انتخاب گزينه 

با سرعت بالا و مصرفک م حافظه اجرا مي‌شود. 
•	  گزينه  ‌Normalحالتي بين دو گزينه High و Low  را ايجاد مي‌کند.

4- يــک مــورد از گزينه‌هــاي Trace layers راک ــهForeground  )رديابــي لايه‌هــاي 
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پيش‌زمينه(،All )همه لايه‌هاي س��ند( يا Background )لايه‌هاي پس‌زمينه( است؛ برگزينيد. 
در برنامه FreeHand همه مسيرها در لايه‌هاي مشخص شدهTrace  مي‌شوند.

5- گزينه Path conversion را براي مش��خص کردن اين که چه‌طور مس��يرها رديابي يا 
Trace مي‌شوند، تنظيم کنيد.

، لبه‌هاي بيروني تصوير را براي ايجاد مس��يرهاي پرش��ده و  • 	Outline انتخ��اب‌ گزينه
بسته رديابي مي‌کند.

• انتخاب‌ گزينه Centerline، مرکز خط‌هاي دور تصوير گرافيکي را Trace ميك‌ند.	
، س��بب ترکيب خط دور و مرکزي مي‌ش��ود. در  • 	Centerline/Outline انتخاب‌ گزينه

بخشOpen Paths Below  مقداري بين 2 تا 10 وارد کنيد.
• انتخاب‌ گزينه Outer Edge، فقط خطوط خارجي تصوير را رديابي ميك‌ند.	

6- ‌مقدار Trace conformity يا تنظيم حساسيت ابزار Trace، براي مشخص کردن ميزان 
نزدکيي و ش��باهت مسيرهاي Trace ش��ده به مدل اوليه، بهك‌ار مي‌روند. عددها مي‌توانند از 
صفر )ش��باهت کمتر با نقطه‌هاي کمتر( تا 10 )شباهت بيش��تر با نقطه‌هاي‌ بيشتر( انتخاب 

شوند.
7- ع��دد Noise tolerance ي ��ا دكمه لغزن��ده آن براي حذف پيكس��ل‌هاي اضافه )نظير 

گردوغبار در اسكن( بهك‌ار مي‌رود. مقدار آن بين 0 تا 20 است.
8- مق��دار Wand color tolerance به ش��ما امكان مي‌دهد مح��دوده رنگ‌هايي را تنظيم 
كني��د كه ابزار Trace به عنوان رنگ نهايي تش��خيص مي‌دهد. مح��دوده آن از صفر )رنگ‌ها 
به محدوده رنگ انتخابي نزد‌کيتر و ش��بيه‌تر و محدوده انتخاب کوچ‌کتر( تا  255 )ميزان 

شباهت رنگ‌ها کمتر و محدوده انتخاب گسترده‌تر( است.
9- روي دکمه OK کليک کنيد.

تمرين 2: در تصوير برگ شکل 7-13 لبه‌هاي ناحيه سبز رنگ را Trace کنيد.
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شکل 13-7

1- روي ابزار Trace Tool کليک ‌کنيد.
2- در تنظيمات‌ Trace Tool مقدار Tolerance را 223 و س��اير تنظيم‌ها را طبق ش��کل 

7-13 تعيين کنيد.
3- در سند ‌روي ناحيه سبز رنگ، کليک کنيد.

4- ب��ا کلي‌ک روي ناحيه انتخاب ش��ده و انتخاب گزين��ه Convert Selection Edge، فقط 
لبه‌هاي ناحيه انتخاب شده راTrace  کنيد. 

5- تصوير Trace ‌ش��ده روي ش��کل اصلي ايجاد مي‌ش��ود )ش��کل 8-13( که با توجه به 
انتخاب رنگ سياه قبل از اعمال Trace، رنگ آن سياه شده است.

Trace شکل 8-13 نتيجه عمل

تمرين 3: لبه‌هاي شکل 9-13 را Trace کنيد. )توجه داشته باشيد كه اين فايل 
در پوشه Samples برنامه فتوشاپ قرار دارد.(
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شکل 13-9

)Bitmap( 5-13 تبديل تصوير برداري به طرح بيتي
براي تبديل سريع تصويرهاي برداري به تصوير Bitmap  فرمانConvert to Image  به‌کار 
 TIFF مي‌شوند و شئ تبديل شده به صورت کي فايل Rasterize ًمي‌رود و تصويرها اصطلاحا

در درون سند FreeHand  قرار مي‌گيرد.

 توجه: تصوير Bitmap ايجاد ش��ده جايگزين تصوير اوليه و اصلي که برداري است، 

مي‌ش��ود. اگر مي‌خواهيد تصوير اصلي را نگه داريد، ابتدا کي کپي از آن ايجاد کرده و عمل 
تبديل را روي کپي آن انجام دهيد.

اگر حجم فايل تصويري زياد باش��د يا تصوير پيچيده باش��د، پيامي مبني بر ايجاد خطا 
 Export ،Bitmap در تبديل ظاهر مي‌ش��ود. بهتر اس��ت که اين تصويرهاي پيچيده به فرمت

شوند.
 Bitmap 1-5-13 مراحل تبديل تصوير برداري به

1- اشياء يا تصاوير برداري موردنظر را انتخاب كنيد.
 Convert to Image را اجرا کنيد تا کادر محاوره Modify→Convert to Image 2- فرم��ان

آشکار شود.
3- در کادر مح��اوره Convert to Image مق��دار  Resolution)کيفيت يا وضوح تصوير( را 

تنظيم کنيد
• براي کارهاي هنري تحت وب به‌کار مي‌رود. 	72 dpi

• به عنوان پيش‌نويس چاپ به‌کار مي‌رود. 	144dpi 

• 300dpi براي کار نهايي شده و آماده چاپ به‌کار مي‌رود.	



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
390

Resolution شکل 10-13 منو بازشوي

4- براي نرمي خط‌ها و هموار ش��دن لبه‌هاي دور تصوير، گزينه Anti-aliasing را تنظيم 
کنيد. عدد بالاتر سبب نرمي بيشتر مي‌شود.

5- روي دکمه OK کليک کنيد. 

 نكت�ه: مي‌تواني��د همزمان بيش از کي تصوير ب��رداري را انتخاب کرده و ب��ه Bitmap تبديل 
کنيد.

 300 dpi مثال 1: يك تصويرِ برداري دلخواه مانند شكل 11-13 را با درجه وضوح
و انتخاب عدد 4 براي گزينه Anti-aliasing به تصوير Bitmap تبديل كنيد.

1- شکل 10-13 را انتخاب ‌کنيد.

شکل 11-13 تصوير برداري

2- مسير Modify→Convert to Image را اجرا ‌کنيد.
 300dpi کيفيت تصوير( را( Resolution مق��دار Convert to Image 3- در ‌کادر مح��اوره

انتخاب کنيد.
4- عدد 4 را براي Anti-aliasing تنظيم کنيد.‌

همان‌طور که با مقايس��ه نوار Info در ‌ش��کل‌هاي 11-13و 12-13 مش��اهده مي‌کنيد، 
ش��ئ تبديل ش��ده به صورت کي فايل TIFF درون س��ند FreeHand  قرار مي‌گيرد )ش��کل 

.)13-12
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شکل 12-13تصوير TIFFكهEmbedded  شده

تمري�ن 4: تصوي��ر برداري زير )قس��متي از يك فايل در پوش��ه Sample برنامه 
FreeHand است( را به پيكسلي يا Bitmap تبديل كنيد.

شکل 13-13
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واژه‌نامه 
Anti-aliasingضدناهمواري، روشي براي هموار نمودن خطوط ناهموار يا دندانه‌دار

Conversionتغيير، تبديل

Draftپيش‌نويس، چر‌کنويس

Embeddedدر درون قرارگرفتن، چسباندن

Lossyپراتلاف

Losslessبدون اتلاف

Noiseاختلال،خش

Optionاختيار

Sourceمنبع، اصلي، اوليه

Outlineخط دور

Rasterizeتبديل

Traceرسم کردن، کشيدن

Vectorبرداري

خلاصه مطالب
( و پيكس��لي  • 	Vector( مي‌توانيد فايل‌هايي با فرمت‌هاي برداري ،FreeHand در برنامه

)Bitmap( را به سند وارد )Import( کنيد.
• مي‌توانيد تصاوير وارد شده در FreeHand را با استفاده از Fireworks ويرايش كنيد.	

 • 	FreeHand مي‌توانيد تصاوير موجود در Optimize In Fireworks با استفاده از فرمان
را با استفاده از برنامه Fireworks بهينه‌‌سازي كنيد.

• و  	Bitmap تصويرهاي ،FreeHand مي‌تواند گرافي‌کهاي ايجاد ش��ده در  Traceاب��زار
متن )Text( را تشخيص داده و آن‌ها را به مسيرهاي برداري تبديل كند.

 • 	 Convert to Imageفرم��ان Bitmap براي‌تبديل‌س��ريع تصويرهاي ب��رداري به تصوير
به‌کارمي‌رود.
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- فايل‌هايMacromedia Fireworks PNG ، در FreeHand ويرايش مي‌شود.
2- فايل‌هاي گرافيکي برداري CorelDRAW همانند مسيرها غيرقابل ويرايش هستند.

3- فايل‌ه��اي JPEG ،TIFF ،TGA ي��ا BMP با همان قالب و فرمت اصلي‌ش��ان در س��ند 
Import ،FreeHand مي‌شوند.

4- فايلSWF در FreeHand قابل ويرايش است.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

5- براي وارد كردن تصاوير طرح بيتي به سند FreeHand از اين فرمان استفاده مي‌شود
GIF                                                                                                        .
Lossy                                    .بهك‌ار مي‌رود Bitmap 6- اين نرم‌افزار براي ويرايش تصاوير
Import                 .7- روش فشرده‌سازي فايل‌ها كه داده‌هاي اوليه بازيابي نمي‌شوند
Fireworks                             .8- عمق رنگ در اين نوع فايل حداكثر 8 بيت است

گزينه صحيح را انتخاب کنيد.

9- براي صادر كردن تصاوير در وب كدام فرمت شفافيت را حفظ نميك‌ند؟
Tiff -د                 Jpeg -ج              Gif -ب          PNG -الف

10- كدام يك از موارد زير به طور اتوماتيك فايل اوليه PNG را باز ميك‌ند؟
Never Use Source PNG -ب              	 Always Use Source PNG -الف

Use This File -د                            Ask When Launching -ج
11- فرمان Optimize in Fireworks چه عملي انجام مي‌دهد؟

الف- حذف فايل‌هاي غيرضروري 	           ب- افزودن طراحي به تصوير
FreeHand فايل تصوير به Link -د ج- تغيير اندازه و تغيير فرمت فايل	

12- با استفاده از ابزار ................... مي‌توان تصاوير Bitmap را برداري كرد.
Trace -د           Optimize -ج           Lasso -ب            Pointer -الف

13- دكم��ه لغزنده Trace conformity در كادر مح��اوره Trace Tool به چه‌منظور بهك‌ار 
مي‌رود؟
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الف- سبب ترکيب خط دور و مرکزي مي‌شود.
ب- ميزان شباهت مسيرهاي Trace شده به مدل اوليه را تعيين ميك‌ند.

ج- براي حذف پيكسل‌هاي اضافه تصاوير بهك‌ار مي‌رود.
د- براي تنظيم محدوده رنگ‌ها استفاده مي‌شود. 

در جاي خالي عبارت مناسب را بنويسيد.

14- فرم��ان .................... ب��راي تبدي��ل تصوير ب��رداري به طرح بيت��ي )Bitmap( بهك‌ار 
مي‌رود.

15- گزينه Anti-aliasing براي تنظيم ......................... استفاده مي‌شود. 
16- ب��راي ك��م كردن ناحيه انتخاب با اب��زار Trace همزمان با كليك كلي��د ....... را نگه 

داريد.
17- در هنگام بهينه‌سازي پس از پايان ويرايش تصوير دكمه ................ را كليك كنيد. 

به سؤالات زير پاسخ تشريحی دهيد.

18- كدامي‌ك از انواع درجه وضوح سبب رديابي با سرعت بالا مي‌شود؟
19- اگر ميزان حافظه كم باشد تصوير چگونه Trace مي‌شود؟

20- مزيت فرمت GIF را با فرمت JPEG مقايسه كنيد؟
آزمون عملي

1- فاي��ل تصويري از ن��وع طرح بيتي وارد FreeHand كنيد س��پس عمليات زير را انجام 
دهيد:

•اندازه تصوير را دو برابر كنيد. 	
• عرض تصوير را به ميزان دلخواه كاهش دهيد. 	Object با استفاده از پنل

• درجه بچرخانيد. تصوير را 90	
•انعكاس عمودي تصوير را در كنار آن قرار دهيد. 	

 Photoshop رنگي دلخ��واه را در برنام��هBitmap  ي��ك فايل تصوي��ري )mode( 2- م��د
خاكستري كرده سپس از طريق Copy-Paste آن را وارد FreeHand كنيد. سپس توسط پنل 

Mixer آن را به رنگ سبز تغيير دهيد.

3- طرح زير را رسم كرده سپس با برنامه Fireworks آن را به نحوي ويرايش كنيد كه در 
هنگام باز شدن پيغامي را نمايش دهد. ويرايش مربوط به تغيير اندازه فايل باشد.
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4- قس��متي از تصوير مورد نظر از پوش��ه My Pictures سيس��تم خود را با ابزار مناسب و 
تنظيمات زير رديابي كنيد.

•جزييات تصوير بيشتر ديده شود. 	
• در نظر بگيريد. حساسيت ابزار رديابي را 7	

•محدوده رنگ تنظيم شده به نحوي باشد كه رنگ‌هاي انتخابي نزديك‌تر قرار گيرد. 	
5- ي��ك تصوير ب��رداري را ب��ه FreeHand وارد كنيد س��پس آن را ب��ه Bitmap تبديل 

نماييد.
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كليات
يکي ‌از ‌جالب‌ترين ‌امکاناتي‌که در FreeHand وجود دارد، ايجاد پويانمايي ‌و حرکت ‌اســت 
‌که‌ مي‌تواند در صفحه‌هاي وب و فيلم‌هاي تعاملي )Interactive( اســتفاده شود. در اين واحد 

کار اين امکانات بررسي مي‌شود.
FreeHand 1-14 مفاهيم اوليه حرکت در

حرکت )Action(: جلوه حرکتي است که به يک موضوع داده مي‌شود.
پارامتر )Parameters(: محل و موقعيت بعدي و مقصد نهايي حرکت را مشخص مي‌کند. 

به عبارتي ديگر ارزش‌هاي موردنظر Action در اين قسمت تعيين مي‌شود.
رويداد )Event(: رخدادهايي اســت كه با اعمال آن‌ها بــه موضوعات، حرکت موردنظر 
نمايش داده مي‌شــود و کاربر آن را  اجرا ميك‌ند، مانند Press كه رويداد کليک کردن روي 

يک موضوع است يا رويداد Over كه با حرکت ماوس روي شئ رخ مي‌دهد.
شــئ مبدأ )Source Object(: موضوعي که عمل کشيدن ماوس )Drag( روي آن انجام 

مي‌شود.
صفحه مقصد )Target Page(: صفحه‌اي که محل پايان يافتن Action را مشخص مي‌کند 

و عمل رها کردن ماوس )Drop( در آن انجام مي‌شود.
صفحه جاري )Current Page(: صفحه‌اي که نشانگر ماوس در آن قرار دارد.

ارايــه )Presentation(: نمايش  Actionدر پنجــره Flash Player 1 که دکمه‌هاي کنترل 
نمايــش تعاملي )Interactive( در آن قرار دارد و همچنين فرمت ارايهSWF  اســت كه به آن 

ارايه نيز گفته مي‌شود.
فيلم تعاملي )Interactive Movie(: فيلمي که در هنگام نمايش به ازاي اجراي اعمالي 
که براي آن در نظر گرفته شــده يعني کنش، واکنش تعريف شــده توســط کاربر را نشان 

مي‌دهد. اين فيلم‌ها در صفحه‌هاي وب نيز قابل استفاده است.
محدوده حرکت )Action Area(: فهرســت زيرمجموعه مــوارد پويانمايي را به صورت 

Action script يعني زبان برنامه‌نويسي برنامه Flash 2 در دسترس قرار مي‌دهد.

فريم يا قاب )Frame(: به هريك از تصاويري كه نمايش متوالي و ســريع آن‌ها باعث 

Flash 1- نمايشگر فيلم
2- نرم‌افزاري براي ساخت انيميشن دو بعدي
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ايجاد فيلم يا انيميشن مي‌شود، Frame مي‌گويند كه در واقع هر قاب، بيانگر يكي از لحظات 
اجراي فيلم است.

  Action Tool 2-14 ابزار
 )drag &drop( جلوه‌هاي حرکتي را با انجام عمل کش��يدن و رها کردن Action Tool ابزار
به موضوع‌ه��ا )objects(، نمادها )Symbols( و صفحه‌ها )Pages( اعمال ميك‌ند وAction هاي 
Flash را براي موارد گفته شده در سند FreeHand در نظر مي‌گيرد و به آن‌ها نسبت مي‌دهد؛ 

به‌عنوان مثال مي‌توانيد در س��ندي دو صفحه‌اي که در صفحه اول آن کي موضوع گرافيکي 
ق��رار دارد، ي��ك Action را در نظر بگيريد که با کليک روي موضوع، صفحه دوم را ظاهر کند 

و نشان دهد.
Action 1-2-14 ايجاد

براي انتساب کي Action به شئ ]موضوع[ به ترتيب مراحل زير را اجرا کنيد:
1- روي ابزار  Action در جعبه ابزار کليک کنيد.

2- از ش��ئ موردنظر به سمت صفحه مقصد درگ کنيد بدين ترتيب خطي از شئ مزبور 
تا صفحه مقصد امتداد ميي‌ابد )شکل 14-1(.

شکل 1-14 درگ شئ مبدأ به مقصد

3- زماني که كليد ماوس را رها کنيد، صفحه جاري که برجس��ته شده، به عنوان صفحه 
 مقصد در نظر گرفته مي‌ش��ود و يك خط ‌انحنادار نشان‌ مي‌دهد كه Action ايجاد شده ‌است

)شکل 14-2(. 
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Action Tool ايجاد شده با ابزار Action 14-2 شکل

زماني که براي کي ش��ئ Action تعريف مي‌کنيد در گوش��ه پايين س��مت راس��ت آن علامتي به نام

Action Proton ظاهر مي‌شود )شکل 14-3(. 

  شکل 14-3
• ايج��اد و به موضوع‌هاي به وجود  	Action Tool ک��ه با ابزار FreeHand پيش‌ف��رض Action
آورنده حرکت، اختصاص داده مي‌ش��ود، Go To and Stop اس��ت که در ش��کل 4-14در پنل 
Navigation مش��خص ش��ده اس��ت و با فش��ردن کليد ماوس محتويات صفحه 2 را که در لايه 

Foreground قرار دارد، نشان مي‌دهد. 

Navigation با استفاده از پنل Flash هايAction شکل 4-14 دسترسي به
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 توجه: ساده‌ترين روش ايجاد Action، استفاده از ابزار Action Tool   است.

 Action 2-2-14 حذف

اگر در صفحه‌اي که ش��ئ مبدأ در آن قرار دارد، Action Proton  را با اس��تفاده از ابزار 
انتخ��اب Subselect يا Pointer درگ ك��رده و آن‌ را در فضاي خالي )فضاي چر‌کنويس( رها 

كنيد در اين صورت Action تخصيص يافته به شئ، حذف مي‌شود.
 Action 3-2-14 تغيير رفتار

1- براي تغيير رفتار پيش‌فرض ابزار Action در جعبه ابزار به صورت زير عمل کنيد:
 Action Tool دابل کليک کنيد ت��ا کادر محاوره Action روي ابزار Tools در جعب��ه اب��زار

ظاهر شود )شکل 14-5(.
2- با توجه به تغييري که مي‌خواهيد در رفتار Action ايجاد ش��ود کيي از گزينه‌هاي آن 

را برگزينيد.
4- روي دكمه OK كليك كنيد.

در شکل 6-14 کي   Action   براي کي موضوع متني )شماره صفحه موردنظر( انتخاب شده است به 
 طوري كه با کليک روي شماره صفحه که در پايين صفحه خانگي )Home Page-Index( ارايه به‌صورت 

متني درج شده، صفحه مربوط به آن با محتوياتش نشان داده مي‌شود.

Action شکل 5-14 تعيين رفتار
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شکل Action 14-6تعريف شده براي موضوع متني

تمرين 1: سه صفحه با اين مشخصات ايجاد کنيد:
 Blue 1- در صفحه اول شئ مربع با رنگ آبي در لايه‌اي به نام
 Red 2- در صفحه دوم شئ دايره با رنگ قرمز در لايه‌اي به نام

 Black 3- در صفحه سوم شئ ستاره با رنگ سياه در لايه‌اي به نام
س��پس با اس��تفاده از Action Tool ترتيبي دهيد که به محض کليک روي شئ اول، شئ 

سوم مشاهده شود و با کليک روي شئ سوم، شئ دوم نمايش يابد.
FreeHand به سند Flash Action 3-14 انتساب يک

در برنامه FreeHand مي‌توانيد، Actionهاي Flash را به طرح‌ها و ترسيم‌هاي ايجاد شده، 
نسبت دهيد و در فيلم‌هاي تعاملي از آن‌ها بهره بگيريد.

همچني��ن مي‌توانيد س��ندهاي FreeHand را که محتواي آن‌هاAction هاي Flash اس��ت 
به‌ص��ورت فايل SWF براي نماي��ش در Flash Player صادر کنيد. در فيلم تعاملي از مجموعه 
صفح��ه کليد، ماوس يا هر دوي آن‌ها براي حرکت اش��ياء و پرش به موقعيت‌ها و بخش‌هاي 
کي فيلم و اجراي تعداد بي‌ش��ماري از فعاليت‌هاي تعاملي1 اس��تفاده مي‌شود. براي انتساب 
کي Flash Action به اش��ياي ترسيمي در FreeHand، محدوده حرکت )Action Area( و پنل 

Navigation به‌‌کار گرفته مي‌شود.

1-  Interactive Actions 
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 FreeHand در Flash هاي Action 14-4
نتيجه کاربردAction هاي Flash در برنامه FreeHand به شرح زير است:

Actionتوضيحات

Go To and Stop
به کي فريم )صفحه‌اي در فيلم( پرش‌ ميك‌ند سپس پخش را متوقف مي‌نمايد به عبارتي 
توقف و تکرار صحنه )Play Back( انجام مي‌شود. بازيابي فهرست URL هاي كادر Link را 

كه در پنل Navigation است فراهم ميك‌ند.

Go To and Play.پرش ميك‌ند، سپس پخش فيلم را از همان نقطه ادامه مي‌دهد )Frame( به کي فريم

Get URL.بهك‌ار مي‌رود Navigation مربوط به پنل Link ليست شده در كادر URL براي رفتن به

Play.سبب اجرا يا نمايش فيلم متوقف شده مي‌شود

Stop.سبب توقف فيلم در حال اجرا مي‌شود

Print فريمي از فيلم مشخص شده را چاپ Flash Player کاربر مي‌تواند به صورت مستقيم در
کند.

Full Screen نمايش فيلم در حالت تمام صفحه و بزرگ‌تر از حالت معمولي انجام مي‌شود. در حالت تمام
صفحه، فيلم كل صفحه نمايش را مي‌پوشاند.

Start/Stop Drag

امكان‌پذير ميك‌ند و  اين عمل در زمان وقوع يك رويداد، درگ كليپ فيلم را در صفحه 
به  مي‌شود.  درگ  قابليت  رفتار  توقف  سبب  مي‌دهد،  رخ  متضاد  رويداد  يك  که  هنگامي 
به عنوان  را   On (press( اگر  مثال  به عنوان  متوقف ميك‌ند.  را  عبارت ديگر عمل درگ 
رويداد شروع اين Action در نظر بگيريد، به‌صورت خودکار )On )release را به‌عنوان عامل 
توقف درگ انتخاب مي‌کند. همچنين رويداد )On (over و )On (out رويدادهاي متضاد 

ديگر هستند.

  Load Movie

Unload Movie

فيلم Flash را از يك صفحه به فريم فيلم جاري بارگذاري ميك‌ند.

يك فيلم بارگذاري شده در فريم فيلم جاري را حذف ميك‌ند.

Tell Target
براي کنترل فيلم‌هايي است که با استفاده از عمل Load Movie در فيلم جاري بارگذاري 
شده‌اند. پارامترهاي اين Action به شما امكان مي‌دهند تا صفحه بارگذاري شده را تنظيم 

كنيد.
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 نكته: Action هاي Unload Movie ، Load Movie و  Tell Target در صورتي فعال 
هستند که سند حداقل دو صفحه داشته باشد.

بر  و   Tell Targetعلاوه   Load/Unload Movie    ،Print  ،Go To     هاي  Action   توجه:    در   

Parameters در  بازشو  را توسط منوي  اعمال  Action ها  رويداد مي‌تو‌انيد، چگونگي  تعيين 
پنل Navigation مشخص کنيد.

 مثال 1: در صفحه اول ش��کل 1 و در صفحه دوم ش��کل 2 را رسم کنيد؛ ترتيبي 
دهيد که با کليک  روي go ، رنگ س��بز چراغ راهنما به نشانه روشن شدن پررنگ شود و در 
 Stop چراغ راهنما در صفحه جابه‌جا ش��ده و به محض اين که روي Stop صفحه دوم با درگ

کليک کرديد، ديگر جابه‌جايي انجام نشود.
1- ابتدا کي س��ند دوصفحه‌اي مطابق ش��كل 7-14 ايجاد كنيد، س��پس شکل 1 را در 
صفحه اول و ش��کل 2 را در صفحه دوم رس��م کنيد. دقت نماييد که رنگ قرمز در ش��کل 1 
پررنگ و در شکل 2 کم‌رنگ است، رنگ زرد در هر دو شکل کيي و رنگ سبز در شکل دوم 
پر‌رنگ‌تر است. كلمه go )رنگ سبز( را در صفحه اول و كلمه Stop )رنگ قرمز( را در صفحه 

دوم بنويسيد.
 2- نوش��ته go از صفح��ه اول را انتخ��اب کرده و پن��ل Navigation را فعال کنيد. گزينه

Go To and Stop را از منوي بازشو Action برگزينيد.

3- در ليس��ت بازش��وي Page2 ،Parameters را انتخاب و رويداد )Event( را Press در نظر 
بگيريد.

4- در صفح��ه دوم کلم��ه Stop را انتخاب ک��رده و Start/Stop Drag را با در نظر گرفتن 
رويداد Press انتخاب کنيد.

5- براي‌مشاهده Action ايجاد شده مسير Window→Movie→Test را اجرا کنيد.
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شکل 7-14 چراغ راهنمايي

5-14 آزمايش فيلم
بعد از ايجاد يك انيميشن مي‌خواهيد نحوه اجراي آن را مشاهده كنيد، براي اين منظور 

يكي از روش‌هاي زير را برگزينيد:
1- فرمان Window→Movie→Test را اجرا نماييد.

2- كليد تركيبي Ctrl+Enter را بفشاريد.
3- روي دكمه Test  در نوار ابزار Controller كليك كنيد.

بدي��ن ترتي��ب FreeHand فيلم را در يك پنجره جداگانه )پنج��ره Flash Player( نمايش 
 Movie Settings دارد، در کادر SWF را که فرمت Flash مي‌دهد. همچنين مي‌توانيد فايل فيلم

ويرايش کنيد.
	Controller 1-5-14 نمايش

براي نمايش نوار ابزار Controller مسيرWindow→Toolbars→Controller را اجرا کنيد.
علاوه بر موارد گفته شده ساير امکانات Controller در شکل 8-14 مشخص شده است.

Controllerشکل 8-14 نوارابزار
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6-14 متحرک‌سازي با متن و شئ
يكي از روش‌هاي متحرك‌سازي اين است كه اشياء را طوري در لايه‌هاي آن‌ها قرار دهيد كه 
هر لايه مانند يك فريم عمل كند. براي متحرک کردن )انيميش��ن( اش��ياء بدون استفاده از بازه 
  Xtras→Animate→Release to Layers از فرم��ان Flash Player زماني و نمايش متحر‌کس��ازي در
اس��تفاده كنيد. در اين صورت اش��ياء در لايه‌ها قرار داده مي‌شوند و لايه‌ها به‌عنوان فريم در 
پويانمايي ايجاد ش��ده، عمل مي‌کنند. همچنين با اجراي اين دس��تور موضوع‌هاي گرافيکي 
گروه‌بندي ش��ده از گروه خارج ش��ده و بر اس��اس جلوه‌هاي منوي بازش��و Animate در کادر 
محاوره Release to Layers ، در لايه‌ها پخش مي‌ش��وند به طوري كه کي لايه جديد براي هر 

شئ ايجاد مي‌شود.

 توجه: براي ايجاد سريع کي پويانمايي از فرمان Release to Layers استفادهك  نيد.

1-6-14 ايجاد متحر‌كسازي با استفاده از لايه‌ها

1- موضوعاتي را كه مي‌خواهيد متحرك شوند، انتخاب كنيد.

 توجه:  کي شئ جاي گرفته در کي گروه مانند کي شئ مستقل و تنها عمل   مي‌کند.

 2- ب��ا اج��راي مس��ير  Window→Layer پن��ل لاي��ه را در صفح��ه، نماي��ش دهي��د 
)شکل 14-9(.

شکل 9-14 انتخاب شئ گروه‌بندي شده

3- فرمان Release to Layers را از مسير Xtras→Animate برگزينيد. در اين صورت كادر 
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محاورهRelease to Layers مطابق شكل 10-14 ظاهر مي‌شود.

شكل 14-10

 Animate 4- براي متحرک کردن ش��ئ، يكي از جلوه‌هاي پويانمايي را از منوي بازشوي
انتخاب كنيد. در اين صورت مش��خص مي‌کنيد كه اش��ياء چطور به لايه‌ها منتشر و در آن‌ها 

پخش شوند )شکل 14-11(.

 

شکل 11-14 انتخاب جلوه پويانمايي 

گزينه‌هاي منوي بازشو Animate عبارتند از:
• اشياء را پشت س��رهم و متوالي در  Sequence )جلوه اس�تاندارد متحرک‌س�ازي(:	

لايه‌هاي مجزا پخش ميك‌ند. 
با كپي كردن اشياي موجود در توالي لايه‌هاي دنبال هم،  • Build )جلوه افزايش�ي(: 	

يك جلوه پشته‌اي ايجاد ميك‌ند.
به عنوان مثال اگر يك گروه متشکل از دو شئ داريد، با اعمال جلوه Build اولين شئ در 

لايه اول قرار مي‌گيرد و کپي‌‌هاي اشياي اول و دوم در لايه دوم قرار مي‌گيرند.
• اشياء را به تمام لايه‌ها كپي ميك‌ند ولي به‌طور متوالي يك  Drop )جلوه کاهش�ي(:	

شئ را از هر لايه حذف مي‌نمايد. 
به‌عنوان مثال اگر کي گروه از س��ه ش��ئ را انتخاب کنيد؛ اشياي اول، دوم و سوم در لايه 
اول قرار گرفته و ش��ئ اول و کي کپي از ش��ئ سوم در لايه دوم و کپي‌‌هاي اشياي دوم و 

سوم در لايه سوم قرار مي‌‌گيرند.
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• اش��ياء را ‌در تعدادي از لايه‌هاي تعيين ش��ده كپي نموده  Trail )جل�وه حرکت�ي(:	

و پخش ميك‌ند. اش��ياء به طور فزاينده‌اي به تعداد لايه‌هاي مش��خص ش��ده، کپي 
مي‌شوند.

5- اگر گزينه Trail را انتخاب نماييد در اين صورت با استفاده از كادر Trail by مي‌توانيد 
تعداد لايه‌هايي را كه اشياء در آن‌ها كپي مي‌شوند، تعيين كنيد. 

به عنوان مثال براي کپي هر شئ در چهار لايه، عدد 4 را براي Trail by وارد کنيد.
6- با انتخاب گزينه Reverse direction ترتيب اش��ياء، معكوس ش��ده و آن بخش از فيلم 

در جهت مخالف، متحرك مي‌شود.
7- انتخاب گزينه Use existing layers اش��ياء را در لايه‌هاي موجود پخش ميك‌ند و اين 
كار را از لايه جاري ش��روع مي‌نمايد. اگر اين گزينه را انتخاب نكنيد؛ اش��ياء را در لايه‌هاي 

جديد قرار مي‌دهد.
                         

 

Release to Layers پس از اعمال فرمان Layers شکل 12-14مشاهده انتشار اشياء در پنل

8- اگ��ر گزين��ه Use existing layers را انتخ��اب کرده‌ايد، گزينهSend to back  اش��ياء را 
برعكس ترتيب پشته‌اي پخش ميك‌ند.

9- روي دكمه OK كليك كنيد.
10- پويانماي��ي ايجادش��ده را مي‌توانيد بااس��تفاده از نواراب��زارController نمايش دهيد 

)شکل14-13(.

 نكته: بلو‌کهاي متن، Blend، اش��ياء گروه‌بندي شده و متن متصل به کي مسير 
با فرمان Release to Layers متحرک مي‌شوند.
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Flash Playerشکل 13-14نمايش پويانمايي در

مثال 2: به نوش��ته شکل 14-14 با اس��تفاده از فرمان Release to Layers، جلوه 
 

پويانمايي Drop را اعمال کنيد.
1- با فرمان Text→Convert to Path هر حرف بلوک متني را به مسير تبديل کرده، سپس 

دستور Join از منو Modify را اجرا کنيد )شکل 14-15(.

          
                               شکل 14-14	 شکل 14-15

2- گزينه Clone را از منوي Edit برگزينيد تا کي نمونه از متن تبديل شده، ايجاد  شود.
3- با انتخاب ابزار Pointer از کپي متن تبديل شده تا محلي که مي‌خواهيد متحر‌کسازي 

پايان يابد، درگ کنيد )شکل 14-16(.
4- با استفاده از کليد Shift متن اصلي و نمونه کپي ايجاد شده را انتخاب کرده و فرمان 

Xtras→Create→Blend  را روي آن اجرا کنيد )شکل 14-17(. 

      

                     شکل 16-14	                 شکل 14-17

5- با اس��تفاده از فرم��ان Release to Layers، جلوه Drop را به متن اعمال کنيد. در پنل 
 Welcome To FreeHand MX 41 لاي��ه ايجاد مي‌ش��ود که هر کدام حاوي عب��ارت ،Layers
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هستند )شکل 14-18(. 

شکل 14-18

Flash  به يک انيميشن Blend 2-6-14 تبديل
همان‌طورک��ه گفته ش��د اج��راي فرم��ان Release to Layers روي ي��ک Blend و تنظيم 

گزينه‌هاي کادرRelease to Layers، کي انيميشن Flash ايجاد ميك‌ند.
روش اجرا:

Blend -1  مورد نظر را انتخاب کنيد )شکل 14-19(.

2- با اجراي مسير Window→Layer پنل لايه را در صفحه، نمايش دهيد.
3- مسير Xtras→Animate→Release to Layers را اجرا کنيد.

برگزيني��د  را   Build گزين��ه   Animate بازش��و  من��وي  از  ش��ده  ظاه��ر  کادر  در   -4 
)شکل 14-19(.

5- گزينه Use existing layers را انتخاب کنيد.
6- در پنجره Flash Player انيميشن ايجاد شده را نمايش دهيد )شکل 14-20(.     

 

 Blend شکل 20-14 نمايش متحر‌کسازي                    Release to Layers شکل 19- 14 اجراي فرمان

Flash در نمايشگر                                                                Blend روي کي     
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 مثال3: با ايجاد کي متحر‌کسازي به‌وسيله Blend ، ترتيبي دهيد که شکل مربع 
به دايره و سپس ستاره تبديل شود.

1- ابتدا ش��کل س��مت راست 21-14 را رس��م و کي Blend از مربع به دايره طبق شکل 
سمت چپ   23-14 ايجاد كنيد. 

2- حال طبق شکل 22-14 کي Blend از دايره به ستاره ايجاد کنيد.
3- پ��س از انتخ��اب Blend موردنظر و در واقع انتخاب کل اش��ياء رس��م ش��ده، مس��ير

Xtras→Animate→Release to Layers را اجرا کنيد.

4- در کادر محاوره ظاهر ش��ده از منوي بازش��و Animate گزينه Sequence را برگزينيد 
)شکل 14-23(.

             

شکل 21-14                                                             شکل 14-22

5- گزينه Use existing layers را انتخاب کنيد.
6- در پنجره Flash Player انيميشن ايجاد شده را نمايش دهيد.

 

شکل 14-23

تمرين 2: با استفاده از Blend، متحر‌کسازي ايجاد کنيد که کلمه Photoshop را 
به FreeHand تبديل کند و جلوه حرکتي )Trail( با عدد 5 را براي آن در نظر بگيريد.

)راهنمايي: پس از نوشتن کلمه‌ها، قبل از ايجاد Blend آن‌ها را به مسير تبديل کنيد.(
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	Navigation 3-6-14 کار با پنل

همان‌طوركه قبلًا شرح داده شد با استفاده از ابزار    Action مي‌توانيد اعمال )Action( را به 
اشياي FreeHand نسبت دهيد. حال در اين‌جا مي‌خواهيم از پنل Navigation استفاده كرده 

و Actionهاي Flash را به اشياء سند FreeHand ارتباط دهيم.
براي نس��بت دادن اعمال )Action( با اس��تفاده از پنل Navigation ، مراحل بعد را انجام 

دهيد:
روش اجرا:

1- شئ يا موضوعات موردنظر را انتخاب نماييد. 
2- براي ظاهر کردن پنل Navigation از مس��ير Window→Navigation استفاده کنيد تا 

اين پنل مطابق شکل 24-14 باز شود.
3- از منوي بازشوي Action براي انتخاب يك عمل )Action( استفاده كنيد.

 Event را فعال ميك‌ند، از منوي بازش��وي )Action( 4- ب��راي انتخاب رويدادي كه عمل
استفاده نماييد )شكل 14-24(. 

 Navigation شکل 24-14 پنل

 Load /Unload،Print ،Go To and Play ،Go To and Stop 5- در ص��ورت انتخاب گزين��ه
Movie يا Tell Target در منوي بازش��وي Action، از اولين منوي بازش��وي Parameters براي 

انتخاب از ليست صفحات سند جاري، استفاده كنيد. 
6- در صورت انتخاب گزينه Go To and Play ، Go To and Stop يا Print براي تعيين اين 
 Parameters كه كدام بخش از سند بايد نمايش داده شود يا چاپ شود، دومين منوي بازشوي

را به كاربريد.
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7- در ص��ورت انتخاب Tell Target براي كنترل پخ��ش فيلم ديگر، يكي از ‌Action هاي 
Stop،Go To and Stop/Play ،Play  يا Print را از دومين منوي بازش��وي  Parameters انتخاب 

كنيد.
8- اگ��ر از دومين منوي بازش��وي  Parameters گزين��ه Go To and Stop/Play يا Print را 
انتخاب كرديد، براي تعيين اين كه كدام بخش از س��ند بايد نمايش داده شود يا چاپ شود، 

از سومين منوي بازشوي Parameters استفاده كنيد.

 مثال 4: در صورتي كه س��ندي از قبل ايجاد كرديد مس��ير File→Open را اجرا 
کنيد تا س��ند موردنظر باز شود، سپس مس��ير View→Fit All را اجرا کنيد تا محتواي فايل 

موردنظر که به عنوان مثال در شكل 25-14چهار صفحه‌اي است، مشاهده شود.

  

شکل 25-14 فايل چهار صفحه‌اي      

1- در اي��ن مث��ال از صفحه اول در لايه Screen  طبق ش��کل 26-14 ش��ئ مورد نظر را 
برگزينيد. 
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شکل 26-14 انتخاب شئ لايه  Screenدر صفحه اول

2- پنل Navigation را از مسير Window→Navigation باز كنيد.
 Parameters و از اولين منوي بازشوي  Go To and Stop گزينه Action 3- از منوي بازشوي

صفحه دوم را انتخاب کنيد، در منوي بازشوي دوم Parameters ، لايه PDA ظاهر مي‌شود.
4- پيش‌فرض منوي بازشوي Event، رويداد Press است )شکل 14-27(. 

 Navigation ايجاد شده در پنل Actionشکل 27-14 نمايش

به اين ترتيب کي Action  ايجاد کرده‌ايد که در پنجره Flash Player  با کليک ماوس روي 
شئ Screen  در صفحه اول، صفحه دوم ظاهر مي‌شود )شکل 14-28(.

5- حال از منوي بازش��و Event گزينه Over  را برگزينيد )ش��کل 29-14(. به اين ترتيب 
کي Action  ايجاد کرد‌ه‌ايد که در پنجره Flash Player، با قراردادن اش��اره‌گر ماوس روي شئ 

Screen  در صفحه اول، صفحه دوم آشکار شود.

شکل Action 14-28 ايجاد شده از صفحه اول به صفحه دوم   
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Over شکل 29-14 انتخاب رويداد

 6- با ابزار Pointer در صفحه دوم، شئ لايه Screen  را انتخاب کنيد. از منوي Action گزينه
Go To and Stop را برگزينيد. به اين ترتيب علامت Action Proton در گوش��ه س��مت راست 

پايين شئ  Screen مشاهده مي‌شود.
7- در اولي��ن منوي بازش��و Page3 ،Parameters را انتخاب کنيد. خط آبي رنگ تا ش��ئ 

صفحه سوم ادامه ميي‌ابد )شکل 14-30(.

شکل Action 14-30 ايجاد شده از صفحه دوم به صفحه سوم

8- از منوي بازش��و Event، گزينه Over  را انتخاب کنيد. به اين ترتيب کي Action  ايجاد 
کرده‌ايد که در پنجره Flash Player با کليک ماوس روي شئ Screen  از صفحه دوم به صفحه 

سوم مي‌رويد.
 FreeHand امکان تست فيلم در داخل برنامه Window→Movie→Test 9- با اجراي مسير
فراهم مي‌آيد و فايل فيلم Flash با فرمت SWF در پنجره Flash Player مش��اهده مي‌شود که 

محتويات صفحه اول را نشان مي‌دهد )شکل 14-31(.
10- با قراردادن ماوس روي شئ صفحه اول، صفحه دوم نمايان مي‌شود )شکل 14-31(.

11- در صفحه دوم اگر براي اش��ياي آن Action تعريف شده باشد، شکل اشاره‌گر ماوس 
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به صورت دس��ت تبديل ‌شده و ش��ئ مربوطه تيره‌تر از ساير اشياء مي‌شود كه با کليک روي 
آن، صفحه سوم در پنجره Flash Player مشاهده مي‌شود )شکل 14-32(.

            

 Flash شکل 32-14 نمايش و تست فيلم                    Flash شکل 31-14 نمايش و تست فيلم                 

Movie Settings و Flash Movie 4-6-14 آشنايي با
در برنامه FreeHand مي‌توانيد Flash Movie 1را در داخل سند FreeHand وارد کرده و به 

صورت تعاملي در وب نمايش دهيد. 

 توجه: فايل Flash با فرمت SWF از طريق اجراي مس��ير File→Import در س��ند وارد 
مي‌شود.

بايد به اين نكته توجه داش��ته باش��يد كه فايل Flash با فرمت FLA فايل قابل ويرايش در 
 Flash Movie اس��ت و با اس��تفاده از آن مي‌توان کي Macromedia Flash MX محيط برنامه

)فيلم Flash( که فرمت آن SWF است، ايجاد كرد )شكل 14-33(.

FreeHand شده در سند Import شکل 33-14 نمايش فيلم
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 FreeHand با استفاده از سند Flash امکان ايجاد کي فيلم سفارشي FreeHand در برنامه
 Movie Settings کادر محاوره ،Flash وج��ود دارد. براي انجام تنظيم‌هاي مورد نظر در فيل��م

به‌کار مي‌رود.
Movie Settings روش اجراي

1- فيلم موردنظر )فيلم ايجاد شده در مثال 4( را در سند وارد کنيد.
2- مسير Window→Movie→Settings را اجرا کنيد.

در کادر محاوره Movie Settings مش��خص مي‌ش��ود که لايه‌هاي موجود در صفحه سند 
FreeHand چگونه به فريم‌هاي فيلم Flash تبديل مي‌شوند.

 توجه: در متحرك‌سازي، لايه‌هاي پنهان و لايه Guides ديده نمي‌شوند.

در اين كادر محاوره سه ناحيه مختلف وجود دارد )شكل 14-34(.
1- در ادامه اجراي مثال‌، گزينه Flatten را در بخش Layers  انتخاب كنيد تا همه لايه‌هاي 

موجود در صفحه‌هاي سند ادغام شده و در کي Frame قرار گيرند )شکل 14-34(.
2- در Page Range محدوده صفحه را 1 تا 3 قرار دهيد. در اين‌ صورت صفحه 4 در فيلم 
ايجاد ش��ده در نظر گرفته نمي‌ش��ود و حجم فايل Movie نسبت به حالت 4 صفحه‌اي کمتر 

مي‌شود.
3- دکمه OK  را کليک کنيد. 

شکل 34-14 کادر تنظيمات فيلم ايجاد شده در مثال 4 	
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FreeHand در داخل محيط Flash ويرايش فايل
اگر برنامه Macromedia Flash MX و  FreeHand MX هر دو در رايانه نصب ش��ده باش��ند؛ 

مي‌توانيد فايل Flash با فرمت FLA را در برنامه FreeHand ويرايش کنيد.
روش اجرا:

1- فيلم Flash موردنظر را که مي‌خواهيد ويرايش کنيد، در صفحه Import کنيد.
2- در پنل Object روي دکمه ويرايش Flash کليک كنيد، س��پس در کادر محاوره ظاهر 
شده، فايل فيلم Flash موردنظر را با فرمت FLA )فرمتي که سبب ايجاد فيلم Flash با فرمت 

SWF مي‌شود( انتخاب کرده و در صفحه ظاهر کنيد )شکل 14-35(.

3- ويرايش مورد نظر را انجام داده، س��پس روي Done کليک کنيد )شکل 35-14(. در 
اين صورت فايل Flash بسته مي‌شود و به سند FreeHand باز مي‌گرديد. 

 نكته: اگر كادر انتخاب Show Snapshot فعال باش��د، مي‌توانيد نمايشي از يكي ‌از 
فريم‌هاي فيلم را ببينيد.

FreeHand در داخل Flash شکل 35-14ويرايش فايل

تمرين 3: تنظيم ويژگي‌هاي کي فيلم Import ش��ده در س��ند FreeHand را با 
استفاده از پنل Object که در شکل 36-14 مشخص شده، بررسي کنيد.
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شکل 14-36

HTML با فرمت Web در FreeHand 7-14  انتشار سند
ويژگي‌هاي وب FreeHand براي طراحي يك وب س��ايت ب��هك‌ار نمي‌رود بلكه براي مواردي 
  Publish as HTMLنظير تبديل يك بروش��ور به مجموعه‌اي از صفحات وب مفيد است. با فرمان
س��ند FreeHand به س��ند HTML تبديل مي‌ش��ود و مي‌توانيد مانند صفحات وب آن را در 

مرورگر وب مشاهده کنيد.
 ب��ا اج��راي فرم��ان File→Publish as HTML كادر مح��اوره HTML Output مطاب��ق 
 ،HTML به فرمت FreeHand ش��كل  37-14 نشان داده مي‌ش��ود. مي‌توانيد براي تبديل سند
تنظيم��ي را از من��وي HTML Setting انتخاب كرده يا تنظيم جديدي )با اس��تفاده از دكمه 
Setup( را ايج��اد كنيد. امکان ويرايش تنظيم پيش‌فرض و تنظيم‌هاي ايجاد ش��ده نيز وجود 

دارد.
	

شکل 14-37
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 HTML كليك كنيد كادر محاوره Setup روي دكمه HTML Output  اگ��ر در كادر محاوره
Setup باز مي‌شود )شكل 14-38(.

HTML به فايل FreeHandشکل 38-14 کادر ايجاد و ويرايش تنظيم تبديل سند

در اين كادر تنظيماتي مانند محل ذخيره‌س��ازي سند HTML، قالب‌بندي و صفحه‌آرايي 
آن، رمزگ��ذاري قلمي که در صفحه به‌کار مي‌رود، تعيي��ن فرمت و نوع فايل براي اثر هنري 
 FreeHand در پوش��ه‌اي به نام HTML وجود دارد. محل ذخيره س��ند )Vector ي��ا Bitmap(

HTML Output در روي صفحه Desktop است. 

1-7-14 ايجاد سند

1- سند FreeHand مورد نظر را باز و مسير File→Publish as HTML را اجرا کنيد.
 ،HTML کيي از موارد زير را براي انتخاب تنظيمات HTML Output 2- در کادرمح��اوره‌

در بخش HTML Setting انجام دهيد:
•تنظيم پيش‌فرض يا تنظيمي را که ايجاد کرده‌ايد، انتخاب کنيد. اگر تنظيمي ايجاد  	

نکرده‌ايد فقط تنظيم پيش‌فرض ديده مي‌شود.
• روي دکمه Setup کليک کنيد تا کادر محاوره HTML Setup ظاهر شود.	

• ارائه  	HTML کليک کرده، دستوراتي که براي انتخاب تنظيمات Wizard روي دکمه
مي‌شود دنبال كنيد و با کليک روي دکمه Finish به کار پايان دهيد. 

3- پس از انجام تنظيمات مورد نظر روي دکمه Save as HTML کليک کنيد.
HTML Output 2-7-14 ايجاد و ويرايش تنظيم‌هاي

1- روي گزين��ه File→Publish as HTML كليك کنيد تا کادرمحاوره HTML Output در 
صفحه ظاهر شود.
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2- روي دکمه Setup  کليک کنيد تا کادر HTML Setup ظاهر شود.

Name for new HTML Setting شکل 39-14 درج نام تنظيم جديد در کادر متني

3- کيي از مواردي را كه در ادامه گفته شده با توجه به نيازتان اجرا کنيد.
• آش��کار  براي ايجاد تنظيم جديد، روي علامت + کليک کنيد تا کادر ش��كل 14-39	
ش��ود. س��پس نام تنظيم جديد را در کادر متني مربوط به آن وارد و دکمه OK را 

کليک کنيد.
 • 	HTML Setting که قبلًا ايجاد ش��ده، از منوي بازش��و HTML براي ويرايش تنظيم

تنظيم مورد نظر را انتخاب کنيد )شکل 14-40(.

شکل 40-14 انتخاب تنظيم موردنظر براي ويرايش

4- محل ذخيره ‌س��ند HTML را با کليک روي دکمه Browse و تعيين پوش��ه نگهداري 
فايل HTML مشخص کرده و روي دکمه Select کليک کنيد.

مثال 5: صفحه FreeHand نش��ان داده شده در شکل 41-14 را براساس تنظيم 
پيش‌فرض به صورت HTML تبديل کنيد. 

 File→Publish as HTML شكل 41-14 را ايجاد كنيد، سپس مسير FreeHand 1- سند
را اجرا کنيد.

2- در کادر محاوره    HTML      Output، تنظيم پيش‌فرض را انتخاب کنيد )شکل 14-42(.
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شکل 41-14                                            شکل 14-42

3- از قس��مت Pages گزين��ه All را انتخاب كنيد تا تنظيم��ات روي تمام صفحات اعمال 
شود )شكل 14-42(.

4- با کليك روي دکمه Browse برنامه مرورگر يا ويرايشگر موردنظر را انتخاب نماييد.
5- روي دکمه Save as HTML کليک کنيد )شکل 14-42(. 

تمري�ن 4: کي فايل FreeHand با ن��ام T14 -3  ايجاد كنيد كه داراي دو صفحه 
باشد. در صفحه اول آن کي تصوير Import ،Bitmap شده و در صفحه دوم آن شکل 14-43 

قرار داده شود، با توجه به موارد خواسته شده آن را به فرمت HTML تبديل کنيد.
1- خروجي در مرورگر وب دلخواه مشاهده شود.
2- کادر هشدار در جريان تبديل مشاهده شود.

شکل 14-43
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1 URL 8-14 انتساب يک
يك��ي از مهم‌ترين ويژگي‌هاي صفحه وب كه در HTML وج��ود دارد، قابليت لينك‌هاي 
URL است. اين لينك‌ها يا پيوندها به شما امكان مي‌دهد تا روي يك كلمه، عبارت يا تصوير 

كليك كنيد و به مكان ديگري در وب س��ايت جاري يا سايت ديگر منتقل شويد. براي ايجاد 
 Navigation که در پنل Link مي‌توانيد از کادر متني URL بين ش��ئ يا متن و )Link( پيوند

است، استفاده کنيد.
 HTML يا PDF ،SWF است در فايلي با فرمت URL که حاوي FreeHand وقتي کي سند
صادر شود در اين صورت کليک روي شئ متصل شده به آدرس URL، سبب پرش به صفحه 

وب مورد نظر مي‌شود.
1-8-14 انتساب URL به شئ

1- شيئي را انتخاب كنيد كه مي‌خواهيد پيوند )لينك( به آن اعمال شود.
2- در پنل Navigation آدرس URL را در كادر Link تايپ كنيد )شكل 14-44(.

ي��ا اگ��ر قبلًا لينكي را به س��ند اضافه كرده‌ايد، از منوي بازش��و Link براي انتخاب پيوند 
موردنظر استفاده نماييد.

شکل 14-44

 نكت�ه: اگر با چندين صفحه در س��ند كار ميك‌نيد، از منوي Link براي انتخاب 
يك پيوند به صفحه ديگر استفاده كنيد.

• را به اش��ياء نسبت دهيد، اشياء  	URL اين امکان را مي‌دهد که کي Navigation پنل

را بررسي کنيد و مشخص کنيد که چه URLهايي به آن‌ها متصل است،URL  همه 
اشياء را به‌روز کنيد و شئ‌هايي را که به کي URL خاص متصل هستند، بيابيد.

Uniform Resource Locator  -1: مشخص کننده منحصر به فرد منبع، آدرس منحصر به فرد صفحات وب
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• کلمه يا عبارت‌هايي را نش��ان مي‌دهد که داخل بلوک متني فعال  	Substring منوي
است و به يك URL در کادرLink  متصل است.

2-8-14 انتساب URL به متن	

1- در فايل FreeHand، متن يا بلوک متني که مي‌خواهيد URL را به آن نسبت دهيد با 
ابزار Text انتخاب کنيد. 

2- مسير Window→Navigation را براي فعال کردن پنل Navigation اجرا کنيد.
3- در منوي Link، آدرس URL موردنظر را درج يا از منوي بازش��و Link، آن را انتخاب 

کنيد. در اين صورت متن انتخابي در کادر Substring آشکار مي‌شود. 
URL 3-8-14 به روز کردن

1- در سند جاري همه اشياء را از حالت انتخاب خارج کنيد.
2- در پن��ل Navigation ي��ک URL را از منوي بازش��و Link، انتخاب يا يك URL را وارد 

كنيد.
3- روي دکمه جس��تجو  که در س��مت راست منوي بازش��و Link قرار دارد، کليک 

کنيد.
4- تمام اشياي موجود در سند جاري كه به URL لينك شده‌اند، انتخاب مي‌شوند.

در اي��ن ص��ورت URL براي همه اش��ياي متصل )Link( به آن در س��ند ج��اري به روز 
مي‌شوند.

URL 4-8-14 جستجوي اشياي متصل شده به
 URL يك Link آدرس را درج کرده يا از منوي بازش��و Link در كادر ،Navigation 1- در پنل

انتخاب کنيد.
کني��د  کلي��ک   ، Link من��وي  راس��ت  س��مت  در    Find Button دکم��ه  روي   -2 

3- تمام اشياي موجود در سند جاري كه به URL  متصل شده‌اند، در سند انتخاب مي‌شوند.
هنگامي که URL را به شئ سند FreeHand که داراي خط دور )Stroke( است، نسبت مي‌دهيد؛ 
وقتي کاربر ‌اشاره‌گر ماوس را روي خط حرکت دهد پيوند ايجاد شده در سند HTML فعال خواهد 

شد.
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Navigation شکل 45-14نمايش دكمه جستجو در پنل

 مثال 6: درفايل FreeHand نشان‌داده‌ش��ده در ش��کل 46-14 کي Link از شئ 
 C:\Documents and Settings\ma\FreeHand متني ب��ه صفحه وب‌ ذخيره ش��ده ‌در مس��ير

html.Output\Untitled001 ايجاد کنيد.

1- پس از ايجاد شکل 46-14در سند FreeHand، متن درج شده را انتخاب کنيد.
2- پنل Navigation را فعال کنيد.

3- در کادر Link، آدرس صفحه HTML موردنظر را درج کنيد.
4- در کادر Substring عبارت انتخاب شده مشاهده مي‌شود )شکل 14-46(. 

        

شکل 14-46

5- فايل FreeHand را به HTML تبديل کنيد )شکل 14-47(.
6- با کليک روي عبارت show button صفحه Link شده به‌آن قابل ‌مشاهده‌ است )شکل 

سمت چپ 14-47(.	
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شکل 14-47

5-8-14 فشرده‌سازي اثر هنري )Artwork( براي نمايش در وب

وقت��ي تصويرها را براي نمايش در وب آماده مي‌کنيد، حجم تصويرهاي فش��رده ش��ده، 
کاه��ش يافته و روي رن��گ تصويرهاي به نمايش درآمده در وب و س��اير ويژگي‌هاي تصوير 

کنترل‌هاي لازم انجام مي‌شود.
اثر هنري Bitmap در FreeHand به صورت JPEG ،GIF يا فرمت PNG فش��رده مي‌ش��ود. 
اث��ر هنري برداري ب��ا فرمت SWF، صادر مي‌ش��ود )Export( و به اين ترتيب فايل ايس��تاي 

FreeHand به کي سند پويانمايي با Action هاي Flash تبديل مي‌شود.

در فشرده‌س��ازي کاره��اي از ن��وع Bitmap بايد قالبي انتخاب ش��ود که اس��اس رنگ و 
مشخصه‌هاي تن‌هاي رنگي اثر هنري اصلي را حفظ کند و نوع مرورگر براي مشاهده صفحه 

نيز در اين مورد مؤثر است.
• و  	Flat بهترين حالت براي تصويرس��ازي و طراحي با رنگ‌هاي GIF به‌طورکلي فرمت

يكنواخت است، مثل رنگي که در متن به‌کار مي‌رود.
• بهترين حالت براي اثر هنري با محدوده گسترده و دامنه‌اي از تناليته‌هاي  	JPEG قالب
پيوسته رنگ است، مثل اثر هنري که در آن رنگ گراديان به کار رفته يا عکس‌هايي 

که اسکن شده‌اند.
• محدوده وس��يعي از رنگ را دربرمي‌گي��رد اما غالباً بهك‌ار  	JPEG مانند PNG فرم��ت

نمي‌رود زيرا فقط امكان نمايش در برخي از مرورگرها را دارد.
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واژه‌نامه 
Actionحرکت، عمل

Flash Playerنمايشگر برنامه

Interactiveتعاملي

Target Pageصفحه مقصد

Navigationجهتي‌ابي

Parametersپارامترها

Unloadعدم بازيابي

Sequenceترتيب، توالي

Trailکشيدن، کشيده شدن

خلاصه مطالب
در اين واحدکار مواردي که سبب نمايش سند FreeHand در وب و ايجاد اثر گرافيکي و 

پويانمايي تحت وب مي‌شود، به شرح زير بررسي شد:
• و ايجاد فيلم تعاملي در وب 	FreeHand به شئ سند Flash Action انتساب کي

( براي اس��تفاده در اثر  • 	SWF( Flash در قالب فاي��ل FreeHand اث��ر هن��ري Export

برداري پويا و نمايش آن در وب.
 • 	Flash با استفاده از پنجره FreeHand در داخل Flash پيش‌نمايش و تست فيلم‌هاي

.Player

 • 	FreeHand براي تبديل سندXtras→Animate→Release to Layers  استفاده از فرمان
به صورت کي انيميشن.

. • 	Publish as HTML با استفاده از فرمان HTML به FreeHand تبديل سند
• با اس��تفاده از پنل  	FreeHand به اش��ياء يا متن در س��ند URL انتس��اب لين‌کهاي

.Navigation

• براي نمايش س��ند به  	PNG يا JPEG ،GIF در قالب FreeHand فشرده‌س��ازي آث��ار
.HTML صورت
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

Over -1، رويداد حرکت ماوس روي شئ است.

2- زماني که براي کي ش��ئ، Action تعريف مي‌کنيد در گوش��ه بالا س��مت راست آن، 
علامتي به نام Action Proton ظاهر مي‌شود.

 Play( پرش به کي فريم و توقف تکرار صحنه  Go To and Stop،Action 3- با استفاده از
Back( انجام مي‌شود.

Action -4ه��اي Load/Unload Movie وTell Target  در صورتي فعال هس��تند که س��ند 

حداقل سه صفحه داشته باشد.
 Macromedia Flash MX فايل قابل ويرايش در محيط برنامه FLA با فرمت Flash 5- فايل

است.
معادل گزينه هاي سمت‌راست را از ستون سمت‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Link to Target Page              .6- جلوه حرکتي است که به کي موضوع داده مي‌شود
7- صفحه‌اي که محل پايان يافتن Action  را مش��خص مي‌کند و عمل رها کردن ماوس 
Action                                                                                    .در آن انجام مي‌شود )Drop(

                   Release to Layers                  .8- کي اتصال و پيوند به صفحه مقصد ايجاد مي‌کند
Blend  -9، بلو‌کهاي متن، اشياء گروه‌بندي شده و متن متصل به کي مسير با اين فرمان 

Target Page                                                                         .متحرک مي‌شوند
گزينه صحيح را انتخاب کنيد.

10-کدامي‌��ک از Actionها، براي نمايش فيل��م در حالت تمام صفحه و بزرگ‌تر از حالت 
معمولي انجام مي‌شود؟

The Print action -ب 	The Tell Target action -الف
  The Full Screen action-د 	The Play and Stop actions -ج

11- كدامي‌ك از گزينه‌هاي انيميش��ن، اش��ياء را به تعداد لايه‌هايي که مشخص مي‌کنيد 
کپي و پخش مي‌کند؟

Build  -د             Drop  -ج           Sequence  -ب       Trail  -الف 
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12- كدام فرمت بهترين حالت براي تصويرسازي و طراحي با رنگ‌هاي Flat است؟
SWF -د         	JPG -ج 	 GIF -ب       PNG -الف

13- كليد تركيبي Ctrl+Enter چه عملي انجام مي‌دهد؟
الف- صدور فايل حركتي به وب        ب- قرار دادن اشياء در فريم

		       د- اعمال جلوه حركتي به شكل ج- تست و اجراي فيلم
در جاي خالي عبارت مناسب را بنويسيد.

14- با فرمان .................. س��ند FreeHand به س��ند HTML تبديل مي‌ش��ود و مي‌توانيد 
مانند صفحات وب آن را در مرورگر وب مشاهده کنيد.

 Flash براي ........... و ........... کي فيلم ،The Load Movie and Unload Movie actions  -15

در داخل فيلم Flash جاري )فيلم در حال نمايش( است.
به سؤالات زير پاسخ تشريحی دهيد.

16- اعمال )Go To and Play )Action با Play چه تفاوتي دارد؟
17- ابزار Action Tool چه كاري انجام مي‌دهد؟ نام ببريد.
18- در شکل زير نام دکمه‌هاي مشخص شده را بنويسيد.
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آزمون عملي
1- متن اين ش��کل را رس��م ک��رده ب��ا اس��تفاده از فرم��ان Release to Layers روي آن 

متحر‌کسازي با جلوه Trail ايجاد کنيد.

2- موارد خواسته شده را اجرا کنيد:
• که دوصفحه‌اي اس��ت ايجاد کرده و شکل‌هاي الف و ب را در  	FreeHand کي س��ند

صفحه اول و دوم آن قرار دهيد.                                                    
• ايجاد شود که با  	Flash Movie کي ،FreeHand ترتيبي دهيد که با اس��تفاده از فايل
حرکت ماوس روي شئ اول، شئ دوم ظاهر شود.                                            

3- کي س��ند FreeHand سه صفحه‌اي شامل تصوير Bitmap و ترسيم برداري ايجاد و آن 

را به کي فايل HTML تبديل کنيد. ترتيبي دهيد که دو صفحه از سه صفحه فايل به فرمت 
HTML تبديل شوند.

4- با استفاده از پنل Navigation بين شکل زير و کي سند HTML دلخواه، ارتباط برقرار 
کنيد.
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کليات 
تاکنون با امکانات و توانايي‌هاي متعدد برنامه گرافيکي FreeHand آش��نا ش��ده‌ايد. گاهي 
اوقات هنگام طراحي لازم مي‌ش��ود براي تکميل طرح، فايل ترسيمي را به کي نرم‌افزار ديگر 
ب��رده و روي آن تغييرات لازم را انجام دهيد همچنين ب��راي خروجي گرفتن از کار طراحي 
نهايي بايد بتوانيد با فرمان Print ترس��يمات را چاپ کنيد. بدين منظور در اين واحد کار به 
بررس��ي نحوه صدور فايل و فرمت‌هاي پشتيباني شده براي صدور فايل همچنين نحوه چاپ 

فايل و تصاوير ايجاد شده در FreeHand خواهيم پرداخت.
Export 1-15 فرمان

چنانچه بخواهيد از فايل ترسيمي در کي برنامه گرافيکي ديگر غير از FreeHand استفاده 
کنيد، لازم است فايل را با فرمتي ذخيره کنيد که با برنامه مقصد سازگاري داشته باشد، در 
اين صورت از فرمان Export استفاده کنيد. همچنين با استفاده از اين فرمان مي‌توان فايل‌ها 

را به فرمت‌هاي گوناگون تبديل و ذخيره کرد.
FreeHand انواع فرمت‌هاي گرافيکي برداري و پيکس��لي را پش��تيباني مي‌کند. مي‌توانيد 

فايل‌هاي گرافيکي يا متني را به فرمت‌هاي زير Export نماييد:
• 	 BMPو GIF ،JPEG ،TIFF ،PNG ،PSD با فرمت‌هاي Bitmap تصاوير

 • 	Flash به منظ��ور نمايش در مرورگر وب ي��ا برنامه SWF ب��ا فرمت Flash فيلم‌ه��اي
Player

و  • 	Enhanced Metafile (EMF( فرمت‌ه��اي  ب��ا   )Vector( ب��رداري   گرافي‌که��اي 
 Windows Metafile (WMF(

• 	FreeHand 8, 9, 10 فايل‌هاي
• 	  Illustrator فايل‌هاي

• نمايش داده  	 Adobe Acrobatکه توس��ط برنام��ه  PDFاس��ناد ايجاد ش��ده با فرمت
مي‌شوند.

• 	RTF و ASCII   مثل )Text( فرمت‌هاي متني
در مورد انواع فرمت‌ها قبلًا در واحد کار 3 توضيح داده شده است.

به‌منظور صادر کردن فايل طراحي ش��ده به نرم‌افزارهاي ديگر از فرمان File→Export يا 
کليد تركيبي Ctrl+Shift+R استفاده کنيد تا کادرمحاوره Export Document در صفحه ظاهر 
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شود )شکل 15-1(.

Export Document شکل 1-15 کادر محاوره

 مثال 1: آرم نشان داده شده در شکل 2-15 را طراحي کنيد؛ سپس آن را با نام 
Arm1 و پس��وند JPG به برنامه Paint ويندوز ص��ادر کرده و از طريق آن برنامه، کلمه ITP را 

جدا کرده و به زير شکل منتقل کنيد.

شکل 15-2

1- ابتدا طراحي آرم را با ابزارهاي مناسب انجام دهيد.
2- از منوي File گزينه Export را برگزينيد.

3- در کادر محاوره ظاهر شده در کادر متني File name نام Arm1  را وارد کنيد.
4- در منوي بازشوي Save as type پسوند JPG را انتخاب کنيد.

5- گزينه Open in external application را فعال کنيد و در کادر محاوره باز ش��ده، فايل 
mspaint.exe را از پوشه ويندوز انتخاب کنيد.
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6- روي دکمه Save کليک کنيد تا وارد برنامه Paint شويد.
7- در اين برنامه با ابزار Select متنITP  را انتخاب کرده و به زير شکل منتقل کنيد.

تمرين 1: براي کي ش��رکت کامپيوتري، کارت ويزيتي مطابق ش��کل 3-15 به 
 Photoshop ابعاد 5×9 س��انتي‌متر و به صورت افقي، طراحي کنيد؛ س��پس آن را به نرم‌افزار

ارسال کرده و براي زيبايي کار روي آن چند فيلتر مناسب اعمال کنيد.

شکل 15-3

 توج�ه: دکم��ه Setup ب��راي اعمال کنترل بر فايل ارس��الي به‌کار م��ي‌رود که در 

فرمت‌هاي مختلف تنظيمات گوناگوني دارد.

1-1-15 نحوه صدور برخي فايل‌ها 

براي‌تنظي��م صدور هر فرمت نظير JPG ،GIF ،TIFF ،BMP و PNG  روي دكمه Setup در 
كادرمحاوره‌ Export Document كليك كنيد. در اين صورت كادري مطابق ش��كل 4-15 باز 

مي‌شود.

شکل 15-4

• و براي  	300 dpi مقدار وضوح را براي اكثر كارهاي چاپي Resolution در منوي بازشو
وب مقدار dpi 72 در نظر بگيريد.

• براي هموار كردن لبه‌هاي تصوير، مقدار Anti-aliasing را انتخاب كنيد.	
 • 	Include alpha براي صادر كردن كانال آلفا كه به عنوان ماس��ك بهك‌ار مي‌رود گزينه
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channel را كليك نماييد. اگر براي تصوير يك كانال آلفا ايجاد كرده باشيد، مي‌توانيد 

از FreeHand براي نش��ان دادن يا مخفي كردن اين كانال اس��تفاده كنيد. اگر كانال 
آلفا قابل رؤيت نباشد تصوير كامل را مي‌بينيد.

كارگي��ري لايه پس‌زمينه به  • انتخ��اب گزينه Alpha includes background س��بب به‌	
عنوان كانال آلفا1 مي‌شود )شكل 15-5(.

شکل 15-5

 نكت�ه: FreeHand به ش��ما امكان مي‌دهد كه كانال‌هاي آلف��اي تصاوير با فرمت 
PNG ،TIFF و GIF را نمايش دهيد.

 Export Again 2-15 فرمان
پس از صدور کي فايل، ممکن اس��ت بخواهيد تغييراتي را در س��ند اصلي ايجاد کنيد و 

سپس بدون تنظيم کادر محاوره Export مجدداً فايل مزبور را صادر کنيد.
 FreeHand را اجرا کني��د. در اين صورت File→Export Again ب��راي اين منظور فرم��ان
بدون استفاده از تنظيم كادرمحاوره Export فايل را با همان نام و پسوند در مسيري که قبلًا 

Export شده بود، ذخيره و صادر مي‌کند.

Email  3-15 ارسال يک سند به‌صورت
در صورتي که ويندوز شما داراي سيس��تم نامه الکترونيکي MAPI32-Compliant باشد، 
 Mail يا تمام س��ندهاي باز شده متصل به آن را ارسال يا FreeHand مي‌توانيد س��ند فعال در

نماييد. مراحل کار به صورت زير است:
1- گزينه File→Send را انتخاب کنيد.

2- با توجه به عملي که مي‌خواهيد انجام دهيد کيي از روش‌هاي زير را اجرا کنيد:
1- كانال آلفا انتخابي است كه به عنوان ماسك و به شكل تصاوير خاكستري ذخيره مي‌شود.
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• براي اتصال )Attach( سند فعال به پيام E-mail، نام فايل را انتخاب کنيد.	
، گزينه • 	E-mail تمام اس��نادي که به تازگي باز شده‌اند، به پيام )Attach( براي اتصال 

All Open Documents را انتخاب کنيد.

اگر براي اولين بار کي سند را به صورت نامه الكترونيكي Mail يا ارسال کنيد کي پنجره 
ظاهر مي‌شود و از شما مي‌خواهد که کي پروفايل را تنظيم کنيد. براي کسب اطلاعات بيشتر 

به مستندات برنامه کاربردي E-mail  خود مراجعه نماييد.
3- در صورت نياز، پيام‌هاي مورد نظر را به متن نامه خود اضافه نماييد.

4- پس از درج آدرسE-mail  ش��خصي که مي‌خواهيد نامه را به او ارس��ال کنيد، روي 
دکمه Send  کليک کنيد.

اسناد به نامه متصل1 مي‌شوند. در صورتي که براي سند جاري که آن را ارسال نموده‌ايد 
نامي تعيين نکرده باشيد، با همان نام پيش‌فرض خود در FreeHand ارسال مي‌شوند. 

Print 4-15 فرمان
پس از تکميل کار طراحي معمولاً لازم اس��ت که نمونه‌اي از آن را روي کاغذ مش��اهده 

کنيد و به اصلاح اشکالات احتمالي آن بپردازيد.
عمل چاپ را مي‌توان به دو روش انجام داد که عبارتند از چاپ خانگي و چاپ تجاري يا 

صنعتي. در اين بخش، کار با ابزارهاي چاپ خانگي مورد بحث و بررسي قرار گرفته است.
 Print نصب شده باشد، مي‌توان از روش‌هاي زير کادر محاوره )Printer( در صورتي که چاپگر 

)شکل 6-15( را باز کرد:
 Print گزينه File روش 1: منوي

Main روش 2: کليک روي آکين  در نوار ابزار
 Ctrl+P روش 3:  به‌کار بردن کليد ترکيبي

پس از باز شدن کادر محاوره Print و قبل از تأييد اين کادر و شروع عمل چاپ، ابتدا بايد 
گزينه‌هاي آن را تنظيم و کنترل کنيد.

 1- Attach        
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Print شکل 6-15 کادر محاوره

 Print 1-4-15 گزينه‌هاي کنترلي کادر محاوره

Printer -1: در منوي بازشوي اين قسمت مي‌توان نوع چاپگري را که به کامپيوتر متصل 

است، انتخاب کرد. 
Properties -2: با کليک روي اين دکمه، کادرمحاوره تنظيمات چاپگر فعال ظاهر مي‌شود 

که از اين طريق مي‌توان اندازه کاغذ، نوع کاغذ، Resolution چاپگر و غيره را تعيين کرد.
Print Range  -3 : در اين قس��مت محدوده چاپ تعيين مي‌ش��ود که شرح آن به صورت 

زير است:
• All: انتخاب اين گزينه سبب چاپ تمام صفحات سند جاري مي‌شود.	

• Current page: اين گزينه فقط صفحه جاري را چاپ مي‌کند.	

• واقع در جعبه  	 Output Area براي چاپ ناحيه تعريف شده توسط ابزار :Area

ابزار Tools، از اين گزينه اس��تفاده مي‌شود )اصول کار با ابزار Output Area در ادامه 
همين فصل آورده شده است(.

• با وارد کردن ش��ماره صفحات خاص در اين قسمت، تنها صفحات مورد نظر  	:Pages

چاپ مي‌شوند.
• اگر‌مي‌خواهي��د صفحات‌متع��ددي را در‌کيصفح��ه چاپ‌کني��د،  	:Page boundary

مي‌توانيد اين گزينه را انتخاب کنيد تا لبه‌هاي صفحه در خروجي چاپ نهايي نشان 
داده شوند.

انتخاب ‌اين‌گزينه س��بب مي‌ش��ود که فقط موضوع انتخابي چاپ  • 	 :Selected objects
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شود.
Output -4: در اين قسمت گزينه‌هاي زير به‌کار مي‌رود:

• در اين کادر متني مي‌توان تعداد کپي‌ها از صفحات مش��خص ش��ده را وارد  	:Copies

کرد.
• انتخاب اين گزينه سبب مي‌شود که همه رنگ‌ها به صورت ترکيب شده  	:Composite

در کي صفحه چاپ شوند يعني ترکيب تمام رنگ‌ها در چاپ نشان داده مي‌شوند.
• فعال مي‌ش��ود و چاپگرهاي  	Postscript اي��ن گزين��ه براي چاپگرهاي :Separations

معمولي قادر به چاپ رنگ‌هاي تفکيکي نيس��تند، با استفاده از اين گزينه رنگ‌ها به 
طور مجزا چاپ مي‌شوند. به عبارت ديگر براي هر کي از رنگ‌هاي جوهر که در ايجاد 

فايل مورد استفاده قرار مي‌گيرند چاپ جداگانه‌اي انجام مي‌گيرد.
• اطلاعات چاپ، به جاي اينکه به چاپگر ارس��ال ش��ود، درون کي فايل  	:Print to file

ذخيره مي‌شود تا بعداً از آن استفاده شود.
• Convert Text: همه عبارات متني را به مسير تبديل مي‌کند.	

Preview -5: براي مشاهده پيش‌نمايش چاپ به كار مي‌رود )شکل 15-7(.

• ب��راي کنت��رل صفح��ات در پيش‌نماي��ش چاپ، از منوي بازش��وي ش��ماره صفحه  	
)شکل 7-15( استفاده کنيد.

• منوي بازشوي انواع پيش‌نمايش به صورت زير است:	
Preview: پيش‌نمايش کار طراحي را با تمام زمينه‌ها و رنگ‌ها نشان مي‌دهد.

Keyline: اين نوع پيش‌نمايش، بدون نمايش رنگ‌ها و زمينه‌ها فقط مس��يرهاي طراحي 

را نشان مي‌دهد.
X-Box: در اين پيش‌نمايش، طراحي به صورت علامت × نشان داده مي‌شود.

تمرين 2: انواع حالت های Print Preview را مشاهده كرده و به تفاوت بين آن‌ها 
دقت كنيد.
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شکل 15-7

 توجه: با استفاده از درگ ماوس مي‌توانيد طراحي خود را به موقعيت‌هاي مختلف 

در ناحي��ه Print Preview منتقل کني��د. اگر بخواهيد طراحي به موقعيت اوليه بازگردد، روي 
ناحيه‌هاي خارج از پيش‌نمايش چاپ کليک کنيد.

Color Management -6: اين گزينه مربوط به مديريت و تفکيک رنگ‌هاست.
7- بخش %Scale: در منوي بازش��وي شکل 8-15 گزينه‌هايي وجود دارد که مي‌توان به 
وس��يله آن‌ها اندازه فايل چاپ شده را تغيير داد، بدون اين‌که روي فايل اصلي تأثيري داشته 

باشد.

Scale % شکل 8-15 بخش

• اين گزينه س��بب مي‌شود که با وارد کردن اعداد بزرگ‌تر يا کوچ‌کتر از  	:Uniform

100%، ابعاد فايل چاپ شده نسبت به تصوير اصلي بزرگ‌تر يا کوچ‌کتر شود بدون 
آن‌که تناسب تصوير تغيير کند.

• تغيير مي‌دهد؛ زيرا در  	y و x مقي��اس تصوير را طبق مقادير مختلف ابعاد :Variable

اي��ن حالت مي‌توان طول و عرض تصوير را مس��تقل از کيديگر تغيير داد، تصوير در 
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خروجي تغيير شکل مي‌دهد.
• ان��دازه تصوير را طوري تغيير مي‌دهد که با کاغذ موردنظر متناس��ب  	:Fit on paper

باش��د. به عبارت ديگر بدون توجه به ابعاد واقعي تصوير، تصوير چاپ ش��ده به اندازه 
حداکثر فضاي قابل چاپ صفحه کاغذ، تغيير خواهد کرد.

Tile -8 : اگ��ر کار طراح��ي موردنظر، بزرگ‌تر از کاغذ چاپگر اس��ت و نمي‌خواهيد اندازه 

آن را کاه��ش دهيد، مي‌توانيد گزينه کاش��ي‌کاري )Tile( را انتخاب کنيد که در اين صورت 
طراحي ش��ما به تعداد قطعات کاغذ تقسيم مي‌شود و هر قسمت در کي صفحه چاپ خواهد 

شد )شکل 15-9(.                                                            

شکل 15-9

منوي بازشوي Tile داراي گزينه‌هايي به اين شرح است:
با اس��تفاده از اين گزينه مي‌توانيد مکان ظاهر ش��دن قطعات کاغذ تقسيم  • 	 :Manual

شده را به‌طور دستي انتخاب کنيد.
مح��ل قرار گرفتن ه��ر کي از قطعات کاغذ را به‌ط��ور خودکار تنظيم  • 	 :Automatic

مي‌کند.
• مي‌توان براي چاپ تصوير در چند قطعه روي کي کاغذ استفاده کرد  	Tile از قسمت

که در اين صورت گزينه Overlap فاصله ميان قطعات را تعيين مي‌کند. 
 Printer Setup 15-4-2

اي��ن گزين��ه وظيفه تنظي��م ويژگي‌هاي چ��اپ پيش��رفته را برعهده دارد که از مس��ير 
File→Printer Setup، قابل دسترسي است.

 مثال 2: تنظيمات زير را براي چاپ انجام دهيد:
الف- تنها صفحه جاري که شکل 3-15 )تمرين 1( در آن قرار دارد دو بار چاپ شود.
ب- در محيط Print Preview شکل را در وسط صفحه قرار داده و سپس چاپ کنيد.

حل:
1- قب��ل از انج��ام اين تنظيمات، از نصب و وصل بودن چاپگر به سيس��تم خود مطمئن 

شويد.
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2- براي تنظيم قسمت الف، از منوي File گزينه Print را انتخاب کرده و در کادر محاوره 
باز شده موارد زير را انتخاب کنيد:

• در قسمت Print Range گزينه Current page را انتخاب کنيد.	
   • در بخش Output در کادر Copies عدد 2 را وارد کنيد.  	

3- براي انجام قس��مت ب، در کادر محاوره Print دکمه Preview را کليک کرده و ش��کل 
را به وسط صفحه درگ کنيد.  

4- دکمه OK را کليک کنيد تا عمل چاپ انجام گيرد.
تمرين 3: شكل 10-15 را ترسيم کنيد، سپس آن را انتخاب کرده و فقط ناحيه 
انتخاب ش��ده را به‌نحوي چاپ کنيد که تصوير چاپ شده به اندازه حداکثر فضاي قابل چاپ 

صفحه کاغذ باشد.

شکل 15-10

 )Color Management( 5-15 آشنايي با مديريت رنگ
گاهي اوقات بين تصاويري که در صفحه نمايش ديده مي‌ش��وند با نمونه چاپ شده آن‌ها 
تفاوت رنگ مشاهده مي‌شود. براي رفع اين مشکل و به‌منظور تنظيم ظاهر تصاوير در صفحه 
نمايش و پس از چاپ در FreeHand مي‌توان از Color Management يا مديريت رنگ استفاده 

نمود. 
صفحه نمايش، رنگ‌ها را با مد رنگ RGB نمايش مي‌دهد در صورتي که در هنگام چاپ، 
رنگ‌ها با اس��تفاده از مد رنگ CMYK چاپ مي‌شوند بنابراين بين رنگ‌هاي صفحه نمايش و 

رنگ‌هاي خروجي نهايي تفاوت وجود دارد.
کي سيستم مديريت رنگ )CMS(1، در صورت لزوم، رنگ را به نحوي تنظيم مي‌کند تا 
رنگ دس��تگاه‌هاي پيش‌نمايش )مانند صفحه نمايش( تا حد ممکن با رنگي که در خروجي 

 Color  Management System -1
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نهايي )چاپ( ايجاد خواهد شد هماهنگي داشته باشد. 
 Output Area 6-15 ابزار

توسط اين ابزار )شكل 17-15( مي‌توانيد کي ناحيه واحد Export را درون محيـط کاري 
براي سند تعريف كنيد. ناحيه Export مي‌تواند شامل نواحي انتخابي صفحه جاري و نواحي 
انتخابي Pasteboard )محيطي که شامل صفحات فايل است( باشد. همچنين مي‌تـوان براي 

تعريف ناحيه چاپ از اين ابزار استفاده كرد.

 نكته: درصورتي که بخواهيد شکل‌هاي رسم شده را چاپ کنيد و آن شکل‌ها در 
Pasteboard و خارج از محدوده صفحه باش��ند تنها با اس��تفاده از ابزار Output Area مي‌توان 

اشکال مورد نظر را چاپ كرد.

Export 1-6-15 تعريف ناحيه

به منظور تعريف و صادر كردن کي ناحيه Export درون سند مراحل بعد را انجام دهيد:
کليک نماييد.

 
 Output Area روي ابزار ،Tools 1- از جعبه ابزار

2- ناحيه Export  را به‌وسيله درگ ماوس انتخاب كنيد.
3- گزينه File→Export را انتخاب کنيد.

4- در کادر مح��اوره‌Export Document ، ب��ه منظور Export کردن ناحيه تعريف ش��ده، 
گزينه Area را انتخاب كنيد.

 Export کلي��ک کنيد. در اي��ن لحظه ناحيه خروجي تعريف ش��ده Save 5- روي دکم��ه
مي‌شود.

بعد از تعريف ناحيه Export  مي‌توان اندازه آن را تغيير داد يا آن را حذف نمود.
Export 2-6-15 تغييراندازه، جابه‌جايي و حذف ناحيه

به منظور تغييراندازه ناحيه Export، در حالي که ابزار Output Area  انتخاب ش��ده است، 
اش��ار‌ه‌گر ماوس را در گوش��ه يا روي دس��تگيره کناري ناحيه قرار داده و آن را درگ نماييد 

)شکل 15-11(.
براي حرکت دادن ناحيه Export بايد اشاره‌گر ماوس را روي آن ناحيه قرار دهيد و زماني 
که اش��اره‌گر به شکل دس��ت تغيير شکل پيدا كرد، به س��مت موردنظر عمل درگ را انجام 
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دهيد. 

                 

Export شکل 11-15 تغيير اندازه ناحيه

 نكته: به منظور حذف ناحيه Export کليد Delete  را از صفحه کليد فشار دهيد.

3-6-15 تعريف ناحيه خروجي

به کمک ابزار Output Area مي‌توانيد ناحيه خروجي براي چاپ را نيز تعريف كنيد. ناحيه 
خروجي شامل ناحيه انتخابي در صفحات موجود و نواحي انتخابي در Pasteboard  است.

چاپ ناحيه خروجي 
1- ناحيه مورد نظر از شکل را با ابزار Output Area انتخاب نماييد.

2- دستور File→Print را اجرا کنيد.
3- در کادرمحاوره‌ Print گزينه Area را در حالت انتخاب قرار دهيد.

 4- به‌منظور چاپ ناحيه کل صفحه گزينه Page boundary را در حالت انتخاب قرار دهيد
)شکل 15-12(.

5- روي دکمه Preview کليک كرده و پيش‌نمايش چاپ را مشاهده كنيد.
6- روي دکم��ه OK  در کادر محاوره Print Preview  و ‌س��پس کادر محاوره Print کليک 

نماييد تا   عمل چاپ آغاز شود.
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شکل 12-15چاپ ناحيه خروجي
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واژه‌نامه
Againدوباره، مجدد

Boundaryکرانه، مرز

Color Managementمديريت رنگ

Compositeمرکب

Exportارسال، صادر کردن

Externalخارجي، بيروني

Previewپيش‌نمايش

Separationsتفکيک

Uniformکيسان، متحدالشکل

خلاصه مطالب 
• اين فرمان به منظور ارس��ال و صادر کردن موضوعات به برنامه‌هاي ديگر يا  	:Export

براي چاپ استفاده مي‌شود.
• با اس��تفاده از اين گزينه مي‌توان تمام يا بخشي از تصوير ترسيمي مورد نظر  	:Print

را روي کاغذ چاپ کرد. 
پ��س از صدور کي فايل، در صورتي که  بخواهيد تغييراتي را در س��ند اصلي ايجاد  • 	 

کنيد و سپس بدون تنظيم کادر محاوره Export مجدداً فايل مزبور را صادر کنيد از 
فرمان File→Export Again استفاده کنيد.

• مي‌توان  	FreeHand به منظور تنظيم رنگ تصاوير در صفحه نمايش و هنگام چاپ در
از Color Management يا مديريت رنگ استفاده كرد.
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آزمون نظري
درستي يا نادرستي گزينه هاي زير را تعيين کنيد.

1- فرمان  Exportبه منظور ارس��ال و صادر کردن موضوعات به برنامه‌هاي ديگر يا براي 
چاپ استفاده مي‌شود.

2- هنگام عمل چاپ گزينه  Current Page فقط ناحيه انتخاب شده را چاپ مي‌کند.
3- هنگام صدور فايل اگر گزينه Page boundary  را انتخاب کنيد، لبه‌هاي صفحه در فايل 

صادر شده نشان داده مي‌شود.
4- از Color Management به منظور مديريت و تفکيک رنگ‌ها استفاده مي‌شود. 

5- هنگام عمل چاپ گزينه  Fit on paper اندازه تصوير را طوري تغيير مي‌دهد که با کاغذ 
مورد نظر متناسب باشد.

معادل گزينه هاي سمت‌ راست را از ستون سمت ‌چپ انتخاب کرده و مقابل هر عبارت بنويسيد.

Keyline          .6- اين گزينه وظيفه تنظيم ويژگي‌هاي چاپ پيشرفته را بر عهده دارد
        All           .7-بدون نمايش رنگ‌ها و زمينه‌ها فقط مسيرهاي طراحي را نشان مي‌دهد

8- اين پيش‌نمايش، کار طراحي را با تمام زمينه‌ها و رنگ‌ها نشان مي‌دهد.
Printer Setup                                                                                        
Output Area        .9-انتخاب اين گزينه سبب چاپ تمام صفحات سند جاري مي‌شود
Preview                   .10- مي‌توان براي تعريف ناحيه چاپ  از اين ابزار استفاده كرد

گزينه صحيح را انتخاب کنيد.

11- کدام فرمان براي صدور فايل‌هاي گرافيکي به برنامه‌هاي ديگر استفاده مي‌شود؟
Export -د 	Import -ج 	Save As -ب 	 Save -الف

12- کدامکي‌ از گزينه‌هاي زير وظيفه فرمان Export است؟ 
الف- ذخيره فايل با فرمتي هم‌ساز با برنامه گرافيکي مقصد 

ب- تبديل فرمت فايل جاري در  FreeHand به فرمت‌هاي گرافيکي ديگر
ج- Export معادل فرمان Save است.

د- گزينه‌هاي الف و ب صحيح هستند.
13- در صورتي که در فايل ارسال شده به نرم‌افزارهاي ديگر، تغييري ايجاد کرده باشيد، 
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کدام فرمان براي صدور تغييرات مناسب است؟
Again Export -ب 	      Export Again -الف

Export Document -د 		  Export As -ج
14- فرمان ............... وظيفه چاپ اسناد گرافيکي را در FreeHand به عهده دارد.

Printer -د 	Output -ج           	Print Range -ب 	 Print -الف
15- ب��راي چ��اپ کي موضوع خاص انتخابي در صفحه توس��ط فرمان Print، کدام مورد 

مناسب است؟ 
Current page -د 		 Area -ج 	Selected Objects -ب 	 All -الف

16- انتخاب گزينه Print to file چه عملي انجام مي‌دهد؟
الف- خروجي فايل گرافيکي را به چاپخانه مي‌فرستد.

ب- خروجي چاپ، به اندازه حداکثر فضاي قابل چاپ صفحه کاغذ خواهد شد.
ج- اطلاعات را به کي چاپگر ديگر غير از چاپگر پيش‌فرض مي‌فرستد.

د- اطلاعات چاپ شده را درون کي فايل ذخيره مي‌کند.
در جاي خالي عبارت مناسب را بنويسيد.

FreeHand -17 فايل‌هاي متني را با فرمت ........... فراخواني مي‌کند.
18- در پيش‌نمايش X-Box، طراحي به صورت ........... نشان داده مي‌شود.

19- براي صدور ناحيه تعريف ش��ده توس��ط ابزار Output Area  واقع در جعبه ابزار 
Tools، بايد گزينه ......... را انتخاب کنيد.

20- انتخاب گزينه ............................ هنگام صدور فايل، باعث مي‌ش��ود که پس از ذخيره 
شدن فايل با فرمت انتخاب شده، بلافاصله برنامه مقصد اجرا شده و فايل ذخيره شده در آن 

نشان داده شود.
به سؤالات زير پاسخ تشريحی دهيد.

21- فرمت‌هاي پشتيباني شده براي صدور فايل در FreeHand را نام ببريد.
22- آيا از طريق فرامين Copy/Paste در FreeHand مي‌توان با فتوش��اپ تبادل اطلاعات 

کرد؟
23- چگونه مي‌توانيد با استفاده از فرمان Print ترسيمات خود را 50% کوچ‌کتر از اندازه 

واقعي چاپ کنيد؟
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آزمون عملي 
1- آرم زير را رسم کنيد.

2- کارت ويزيتي به ابعاد موردنظر و با استفاده از آرم دلخواه براي کي سالن بدن‌سازي طراحي 
 و چاپ کنيد که شامل نام سالن، نام مديريت سالن ورزشي، خدمات ارايه شده، آدرس، شماره تلفن و

E-mail باشد. 

3- براي يك سالن ورزشي سربرگ مناسب طراحي کنيد که شامل نام سالن، آرم )شكل 
س��ؤال 1(، تاريخ، پيوست، آدرس، شماره تلفن وE-mail باشد. همچنين کي تصوير مرتبط با 

موضوع نيز به صورت محو در زمينه سربرگ وجود داشته باشد.
4- سربرگ طراحي شده را به نام My design براي چاپخانه صادر کنيد )به فرمت ارسالي 

توجه کنيد(.
5- در کي کاغذ A4، 2 نسخه از سربرگ را توسط چاپگر، چاپ کنيد. 
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آزمون پاياني )نظري(

1- کدامکي‌ از عبارات زير صحيح است؟
الف- کليک روي  در نوار ابزار اصلي، سند جديد را ايجاد مي‌کند.

ب- نوار اطلاعات )Info( همان نوار ابزار استاندارد است.
ج- برنامه FreeHand 10 بدون سند جديد باز مي‌شود.

د- امکان باز کردن فايل‌هاي قبلي در کادر Wizard ورودي وجود ندارد.
2- در پنل Document گزينه  چه عملي انجام مي‌دهد؟
ب- نمايش دو صفحه‌اي الف- نمايش تک صفحه‌اي   	
د- نمايش حاشيه صفحه ج- نمايش چند صفحه‌اي        	

Define Grids -3  ب��ه منظ��ور ............ و .............. نماي پرس��پکتيو )Perspective(  به‌کار 
مي‌رود.        

الف- نمايش - تغيير جهت                               ب- حذف - غيرفعال شدن 
د- ايجاد - ويرايش  ج- فعال شدن- تعويض                           	

4- هر چقدر ش��عاع گردي گوش��ه‌ها )Corner Radius( در ابزار Rectangle  کمتر باش��د، 
ميزان انحناي گوشه‌هاي چهارگوش ......................... خواهد بود. 

ج- بيشتر             د- تأثيري ندارد. الف- گردتر        ب- کمتر	
5- شکل مقابل توسط کدام ابزار ترسيم مي‌شود؟

		  Pen -الف 	
		               Line  -ب 	

                     Bezigon -ج 	
د- گزينه‌هاي الف ‌و ج صحيح ‌هستند.      	

6- هنگام استفاده از ابزار Polygon و انتخاب گزينه Star اگر عبارت Number of Sides را 
برابر 4 قرار دهيد كدام شكل ترسيم مي‌شود؟

د-   	 	        ج-     ب-
 

الف- 
7- کدامي‌��ک از فرمت‌ه��اي زي��ر، فايل را ب��ا حجم پايي��ن و 16 ميلي��ون رنگ ذخيره 
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مي‌سازد؟
 bmp-د       	 fh10 -ج            jpeg -ب               gif -الف

8- در هنگام طراحي با اس��تفاده از کدام گزينه مي‌توان نماهاي مختلف ديد را تعريف و 
ذخيره کرد؟

	magnification -ب 		  custom -الف

د- با استفاده از نواروضعيت  		    zoom-ج

9- اگر در هنگام رسم خط، کليدShift  را نگه‌داريد، خط چگونه رسم مي‌شود؟
الف- در زواياي 45 درجه و صاف 	

ب- نرم و عمودي
ج- از مرکز و بدون زاويه  	

د- به‌صورت منحني 
Text Rulers-10  چه امکاني را ايجاد مي‌کند؟

الف- سبب نمايش خط‌هاي راهنما روي صفحه خواهد شد.
ب- براي ترسيم دقيق اشکال به‌کار مي‌رود.

ج- در زمان تايپ، خط‌کش کوچکي در بالاي متن ظاهر مي‌کند.
د- همان Page Ruler است.

11- اگر دس��تگيره‌هاي وس��طي سمت چپ و راس��ت متن بلوک ش��ده را درگ کنيد، 
مي‌توانيد:

ب- سايز قلم را بزرگ کنيد. الف- متن را بچرخانيد.                 	
د- فاصله بين حروف را تغيير دهيد. ج- سايز حروف را کاهش دهيد.       	

12- در متن زير کدام Effect  به‌کار رفته است؟

Shadow -ب 		  Highlight -الف
    Inline -د            		   Zoom -ج

13- براي وارد كردنStyle هاي آماده قبلي بايد گزينه ........... را انتخاب کنيد.
   Export-ب 		   Edit  -الف
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  Redefine -د 		   Import-ج
14- کليک روي دکمه  در نوار ابزار Text چه عملي را انجام مي‌دهد؟

الف- متن را روي مسير مورد نظر قرار مي‌دهد.
ب- مسير را روي متن مورد نظر قرار مي‌دهد.

ج- متن را از مسير جدا مي‌سازد.	
د- متن داخل شکل موردنظر قرار مي‌گيرد.

15- توس��ط کدام ‌گزينهConvert Case  کلمه‌ س��مت چپ به کلمه س��مت‌ راست تبديل 
مي‌شود؟

       EXAMINATION             	Examination

 lower -ب           		  upper -الف
small caps -د            		  title -ج

 Select 16- به‌منظ��ور انتخاب‌ کليه موضوعات طراحي‌ش��ده در کل ‌س��ند از کدام گزينه
مي‌توان استفاده کرد؟

  Super Select-ب 	            	 All -الف
    All in Document-د 	      Pointerج- با استفاده از

17- توسط چه گزينه‌اي از پنلTransform  مي‌توان شکل 1 را به 2 تغيير داد؟

           

Copy و Rotate  -د           Skew -ج               Rotate -ب     Copy و Scale -الف
18- براي ساخت اشکال خميده از ابزار ...................... استفاده مي‌شود.

 Fill  -د         	Knife -ج               Trace -ب               Freeform-الف
19- براي تبديل شکل 1 به 2 کدام ابزار به کار رفته است؟
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  Object -د            	Scale -ج                 Rotate -ب           Reflect -الف
20- به منظور برش خط صاف کدام گزينه از ابزار Knife به کار مي‌رود؟

 Freehand-د           	 Straight -ج           	Length -ب        	Tight fit -الف
21- کدام گزينه در مورد پنل Object صحيح است؟

الف- مشخصات موضوع ترسيمي را نشان مي‌دهد.
ب- تنظيمات و مشخصات پنل Object  بستگي به موضوع انتخابي ندارد.

ج- گزينه‌هاي داخل Panel  فقط زماني فعال مي‌شوند که شکل با ابزارRectangle  ترسيم 
شود.

د- براي تغيير رنگ شكل رسم شده مورد استفاده قرار مي‌گيرد.
22- در کدامکي‌ از پنل‌ها مي‌توان رنگ‌هاي جديدي را از ترکيب رنگ‌ها ايجاد کرد؟

 Export Color-د 	    Swatches -ج     Color Mixer-ب 	Replace Color -الف
23- توسط کدام گزينه شکل 2 و شكل 1 به‌وجود مي‌آيد؟

   Pattern-د 	Text     -ج 	Fill  -ب   	  Stroke -الف
24- براي تکرار کي طرح در داخل کي شکل از کدام گزينه زير استفاده مي‌شود؟

  Texture -د 		  None-ج            Tiled -ب               Basic -الف
25- انتخابJoin  به صورت   در پنل Object چه عملي را انجام مي‌دهد؟

الف- نوع گره را در انتهاي مسير مشخص مي‌کند.
ب- گوشه‌هاي دو خط کي مسير را پخ مي‌کند.
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ج- گوشه‌هاي دو خط کي مسير را گرد مي‌کند.
د- گوشه‌هاي دو خط کي مسير را نوک تيز مي‌کند.

26- براي نگهداري رنگ‌هاي ايجاد شده از گزينه .................. استفاده مي‌شود.
Color -ب 		              Tint-الف

 Color Mixer -د 	            	  Swatches-ج
27- پنلTransform  کدامکي‌ از اعمال زير را کنترل مي‌کند؟

ب- تغيير جهت، اندازه و چرخش تصوير       الف- نکات مربوط به نوشته‌ها در تصوير  	
ج- تغيير بزرگنمايي تصوير	            د- تغيير رنگ‌هاي تصوير

28- براي تبديل کي خط باز به کي پيکان از کدام گزينه استفاده مي‌شود؟
 Grid-د      	Arrowheads -ج        Cap -ب 	     Color List -الف

29- اگر بخواهيد موضوع انتخاب ش��ده در بزرگ‌ترين حالت ممکن نمايش يابد از کدام 
گزينه استفاده مي‌شود؟

 Custom -د 		 Fit to Page -ج   	 Fit All -ب 	    Fit Selection -الف
30- براي نمايش ....................... بايد خط‌کش )Ruler( روي صفحه ظاهر شود.

 Grid -ب 		  Perspective -الف
    Guides-د            		  Lock -ج

31- با استفاده از گزينه ..................... مي‌توان از چند شکل مجزا کي شکل   واحد  ساخت.
 Lock -د                Join -ج     	   Union-ب        Group-الف

32- براي انتخاب اجزاي کي گروه کدام ابزار به‌کار مي‌رود؟
د- همه‌ گزينه‌ها صحيح هستند.  	 Subselect -ج 	 Pointer -ب  	 Group -الف

33- براي اتصال دو پاره‌خط به کيديگر، پس از انتخاب هردو خط چه بايد کرد؟ 
الف- از فرمان Modify→Join  استفاده شود.

ب- از کليد ميانبر Ctrl+J استفاده شود.
ج- از فرمان Modify→Split  استفاده شود.	

د- از فرمان wtras → Join استفاده شود.
34- براي بريدن و جدا کردن قسمت‌هاي روي هم افتاده مسيرها از کدام فرمان استفاده 

مي‌شود؟
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  Punch -د       	   Crop -ج          Ungroup-ب    	 Split -الف
35- به کمک کدام ابزار مي‌توانيد با استفاده از اشکال گرافيکي از پيش آماده و با حرکت 

دادن  ماوس در صفحه، جلوه گرافيکي جالبي ايجاد کنيد؟ 
 Smudge -د                 Spiral-ج           Arc -ب       Graphic Hose-الف

36- ابزار 3D Rotation  در نوار ابزارXtra چه کاربردي دارد؟
الف- ايجاد عمق در موضوعات با استفاده از سايه

ب- ايجاد دوران سه بعدي در موضوعات 
ج- ايجاد تقعر و تحدب در موضوعات 

د- ايجاد دوران در موضوعات به صورت دو بعدي 
37- براي ترسيم خطوط مارپيچ از چه ابزاري استفاده مي‌شود‌؟

 Bend -د      	 Smudge -ج             Spiral -ب              Arc -الف
38- کدام گزينه صحيح است؟

الف- پنل Align از طريق منوي Window ظاهر مي‌شود.
ب- براي باز کردن پنل Align  مي‌توانيد از کليد تركيبي Ctrl+Alt+A استفاده کنيد.

ج- ازطريق‌پنل Align مي‌توانيد چندين‌موضوع را نس��بت‌به‌هم يا به صفحه در کي راستا 
قرار دهيد.

د- همه گزينه‌ها صحيح هستند.
39- با استفاده از کدام فرمان، شکل 1 به 2 تبديل مي‌شود؟

 Ungroup-د                Intersect-ج          Divide-ب         Transparency -الف
40- براي محدب كردن کي متن کدام مورد زير صحيح است؟

الف- ابتدا دستور Convert to path  و سپس ابزار Fisheye Lens را اجرا كنيد.
ب- براي محدب کردن موضوعات بايد ابزار Arc را براي ايجاد قوس و انحنا به کار برد. 
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 Xtra  Toolsاز نوار ابزار Fisheye Lens ج- انتخاب ابزار
د- چنين امکاني وجود ندارد.

41- براي اصلاح جهت قرارگيري مس��يرها و کاهش تع��داد گره‌ها کدام گزينه از منوي 
Xtras به كار مي‌رود؟

 Clean up -د           Distort -ج           Create -ب    	 Colors -الف
42- نحوه عملکرد ابزار Blend در کدام گزينه زير نشان داده شده است؟

الف-         	ب-    	

ج-      د-         
43- براي تبديل رنگ موضوعات از مدل RGB يا CMYK به مدل خاکستري کدام مورد 

زير صحيح است؟ 
Convert to Grayscale -ب 	                      Darken Colors -الف
         Lighten Colors -د 	               Desaturate Colors-ج
44- فرمان Emboss از گزينه‌هاي فرمان  Create چه کاربردي دارد؟

الف- براي ايجاد جلوه آميختگي بين دو موضوع به كار مي‌رود.
ب- به منظور روي هم افتادن رنگ‌ها در چاپ استفاده مي‌شود.

ج- تعدادي گره به خطوط مسير اضافه مي‌کند.
د- انواع جلوه‌هاي برجسته‌سازي را ايجاد مي‌کند.

45- فرامين موجود در منوي Path Operation چه عملي را انجام مي‌دهند؟
الف- جلوه‌هايي به منظور زيباترکردن کار توليد مي‌کنند.

ب- مسيرهاي انتخاب شده را تغيير شکل مي‌دهند.



Free Hand پیمانه مهارتی : کاربر
455آزمون پایانی

ج- عملکرد فرامين آن مانند گزينه‌هاي منوي Modify است.
د- بعضي از خصوصيات غيرضروري موضوعات را حذف مي‌کند.

46-  با استفاده از کدام فرمان، شکل 2 از شکل 1 به‌وجود مي‌آيد؟
Roughen -الف

                                                          Bend-ب
 Distort -ج

                          Simplify -د
47- کدامکي‌ از موارد زير جزء انواع سايه در ابزار Shadow نيست؟

 Soft Edge -د               Zoom -ج             Trap -ب 	     Hard Edge -الف
48-براي‌صدورفايل‌ايجاد‌شده در FreeHand   به‌نرم‌افزارهاي‌ديگر‌از‌چه‌فرماني اس��تفاده‌ 

مي‌شود؟
Export -د    	  Import -ج          Open -ب          	 Save -الف

49- براي تعيين مشخصات چاپ از قبيل سايز، نوع کاغذ و کيفيت چاپ از کدام قسمت 
كادر محاوره Print  استفاده مي‌شود؟

  Color Management -ب 		 Properties -الف
   Scale -د 	          Print Range -ج

50- براي تبديل موضوعات برداري به طرح بيتي از دستور .................. استفاده مي‌شود.
                                      Output options -د            Rasterize -ج      Extract -ب        Links -الف 

به سؤالات زير پاسخ تشريحي دهيد.

     1- تفاوت دستور Import  وOpen  در FreeHand چيست؟
2- ي��ک روش براي اضافه کردن نقاط گره‌اي به مس��يرها و ي��ک روش براي کم کردن 

گره‌ها نام ببريد؟
3- اب��زار ................. براي ايجاد نمودارهاي گرافيکي و گزينه .............. براي ش��فاف كردن 

رنگ قسمت‌هاي مشترک بهك‌ار مي‌روند.
4- عملکرد گزينه‌ها و کليدهاي زير را بنويسيد؟

 Ctrl+R -د 	           Ctrl+L -ج         	Crop -ب              Split -الف
5- گزينه Snap to Grid چه عملي را انجام مي‌دهد؟
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6- ابزارZoom  مشابه با کدام گزينه يا ابزار عمل مي‌کند؟                                            
7- تفاوت ابزارPen  و Bezigon در چيست؟	

8- در هنگام کار با متن براي رنگ کردن دور متن از کدام ابزار استفاده مي‌شود؟
9- دو روش را براي انتخاب موضوعات در کي صفحه بنويسيد؟

10- معادل کليدي و دستوري موارد زير را بنويسيد.
       Text→Attach to Path-ب           	 Edit→Select→All-الف

 Ctrl+F2 -د 		           Ctrl+T  -ج



Free Hand پیمانه مهارتی : کاربر
457آزمون پایانی

آزمون پاياني )عملي(

سري الف
1- الف( فايلي به نام Student بسازيد که حاوي 2 صفحه افقي و 2 صفحه عمودي با واحد 

ميلي‌متر و به ابعاد A4  باشد، سپس نماي ديد را دو برابر نماي فعلي قرار دهيد.
ب( تعدادUndo ها را به 16 افزايش دهيد.

 18x30 2- ش��کل زير را ترس��يم کنيد و سپس آن را طرح کي کاغذ کادو به ابعاد کاغذ
قرار دهيد. 

3- شکل زير را رسم کنيد.

4- رنگ‌هاي )M = 50 ،Y =80 ،K =0 و C =65( و )G =80 ،B =50 و R = 10( را ايجاد 
کنيد، سپس آن‌ها را به Swatches منتقل کرده و با نام‌هاي Rang1 و Rang2 ذخيره کنيد

رنگ خطوط شکل سؤال 3 را كه به رنگ CMYK است، رنگ‌آميزي کنيد.
سري ب

سربرگي با مشخصات زير براي يک مؤسسه طراحي کنيد:

1- ابعاد سربرگ30×15 سانتي‌متر باشد. 	
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					    2- از آرم زير در سربرگ استفاده شود.

3- با رعايت نکات صفحه‌آرايي، آرم ‌را در محل مناس��ب قرار داده و نام مؤسس��ه، شماره 
نامه، تاريخ، پيوست، آدرس و تلفن را در سربرگ بنويسيد.

4- آرم را به Photoshop ارس��ال کرده و براي زيبايي کار، روي آن فيلتر مناس��بي اعمال 
کنيد، سپس آن را به فايل خود وارد کرده و در زمينه سربرگ استفاده کنيد.
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پاسخنامه

آزمون نظري واحد كار 2

1- غلط                   2- صحيح                      3- صحيح	
Welcome -6                       Setup -5                   4- غلط

	Screen-based -9                Publication -8           Stationery -7
10- د(گزینه های ب و ج صحیح هستند        11- ب( Setup.exe         12- ج( 100	

Online 14- ب( مرور سرفصل‌ها و درس‌هاي برنامه به صورت   Previous File )13- ج
17- افزايش - کاهش 	            Wizard-16 	Template -15

آزمون نظري واحد كار 3

2- غلط	           3- صحيح 1- صحيح	
Revert -6 	Zoom -5 	Import -4

Customize  Toolbar -7
10- ج( منوي Unit در نوار ابزار Info قرار دارد. 	Info 9- ب( نوار 8- د( حذف	

11- ب( تايپ 130% در منوي  Magnification از نواروضعيت
Keyline )13- ج 	Preferences )12- الف

14- ب( اگر چندين صفحه گرافيکي داش��ته باش��يد همه صفحات را در محيط نش��ان 
مي‌دهد.

15- ج( کليه تغييرات در ترسيم به آخرين مرحله ذخيره سازي برمي‌گردد.
Keyboard Shortcuts -18 	TIF )17- د           	FH11)16- ب

Text 20- زبانه 	Save As -19
آزمون نظري واحد كار 4

2- غلط             	3- غلط	 1- صحيح	
Release -6 	Library -5 	Bleed -4

Snap Distance -7
8- د( همه‌ گزينه‌ها صحيح هستند.

9- الف( تغيير اندازه صفحه بر اندازه موضوع ترسيمي تأثير مي‌گذارد.
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Alt )11- د 		 Custom )10- ج
12- د( رنگ و تعداد خطوط شبکه سه بعدي را نمي‌توان تغيير داد.

Duplicate )13- ج
14- ب( براي استفاده ازMaster Page هاي ايجاد شده در سندهاي ديگرِ FreeHand آن‌ها 

را Export مي‌کنند.
	Release -16 	View→Snap to Object )15- ب

17- جابه‌جايي صفحه
آزمون نظري واحد كار5

2- غلط             3- صحيح 1- صحيح	
Star -6 	Rectangle -5 4- غلط	

Pen -8	           9- ب( رسم دايره و بيضي 	Line -7
Polygon )11- ج 	  Alt)10- د

12- ب( تعداد اضلاع چندضلعي را مشخص مي‌کند.
Shift )14- ج           	Line )13- الف

15- ج( در ص��ورت فع��ال بودن ابزار Pen هنگامي ک��ه روي صفحه کليک مي‌کنيم کي 
16- امکان بالا بردن دقت کار	 نقطه گوشه به ‌وجود مي‌آيد.	
Shift -17	  Alt -18          19- رسم خط صاف يا منحني

آزمون نظري واحد كار 6

2- غلط	           3- غلط 1- صحيح	
	Pointer -6 	Knife -5 4- صحيح	

Freeform -8 	Alt -7
9- ب( رسم مارپيچ    10- د( رسم کمان    11- د( گزینه های ب و ج صحیح هستند

12- ج( برش زدن تصاوير	
13- د( همه گزینه ها صحیح هستند

Clone)15- ج 		 Straight )14- ب
Subselect -16	                     17- چندين موضوع را باهم درحالت انتخاب قرارداد.

Alt -19 18- اتصال اشکال به کيديگر	
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آزمون نظري واحد كار 7 

3- صحيح 2- غلط  	 1- صحيح	
Remove -6 	Duplicate -5 4- غلط	

Saturate Colors )8- ب 	Replace -7
WebSafe 216  )10- د             	Darken Colors  )9- ب

HLS  )13- ج 	Alt  )12- ب 	 11- د( 
	CMYK -15 	Show /Hide names  )14- ج

	Name All Colors -17            		 16- کاهشي
18- 360+% تا 360-%	            19- تک رنگ و دورنگ

آزمون نظري واحد كار 8

3- صحيح 2- صحيح	 1- غلط	
6- شيب تابعي 5- شيب کروي	 4- غلط	
Pattern )9- د 	 Trap -8 	Fractalize -7

11- د( گزينه‌هاي الف و ج صحيح هستند.	 	           Gradient )10- ب
	   Eye Dropper)13- الف 12- ج( تعيين وضعيت انتهاي خطوط	

Blend -16 	Stroke -15 14- د( مخروطي	
Ctrl+Shift+B -18                  17-جلوه‌هاي برجسته‌سازي

آزمون نظري واحد كار 9

3- صحيح 2- صحيح	 1- غلط	
Remove Transform -6 	Text Editor -5 4- غلط	

 Flow Around Selection -8 	Attach To Path -7
9- ب( در روي متن خط رسم مي‌کند.

Text از منوي Attach To Path )11- ب 10- ج( ايجاد سبک قلم نازک و معمولي	
Shadow )13- د              	Text→Leading→Other )12- الف

14- د( گزينه‌هاي الف و ب صحيح هستند.
15- ج( تبديل حروف کوچک و بزرگ به کيديگر در متون انگليسي
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16- ب( حرف اول همه كلمات متن انتخابي را بزرگ و بقيه را کوچک مي‌کند.
19- متن را به موضوع ترسيمي 	Percentage -18 	Sentence )17- ب

آزمون نظري واحد كار 10

3- غلط	 2- صحيح	 1- غلط	
Punch -6 	Intersect -5 4- غلط	

Reverse Direction -8 	Crop -7
Remove Overlap  )10- ب 	Join )9- الف

	Unlock )13- ج 	Union )12- ج 	Align )11- الف
Expand Stroke )15- ب           	Join )14- د

	Inset Path -18 	Subselect )17- ب 	Divide )16- الف
Skew -20 	Horizontal -19

آزمون نظري واحد كار 11

2- صحيح	  3- صحيح 1- غلط	
	Bend -6              	Blur -5 4- غلط	

	Rotate from )9- ج  	Emboss -8 	Bevel -7
Bend  )11- ب             	Fisheye Lens   )10- ج

Paste as envelope )13- د              Transparency )12- ب
Sketch -16 	Ragged -15 	Expand Path -14

آزمون نظري واحد كار 12

3- صحيح 2- صحيح	 1- غلط	
6- غلط 5- صحيح	 4- صحيح	

Unlock -Visible -8 	Active -7
Remove Unused -11       Remove -10       Edit -9

Duplicate  )13- ب 	Decimal Precision )12- ج
15- ج(   	Merge Foreground Layers  )14- الف

	Guides -17           	Large List View )16- الف
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19- والد يا اصلي	        20- والد )اصلي( - فرزند 	Auto-Update -18
آزمون نظري واحد كار 13

3- صحيح 2- غلط   	 1- صحيح	
Fireworks -6 	Import -5 4- غلط	

	Jpeg )9- ج           	GIF -8 	Lossy -7
	Always Use Source PNG )10- الف

Trace )12- د 11- ج( تغيير اندازه و تغيير فرمت فايل	
13- ب( ميزان شباهت مسيرهاي Trace شده به مدل اوليه را تعيين ميك‌ند.

Convert to Image -14	               15- نرمي لبه‌هاي دور تصوير
Update -17 		 Alt -16

آزمون نظري واحد كار 14

3- صحيح 2- غلط  	 1- صحيح	
Action -6 5- صحيح	 4- غلط	

Link to Target Page -8 	Target Page -7
 The Full Screen action )10- د 	Release to Layers -9

13- ج( تست و اجراي فيلم	 	GIF  )12- ب 	Trail  )11- الف
Publish as HTML -14	           15- بازيابي يا بارگذاري - عدم بازيابي

آزمون نظري واحد كار 15

2- غلط	            3- صحيح 1- صحيح	
 Printer setup -6 5- صحيح	 4- صحيح	

	All -9 	Preview -8 	Keyline -7
	Export )11- د 	Output -10

Export Again )13- الف 12- گزینه های الف و ب صحیح هستند 	
Selected Objects  )15- ب                       	   Print )14- الف

16- د( اطلاعات چاپ شده را درون کي فايل ذخيره مي‌کند.	
	  RTF, ASCII-17

Open in external application -20 	area -19 18- علامت ×  	
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ضميمه الف
تمرينات كاربردي

1- تصاويرکتاب‌کود‌کرا که در شکل 1- الف‏، 2- الف و 3- الف نشان داده شده، ترسيم 
کنيد.

    

شكل 1- الف

شكل 2- الف
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شكل 3- الف

2- جلد کتاب با مشخصات زير را طراحي کنيد.
الف( آموزش درس زبان انگليسي باشد.
ب( مربوط به پايه دوم دبيرستان باشد.

ج( سال چاپ و قيمت روي آن مشخص باشد.
3- کارت ويزيت مربوط به يك ش��ركت گرافيكي كه در زمينه كار تبليغاتي فعاليت دارد 

را ترسيم کنيد.
4- يك سربرگ براي كلينيك تخصصي چشم پزشكي طراحي كنيد.

5- يك پوستر در ابعاد مناسب طراحي کنيد كه موضوع آن اصلاح الگوي مصرف باشد.



وزارت فرهنگ و ارشاد اسلامی
Free Hand نام استاندارد : کاربر

شماره : 15/7- ف - هـ
466

6- تصوير زير را رسم کنيد.

شكل 4- الف

7- يك جعبه دستمال كاغذي را طراحي كنيد )از دستور Import براي استفاده از تصاوير 
استفاده كنيد(.

8- آرم‌هاي زير را طراحي کنيد.

  

شكل 5- الف
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9- پشت و روي ساک دستي مربوط به يك فروشگاه كيف و كفش را طراحي کنيد.
10- کاغذ کادويي را ترسيم کنيد كه مناسب براي كادوي تولد يك كودك باشد.

11- براي شعر زير تصوير‌سازي کنيد.
» اي شاپرک! تن تو

ُپر موج، مثل آب است
آن بال کاغذينت 

				   مانند کي کتاب است
در آن کتاب رنگی

عکس بهار پيداست
هم کوه و باغ و صحرا 

هم جويبار پيداست
کار تو، صبح تا شب

گشتن ميان باغ است
در اين بهار زيبا

بازار تو چه داغ است!
اي شاپرک بيا، باز

 واکن کتاب خود را

در انتظار هستند

گل‌هاي خانه ما.” 
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ضميمه ب
MX FreeHand ميانبرهاي صفحه كليد در برنامه

File منوي

معادل كليديگزينه

NewCtrl+N

OpenCtrl+O

Close‍‍Ctrl+W

SaveCtrl+S

Save AsCtrl+Shift+S

ImportCtrl+R

ExportCtrl+Shift+R

PrintCtrl+P

QuitCtrl+Q

Edit منوي

UndoCtrl+Z

RedoCtrl+Y

CutCtrl+X

CopyCtrl+C

PasteCtrl+V

Special: Paste AttributesCtrl+Alt+Shift+V

Cut ContentsCtrl+Shift+X

Paste InsideCtrl+Shift+V

Duplicate Ctrl+Alt+D

CloneCtrl+Shift+D

Select:AllCtrl+A

Select All In DocumentCtrl+Shift+A

Select:NoneCtrl+D
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Find And ReplaceCtrl+F

PreferencesCtrl+U

  View منوي

Fit SelectionCtrl+Alt+ 0

Fit To PageCtrl+Shift+W

Fit AllCtrl+0

Magnification :%50Ctrl+5

Magnification :%100Ctrl+1

Magnification :%200Ctrl+2

Magnification : %400Ctrl+4

Magnification : %800Ctrl+8

KeylineCtrl+K

Fast ModeCtrl+Shift+K

ToolbarsCtrl+Alt+T

PanelsF4,Ctrl+Shift+H

Page Rulers:ShowCtrl+Alt+R

Text Rulers Ctrl+/

Guides:ShowCtrl+;

Guides: LockCtrl+Alt+;

Guides:Snap To GuidesCtrl+Shift+;

Grid: ShowCtrl+Alt+G

Grid:Snap To GridCtrl+Alt+Shift+G

Snap To PointCtrl+ '

Modify منوي

Transform:Scale…Ctrl+ F10

Transform AgainCtrl+,

 Arrange:Bring To FrontCtrl+Shift+Up Arrow
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Arrange:Move ForwardCtrl+Up Arrow

 Arrange:Move BackwardCtrl+Down Arrow

 Arrange:Send To BackCtrl+Shift+Down Arrow

Align:TopCtrl+Alt+ 4

Align:BottomCtrl+Alt+ 6

Align:Center HorizontalCtrl+Alt+ 5

Align:Center VerticalCtrl+Alt+ 2

Align:LeftCtrl+Alt+ 1

Align:RightCtrl+Alt+ 3

Align AgainCtrl+Alt+Shift+A

JoinCtrl+J

SplitCtrl+Shift+J

Combine:BlendCtrl+Shift+B

Combine:Join Blend To PathCtrl+Alt+Shift+B

LockCtrl+L

UnlockCtrl+Shift+L

GroupCtrl+G

UngroupCtrl+Shift+G

Symbol:Edit SymbolCtrl+ E

Symbol:Convert To SymbolF8

Convert to ImageCtrl+Alt+Shift+Z

Text منوي

Size:SmallerCtrl+Shift+ ,

Size:LargerCtrl+Shift+ .

Font Style: BoldCtrl+B

Font Style: ItalicCtrl+I

Font Style: BoldItalicCtrl+Alt+Shift+O
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Effect:HighlightCtrl+Alt+Shift+H

Effect:StrikethroughCtrl+Alt+Shift+S

Effect:UnderlineCtrl+Alt+Shift+U

Align:LeftCtrl+Alt+Shift+L

Align:RightCtrl+Alt+Shift+R

Align:CenterCtrl+Alt+Shift+C

Align:JustifyCtrl+Alt+Shift+J

Special Character:Em SpaceCtrl+Shift+M

Special Character:En SpaceCtrl+Shift+N

Special Character:Thin SpaceCtrl+Shift+T

Special Character:Discretionary HyphenCtrl+ -

EditorCtrl+Shift+E

Flow Around SelectionCtrl+Alt+W

Flow Inside PathCtrl+Shift+U

Attach To PathCtrl+Shift+P

Xtras منوي

RepeatCtrl+Shift+ =

Window منوي

New WindowCtrl+Alt+N

ToolsCtrl+F2

ObjectCtrl+F3

AnswersCtrl+Alt+F1

LayersF2,Ctrl+ 6

SwatchesCtrl+F9

Styles Shift+F11, Ctrl+ 3

LibraryF11

Color MixerShift+F9, Ctrl+Shift+C
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HalftonesCtrl+H

AlignCtrl+Alt+A

TransformCtrl+M

Movie:TestCtrl+Return

Movie: SettingsCtrl+Shift+Return
 

فهرست منابع

 • 	www.adobe.com/Support/FreeHand سايت
 • 	Macromedia FreeHand MX for Windows and Macintosh: Visual Quickكت��اب

)Sandy Kohen( مؤلف: سندي كوهن  Start Guide

 • 	Macromedia FreeHand MX: Training from the Sourceكتاب
• 	Patti Schulze :مؤلف
• 	FreeHand MX برنامه Help
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